Jump to content

MSI X299 SLI Plus and Intel 7820X: installation and post installation steps

197 posts in this topic

Recommended Posts

Sleep, USB 2.0 and USB 3.1 work after installation.
USB3.0 needs post installation steps, although some ports are recognized.
Audio also needs some post installation work.
This is just a guide on how to install the OS. The post installation setup follows on a post below.
Motherboard: MSI X299 SLI Plus
RAM: 4x 8GB Corsair Vengeance DDR4 @ 3200MHz (32GB total, quad channel mode).
Storage: Samsung EVO 960 M.2 250GB (for OS)
          Crucial MX300 1TB (for data)
Network: WiFi TP-LINK Archer T9E AC1900 (PCI, supported by macOS)
Bluetooth: Broadcom BCM20702 (USB, supported by macOS)
Video: MSI GT 710 2GB (supported by macOS)
     Asus ROG Strix GTX1 070 8GB (needs NVIDIA Web Drivers)
I used version 140, the latest at the time. I am running version 150 now, with no differences.
Disable "CFG Lock":
  • Enter BIOS
  • Load defaults (F6)
  • Expert mode (F7)
  • OC  and then CPU Features (last item)
  • Disable "CFG Lock".
  • Save and reboot (F10)
You have to disable CFG Lock, otherwise the kernel does not boot. The system restarts after "+++++" from Clover.
In addition, I advise to disable legacy mode in the UEFI, to avoid booting in legacy mode and get confusing errors from Windows or Disk Utility.
Clover installation on the USB:
  • Install for UEFI booting only
  • Install Clover in the ESP
  • drivers64UEFI all selected (more on this below)
  • all rest is off
Clover drivers:
 When the Clover installation finishes, you have to manipulate a few efi drivers.
  • Navigate to <USB ESP partition>/EFI/CLOVER
  • Create a folder called drivers_disabled
  • Move the following drivers from drivers64UEFI to drivers_disabled:
    • OsxAptioFix2Drv-64.efi
    • OsxLowMemFixDrv-64.efi
  • You will have to add an extra driver from here:
    Download Test2-2016.efi and save it in drivers64UEFI.
    Without this fix, you'll have the memory allocation problems described in the link above.
    If you still get that problem, don't just reboot but really turn the computer off and then on between tries.
  • I also had to install apfs.efi.
Clover config.plist:
I used Clover Configurator to load the default clover.plist and then:
  • ACPI: disable everything.
  • Boot: npci=0x2000. I also added -v.
  • SMBIOS: iMac18,3
    Any iMac18 should work (I tried with 18,1 and 18,3). I also tried with iMac14 and iMac17, and they gave me problems. For example, iMac17,1 could not initialize the graphic screen properly.
  • Leave all the rest as default. Save.
All these changes can also be done at the clover menu during boot.
Note that I am not claiming this is the best configuration for a running machine. It is the simplest that allowed me to finished the installation and reboot successfully.
I think it is possible to handle the efi Clover drivers installation using Clover Configurator, but I have never done that.
  • FakeSMC.kext. I used the one from Rehabman, but I think the official one will work as well.
  • VoodooTSCSync.kext. This is mandatory, otherwise the system does not boot properly. It needs to be configured as follows: open VoodooTSCSync.kext/Contents/Info.plist and change the line under
    This is the number of threads of your CPU minus 1.
Place both kexts in EFI/CLOVER/kexts/Other.
I used the MSI GT 710 for installation and all post-installation steps. The 1070 only works with NVIDIA's Web drivers. Don't use it during installation. Check the post-installation post below to make it work.
And this is it. Installation should work without a problem. Remember to use always the USB during the several installation reboots.
I did not activate iCloud and my Apple account during installation. I wanted to generate a real fake machine UUID and serial number, so that I can use all the Apple services. This was done after installation, while booting from disk.
What needs to be done during post-installation:
  • Fix USB3.
  • Fix audio.
  • CPU ID recognition, although this might be fixed by Apple on a new iteration of the OS.
  • Confirm that the CPU is working properly with all cores and different power states.
  • Install NVIDI's Web Drivers for the Asus GTX 1070.

Share this post

Link to post
Share on other sites

Post installation steps:
Update Clover regularly.
The installation was done with Clover 4200, and most post-installation steps were done with 4220. I found out that 4220 does not need the Test2-2016.efi  driver to fix Clover's memory allocation problems at boot. So at the moment I am using stock Clover (with the apfs.efi driver).
Note that Clover does not install in the ESP of a NVME disk. Instead, it install in the macOS partition. I have to mount the ESP partition and move the EFI folder to it. This happens with 4220 too.
Since I have also a SSD disk and Clover installs there without any issues, I keep disks ESP in sync, so I can boot from any disk. Sometimes this gets Windows a bit confused.
Use the fork of Mieze's Intel Mausi Network Driver by RehabMan. I placed the kext in Clover, and it works fine.
I am using VoodooHDA. I wanted to try Toleda's Audio CloverALC, but I couldn't make it work. VoodooHDA has a few problems (it disables Apple's kext and needs a bit of tune up after each reboot), but at least it works ok. If I can make Toleda's audio work, I'll report it here.
Get VoodooHDA from here. Also get the PreferencePane, so that you can tweak the settings. Install both the kext and the pane and reboot. 
After reboot, HDMI should work ok. I got several HDMI outputs, bot only one really works. Sound level can't be setup by macOS, it has to be changed in the monitor.
The audio from the jacks is very noisy. To fix this, you have to go to the VoodooHDA preference pane and tweak it:
1. Select the correct PCI path: the shortest (see screenshot).
2. Now different outputs are available. Select the one you want to change.
3. Move the "Input Gain" slider. I simply move it all the way to the left.
4. Select the PCI path again.
This should remove the noise. It works on my headphones.
Besides this issue, VoodooHDA gives a loud crack when it loads, so it is recommended to boot with speakers off or not wearing headphones. Note that there is no issue with HDMI out, besides not being able to control the volume level with the OS, only with the monitor.
I used VoodooHDA in my two previous hacks (a laptop and a desktop from 2012) and both had similar issues: sound cracks at boot and needing to fiddle with the Voodoo Prefpane at each reboot. There is a Voodoo app that should save/load the prefpane settings at boot, but I never understood how it works. I used it for a while without it doing anything, and then one day it worked and the Voodoo settings were loaded properly at boot. At the moment it hasn't work for me on this system...
Power management
Get Intel Power Gadget to be able to check the power and frequency of your CPU. See how it behaves at idle. Ideally it would idle at 1.2GHz using 10W. Probably if you are using my default config, it is oscillating a bit above this value. I got an average of 15W and lots of frequency oscillations.  
The trick here is to create a custom SSDT using ssdtprgen and to enable XCPM in Clover.
Download ssprgen from here. Then run it from the terminal with "-x 1" to enable XPCM. Here's my output:

[size=4][font=verdana,geneva,sans-serif]Paulos-iMac:X299 pabreu$ ./ssdtPRGen.sh -x 1
ssdtPRGen.sh v0.9 Copyright (c) 2011-2012 by † RevoGirl
  v6.6 Copyright (c) 2013 by † Jeroen
  v21.5 Copyright (c) 2013-2017 by Pike R. Alpha
Bugs > https://github.com/Piker-Alpha/ssdtPRGen.sh/issues <
System information: Mac OS X 10.13 (17A365)
Brandstring: "Intel(R) Core(TM) i7-7820X CPU @ 3.60GHz"
Override value: (-x) XCPM mode, now set to: 1!
Version: models.cfg v171 / Skylake.cfg v195
Generating ssdt.dsl for a 'iMac18,3' with board-id [Mac-BE088AF8C5EB4FA2]
Skylake Core i7-7820X processor [0x50654] setup [0x0705]
With a maximum TDP of 140 Watt, as specified by Intel
Number logical CPU's: 16 (Core Frequency: 3600 MHz)
Number of Turbo States: 7 (3700-4300 MHz)
Number of P-States: 36 (800-4300 MHz)
Injected C-States for CP00 (C1,C3,C6,C7,C8,C9,C10)
Injected C-States for CP01 (C1,C2,C3,C6,C7)
Warning: Model identifier (iMac18,3) not found in..: /S*/L*/CoreServices/PlatformSupport.plist
Warning: 'cpu-type' may be set improperly (0x0705 instead of 0x0905)
- Clover users should read https://clover-wiki.zetam.org/Configuration/CPU#cpu_type
Error: board-id [Mac-BE088AF8C5EB4FA2] not supported by Skylake – check SMBIOS data / use the -target option
Do you want to continue (y/n)? y
Warning: 'system-type' may be set improperly (1 instead of 2)
- Clover users should read https://clover-wiki.zetam.org/Configuration/ACPI#acpi_smartups
Compiling: ssdt_pr.dsl
Intel ACPI Component Architecture
ASL Optimizing Compiler version 20140926-64 [Nov 6 2014]
Copyright (c) 2000 - 2014 Intel Corporation
ASL Input: /Users/pabreu/Library/ssdtPRGen/ssdt.dsl - 469 lines, 14213 bytes, 121 keywords
AML Output: /Users/pabreu/Library/ssdtPRGen/ssdt.aml - 3470 bytes, 52 named objects, 69 executable opcodes
Compilation complete. 0 Errors, 0 Warnings, 0 Remarks, 0 Optimizations
Do you want to open ssdt.dsl (y/n)? n

Copy the ssdt.aml file to your Clover installation, to EFI/CLOVER/ACPI/patched.
You should now have the ideal power management.
System stability
After installation my system was very unstable. It would randomly reboot without any warning. Sometimes it would reboot at login, other times during normal usage. First I was convinced it was Google Chrome, but then it also occurred with Safari. Then I thought it had something to do with 3D acceleration, because it would reboot when I ran a 3D program in OpenGL I am working on. But I ran Unigine's Valley and Heaven without trouble.
Finally I got a suggestion that the default core voltage in BIOS might not be adequate, and that solved the issue. I set the core voltage to 1.12V with no overclocking and to 1.21V with some mild overclocking, and the system is solid. I am able to run Prime95 for 8 hours with no crashes.
Before adjusting any voltage, I advise you to do some stability tests. Perhaps my problems are related with bad luck in the silicon lottery, and not some specific fault of the motherboard.
Download Prime95 and Geekbench 4, both for Windows and for macOS, and run them both with standard BIOS settings. In my case, Prime95 crashed the system in macOS but ran fine in Windows 10, and Geekbench 4 was the opposite: it ran fine under macOS but crashed under Windows 10. If you find that both programs run fine, perhaps there is no need to set the voltage.
To run these tests, keep Intel Power Gadget running in the background, so you can check the CPU's power consumption,  temperature, and frequency.
In Prime95, go to the Options menu and choose "Torture Test". Press OK and let it run for some time. The test goes over some different configurations over a period of several minutes. If after say 15min you have no crashes, then you can stop the test (in the Test menu) and try Geekbench. Geekbench CPU test only lasts a few minutes. If you system passes both tests (10-15 min of Prime95 and the CPU test in Geekbench), then you might consider a full torture test of Prime95. In my case it lasted for about 8 hours (I let it run during the night).
If your system crashes during one of these tests, then consider booting into the UEFI and changing the Core Voltage (under the OC menu). Set it at 1.2, reboot and redo the tests again. Keep lowering the voltage until they fail, and use the last known good voltage to do the full Prime95 torture test.
I was able even to do a very minimal overclocking to 4.4GHz with core voltage at 1.21V. The system is fine.
USB 3.0:
To be done. Note that USB 2.0 and 3.1 work without any post-installation work. But USB 3.0 (XHCI) need a few steps. I need to rename the XHCI entries in ACPI, then run USBInjectAll, etc, but I just haven't done it yet...
NVIDIA Web drivers:
You should start by installing NVWebDriverLibValFix.kext. This kext is necessary if you have any extra kext installed in /S/L/E. Then macOS will detect this folder as tainted and will not load the NVIDIA drivers from there. The result is boot stuck at "at gIOScreenLockstate 3 I". You can log in remotely, but you have no graphics. Simply place this kext in Clover, reboot, and you can start the NVIDIA drivers installation.
I used the MSI GT 710, which is supported my macOS, to download latest NVIDIA Web Drivers. Then:

  • Install the Web drivers. Reboot without making them the default.
  • Edit config.plist and activate the NVIDIA Web drivers.
  • Use the NVIDIA Preference Pane to use the NVIDIA drivers.
  • Reboot.

You should now be using the Web drivers instead of the built in. In that case, you can now install the NVIDIA card (in my case, the GTX 1070).
Each time you update the macOS, the Web drivers stop working and you need to download the adequate ones from NVIDIA again. Only update your system when the NVIDIA drivers for the new system are available.

Share this post

Link to post
Share on other sites

Update to 10.13.1:


Update was straightforward. I used Clover 4289 However, there are a few pitfalls that are worth remembering.


1. Make sure your Clover inject kexts are in


and not in


otherwise the 2nd phase of the installation (after reboot) hangs.


2. If you reboot into your previous system by mistake, and then try to boot into the 2nd phase of the installation, you'll get an error about some BaseSystem.dmg not found. Simply reboot into the previous system and start the upgrade again.



Updating the NVIDIA drivers


The most straightforward way is to use a supported card for the macOS upgrade (like the GT 710). Install the card, do the macOS upgrade, upgrade the NVIDIA Web Drivers, and replace the cheap card with a more recent one.


However, I found a way to use the unsupported card (the GTX 1070):


1. In the old macOS system, make sure you have Remote Login enabled in System Preferences -> Sharing. And make sure you can login remotely with another computer using SSH.


2. Download the NVIDIA Web Drivers for the system you are going to upgrade to. Check here to see what you need:



3. Do the macOS upgrade. On the 2nd phase, after reboot, you will be in VGA mode.


4. After the second reboot, make sure you select to disable the NVIDIA drivers in Clover. Press the space bar at the Clover menu and select the option.


5. The system will boot into a black screen. If you have verbose mode on, you'll see a repeating message on the screen. Don't worry, the system is up, only the graphics can't be initialised.


6. Login remotely to your system.


7. Go to the place where the WebDriver is and install it with the command:

sudo installer -pkg WebDriver-378. -target /

8. Reboot with

sudo shutdown -r now

You should now have the new WEBDriver working.


I also tried doing this under single user mode (booting with -s). It would avoid the complication of remote login. However the installer command failed because it could not understand the "/" as root.

Share this post

Link to post
Share on other sites

So you didn't do something special to enable sleep mode? No use of custom dsdt?

No custom dsdt, But I enable XCPM in Clover and I use the SSDT created with ssprgen. Sleep/wake work fine, but Power Nap does not work: the system restarts when it tries to wake up by itself. So it is disabled in System Preferences -> Energy Saver.

Share this post

Link to post
Share on other sites

OsxAptioFixDrv: starting overrides for \.IABootFiles\boot.efi


Using reloc block: yes, hibernate wake: no





Do you have any idea what i did wrong? I tested wirh the test-2016 and others but i keep getting this problem. 




Between ++++ and the macOS kernel boot is where most of the Clover magic happens. So I suspect something is not right with your Clover configuration.


Since you are already in +++, this is not a OsxAptioFix issue, which happens before. Also note that since yesterday I am able to boot with OsxAptioFixDrv from the latest Clover (4369), no need for Test2.efi and its variations. (I am waiting for 10.13.3 to update this guide with iMacPro1,1 SMBIOS, I'll put this update there too.)


Some things that come to mind:


Do you have VoodooTSCSync.kext correctly configured? 


Do you have a good FakeSMC from Rehabman?


Do you have the latest Clover (now is 4369)?


Did you disable all stuff except Windows 7 in the ACPI/DSDT fix mask in Clover?


Also, if you boot Clover in verbose mode, it might help: when you boot Clover, go to Options/System Parameters and select Debug.  There, I have everything off except AppleIntelCPUPM Patch. There is a 10 sec pause at the end, you might want to make a pic of the screen then to show us here.


Good luck.

Share this post

Link to post
Share on other sites

Thanks for your quick reply!

First of all... are there different High Sierra version numbers? I have downloaded one version using my Macbook Pro. Is it possible i have a newer version than requested?

I also have a GTX 1080i but for the installation i am using the GT 710 2GB from MSI. This should work without a problem? Can i install the GTX 1080 ti after installation?


I will awnser the questions here:

  • Do you have VoodooTSCSync.kext correctly configured? 
    I think i did. I updated the info.plist with IOCPUNumber set to 15
  • Do you have a good FakeSMC from Rehabman?
    I used the download link you told me so i guess it is the same (or the download has been updated?)
  • Do you have the latest Clover (now is 4369)
    I will check this later (i'm not at my mac now) but i thought i downloaded the latest version
  • Did you disable all stuff except Windows 7 in the ACPI/DSDT fix mask in Clover?
    This part is really new for me. I unchecked all checkboxes. This is what i need to do? Uncheck everything? I guess the Windows 7 option is in the DSDT? I need to disable everything there except the Windows 7 option?. I didn't think i saw a windows 7 option. My clover screen looks similar to this (again, i can't post a screenshot since i don't have my Mac with me now)



Thank you for your help! I really appreciate it!

Share this post

Link to post
Share on other sites

Also You might want to try a previous version of clover or at least it’s AptioFix. They are working on it at the moment and I’m not sure if the changes have been released yet. Maybe the new version doesn’t fit you.


Concerning your screenshot: try to UNCHECK most fixes. In your Screenshot almost all are checked :)


You can keep your gtx 1080 ti during installation. At least this worked for me. After installing the drivers check clover configurator for NVIDIA web drivers.

Share this post

Link to post
Share on other sites

Like @UcaUca said, you have most everything checked. I meant uncheck, disable. The windows 7 thing is in the Clover boot menu, when you go to options. Apparently it is not in Clover Config, so don't worry about that.


About the AptioFix thing: If you see the +++, you are already past that problem. So I suggest you keep what you have now, since it is working for you. However, it is true that updating Clover might change the way AptioFix works (it sure changes a lot with me). 


About the Clover version: you don't need to have the latest version. If you used the one I linked, it should be fine.


About the macOS versions: Apple updates the installer image when it releases a new macOS update. The installer available now is for 10.13.2, while I did the installation with 10.13.0 (or 1, I don't remember anymore). I do keep a 50GB partition available just for testing installations, but I haven't done that in a while, I want to do it again for 10.13.3 and iMacPro1,1. At the moment people are testing that SMBIOS and it looks promising.


And about the card: I installed using the GT710, and it went smoothly. @UcaUca says he was able to install using 1080, but I was not able to do that with my 1070. Perhaps I missed some Clover option. In addition, I got no GUI while doing the update, as I reported in a post above. Since you already have the GT710 in place, I suggest you keep it there until you get over the +++ issue. After installation, do a macOS update and then install the Web Drivers adequate for the macOS. And then change the card. And remember to never update the OS without being sure that there are the new webdrivers available from Nvidia. Otherwise you have to use the GT710 again, or use some Terminal magic to make things work again ;-)


Good luck and keep us posted. I have been enjoying the system immensely. It is fast powerful and stable. My performance values are even better in macOS than Windows ;-)

Share this post

Link to post
Share on other sites

Thanks for both your replies! The clover screenshot was from  internet, not mine but just as an example. I will try tonight when i am home again. I can imagine this works pretty good.. The hardware must be capable of doing great things.


I will definately keep you updated!


Thanks again

Share this post

Link to post
Share on other sites

u can use a native audio, in x299 device is CAVS

use it in config.plist




+ AppleAlc + Lilu and inject id with Clover

Share this post

Link to post
Share on other sites

u can use a native audio, in x299 device is CAVS

use it in config.plist




+ AppleAlc + Lilu and inject id with Clover

Thanks for the tip. This has been bothering me, the VoodooHDA isn't really satisfying, too many bugs to work around. 


I spent several hours this evening, but I was not able to make this work.


First implemented the DSDT patch replace CAVS with HDEF. MacIASL showed that there was no CAVS, only HDEF. So it seems this is good.


Then I installed Lilu and AppleALC, tried several IDs in Clover (1, 5, 7, 11) and no result.


I then installed the debug version, but the output messages aren't really useful.


So I gave up and went back to VoodooHDA...

Share this post

Link to post
Share on other sites
I now get the following error:




I think i will try to create a completely new usb stick because i might have messed up some things.

I'm not sure why i get the errors.



I first tried with the GTX 1080 ti and i also got a "Does printf work?" message.


After seeing these ++++ for a second or 2 my pc just restarts. Nothing happens anymore.

I will try to reinstall my usb stick and then try again, or is this a normal error message which i can fix?


BTW: I'm using Clover 4369

Share this post

Link to post
Share on other sites

use only OsxAptioFix2Drv-64.efi from Clover 4369 and calculate ur slide, u can test with slide=128

Share this post

Link to post
Share on other sites

use only OsxAptioFix2Drv-64.efi from Clover 4369 and calculate ur slide, u can test with slide=128


I tried this. I got the same error. How can i calculate my slide? 


BTW, i'm using a SIGMA 64gb USB stick... can this be a problem?

Share this post

Link to post
Share on other sites

wow, i tried to understand it but i can't figure out how that works. I tried memmap. I get a lot of values (available or other values) but i have no idea how to calculate the slide from that (even with reading the forum).

It is also to much for my screen so half of it goes away. I have no idea how to save the results

But thanks again for your help.

Share this post

Link to post
Share on other sites



This is my experience with OsxAptioFix:


* I don't use slide, just npci=0x3000


* Before Clover 4369, the best combination was OsxAptioFixDrv.efi + Test2.efi. This allowed me to boot without any problems all the time.


* With Clover 4369, I can boot all the time just with OsxAptioFixDrv.efi, no need for Test2.efi.


* Notice that OsxAptioFix2Drv.efi also works, but only when booting from a full off machine. When I "warm" restart, I get the "printf works" message.


So my suggestion is to try just OsxAptioFixDrv.efi. If that doesn't work, go for OsxAptioFixDrv.efi + Test2.efi. And remember to fully shutdown the machine before booting, to increase the chances of success.


Hey, thanks for the link, that looks like something to try.


@bbuster, that's some calculations in hexadecimal (perhaps that's why it seems strange to you). The macOS calculator has a mode that works in hex, if you want to give it a try. Just leave the trailing "0x" out. I'm going to try doing that, but I suspect that each machine is different, because it depends on the hardware you have connected to the MB. So my result might not ne useful to you.


To save the memmap output, you can direct it to a file in the ESP with:

memmap > fs0:\m.txt

(I can't check now that fs0 is the ESP, but I think it is).

You'll find the file m.txt in the ESP with the output of the memmap command.

(The ESP is the partition where you boot Clover from = EFI System Partition)

Share this post

Link to post
Share on other sites



If you still can't pass the OsxAptio issue, I just did the calculations of slide using my memmap. I haven't tested the result yet (can't access the UEFI of the machine during work hours) but here are my calculations:


My memmap:

Type       Start            End              # Pages          Attributes
BS_Code    0000000000000000-0000000000007FFF 0000000000000008 000000000000000F
Available  0000000000008000-000000000005EFFF 0000000000000057 000000000000000F
BS_Data    000000000005F000-000000000005FFFF 0000000000000001 000000000000000F
BS_Code    0000000000060000-000000000009FFFF 0000000000000040 000000000000000F
Available  0000000000100000-000000000FFFFFFF 000000000000FF00 000000000000000F
BS_Code    0000000010000000-000000001000AFFF 000000000000000B 000000000000000F
Available  000000001000B000-0000000015068FFF 000000000000505E 000000000000000F
LoaderCode 0000000015069000-0000000015201FFF 0000000000000199 000000000000000F
LoaderData 0000000015202000-0000000015202FFF 0000000000000001 000000000000000F
BS_Data    0000000015203000-0000000023190FFF 000000000000DF8E 000000000000000F
Available  0000000023191000-0000000023E9EFFF 0000000000000D0E 000000000000000F
BS_Code    0000000023E9F000-0000000024990FFF 0000000000000AF2 000000000000000F
Reserved   0000000024991000-0000000026190FFF 0000000000001800 000000000000000F
Available  0000000026191000-0000000027FCEFFF 0000000000001E3E 000000000000000F
ACPI_NVS   0000000027FCF000-0000000028DD0FFF 0000000000000E02 000000000000000F
RT_Data    0000000028DD1000-000000002A7D0FFF 0000000000001A00 800000000000000F
RT_Code    000000002A7D1000-000000002A900FFF 0000000000000130 800000000000000F
BS_Data    000000002A901000-000000002AA01FFF 0000000000000101 000000000000000F
Available  000000002AA02000-000000003A427FFF 000000000000FA26 000000000000000F
BS_Data    000000003A428000-000000003A8FDFFF 00000000000004D6 000000000000000F
Available  000000003A8FE000-000000004FFFFFFF 0000000000015702 000000000000000F
Available  0000000100000000-000000089FFFFFFF 00000000007A0000 000000000000000F
Reserved   00000000000A0000-00000000000FFFFF 0000000000000060 0000000000000000
Reserved   0000000050000000-000000005FFFFFFF 0000000000010000 0000000000000000
MMIO       0000000060000000-000000006FFFFFFF 0000000000010000 8000000000000001
MMIO       00000000FE000000-00000000FE010FFF 0000000000000011 8000000000000001
MMIO       00000000FEC00000-00000000FEC00FFF 0000000000000001 8000000000000001
MMIO       00000000FED00000-00000000FED00FFF 0000000000000001 8000000000000001
MMIO       00000000FEE00000-00000000FEE00FFF 0000000000000001 800000000000100D
MMIO       00000000FF000000-00000000FFFFFFFF 0000000000001000 800000000000100D
  Reserved  :         71,776 Pages (293,994,496 Bytes)
  LoaderCode:            409 Pages (1,675,264 Bytes)
  LoaderData:              1 Pages (4,096 Bytes)
  BS_Code   :          2,885 Pages (11,816,960 Bytes)
  BS_Data   :         58,726 Pages (240,541,696 Bytes)
  RT_Code   :            304 Pages (1,245,184 Bytes)
  RT_Data   :          6,656 Pages (27,262,976 Bytes)
  ACPI_Recl :              0 Pages (0 Bytes)
  ACPI_NVS  :          3,586 Pages (14,688,256 Bytes)
  MMIO      :         69,652 Pages (285,294,592 Bytes)
  MMIO_Port :              0 Pages (0 Bytes)
  PalCode   :              0 Pages (0 Bytes)
  Available :      8,244,265 Pages (33,768,509,440 Bytes)
  Persistent:              0 Pages (0 Bytes)
Total Memory:         32,487 MB (34,065,743,872 Bytes)

To select the largest free area, look for a row that starts with "Available" and that has the largest hex number in the 4th column (# pages). In my case, the value is
0x 7A 0000,
starting at
0x 1 0000 0000
(I'm grouping the digits in groups of 4 to make numbers easier to understand; I'm also adding 0x to make clear they are hex numbers).


Now the calculation of the slide value goes like this: subtract 0x 10 0000 to the start and divide the result by 0x 20 0000. I get 0x 7FF.


This is not an exact division. In fact, my hex calculator shows an hex float, like this: 0x 7FF.8. So I'm guessing that 0x 7FF is too short and 0x 800 is the right value. Let's check:


( 0x 7FF * 0x 20 0000 ) + 0x 10 0000 = 0x FFF0 0000 

which indeed is smaller than the original 0x 1 0000 0000


( 0x 800 * 0x 20 0000 ) + 0x 10 0000 = 0x 1  0010 0000

which is above 0x1 0000 0000


So 0x 800 is my slide value. Converted to decimal is 2048.


I'll try it this evening and see how this goes. I'll just use OsxAptioFix2Drv during a reboot, this usually gives me a printf error.


No luck. Trying slide=2048 or slide=0x800 with OsxAptioFix2Drv gives exactly the same result: Does printf work?? 
So I'm leaving this for now, since  OsxAptioFixDrv works fine, without any need for slider.

Share this post

Link to post
Share on other sites

Thnx. I have absolutely no idea what i do wrong, but i use the OsxAptioFixDrv-64.efi and i don't get a printf error. I see the many + characters but after that it just reboots.


I tried slide=0 but that didn't help either. Why doesn't this work? I'm using the exact same hardware as you do...






owhno!!! can i be so stupid???

During all my tries i resetted my bios... 1 thing i could forget to do was to lock CFG... guess what i forgot...

It goes on now... let's see if it works


Thanks for all the help so far!

Share this post

Link to post
Share on other sites

Hmm... i have another problem.

I tried to format my partition to install Mac OS on. It is a Samsung 960 evo. I formatted it as MacOS Journaled but it can't install on this drive. The error message is:


Guid partition table partitioning scheme is required


What can i do about this?



// Edit:


I did it, using my windows setup disc i formatted the ssd to gpt. Now it works.

The only stupid thing is that i erased my windows boot partition trying to format it using the Mac Installer... apperently i selected the wrong disk or partition, but yeah... it is installing!  :thumbsup_anim:  

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ale003
      Boa noite galera!
      já a alguns anos que tenho hackintosh, é um I7 6700K em uma Asus Maximus Hero VIII Z170 com GPU RX480 8gb
      Porém desde sempre tenho congelamentos aleatórios, na maioria das vezes quando coloco um filme pra exportar no final cut. mas já aconteceu enquanto via videos ou escutava musicas no spotify e recentemente até ao ligar o computador, mal ligou congelou. ele congela todo não dá pra mexer em nada, só desligando segurando botão power que ele volta.
      Me disseram que era gerenciamento de energia, eu baixei a DSDT do meu processador, segui alguns outros tutoriais e ainda nada. não consigo de jeito nenhum resolver esse problema, já instalei varias versões desde o yosemite até o High sierra, e ainda nada. Só esse pequeno detalhe que me desanima do Hack. 
      Alguem pode ajudar?
      High Sierra 10.13.6
      Asus Maximus Hero VIII
      RX 480 Nitrous + 8GB
      Trident Z 16GB DDR4 3200MHZ
    • By slapbass_
      Hola compañeros, buen dia, espero que esten bien en todo,
      necesito de su ayuda por favor,
      no lógro activar el sonido de mi laptop eh aqui las especificaciones:
      Dell Inspiron 14 5000 series (5458)
      - Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz
      - Ram 4GB»
      - Intel HD Graphics 5500
      - Red PCI :
      Intel Dual Band Wireless-AC 3160 AC HMC WiFi Adapter
      Realtek RTL8139/810x Fast Ethernet Adapter
      - Audio
      Intel Broadwell HDMI @ Intel Broadwell - Mini HD Audio
      Realtek ALC255 @ Intel Wildcat Point-LP PCH High defi.....
      alguien de ustedes que pueda darme una mano para ACTIVAR y que funcione todo el sonido y hdmi de mi laptop, les estare infinitamente agradecido con ustedes...
      aqui les dejo mi EFI
      Dios les bendiga n.n
    • By slapbass_
      Hello colleagues, good morning, I hope they are good in everything,
      I need your help please,
      I do not logically activate the sound of my laptop here specifications:
      Dell Inspiron 14 5000 series (5458)
      - Intel (R) Core (TM) i5-5200U CPU @ 2.20GHz
      - Ram 4GB »
      - Intel HD Graphics 5500
      - PCI Network:
      Intel Dual Band Wireless-AC 3160 AC HMC WiFi Adapter
      Realtek RTL8139 / 810x Fast Ethernet Adapter
      - Audio
      Intel Broadwell HDMI @ Intel Broadwell - Mini HD Audio
      Realtek ALC255 @ Intel Wildcat Point-LP PCH High defi .....
      Someone of you who can give me a hand to ACTIVATE and let all the sound and hdmi of my laptop work, I will be infinitely grateful to you ...
      Here is my EFI
      God bless you n.n
    • By THE M
      i've struggled to install Mac High Sierra from three days ago  with an strange error then my pc restart ......
      My PC specifications is
      Cpu amd Athlon 620 II x2
      Ram 8g
      Graphic Ati 5670 DDR3 2g
      Motharboard msi 970 amd

    • By kromakey
      Hello ,
      Just changed my CPU to a E5450 to be able to Run Mojave , but now I can not run not even EL Capitan    (it was working well with CORE2DUO)
      I already flashed a modified bios to be able to recognise the CPU.
      here some print screens from Verbose :
      AZUS P5K PRO  - CPU E5450 - NVIDIA 9600GT - 5G RAM