Jump to content
Allan

macOS High Sierra - Final Release is out! (17A365)

448 posts in this topic

Recommended Posts

If you leave out the FF/FFM values in your config.plist Clover will auto-fill them (not sure about BIOS string but you could try).

 

My FF value was out of date and gave me the firmware verify error at first. So I deleted it and let Clover take care of things and the install completed.

Share this post


Link to post
Share on other sites
Advertisement

my FF and FFM is empty (now, before i use 0xE907F537, get from internet). but the installation got error about can't pass the firmware checks

 

my bios version is MP51.88Z.007F.B03.1010071432 and the release date is 10/07/10

Share this post


Link to post
Share on other sites

Hi Guys,

 

Successfully updated both my desktop systems and my Dell XPS M1530 notebook to High Sierra Release - 10.13_17A365 :).

 

1.  GA-P55aUD3 with legacy BIOS/Intel i5-750/ATI HD5770/HFS+ HDD

post-846696-0-56828800-1506379506_thumb.png

 

2.  Skylake NUC6i5SYH with UEFI/Intel i5-6260U/Iris 540/APFS SSD

post-846696-0-40567100-1506385018_thumb.png

 

3.  Dell XPS M1530 legacy BIOS/Intel T9300/Geforce 8600M GT/HFS+ Ext HDD

post-846696-0-09624800-1506385121_thumb.png

 

 

Installation Notes
  • "Install macOS High Sierra.app" v 13.0.64 run directly from Applications folder for upgrade install of existing GM_17A362a
  • Updated to latest Clover r4220, Clover injected default values for FF/FFM/PF and BIOS ver/date/Board-ID data (iMac11,3, iMac17,1, MBP7,1) --> avoid error while "verifying firmware"
  • Latest apfs.efi driver in /EFI/CLOVER/drivers64 or /EFI/CLOVER/drivers64UEFI (only needed if APFS target volume)
  • Removed NVRAM.plist files from all EFI partitions (incl USB drives), ran sudo NVRAM -c command in terminal to reset NVRAM prior to update
  • On my Skylake NUC, I don't need or use EmuVariableUefi-64 ---> avoid OSInstall.mpkg damaged/missing error
  • If upgrading existing OS X on HDD, HFS+ is preserved (on SSD HFS+ will be converted automatically to APFS)
  • Certain SATA controllers will still have issues with AppleAHCIPort v329 (eg ICH10, 5 series, 7 series, ASMedia 1061) ---> Disks may fail to initialize, not readable or hot plug may fail.  AppleAHCIPort.kext v328 with version bundle 999.1.1 survives upgrade if installed in /L/E, and is loaded in preference to v329
  • A windows disk present on the machine during installation is OK.

Update 30 Sep 2017

@SunKi has discovered a patch for AppleAHCIPort.kext that fixes the SATA issues described above.  This can be applied in Clover config.plist/KextsToPatch...

 

 

			<dict>
				<key>Comment</key>
				<string>fix IO error ICH10 for 10.13, credit SunKi</string>
				<key>MatchOS</key>
				<string>10.13.x</string>
				<key>Disabled</key>
				<false/>
				<key>Name</key>
				<string>AppleAHCIPort</string>
				<key>Find</key>
				<data>RYX2D5XCiciD4P5mhcl4D4TSdQs=</data>
				<key>Replace</key>
				<data>iciD4P5mhckPmMFBCMyQkJCQdQs=</data>
			</dict>

 

 

Clover_v2.4k_r4221.zip

apfs_17A365.efi.zip

Share this post


Link to post
Share on other sites

my bios version is MP51.88Z.007F.B03.1010071432 and the release date is 10/07/10

 

That's too old. What version of Clover are you using? I use MP5,1 on my X79 and I'm pretty sure Clover replaced my bios string values with the newer ones. If you haven't updated Clover in a while, grab 4220 from sourceforge and try with that.

Share this post


Link to post
Share on other sites

That's too old. What version of Clover are you using? I use MP5,1 on my X79 and I'm pretty sure Clover replaced my bios string values with the newer ones. If you haven't updated Clover in a while, grab 4220 from sourceforge and try with that.

4220

Share this post


Link to post
Share on other sites

@ricoc90 and @mnfesq - O.T: Did you notice a good (reasonable/excellent) performance with Intel HD 4000 + macOS 10.13?  :)

 

Yup, no issues at all. Well, The screen sometimes gets a little distorted when transitioning from the boot to the login UI, but that's about it  :)

Share this post


Link to post
Share on other sites

Jesus, finaly, now can install the update! (I hope this don't crash durning I sleep)

 

Leave empty the FF, FFM, bios version and release date do the trick.

 

Tomorrow more things

 

Greetings

Share this post


Link to post
Share on other sites

Make sure your iGPU is at _/SB.PCI0.IGPU

 

Are you sure this is accurate?  I don't have any forward slashes in my DSDT.  Do you mind attaching your DSDT, please?

@ricoc90 and @mnfesq - O.T: Did you notice a good (reasonable/excellent) performance with Intel HD 4000 + macOS 10.13?  :)

 

Once video loads for me, it is, indeed, excellent.  However, I have had lots of trouble getting video to load because of my discreet GPU.  High Sierra doesn't seem to like both onboard and discreet GPU's.  It seems to want one or the other.

Share this post


Link to post
Share on other sites

Are you sure this is accurate?  I don't have any forward slashes in my DSDT.  Do you mind attaching your DSDT, please?

 

No, the / was a typo. I just meant to say that your IGPU should be named IGPU (so not GFX0)

Share this post


Link to post
Share on other sites

No, the / was a typo. I just meant to say that your IGPU should be named IGPU (so not GFX0)

 

So that's where I get stuck.  When I change GFX0 to IGPU, video no longer loads in High Sierra.  That's what I'm working on now.

Share this post


Link to post
Share on other sites

Hi Guys,

 

Successfully updated both my desktop systems and my Dell XPS M1530 notebook to High Sierra Release - 10.13_17A365 :).

 

1. GA-P55aUD3 with legacy BIOS/Intel i5-750/ATI HD5770/HFS+ HDD

 

 

2. Skylake NUC6i5SYH with UEFI/Intel i5-6260U/Iris 540/APFS SSD

 

3. Dell XPS M1530 legacy BIOS/Intel T9300/Geforce 8600M GT/HFS+ Ext HDD

 

Installation Notes

  • "Install macOS High Sierra.app" v 13.0.64 run directly from Applications folder for upgrade install of existing GM_17A362a
  • Updated to latest Clover r4220, Clover injected default values for FF/FFM/PF and BIOS ver/date/Board-ID data (iMac11,3, iMac17,1, MBP7,1) --> avoid error while "verifying firmware"
  • Latest apfs.efi driver in /EFI/CLOVER/drivers64 or /EFI/CLOVER/drivers64UEFI (only needed if APFS target volume)
  • Removed NVRAM.plist files from all EFI partitions (incl USB drives), ran sudo NVRAM -c command in terminal to reset NVRAM prior to update
  • On my Skylake NUC, I don't need or use EmuVariableUefi-64 ---> avoid OSInstall.mpkg damaged/missing error
  • If upgrading existing OS X on HDD, HFS+ is preserved (on SSD HFS+ will be converted automatically to APFS)
  • Certain SATA controllers will still have issues with AppleAHCIPort v329 (eg ICH10, 5 series, 7 series, ASMedia 1061) ---> Disks may fail to initialize, not readable or hot plug may fail. AppleAHCIPort.kext v328 with version bundle 999.1.1 survives upgrade if installed in /L/E, and is loaded in preference to v329
  • A windows disk present on the machine during installation is OK.
Do you have itune crash(randomly) on your NUC6i5SYH?

 

I'm gathering reason about itunes crash.

 

I suspect igpu driver or something

 

나의 LG-F800S 의 Tapatalk에서 보냄

iTunes always crash crash and crash.

 

6700HQ+HD530

8250U+UHD620

This two have same problem when open the itunes and forceclsed.

 

But the 2410m+HD3000 with no crash with iTunes.

 

 

从我的 iPhone 发送,使用 Tapatalk

What is your platformid for uhd620?

Empty with lastest clover?

 

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

Do you have itune crash(randomly) on your NUC6i5SYH?

 

I'm gathering reason about itunes crash.

 

I suspect igpu driver or something

 

나의 LG-F800S 의 Tapatalk에서 보냄

What is your platformid for uhd620?

Empty with lastest clover?

 

나의 LG-F800S 의 Tapatalk에서 보냄

UHD620 using fakeid with 59160000.

But HD530 was empty with Clover and with no problem in 10.12.

 

 

从我的 iPhone 发送,使用 Tapatalk

Share this post


Link to post
Share on other sites

UHD620 using fakeid with 59160000.

But HD530 was empty with Clover and with no problem in 10.12.

 

 

从我的 iPhone 发送,使用 Tapatalk

I did latest clover has 59160000 for uhd 620.

I just ask you to check fakeid and platformid with both empty.

 

Sorry for my bad english

 

Thanks

 

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

I did latest clover has 59160000 for uhd 620.

I just ask you to check fakeid and platformid with both empty.

 

Sorry for my bad english

 

Thanks

 

나의 LG-F800S 의 Tapatalk에서 보냄

and in my xps with HD530 when i drag files to some folders the windows of the folders will be gitches.

 

 

从我的 iPhone 发送,使用 Tapatalk

Share this post


Link to post
Share on other sites

and in my xps with HD530 when i drag files to some folders the windows of the folders will be gitches.

 

 

从我的 iPhone 发送,使用 Tapatalk

I never see glitches of folders on my hd 520 laptop. This case only high sierra?

 

Also itunes crash is hard to catch problem point.

I removed all acpi stuff and binary patch, changed smbios and test. Still exist problem.

In my desktop, there is no itunes crash. I compared both system. But still no luck.

 

 

 

 

 

 

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

I never see glitches of folders on my hd 520 laptop. This case only high sierra?

 

Also itunes crash is hard to catch problem point.

I removed all acpi stuff and binary patch, changed smbios and test. Still exist problem.

In my desktop, there is no itunes crash. I compared both system. But still no luck.

 

 

나의 LG-F800S 의 Tapatalk에서 보냄

Not all folder will have gitches.

 

I test it with when i drag kexts to EFI/Clover/Kexts/Others it will githes but it is not 100% shows up.

 

 

 

从我的 iPhone 发送,使用 Tapatalk

I never see glitches of folders on my hd 520 laptop. This case only high sierra?

 

Also itunes crash is hard to catch problem point.

I removed all acpi stuff and binary patch, changed smbios and test. Still exist problem.

In my desktop, there is no itunes crash. I compared both system. But still no luck.

 

나의 LG-F800S 의 Tapatalk에서 보냄

Do you use shiki.kext?

 

I will test if it is related with shiki because only this kext related with iTunes.

 

 

 

从我的 iPhone 发送,使用 Tapatalk

Share this post


Link to post
Share on other sites

Not all folder will have gitches.

 

I test it with when i drag kexts to EFI/Clover/Kexts/Others it will githes but it is not 100% shows up.

 

 

 

从我的 iPhone 发送,使用 Tapatalk

 

Do you use shiki.kext?

 

I will test if it is related with shiki because only this kext related with iTunes.

 

 

 

从我的 iPhone 发送,使用 Tapatalk

 

Do you use shiki.kext

- i tested both "with" or "without". but still no luck. very strange issue.

 

your laptop hdmi work on high sierrra? i dont have any issue in sierra. hdmi and itunes. strangely not detect hdmi. ofc patches are same like sierra.

 

i changed smbios imac13,1 and i tested itunes. seems no itunes crash. not sure. but shown better.

Share this post


Link to post
Share on other sites

Do you use shiki.kext

- i tested both "with" or "without". but still no luck. very strange issue.

 

your laptop hdmi work on high sierrra? i dont have any issue in sierra. hdmi and itunes. strangely not detect hdmi. ofc patches are same like sierra.

 

i changed smbios imac13,1 and i tested itunes. seems no itunes crash. not sure. but shown better.

Yes i test shiki with and without but no lucky.

 

I have no idea about this problem.

 

Wait someone fine error log about the crash.

 

 

从我的 iPhone 发送,使用 Tapatalk

Share this post


Link to post
Share on other sites

Hi,

 

How can I create an USB installer ? Because when download High Sierra it downloads just 15 MB and after I start the installer it gets the other 4 GB part..

Share this post


Link to post
Share on other sites

Sleep mode issue.

Anybody else got this behaviour?

Laptop Yoga 710IKB.

Everything else is working as it should, and only problem is duplicate screen at the right side.

Hdmi out is working (wake after sleep) and the problem is not related to it!

This problem existed at previous beta versions too, and I hoped it would be fixed HS final release.

But it’s still there…

Anyone?

 

High Sierra related bug?

post-2200747-0-78020400-1506411193_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By plasticworld
      After a long run, I successfully upgraded High Sierra to mojave 10.14 on an intel 5 series chipset MotherBoard.
       
      MotherBoard: H55ms2
      RAM: 6GB
      GPU1: Saphire AMD RX 460
      GPU2: Nvidia 8400GS
      Storage: 500 GB HDD WD Green.
       
      The requirement:
      1) macOS pre mojave.
      2) macOS mojave installer from Apple store.
      3) Empty partition or USB to upgrade from.
      4) Un-mout all unused dmgs.
      5) GPT/GUID HDD.
       
      HOWOT:
      1) Prepare an empty partition or USB with at least 6 GB.
      2) Format the partition or USB with GUID partition table and HFS+ partition with a name BootablePartition.
      3) Go to /Application/Install macOS Mojave.app.
      4) Show Package Contents.
      5) Go to Contents/SharedSupport you will find BaseSystem.dmg.
      6) Double click on BaseSystem.dmg to mount.
      7) From Disk Utilty click on your partition or the USB that you prepared from number (2).
      8) Click on restore, and chose OS X Base System (BaseSystem.dmg image), then restore it to that partition or USB.
      9) After restoring rename the partition back to BootablePartition.
      9) Run this command:
      rm -rfv /Volumes/BootablePartition/System/Installation/Packages 10) Create a new folder instead of the broken link and name it Packages, run this command:
      mkdir -v /Volumes/BootablePartition/System/Installation/Packages 11) Go back to /Application/Install macOS Mojave.app and repeat number 2.
      12) Go to Contents/SharedSupport you will find InstallESD.dmg.
      13) Mount InstallESD.dmg.
      14) Run this command:
      cp -v /Volumes/InstallESD/Packages/OSInstall.mpkg /Volumes/BootablePartition/System/Installation/Packages/ 15) Download the latest clover from https://sourceforge.net/projects/cloverefiboot/
      16) Install clover on your USB BootablePartition or in a different USB to boot from it. delete all your CLOVER/kext/10.xx and keep others, make sure you don't have any extra kext rather than FakeSMC.kext in the other folder.
      in my case I used FakeSMC.kext and my lan kext RealtekRTL8111.kext.
      17) known Problems in my build: 
      If I updated directly from the apple store the installer in clover will boot with a cross circle sign.
      The FIX is to add this to Clover KextToPatch Thanks to @sunKi http://www.insanelymac.com/forum/topic/327488-macos-high-sierra-final-release-is-out-17a365/page-10?do=findComment&comment=2505086 this fix is still working for me in mojave.
      <key>KextsToPatch</key> <array> <dict> <key>Comment</key> <string>fix IO error ICH10 for 10.13, credit SunKi</string> <key>Disabled</key> <false/> <key>Find</key> <data> RYX2D5XCiciD4P5mhcl4D4TSdQs= </data> <key>Name</key> <string>AppleAHCIPort</string> <key>Replace</key> <data> iciD4P5mhckPmMFBCMyQkJCQdQs= </data> </dict> <dict> <key>Comment</key> <string>fix hotplug ICH10 for 10.13, credit SunKi</string> <key>Disabled</key> <false/> <key>Find</key> <data> icglQGACAD1AIAAAdQyB4b9///+Ji1EBAAA= </data> <key>Name</key> <string>AppleAHCIPort</string> <key>Replace</key> <data> kJCQkJCQkJCQkJCQkJCQkJCQkJCQkJCQkJA= </data> </dict> <dict> <key>Comment</key> <string>External icons patch</string> <key>Disabled</key> <false/> <key>Find</key> <data> RXh0ZXJuYWw= </data> <key>Name</key> <string>AppleAHCIPort</string> <key>Replace</key> <data> SW50ZXJuYWw= </data> </dict> </array> 18) make sure you have apfs.efi copy it from /Volumes/BootablePartition/usr/standalone/i386/apfs.efi to your EFI/CLOVER/drivers64/ and EFI/CLOVER/drivers64UEFI/.
      19) SMBIOS mac model that I use is iMac13,2.
      20) Go to /Application/Install macOS Mojave.app click on it and chose to install to your macOS Mojave partition.
      21) Reboot.
      22) From clover chose BootablePartion.
      23) If everything is okie BootablePartition will boot to install macOS mojave, wait wait wait till it finish it might take to 1 hour just wait it will reach the auto reboot soon .
      24) Boot to your old macOS Hight Sierra that will be your mojave partition now and enjoy.
       
      POST Install:
      1) audio: 
      a) Download Lilu.kext and AppleALC.kext or build them from source (which I did).
      b) place them in your /EFI/CLOVER/kext/others/
      c) add your audio layout in clover/Devices dict options in my case it's ALC888B which has the layout of 1:
      <key>Audio</key> <dict> <key>Inject</key> <string>1</string> </dict> d) I had to add beta args to clover/Boot dict, argument (-lilubeta -alcbeta):
       
      <key>Arguments</key> <string>-lilubeta -alcbeta</string> 2) Add number 14 KextsToPath array to your clover as well.

      Anything else is working for me I didn't need any extra clover kext so far, I tried whatevergreen.kext to fire up my rx 460 without the helper card but no success, So I am just sticking with booting from Nvidia as a first GPU from my motherboard configuration then swap the cables after choosing my macOS partion from clover.
       
      After upgrading my HFS+ High Sierra partition converted to APFS, no know problem so far.

      Happy build and more info about the partitioning method with a more detailed instructions in this post that I used to update my Sierra to High Sierra
       
      Special thanks to crazybirdy, sunKi and all of you out there that make this happens.
    • By NoEnd
      Hi team,
       
      I have tried to update to security update 2019-001 multiple time with no luck, today I've booted the update with -verbose and attached videos shows the details.
       
      Appreciate your help
       
      Thanks
      Untitled.mov
    • By JhonneR
      Good morning, everyone, I'm sorry if I was wrong in choosing the topic but I need help.
      I have found it extremely difficult to mount a Hackintosh in my acer.
      Setup;
      I5 2430m 2.4 6GB RAM
      Mobo P5we0 - Intel intel Graphics 3000
      At the moment I have not found out what my audio codecs are.
      but I'll leave the link on the motherboard.
      however, my real problem is several.
      I have already used the itakos image, I have already used several images that could be installed normally and that after installing the image I do not have internet via cable or wireless.
      And another, I already looked in other forums and I know that I will be called a donkey in the logical question but I have not been able to install the [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] or clover to start from the Hard Disk, so I do not know what to do.At the moment I still do not know if there has already been someone who has already installed the High Sierra or just the Sierra in this notebook model and obtained permanent success.
      If anyone can help me, I'll be grateful.
      Installations without success, but with the system already installed in ACER;
      SIERRA
      HIGH SIERRA
      MOJAVE
      All with the same symptom. Starting only by the bootable USB stick and without internet connection via cable and wireless.
      Appreciate ! Acer 5750 Official Page
    • By gengik84
      Ciro82==>>Thanks
      Uno dei tre Requisiti:
      Hack funzionante Mac vero Macchina virtuale Impostazioni Bios per il boot:
      Cercate una voce  del tipo “Sata Mode”e settatela  in AHCI
      Secure Boot: disabilitare o altri sistemi operativi
      CSM: UEFI o LEGACY, oppure a secondo del tipo di installazione
      VT-x / VT-d disable
      *Nota: Secure boot e csm valido solo per bios UEFI
      Materiale Occorrente 
      "OS X (Versione App.Store)”
      USB 8GB  *nota: nel caso di usb superiori dovrà essere partizionata, in modo da avere una partizione su cui "lavoreremo,di questa dimensione
      ShowAllfiles 
      kext Wizard 
      Bootloader Clover_2.3k_r xxx:                   http: //sourceforge.n.../cloverefiboot/
      Clover Configurator:                                    http: //mackie100proj...a.org/download/
      FakeSmc.kext:                                            https://github.com/kozlek/HWSensors/releases
      In allegato,a fondo pagina troverete un "pacchetto" contenente : ShowAllfiles, Kext Wizard, FakeSmc.kext: 
      App alternative:
      ESP Mounter Pro: per montare la partizione EFI
      Vi illustrerò tre metodi per creare la usb, ma sono ben distinti… quindi usatene soltanto uno
      Metodo 1: “Install Mac_OS_X.command” Metodo 2: “Create Install Media di Apple” Metodo 3:  Metodo Manuale Alla fine delle preparazione dell’installer, tutti i metodi necessitano l’installazione del Bootloader Clover sulla a vostra USB.
      “CONDIZIONI OBBLIGATORIE”
      PUNTO 1: che la vostra usb sia stata preventivamente nominata USB (caratteri maiuscoli) Tabella di partizione GUID e la formattazione in  Mac esteso Journaled.
      PUNTO 2: che l’installer di OSX si trovi in Applicazioni
      Utility Disco 
      Selezionate la pendrive, andate su “partizione”, selezionate “1 partizione”, impostate Mac OS esteso journaled e date il nome USB, poi in basso cliccate su opzioni e scegliete Tabella partizione (GUID), poi “applica”.
      Immagine 
      Riporto nuovamente l’operazione sopra citata adoperando dal nuovo Utility Disco introdotto su El Capitan.
      Rimane ovviamente invariato nome della usb in ==>> USB (maiuscolo), la formattazione in Mac esteso Journaled e sia la mappa partizione in GUID
      Da utility disco selezionate la usb, cliccate su inizializza.
      dal menù a tendina scegliete la relative impostazioni
      Immagine  
      Procedura effettua da High Sierra è la stessa della precedente, l'unica attenzione e operazione da aggiungere in primis  è cliccare nel menù a tendina in alto sulla sinistra di utility disco e selezionare "mostra tutti i dispositivi"
      Immagine 
       
      =====================
        METODO 1: "Install_Mac_OS_X.Command" Lo script che trovate allegato in fondo alla guida permette la creazione dell’installer in maniera automatica
      Include la possibilità di scelta di tre versioni di osx
      Yosemite El Capitan Sierra Il risultato finale è come quello del metodo "manuale" descritto nella guida, per cui l'installazione avverrà in un solo passaggio, non in due come con il metodo createinstallmedia. 
      Offre inoltre la possibilità di inserire un kernel patchato, utile, per esempio, per chi usa AMD.
      Rimane invariato il nome dato alla usb in USB, mappa partizione e tipo di formattazione
      Se la vostra usb non sarà rinominata nel modo corretto, verrete avvisati dal terminale, quindi non dovrete far altro che apportare la relativa modifica e rilanciare nuovamente lo script
      Esempio
      ===========================
      Metodo 2 
      L'intento è quello di usare la procedura fornitaci direttamente da Apple, "createinstallmedia", introdotta  con Mavericks. 
      Tale metodo prevede l’uso del terminale che via via se ne sta perdendo il “valore e l’uso”
      Inizialmente per i neofiti potrà sembrare problematico ma alla fine non è così.
      Durante il post installazione alcune operazioni ne richiedono l’ uso.
      Perciò mi sono chiesto perchè, qualora uno volesse, non far conoscere da subito un po’ questo “strumento”???
      Per favorirvi vi ho allegato i comandi già  “pronti”, i quali li potrete copiare ed incollare sul terminale.
      A questo punto aprite il terminale, copiate ed incollate il comando sottostante e premete invio, digitate la vostra password e premete nuovamente invio.
      Comando per creare USB con Yosemite:
      sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction  
      Comando per creare USB con El Capitan
      sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction Comando per creare USB con Sierra 
      sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ Sierra.app/ --nointeraction Per creare USB con Hight Sierra o Mojave usate --> C_I_M (aggiornato per 10.14)
       
      Funziona con il drag & drop sul terminale, in questo caso non vi è necessità che la usb sia nominata in un determinato modo ed essendo basato su create install media ovviamente funziona da 10.9 a 10.14.... 
      BENE…IL PROCESSO DI CREAZIONE E’ INIZIATO…
      AVREMO CIRCA 20/30 MINUTI DI TEMPO LIBERO A CUI DEDICARSI A CIO’ CHE VOGLIAMO………………………………………..  
      COLGO L’OCCASIONE PER FARVI NOTARE LA VELOCITA’ E LA SICUREZZA DI QUESTO METODO
      CONFRONTATE QUESTO CON IL TERZO METODO E NOTERETE CHE CON UN SOLO PASSAGGIO, OSSIA IL COMANDO DATO AL TERMINALE, FACCIAMO IN UNA SINGOLA OPERAZIONE TUTTI I VARI STEP DESCRITTI SULL’ ALTRO METODO.
      DETTO QUESTO, MOLTO IMPORTANTE E’ SOTTOLINEARE CHE COSI’ FACENDO EVITEREMO ERRORI  DI DISTRAZIONE RIGUARDO AI PASSAGGI O FRAINTENDIMENTI.
      Immagine 
      Potete adesso passare ad installare il bootloader Clover sulla vostra usb.
      *NOTA*:
      Avendo usato questo metodo l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      =========================
      METODO "MANUALE"....  (lascio per futura memoria-Compatibile fino a 10.12)
      ==========================
      Bootloader
      **Nota:** Installazione in UEFI  dipenderà dalla scheda madre in vostro possesso, quindi se non supporta tale opzione , il bootloader dovrà essere installato in  modalità Legacy.
       Vi invito, qualora non sapeste questa informazione, a recarvi nel sito ufficiale del produttore e controllare le informazioni a riguardo
      Fatto questo dobbiamo installare  Clover sulla usb.
      A seconda del tipo di Bios o al tipo di installazione che vogliamo fare UEFI o Legacy avremo ovviamente configurazioni diverse in questa fase.
      Lanciate il pkg.
      Immagine 

       
      Cambiate la destinazione di installazione ad USB oppure Install Mac_OS_X (a secondo del tipo di creazione eseguita)
      Successivamente clicchiamo su "Ad Hoc"
      Per Installazione UEFI
      Mettete i flag   : Installazione solo per avvio UEFI
                               : installare Clover nella ESP
                               : Driver64UEFI  AptioMemory --> (consigliato) 
                               : Driver64UEFI  ApfsDriverLoader --> (consigliato) --> sostituisce l'uso del driver apfs.efi
                               : Selezionate l'altri driver come da successiva immagine,
       
      *Nota: Altri driver che si possono usare  al suo posto  sono:
       informazioni 
       
      Proseguite con l’installazione.
      Immagine 
      ** Ricordate che avrete accesso a questa cartella dopo aver montato la partizione EFI**
      ===========================
      Per installazione Legacy
      Immagine 
      ===========================
      Impostazione per config.plist:
      Con clover configurator “montate” la partizione EFI della usb.
      1) Per fare questo nel menù di sinistra, cliccate su “Mount EFI”
      2) individuate la partizione relativa alla vostra usb, a questo punto montiamo la relativa partizione EFI  selezionando l’apposito pulsante “Mount Partition”
      Immagine 
      3) Successivamente cliccate su “Open Partition”.. recatevi in EFI/Clover ed aprite il config.plist
      4) Sezione ACPI: Disabilitate tutti i fix sia del menù 1 che del menù 2
      Immagine 
      5) Sezione BOOT: Sole se si sta installando Yosemite mettete il flag su kext-dev-mode=1
      Immagine 
      6) Sezione RT Variables: Se si sta installando El Capitan oppure Sierra, aggiungere i valori: BooterConfig= 0x28, CsrActiveConfig= 0x67
      Immagine 
      7) Sezione System Parameters: Su inject kext mettete YES
      Immagine 
      ===========================
      Nota: Su El Capitan, è stato introdotto SIP (System Integrity Protection)
      Info:
      ===========================
      Recatevi in EFI/Clover/kext/10.x 
      X= alla versione di osx che state installando. Per esempio se installerete Yosemite dovrete recarvi nella cartella 10.10, con El Capitan in 10.11….ecc
      Se non ci fosse tale cartella, createla e nominatela voi a “modo”.
      Copiatevi all’interno FakeSmc.kext
      *Nota se venite già da altre vostre configurazioni, oltre kext sopra citato ,potete mettere gli altri necessari per il vostro hardware
      Stessa cosa se avete DSDT e/o SSDT potete copiarli in EFI/Clover/Acpi/Patched
      Immagine 
      
      Per High Sierra:
      Scaricare il driver apfs.efi a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
       
      Per chi volesse continuare ad usare HFS vi rimando a questo post:
        Come installare High Sierra in HFS direttamente dalla usb  
      Utenti Laptop:  Nel 99% è obbligatorio disattivare la grafica discreta Nvidia/Amd per installare questo nuovo osx
                                     Quindi aggiungete --> SSDT-Disable_DGPU.aml.zip
                                     in EFI/Clover/acpi/Patched della usb
      --------------------------------------------------------------------
      Per Mojave:
      Scaricare il driver apfs.efi per 10.14 a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
      Versione di clover non antecedente a V_4015
      Volete usare HFS?
      E' possibile fare un installazione diretta su altro disco o partizione, nel caso può essere usato anche per effettuare aggiornamenti...
      nel caso guardate...
       Mojave in HFS 
       Oppure direttamente da usb  
       
      Fatto questo avrete la vostra USB bootable per installare OSX.
      ………Non scordatevi Fakesmc.kext da mettere nella relativa cartella…. senza il quale non farete mai il Boot......
      *NOTA: se usato il terminale per la creazione della usb, l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      **NOTA** Se avete processori Broadwell,Skylake o Kabylake...usate FakeSmc.kext e relativi sensors che trovate all'interno del secondo pacchetto.. (potete usarlo anche sui precedenti senza problemi, essendo una versione più aggiornata ha ulteriore supporto per le cpu più recenti)
      Update: Fakesmc e sensors versione 6.26
      Post installazione... post #2           
       Buon Hack….. 
      Aggiornamento:Install_Mac_OS_X.command.zip (compatibile da 10.10 a 10.12)
      le info le trovate a questo post
      Ringrazio @Ciro82 che mi ha aiutato nel preparare questa guida.
      Pacchetto.zip
      Pacchetto-2.zip
      apfs.efi-10.13-NoLog.zip
      Pacchetto-Fake+Sensors 6.26.1440.zip
      apfs.efi-10.13.1-No_LOG.zip
      apfs.efi-10.13.2_No_Log.zip
      apfs.efi-10.13.3-No_Log.zip
      apfs.efi-10.13.4-No_Log.zip
      apfs.efi-10.13.5_No_Log.zip
      C_I_M.zip
       
      apfs.efi-10.14-beta1_No_Log.zip





       

×