Jump to content
Allan

macOS High Sierra - Final Release is out! (17A365)

448 posts in this topic

Recommended Posts

If you leave out the FF/FFM values in your config.plist Clover will auto-fill them (not sure about BIOS string but you could try).

 

My FF value was out of date and gave me the firmware verify error at first. So I deleted it and let Clover take care of things and the install completed.

Share this post


Link to post
Share on other sites
Advertisement

my FF and FFM is empty (now, before i use 0xE907F537, get from internet). but the installation got error about can't pass the firmware checks

 

my bios version is MP51.88Z.007F.B03.1010071432 and the release date is 10/07/10

Share this post


Link to post
Share on other sites

Hi Guys,

 

Successfully updated both my desktop systems and my Dell XPS M1530 notebook to High Sierra Release - 10.13_17A365 :).

 

1.  GA-P55aUD3 with legacy BIOS/Intel i5-750/ATI HD5770/HFS+ HDD

post-846696-0-56828800-1506379506_thumb.png

 

2.  Skylake NUC6i5SYH with UEFI/Intel i5-6260U/Iris 540/APFS SSD

post-846696-0-40567100-1506385018_thumb.png

 

3.  Dell XPS M1530 legacy BIOS/Intel T9300/Geforce 8600M GT/HFS+ Ext HDD

post-846696-0-09624800-1506385121_thumb.png

 

 

Installation Notes
  • "Install macOS High Sierra.app" v 13.0.64 run directly from Applications folder for upgrade install of existing GM_17A362a
  • Updated to latest Clover r4220, Clover injected default values for FF/FFM/PF and BIOS ver/date/Board-ID data (iMac11,3, iMac17,1, MBP7,1) --> avoid error while "verifying firmware"
  • Latest apfs.efi driver in /EFI/CLOVER/drivers64 or /EFI/CLOVER/drivers64UEFI (only needed if APFS target volume)
  • Removed NVRAM.plist files from all EFI partitions (incl USB drives), ran sudo NVRAM -c command in terminal to reset NVRAM prior to update
  • On my Skylake NUC, I don't need or use EmuVariableUefi-64 ---> avoid OSInstall.mpkg damaged/missing error
  • If upgrading existing OS X on HDD, HFS+ is preserved (on SSD HFS+ will be converted automatically to APFS)
  • Certain SATA controllers will still have issues with AppleAHCIPort v329 (eg ICH10, 5 series, 7 series, ASMedia 1061) ---> Disks may fail to initialize, not readable or hot plug may fail.  AppleAHCIPort.kext v328 with version bundle 999.1.1 survives upgrade if installed in /L/E, and is loaded in preference to v329
  • A windows disk present on the machine during installation is OK.

Update 30 Sep 2017

@SunKi has discovered a patch for AppleAHCIPort.kext that fixes the SATA issues described above.  This can be applied in Clover config.plist/KextsToPatch...

 

 

			<dict>
				<key>Comment</key>
				<string>fix IO error ICH10 for 10.13, credit SunKi</string>
				<key>MatchOS</key>
				<string>10.13.x</string>
				<key>Disabled</key>
				<false/>
				<key>Name</key>
				<string>AppleAHCIPort</string>
				<key>Find</key>
				<data>RYX2D5XCiciD4P5mhcl4D4TSdQs=</data>
				<key>Replace</key>
				<data>iciD4P5mhckPmMFBCMyQkJCQdQs=</data>
			</dict>

 

 

Clover_v2.4k_r4221.zip

apfs_17A365.efi.zip

Share this post


Link to post
Share on other sites

my bios version is MP51.88Z.007F.B03.1010071432 and the release date is 10/07/10

 

That's too old. What version of Clover are you using? I use MP5,1 on my X79 and I'm pretty sure Clover replaced my bios string values with the newer ones. If you haven't updated Clover in a while, grab 4220 from sourceforge and try with that.

Share this post


Link to post
Share on other sites

That's too old. What version of Clover are you using? I use MP5,1 on my X79 and I'm pretty sure Clover replaced my bios string values with the newer ones. If you haven't updated Clover in a while, grab 4220 from sourceforge and try with that.

4220

Share this post


Link to post
Share on other sites

@ricoc90 and @mnfesq - O.T: Did you notice a good (reasonable/excellent) performance with Intel HD 4000 + macOS 10.13?  :)

 

Yup, no issues at all. Well, The screen sometimes gets a little distorted when transitioning from the boot to the login UI, but that's about it  :)

Share this post


Link to post
Share on other sites

Jesus, finaly, now can install the update! (I hope this don't crash durning I sleep)

 

Leave empty the FF, FFM, bios version and release date do the trick.

 

Tomorrow more things

 

Greetings

Share this post


Link to post
Share on other sites

Make sure your iGPU is at _/SB.PCI0.IGPU

 

Are you sure this is accurate?  I don't have any forward slashes in my DSDT.  Do you mind attaching your DSDT, please?

@ricoc90 and @mnfesq - O.T: Did you notice a good (reasonable/excellent) performance with Intel HD 4000 + macOS 10.13?  :)

 

Once video loads for me, it is, indeed, excellent.  However, I have had lots of trouble getting video to load because of my discreet GPU.  High Sierra doesn't seem to like both onboard and discreet GPU's.  It seems to want one or the other.

Share this post


Link to post
Share on other sites

Are you sure this is accurate?  I don't have any forward slashes in my DSDT.  Do you mind attaching your DSDT, please?

 

No, the / was a typo. I just meant to say that your IGPU should be named IGPU (so not GFX0)

Share this post


Link to post
Share on other sites

No, the / was a typo. I just meant to say that your IGPU should be named IGPU (so not GFX0)

 

So that's where I get stuck.  When I change GFX0 to IGPU, video no longer loads in High Sierra.  That's what I'm working on now.

Share this post


Link to post
Share on other sites

Hi Guys,

 

Successfully updated both my desktop systems and my Dell XPS M1530 notebook to High Sierra Release - 10.13_17A365 :).

 

1. GA-P55aUD3 with legacy BIOS/Intel i5-750/ATI HD5770/HFS+ HDD

 

 

2. Skylake NUC6i5SYH with UEFI/Intel i5-6260U/Iris 540/APFS SSD

 

3. Dell XPS M1530 legacy BIOS/Intel T9300/Geforce 8600M GT/HFS+ Ext HDD

 

Installation Notes

  • "Install macOS High Sierra.app" v 13.0.64 run directly from Applications folder for upgrade install of existing GM_17A362a
  • Updated to latest Clover r4220, Clover injected default values for FF/FFM/PF and BIOS ver/date/Board-ID data (iMac11,3, iMac17,1, MBP7,1) --> avoid error while "verifying firmware"
  • Latest apfs.efi driver in /EFI/CLOVER/drivers64 or /EFI/CLOVER/drivers64UEFI (only needed if APFS target volume)
  • Removed NVRAM.plist files from all EFI partitions (incl USB drives), ran sudo NVRAM -c command in terminal to reset NVRAM prior to update
  • On my Skylake NUC, I don't need or use EmuVariableUefi-64 ---> avoid OSInstall.mpkg damaged/missing error
  • If upgrading existing OS X on HDD, HFS+ is preserved (on SSD HFS+ will be converted automatically to APFS)
  • Certain SATA controllers will still have issues with AppleAHCIPort v329 (eg ICH10, 5 series, 7 series, ASMedia 1061) ---> Disks may fail to initialize, not readable or hot plug may fail. AppleAHCIPort.kext v328 with version bundle 999.1.1 survives upgrade if installed in /L/E, and is loaded in preference to v329
  • A windows disk present on the machine during installation is OK.
Do you have itune crash(randomly) on your NUC6i5SYH?

 

I'm gathering reason about itunes crash.

 

I suspect igpu driver or something

 

나의 LG-F800S 의 Tapatalk에서 보냄

iTunes always crash crash and crash.

 

6700HQ+HD530

8250U+UHD620

This two have same problem when open the itunes and forceclsed.

 

But the 2410m+HD3000 with no crash with iTunes.

 

 

从我的 iPhone 发送,使用 Tapatalk

What is your platformid for uhd620?

Empty with lastest clover?

 

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

Do you have itune crash(randomly) on your NUC6i5SYH?

 

I'm gathering reason about itunes crash.

 

I suspect igpu driver or something

 

나의 LG-F800S 의 Tapatalk에서 보냄

What is your platformid for uhd620?

Empty with lastest clover?

 

나의 LG-F800S 의 Tapatalk에서 보냄

UHD620 using fakeid with 59160000.

But HD530 was empty with Clover and with no problem in 10.12.

 

 

从我的 iPhone 发送,使用 Tapatalk

Share this post


Link to post
Share on other sites

UHD620 using fakeid with 59160000.

But HD530 was empty with Clover and with no problem in 10.12.

 

 

从我的 iPhone 发送,使用 Tapatalk

I did latest clover has 59160000 for uhd 620.

I just ask you to check fakeid and platformid with both empty.

 

Sorry for my bad english

 

Thanks

 

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

I did latest clover has 59160000 for uhd 620.

I just ask you to check fakeid and platformid with both empty.

 

Sorry for my bad english

 

Thanks

 

나의 LG-F800S 의 Tapatalk에서 보냄

and in my xps with HD530 when i drag files to some folders the windows of the folders will be gitches.

 

 

从我的 iPhone 发送,使用 Tapatalk

Share this post


Link to post
Share on other sites

and in my xps with HD530 when i drag files to some folders the windows of the folders will be gitches.

 

 

从我的 iPhone 发送,使用 Tapatalk

I never see glitches of folders on my hd 520 laptop. This case only high sierra?

 

Also itunes crash is hard to catch problem point.

I removed all acpi stuff and binary patch, changed smbios and test. Still exist problem.

In my desktop, there is no itunes crash. I compared both system. But still no luck.

 

 

 

 

 

 

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

I never see glitches of folders on my hd 520 laptop. This case only high sierra?

 

Also itunes crash is hard to catch problem point.

I removed all acpi stuff and binary patch, changed smbios and test. Still exist problem.

In my desktop, there is no itunes crash. I compared both system. But still no luck.

 

 

나의 LG-F800S 의 Tapatalk에서 보냄

Not all folder will have gitches.

 

I test it with when i drag kexts to EFI/Clover/Kexts/Others it will githes but it is not 100% shows up.

 

 

 

从我的 iPhone 发送,使用 Tapatalk

I never see glitches of folders on my hd 520 laptop. This case only high sierra?

 

Also itunes crash is hard to catch problem point.

I removed all acpi stuff and binary patch, changed smbios and test. Still exist problem.

In my desktop, there is no itunes crash. I compared both system. But still no luck.

 

나의 LG-F800S 의 Tapatalk에서 보냄

Do you use shiki.kext?

 

I will test if it is related with shiki because only this kext related with iTunes.

 

 

 

从我的 iPhone 发送,使用 Tapatalk

Share this post


Link to post
Share on other sites

Not all folder will have gitches.

 

I test it with when i drag kexts to EFI/Clover/Kexts/Others it will githes but it is not 100% shows up.

 

 

 

从我的 iPhone 发送,使用 Tapatalk

 

Do you use shiki.kext?

 

I will test if it is related with shiki because only this kext related with iTunes.

 

 

 

从我的 iPhone 发送,使用 Tapatalk

 

Do you use shiki.kext

- i tested both "with" or "without". but still no luck. very strange issue.

 

your laptop hdmi work on high sierrra? i dont have any issue in sierra. hdmi and itunes. strangely not detect hdmi. ofc patches are same like sierra.

 

i changed smbios imac13,1 and i tested itunes. seems no itunes crash. not sure. but shown better.

Share this post


Link to post
Share on other sites

Do you use shiki.kext

- i tested both "with" or "without". but still no luck. very strange issue.

 

your laptop hdmi work on high sierrra? i dont have any issue in sierra. hdmi and itunes. strangely not detect hdmi. ofc patches are same like sierra.

 

i changed smbios imac13,1 and i tested itunes. seems no itunes crash. not sure. but shown better.

Yes i test shiki with and without but no lucky.

 

I have no idea about this problem.

 

Wait someone fine error log about the crash.

 

 

从我的 iPhone 发送,使用 Tapatalk

Share this post


Link to post
Share on other sites

Hi,

 

How can I create an USB installer ? Because when download High Sierra it downloads just 15 MB and after I start the installer it gets the other 4 GB part..

Share this post


Link to post
Share on other sites

Sleep mode issue.

Anybody else got this behaviour?

Laptop Yoga 710IKB.

Everything else is working as it should, and only problem is duplicate screen at the right side.

Hdmi out is working (wake after sleep) and the problem is not related to it!

This problem existed at previous beta versions too, and I hoped it would be fixed HS final release.

But it’s still there…

Anyone?

 

High Sierra related bug?

post-2200747-0-78020400-1506411193_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By NikTheNoob
      Hi,
       
      I'm rather new to Hackintosh and trying my first build with OpenCore on AMD, but I run into issues causing OpenCore to crash before even loading the macOS installer. As I'm not sure which one is causing the crash, I'm trying to resolve all of them and one of the error messages has to do with WhateverGreen, which I was able to see in this slow-mo loading video. Basically I'm getting an error that I'm running an unsupported processor, even though I think I was following this guide by the step.
      What could be causing this and what do I need to do to resolve it?
       
      CPU: AMD Ryzen 2700X
      MB: Gigabyte Aorus X470 Ultra Gaming
      Memory: 4x8 GB HyperX Predator, 3000 MHz Cl15
      Storage: Samsung Evo 970 Nvme 512 GB, Crucial MX500 500GB SATA
      GPU: MSI Radeon RX580 GamingX 8GB
    • By MaLd0n
      --Donations via PayPal--
      https://tinyurl.com/r2bvzm7
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      Just paste EFI folder inside EFI partition
      https://www.olarila.com/files/Clover.Folder/Lenovo IdeaPad S145.zip
      Notebooks with ELAN trackpad use it with my folder above
      IdeaPad S145 ELAN.zip
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Cannon Point-LP Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
    • By fantomas
      macOS Catalina 10.15.4 beta (19E224g)
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://www.olarila.com/topic/5165-olarila-app-images-and-folders/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
        First... If you need DSDT edits... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation --Create a bootable copy of El Capitan /  Sierra / High Sierra / Mojave https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install EL Capitan / Sierra / High Sierra and boot into system!     Post Installation   --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/     --Reboot and activate video!   Bingo! Now you need a fine tune! DSDT Time!   My DSDT GA P35-DS3   DSDT.MaLd0n.zip     Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -LPC -HDEF -RTC -EHCI -UHCI -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF --Native Power Management
       
      Use Clover, check Generate P and C States
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --AUDIO
       
      Device HDEF + AppleAlc + Lilu
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
×