Jump to content
ivanmacx85

MacOS Sierra Asus X54HR

165 posts in this topic

Recommended Posts

Advertisement

Hai provato AppleALC?

Si certo lo usavo prima di fixare il DSDT è andava su layout 9 ma una volta fixato di DSDT ha smesso di funzionare!! Ho anche provato diversi layout prima di cercare un altro kext funzionante

Share this post


Link to post
Share on other sites

mmmmm non ho mai usato MaciASL.... una guida?? Quella di Gengik84 e' su DSDT editor

non è mia la guida su DSDT editor  :)

 

Quella guida risale ahimè al medioevo (è valida, ma alcune cose sono diverse). Molte delle correzioni che ci sono in quella guida (spero di aver capito quella a cui ti riferisci) non servono più. Per quanto ne so, DSDT Editor non è più aggiornato.

Quanto alle guide... io vado ad esperienza. Su github forse ci sono delle guide.

 non è aggiornato perché compila in acpi 4.0...

ma suoi portatili sandy/ivy bridge potete usarlo e al dire il vero è il suo...perchè le acpi sono scritte con quella versione  ;)

Share this post


Link to post
Share on other sites

non è aggiornato perché compila in acpi 4.0...

ma suoi portatili sandy/ivy bridge potete usarlo e al dire il vero è il suo...perchè le acpi sono scritte con quella versione ;)

Infatti va benone perché usando la funzione automatica fix error mi ha risolto da solo i 5 problemi che avevo e ora il pc si avvia senza problemi!!! Unica pecca è che da quel momento l’audio ha smesso di funzionare

Share this post


Link to post
Share on other sites

manca il layout, puoi allegare il dsdt quello fatto da te?

Tra poco lo allego!! Il layout non basta impostarlo sul .config con Clover configurator??

Share this post


Link to post
Share on other sites

Tra poco lo allego!! Il layout non basta impostarlo sul .config con Clover configurator??

certo...

ma se non hai Hdef sul dsdt...niente audio

E' come "no lucano no party"... :hysterical:

se non vi è.. va aggiunto, altrimenti se vi fosse è possibile che sia nominato in altro modo e quindi occorre modificarlo

 

intanto puoi provare FixHDA cha applica alcuni Rename sulle acpi e nel tuo caso dovrebbe andar bene

 

Ripeto rename... se non c'è il Device va aggiunto sul dsdt

Share this post


Link to post
Share on other sites

quello che dici fa da Rename come ti dicevo prima, ma non aggiunge se non è presente

Comunque nel tuo dsdt HDEF è presente

sul config seleziona FixHpet, imposta il layout e riprova

Share this post


Link to post
Share on other sites

quello che dici fa da Rename come ti dicevo prima, ma non aggiunge se non è presente

Comunque nel tuo dsdt HDEF è presente

sul config seleziona FixHpet, imposta il layout e riprova

 

Ok provo!!! Layout numero? 12?

Share this post


Link to post
Share on other sites

dipende dal tuo codec audio, io non so quale hai

con appleALC ce ne sono diversi supportati per stesso codec

Prova con il 3  è quello più "versatile"

Share this post


Link to post
Share on other sites

quello che dici fa da Rename come ti dicevo prima, ma non aggiunge se non è presente

Comunque nel tuo dsdt HDEF è presente

sul config seleziona FixHpet, imposta il layout e riprova

 

Come si verifica se e' presente? Cosi la prossima volta so dove guardare   ;)

Share this post


Link to post
Share on other sites

Come risolvo?

Ora non sono al pc. Probabilmente hai una graffa prima di una tonda. Guarda alla riga del primo errore.

Share this post


Link to post
Share on other sites

Ora non sono al pc. Probabilmente hai una graffa prima di una tonda. Guarda alla riga del primo errore.

 

Ecco qui le schermate  :)

post-681980-0-58620200-1507048342_thumb.png

post-681980-0-72659900-1507048348.png

Share this post


Link to post
Share on other sites

Aggiornamento:

 

 
Sono ripartito dal dsdt originale preso dalla cartella Origin di Clover dopo aver fatto F4 al boot
 
1.) Controllato il DSDT su MaciASL e non mi dava errori quindi l'ho lasciato così
 
2.) Messo nella cartella kext 10.12 AppleALC.kext e Lilu.kext
 
3.) Impostato con Clover Configurator il layout 3
 
4.) Ripristinato per sicurezza il kext AppleHDA.kext in S/L/E
 
Riavviato ma l'audio non va
 
 
5.) Aggiunto al DSDT la patch "Audio Layout 3" di RehabMan Laptop e salvato il DSDT patchato nella cartella patched di Clover
 
Riavviato ma l'audio non va   :(

DSDT.aml.zip

Share this post


Link to post
Share on other sites

Controlla se AppleALC e lilu sono caricati

 

Come faccio?? ho un lapsus

 

kextstat da terminale  :lol:

 

ho controllato ma non vengono caricati

 

invece ci sono:

post-681980-0-64052700-1507118805_thumb.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×