Jump to content
ivanmacx85

MacOS Sierra Asus X54HR

165 posts in this topic

Recommended Posts

Advertisement

Questo è strano perché l'audio dovrebbe comunque andare anche senza dsdt

Non hai particolari configurazioni sul dsdt attuale a riguardo di questo

 

Le usb non sono intel, te lo posso garantire

 

Cosa potrebbe essere allora??? Hai modo di spulciare la cartella clover che ho allegato??

 

Comunque c’è stato un momento che la usb 3.0 andava con collegato un mouse magari sarà andata a 2.0

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Per le usb3.0 non intel mi ricordo che c'era un kext di rehabman, ma ho appena visto che non viene caricato su osx 10.11+, quindi nisba.

 

Provo ma la modifica del eh01 me l’avevi già fatta provare ieri ti ricordi???

Dopo una giornata di lavoro, no :D . Non ti fa andare le usb2?

Share this post


Link to post
Share on other sites

Cosa potrebbe essere allora??? Hai modo di spulciare la cartella clover che ho allegato??

 

Comunque c’è stato un momento che la usb 3.0 andava con collegato un mouse magari sarà andata a 2.0

 

 

Inviato dal mio iPhone utilizzando Tapatalk

 

Probabile..

Scarica DPCIManager.zip

fai foto alla parte pci list, postala

Share this post


Link to post
Share on other sites

Per le usb3.0 non intel mi ricordo che c'era un kext di rehabman, ma ho appena visto che non viene caricato su osx 10.11+, quindi nisba.

ci sono anche più di un kext... ma magra consolazione

KP... oppure funzionamento solo partendo da portatile spento con una usb collegata che spesso smette di funzionare subito dopo il login

Già fatta è in prima pagina

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Ok scusa, ma avevo perso il filo, le usb 3.0 nemmeno risultano.. detto sinceramente è una battaglia quasi persa in partenza

Share this post


Link to post
Share on other sites

ci sono anche più di un kext... ma magra consolazione

KP... oppure funzionamento solo partendo da portatile spento con una usb collegata che spesso smette di funzionare subito dopo il login

Si, ho visto. L'ultima versione non viene caricata proprio per evitare i kernel panic. Mi spiace che non possano funzionare, perché effettivamente fanno comodo.

Share this post


Link to post
Share on other sites

Si, ho visto. L'ultima versione non viene caricata proprio per evitare i kernel panic. Mi spiace che non possano funzionare, perché effettivamente fanno comodo.

Eh a chi lo dici...condivido in pieno, su un mio HP ho usb Nec...abbandonate tristemente da 10.10...

Purtroppo hackintosh è anche questo

Share this post


Link to post
Share on other sites

ci sono anche più di un kext... ma magra consolazione

KP... oppure funzionamento solo partendo da portatile spento con una usb collegata che spesso smette di funzionare subito dopo il login

Ok scusa, ma avevo perso il filo, le usb 3.0 nemmeno risultano.. detto sinceramente è una battaglia quasi persa in partenza

 A me interessas che funzioni l'audio e la usb 2.0 contemporaneamente!!! :)

 

La usb 3.0 pace se non va

Share this post


Link to post
Share on other sites

Eh a chi lo dici...condivido in pieno, su un mio HP ho usb Nec...abbandonate tristemente da 10.10...

Purtroppo hackintosh è anche questo

Giusto. È da un bel po' che seguo le discussioni riguardo a thunderbolt qui su IM e vedo che è lo stesso. Ma in fondo se uno vuole macOS compatibile al 100% si compra un mac. Costeranno anche tanto, ma si porta comunque a casa una bella macchina.

Share this post


Link to post
Share on other sites

 A me interessas che funzioni l'audio e la usb 2.0 contemporaneamente!!! :)

 

La usb 3.0 pace se non va

le usb 2 sono intel e dovrebbero andare, è quasi assurdo tale comportamento

 

il dsdt è anche patchato a riguardo, ma questo è relativo dovrebbero andare comunque.

 

Non vanno nemmeno se colleghi una usb 2.0?

Share this post


Link to post
Share on other sites

 A me interessas che funzioni l'audio e la usb 2.0 contemporaneamente!!! :)

 

La usb 3.0 pace se non va

Puoi allegare un ioreg con e senza il dsdt "incriminato"? Se hai ioregistryexplorer, usa quello.

Share this post


Link to post
Share on other sites

le usb 2 sono intel e dovrebbero andare, è quasi assurdo tale comportamento

 

il dsdt è anche patchato a riguardo, ma questo è relativo dovrebbero andare comunque.

 

Non vanno nemmeno se colleghi una usb 2.0?

No no non funziona proprio, calcola che io ci tengo collegato un mouse per comodità e funziona solo se tolgo il file dsdt

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

ho guardato meglio...hai un controller  Asmedia 1042...

bel problema...

 Riguardo al dsdt che usi, l'hai trovato in rete, l'hai patchato tu o cosa?

 

Sul bios hai qualche possibile impostazione per le usb?

Share this post


Link to post
Share on other sites

ho guardato meglio...hai un controller Asmedia 1042...

bel problema...

Riguardo al dsdt che usi, l'hai trovato in rete, l'hai patchato tu o cosa?

 

Sul bios hai qualche possibile impostazione per le usb?

Il dsdt l’ho trovato in rete!! Avevo provato a metterlo quando stavo cercando di far partire l’accelerazione nella scheda video. L’ho preso da un utente che aveva la mia stessa scheda video e pensavo che magari potesse aiutare. Poi mi sono accorto che con quello l’audio mi funzionava e togliendolo smetteva di funzionare quindi lo sto tenendo ma secondo me c’è qualcosa all’interno che va in conflitto con il resto dell’hardware.

 

Nel bios come impostazioni ho solo usb legacy support su enable

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Il dsdt l’ho trovato in rete!! Avevo provato a metterlo quando stavo cercando di far partire l’accelerazione nella scheda video. L’ho preso da un utente che aveva la mia stessa scheda video e pensavo che magari potesse aiutare. Poi mi sono accorto che con quello l’audio mi funzionava e togliendolo smetteva di funzionare quindi lo sto tenendo ma secondo me c’è qualcosa all’interno che va in conflitto con il resto dell’hardware.

 

Nel bios come impostazioni ho solo usb legacy support su enable

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Che io sappia, è sempre meglio partire dal proprio. Mai usare quelli scaricati. Sai che patch c'erano già applicate?

Share this post


Link to post
Share on other sites

Che io sappia, è sempre meglio partire dal proprio. Mai usare quelli scaricati. Sai che patch c'erano già applicate?

Sinceramente non ne ho idea di quali patch ci sono applicate

e non so come patchare il mio e quale programma usate per editare il dsdt.

Help meeeee

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Sinceramente non ne ho idea di quali patch ci sono applicate

e non so come patchare il mio e quale programma usate per editare il dsdt.

Help meeeee

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Per il programma, usa quello che ti allego. Le tabelle originali le trovi in EFI/clover/acpi/origin

 

Edit:

 

Preferisco non modificare le tabelle acpi agli altri, finora ho toccato solo le mie. Mio danno mia responsabilità :rolleyes: . Qui su IM ci sono delle guide che spiegano le basi di come patchare dsdt e ssdt. In alternativa, vedi se c'è qualche buon'anima che ha tempo di patchartele.

MaciASL.zip

Share this post


Link to post
Share on other sites

Per il programma, usa quello che ti allego. Le tabelle originali le trovi in EFI/clover/acpi/origin

Ok grazie, ora ho il programma e so dove trovare il file originale, ma cosa devo patchare esattamente? ???

 

Abbia pazienza e scusa per la mia ignoranza

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Ivanz85

Mi fai una prova...questo è il dsdt che hai usato e usi tutt'ora, ho fatto una modifica

Provalo e dimmi se funzionano le usb come quando lo togli

Ok provo e ti dico

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Ok grazie, ora ho il programma e so dove trovare il file originale, ma cosa devo patchare esattamente?

 

Abbia pazienza e scusa per la mia ignoranza

Prima prova quello di gengik.

In origin trovi il dsdt.aml originale e i ssdt-x.aml (x va da 0 a 7/8 circa sui portatili) copiali in una cartella e parti con il modificare quelli. Se compilando con MaciASL ti escono degli errori, prova a decompilare le tabelle e lavorare sui file .dsl

Share this post


Link to post
Share on other sites

Prima prova quello di gengik.

In origin trovi il dsdt.aml originale e i ssdt-x.aml (x va da 0 a 7/8 circa sui portatili) copiali in una cartella e parti con il modificare quelli. Se compilando con MaciASL ti escono degli errori, prova a decompilare le tabelle e lavorare sui file .dsl

Provato quello di gengik ma la usb 2.0 ancora non funziona

 

 

EDIT :

 

Dopo aver cambiato l'dsdt con quello che mi ha girato gengik le usb non andavano ancora, poi mi sono ricordato che nel config avevo ancora la patch EHC1 to EH01 - EHC2 to EH02 che mi aveva impostato foskvs.

 

le ho cancellate, riavviato e ora......va il mouse nella porta usb 3.0 ma non va la porta 2.0  :hysterical:

Share this post


Link to post
Share on other sites

Provato quello di gengik ma la usb 2.0 ancora non funzionaEDIT :

 

Dopo aver cambiato l'dsdt con quello che mi ha girato gengik le usb non andavano ancora, poi mi sono ricordato che nel config avevo ancora la patch EHC1 to EH01 - EHC2 to EH02 che mi aveva impostato foskvs.

 

le ho cancellate, riavviato e ora......va il mouse nella porta usb 3.0 ma non va la porta 2.0  :hysterical:

Ammettilo che lo fai apposta!! :hysterical:

Con usbinjectall.kext funzionano?

Share this post


Link to post
Share on other sites

Ammettilo che lo fai apposta!! :hysterical:

Con usbinjectall.kext funzionano?

Ora non ho nessun kext nella cartella 10.12 riguardante le usb e come dicevo qui sopra la usb 3.0 funziona tranquillamente anche collegando e scollegando a pc acceso. La usb 2.0 non vuole saperne di andare con il dsdt patchato

 

Edit:

Tra l’altro tra poco provo il test di velocità perché voglio capire se la porta USB 2.0 sta funzionando a velocità 2.0 o a 3.0

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Ora non ho nessun kext nella cartella 10.12 riguardante le usb è come dicevo qui sopra la usb 3.0 funziona tranquillamente anche collegando e scollegando a pc acceso. La usb 2.0 non vuole saperne di andare con il dsdt patchato

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Domani provo a guardare.

 

Esegui il comando che allego. Prima con il dsdt e il mouse collegato e poi senza il dsdt. Allega i file che ti genera.

ioreg.command.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×