Jump to content
SteveRings

Running High Sierra GM on SSD formatted HFS+

6 posts in this topic

Recommended Posts

So my High Sierra boot partition disappeared after HS GM install which is when I discovered there is no option to install without APFS.  Well, that maybe the future but I don't want it.  So, I removed it.

 

My setup is a dual boot with Win 8 (I use it about once a month, by accident).  My Mac boot disk is disk0s6, 70GB, and I have my user data on disk0s8, about 300GB, not the boot disk.  This division allows quicker restores and less-dangerous upgrades as the data is always safe.  You may need far more than 70GB depending on your applications so think about it before you do that split.

 

I mention that because you have to destroy your boot disk in order to revert to HFS+; having to restore all of your data every time is both tedious and a little more dangerous than having it safely housed away from what ever APPLE has decided is best for us this week.

 

So here are the steps:

 

1) Make a local USB Time Machine backup of your boot disk;  you can use a network version (make sure it is up-to-date!) but the restore will take HOURS.

2) Install the High Sierra GM onto a bootable USB device

3) Migrate your previous backup onto the new install (if your USB is too small, do step 4 before step 3)

4) Boot into Recovery; using DISK Utility, restore the USB install onto your HFS+ boot partition.

 

I'm staying on HFS+ as long as possible - the world is not ready for APFS and way too much stuff is affected without good alternatives. 

 

Share this post


Link to post
Share on other sites
Advertisement
there is no compulsive conversion to APFS if you install correctly.

 

there is a page where you can choose to install, by ticking a checkbox in a box, whether you want to install on APFS or not, i. e. as usual on HFS+.

 

No compulsion, but a selection ! I have read about "forced conversion" in several forums, it seems they don't know how to install High Sierra correctly.

Share this post


Link to post
Share on other sites

The conversion CANNOT be avoided if you have flash storage.  I chose the box on Beta 1 and had HFS+ on my flash storage thru out the Beta but the GM has no such check box for flash storage.  If you get a box then you do NOT have Apple recognized FLASH storage.

 

Another option might be to cripple the KEXT for flash storage until after the install ... unfortunately, I'm out of town for two weeks so I'll have to get back to y'all about that ... 

Share this post


Link to post
Share on other sites

Alternatively you can deploy the HS installation directly onto your drive from within another mac or hack, by using the "startosinstall --converttoapfs NO" command OR change the FFM in your SMBIOS: http://www.insanelymac.com/forum/topic/324194-pre-release-macos-high-sierra/?p=2471719

Share this post


Link to post
Share on other sites

Alternatively you can deploy the HS installation directly onto your drive from within another mac or hack, by using the "startosinstall --converttoapfs NO" command OR change the FFM in your SMBIOS: http://www.insanelymac.com/forum/topic/324194-pre-release-macos-high-sierra/?p=2471719

Hi Everyone,

 

Just did upgrade on SSD drive running this command:

 

sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/startosinstall --converttoapfs NO

 

No problems noticed so far and macOS loads much faster than from APFS partition.

 

Thank for tip Ricoc90.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By h2onions
      Hey all,
       
      First Hackintosh that I think I have completed! I've been working on it on and off for a month, but just grinded it this past weekend. I just have a small QOL issue. I have posted in the r/Hackintosh reddit, but have not gotten a reply to this specific issue, but did for other issues I was having. I also posted at tonymacx86 and was getting replies for other issues I was having, but got banned because I said, "used VM, but didn't work" in my OP I think ...
       
      I followed a PC vanilla guide from r/Hackintosh that I found as I did not have an Apple system. One monitor connected to a GTX 1080, CPU: i7-8700, Coffee Lake. Motherboard is Alienware specific 0VDT73, with chipset Z370.
       
      The issue is every time High Sierra boots up and gets to the login screen, my keyboard and mouse do not work. I only have to reseat both and then they work the whole time until I restart. They are both plugged into USB2.0 ports. I do have Lilu, WhateverGreen, USBInjectAll, and VoodooPS2 installed in my /Library/Extensions folder using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]. Mouse and Keyboard work fine each time I boot to Clover (USB). Any ideas?
       
      Thank you!
      Working: NVIDIA using (One) DisplayPort, USB3.0 (rear), USB-C (rear), USB2.0 (rear), Audio, Ethernet
    • By STLVNUB
      No sense re-inventing the wheel.
       
    • By Utku
      Hi guys, I have a big problem for VT -x. I tried any things for example: dark=0 or already bios option is virtualization is enable. I don't understand this problem.
       
      Thanks guys!! And yes I have intel Q8400 quad core cpu, motherboard is Asus asus p5g41c-m lx.
       


    • By NoEnd
      Hi team,
       
      I have tried to update to security update 2019-001 multiple time with no luck, today I've booted the update with -verbose and attached videos shows the details.
       
      Appreciate your help
       
      Thanks
      Untitled.mov
    • By JhonneR
      Good morning, everyone, I'm sorry if I was wrong in choosing the topic but I need help.
      I have found it extremely difficult to mount a Hackintosh in my acer.
      Setup;
      I5 2430m 2.4 6GB RAM
      Mobo P5we0 - Intel intel Graphics 3000
      At the moment I have not found out what my audio codecs are.
      but I'll leave the link on the motherboard.
      however, my real problem is several.
      I have already used the itakos image, I have already used several images that could be installed normally and that after installing the image I do not have internet via cable or wireless.
      And another, I already looked in other forums and I know that I will be called a donkey in the logical question but I have not been able to install the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] or clover to start from the Hard Disk, so I do not know what to do.At the moment I still do not know if there has already been someone who has already installed the High Sierra or just the Sierra in this notebook model and obtained permanent success.
      If anyone can help me, I'll be grateful.
      Installations without success, but with the system already installed in ACER;
      SIERRA
      HIGH SIERRA
      MOJAVE
      All with the same symptom. Starting only by the bootable USB stick and without internet connection via cable and wireless.
      Appreciate ! Acer 5750 Official Page
×