Jump to content
Alex.C

Alienware 15 R3 on OS X 10.12.6

149 posts in this topic

Recommended Posts

Hey, just wanted to add to this thread. With the MacBook Pro SMBIOS I've been having laggy log in screen and other password prompts. Highly recommend adding NoTouchID.kext to your EFI.

 

 

Share this post


Link to post
Share on other sites
Advertisement
1 hour ago, 10rb1988 said:

Hey, just wanted to add to this thread. With the MacBook Pro SMBIOS I've been having laggy log in screen and other password prompts. Highly recommend adding NoTouchID.kext to your EFI.

 

 

Thanks !

Share this post


Link to post
Share on other sites
On 8/29/2018 at 6:15 AM, 10rb1988 said:

Hey, just wanted to add to this thread. With the MacBook Pro SMBIOS I've been having laggy log in screen and other password prompts. Highly recommend adding NoTouchID.kext to your EFI.

 

 

Where is this kext ?

Share this post


Link to post
Share on other sites

Thanks @xela i was able to have my Alienware running with both graphics cards, intel and gtx, i have an issue with IntelGraphicsDVMTFixup.kext once i removed my graphics loaded without errors
my specs:
Bios version 1.3.0

4k panel (no-gsycn)

i7 6700HQ
16 GB DDR4 of ram
Intel 530
GTX 1070

Working
HDMI - Mini display port (both)

Trackpad

Keyboard

Audio, only speakers

Bluetooth

Intel 530

GTX 1070

Webcam

 

Not working

Screen brightness

Audio jack - weird sounds when is connected

Killer wifi 1435 - i'll add an usb mac compatible wifi,

Turn on/off bluetooth (always on)

 

Note: since my audio jack isn't working i connected bluetooth headphones and sound is good

Clover.zip

Screen Shot 2018-09-18 at 11.38.22 PM.png

Share this post


Link to post
Share on other sites
5 hours ago, luisrene88 said:

Thanks @xela i was able to have my Alienware running with both graphics cards, intel and gtx, i have an issue with IntelGraphicsDVMTFixup.kext once i removed my graphics loaded without errors
my specs:
Bios version 1.3.0

4k panel (no-gsycn)

i7 6700HQ
16 GB DDR4 of ram
Intel 530
GTX 1070

Working
HDMI - Mini display port (both)

Trackpad

Keyboard

Audio, only speakers

Bluetooth

Intel 530

GTX 1070

Webcam

 

Not working

Screen brightness

Audio jack - weird sounds when is connected

Killer wifi 1435 - i'll add an usb mac compatible wifi,

Turn on/off bluetooth (always on)

 

Note: since my audio jack isn't working i connected bluetooth headphones and sound is good

Clover.zip

Screen Shot 2018-09-18 at 11.38.22 PM.png

Screen brightness should work with AppleBacklightInjector.kext installed into /Library/Extension, check out the attached. If the AppleBacklightInjector.kext does not work for you, follow the link and create your own 4k panel AppleBacklightInjector.kext.

 

Audio jack, try enable HDAEnabler11.kext in Clover/kext and remove CloverHDA.kext.

 

AppleBacklightInjector.zip

Edited by xela

Share this post


Link to post
Share on other sites
5 hours ago, xela said:

Screen brightness should work with AppleBacklightInjector.kext installed into /Library/Extension, check out the attached. If the AppleBacklightInjector.kext does not work for you, follow the link and create your own 4k panel AppleBacklightInjector.kext.

 

Audio jack, try enable HDAEnabler11.kext in Clover/kext and remove CloverHDA.kext.

 

AppleBacklightInjector.zip

AppleBacklightInjector doesn't work, follow which link? i think is missing
I googled HDAEnabler11 without results only results for HDAEnabler1 but doesn't work, my audio is disabled when the kext is added, also tried with HDAEnabler2 and HDAEnabler12 with the same bahavior

Share this post


Link to post
Share on other sites
1 hour ago, luisrene88 said:

AppleBacklightInjector doesn't work, follow which link? i think is missing
I googled HDAEnabler11 without results only results for HDAEnabler1 but doesn't work, my audio is disabled when the kext is added, also tried with HDAEnabler2 and HDAEnabler12 with the same bahavior

In the attached,you should have "Laptop backlight control using AppleBacklightInjector" , thats the link 

You can find HDAEnabler11.kext in your Clover/kext/Others/_disable/HDAEnabler11.kext, remove CloverHDA also

 

 

Share this post


Link to post
Share on other sites
30 minutes ago, 10rb1988 said:

Does the above brightness guide work with Nvidia graphics? I love my Alienware hack but woof it is BRIGHT!

it works on system without g-sync panel

 

 

Share this post


Link to post
Share on other sites

@xela Hi, I tried using your latest uploaded clover folder to install 10.13.6, but it doesn't work.

I am using 7820HK+1080MaxQ with G-Sync

Is there anything I am missing? What is the methodology you use to bypass the iGPU?

 

Thanks a lot.

Share this post


Link to post
Share on other sites
22 hours ago, EinNarr said:

@xela Hi, I tried using your latest uploaded clover folder to install 10.13.6, but it doesn't work.

I am using 7820HK+1080MaxQ with G-Sync

Is there anything I am missing? What is the methodology you use to bypass the iGPU?

 

Thanks a lot.

I do not know which one you are referring. You might want to check if SSDT-DDGPU.aml exist in Clover/ACPI/patched, remove it as it disable nvidia gpu. For gsync model, igpu is not connect to anything and mainly use for quick sync in os x.

 

If you are installing osx 10.13.6, try cpus=1 boot argument should fix most KP during install.

Edited by xela

Share this post


Link to post
Share on other sites

@xela

Thank you very much for your suggestion.

Currently I can log into the OS but only with -x mode and only have 7mb video memory. Also I cannot set webdriver flag to 1 or it will be blackscreen.

I hate to shamelessly ask but would you please share your latest clover folder for your g-sync 15r3?

Share this post


Link to post
Share on other sites
26 minutes ago, EinNarr said:

@xela

Thank you very much for your suggestion.

Currently I can log into the OS but only with -x mode and only have 7mb video memory. Also I cannot set webdriver flag to 1 or it will be blackscreen.

I hate to shamelessly ask but would you please share your latest clover folder for your g-sync 15r3?

Here you go, see attached.

 

aw15r3 ESP 2018-0710-00.zip

Share this post


Link to post
Share on other sites

Hello guys,
Thank you all so much for your hard work.
First of all, I've got an Alienware 15R3, FHD panel with G-SYNC, GTX1070, 630igpu, 7700HQ processor and High Sierra OS.

 

I've got the GTX1070 working perfectly, however I would like to fix as many things as possible.

I really don't understand how to get audio working. It seems that no matter what I do, nothing shows up under Devices. I currently have the patched AppleHDA with the Layout 13. Still nothing.
Minor issues like brightness and lack of touchpad gestures also need fixing.

Funnily enough, when I copy xela's Clover folder over mine, my machine seems to break completely. I get no GPU support, etc.

I would be really thankful if someone could point me in the right direction.

Thanks all!

 

 

Edited by DasIstEmpy

Share this post


Link to post
Share on other sites
On 11/13/2018 at 12:30 AM, DasIstEmpy said:

Hello guys,
Thank you all so much for your hard work.
First of all, I've got an Alienware 15R3, FHD panel with G-SYNC, GTX1070, 630igpu, 7700HQ processor and High Sierra OS.

 

I've got the GTX1070 working perfectly, however I would like to fix as many things as possible.

I really don't understand how to get audio working. It seems that no matter what I do, nothing shows up under Devices. I currently have the patched AppleHDA with the Layout 13. Still nothing.
Minor issues like brightness and lack of touchpad gestures also need fixing.

Funnily enough, when I copy xela's Clover folder over mine, my machine seems to break completely. I get no GPU support, etc.

I would be really thankful if someone could point me in the right direction.

Thanks all!

 

 

Most likely you have SSDT-DDGPU.aml in clover/acpi/patched, remove it. It exist because non-gsync model have the option to turn off nvidia gpu via patch.

Share this post


Link to post
Share on other sites
4 hours ago, DasIstEmpy said:

@xela

Does your back Thunderbolt port work after sleep? Can you hotplug devices?

I do not have any TB device but I tested with usb storage device, sleep work but no hot plug. Try searching "IOElectrify.kext" (or this link https://github.com/the-darkvoid/macOS-IOElectrify) for hot plugging tb port. I tested it work with 10.12.6, did not border with 10.13.6.

 

I use screen shader to tame my screen for now until screen brightness fix.

 

Edited by xela

Share this post


Link to post
Share on other sites
On 10/25/2018 at 4:00 AM, xela said:

Here you go, see attached.

 

aw15r3 ESP 2018-0710-00.zip

Hey there, I have an Alienware 15r3. Similar Specs. 7700HQ, GTX 1070, 1080p Gsync 60hz panel.

This clover file I'm not able to get Nvidia Hardware acceleration, wifi or ethernet to work for some odd reason.

 

I found a clover file posted earlier here that uses an imac smbios. I got wifi/ethernet/nvidia graphics working but no backlight control or sound.

 

Looking for a clover folder I could use to get everything working! Thanks a lot!

Share this post


Link to post
Share on other sites

Hey, working on a 17 R5 with 8750h and 1070.
I can't figure out exactly how to apply the alc fix, nor can I find directions I can understand.
Can anyone help out with guidance on this?
*Edit* High Sierra

Edited by Lrnzo

Share this post


Link to post
Share on other sites
On 11/26/2018 at 6:48 PM, Lrnzo said:

Hey, working on a 17 R5 with 8750h and 1070.
I can't figure out exactly how to apply the alc fix, nor can I find directions I can understand.
Can anyone help out with guidance on this?
*Edit* High Sierra

Use these Clovers and you will have Mojave without any issues.

 

CLOVER_james_working.zip

Share this post


Link to post
Share on other sites
On 2/6/2019 at 5:31 PM, seomaii said:

Will this work with AW 15 R3 i7-7820HQ, 16GB Ram, Nvidia 1070?

 

Thanks

yes like a charm!

Share this post


Link to post
Share on other sites
On 2/6/2019 at 5:31 PM, seomaii said:

Hey guys recently I have started to face a new problem and this is with the ssd's. When I start to copy files from another windows ssd on to Mac (when logged on to the Mac), the system crashes. 

Application error stack that I get is mentioned below. Any help on this would be greatly appreciated.

--------------------------------------
<start of Message>

 

 

Anonymous UUID:       04AA0D25-2E2D-6721-CBEA-E72733B1CBBF

Sat Mar  9 14:59:05 2019

*** Panic Report ***
panic(cpu 0 caller 0xffffff7f86de4e2b): nvme: " NVMe: Command timed-out and request found in the completion queue \n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/IONVMeFamily/IONVMeFamily-356.71.1/IONVMeController.cpp:5184
Backtrace (CPU 0), Frame : Return Address
0xffffff83bdbf3b60 : 0xffffff800486e1c6 
0xffffff83bdbf3bb0 : 0xffffff8004996a74 
0xffffff83bdbf3bf0 : 0xffffff8004988d44 
0xffffff83bdbf3c60 : 0xffffff80048201e0 
0xffffff83bdbf3c80 : 0xffffff800486dc3c 
0xffffff83bdbf3db0 : 0xffffff800486d9fc 
0xffffff83bdbf3e10 : 0xffffff7f86de4e2b 
0xffffff83bdbf3e30 : 0xffffff8004e9f7ac 
0xffffff83bdbf3ea0 : 0xffffff8004e9f6d6 
0xffffff83bdbf3ed0 : 0xffffff80048a7624 
0xffffff83bdbf3f40 : 0xffffff80048a7185 
0xffffff83bdbf3fa0 : 0xffffff800481f557 
      Kernel Extensions in backtrace:
         com.apple.iokit.IONVMeFamily(2.1)[1170C79B-9E09-3CD3-970B-C419EBF9037F]@0xffffff7f86dd0000->0xffffff7f86e0ffff
            dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[F314E6BA-45C5-3D8B-A3BF-C4CAE13DDADC]@0xffffff7f86194000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[D91E9813-9717-31B8-BFE5-2F3A00F375F3]@0xffffff7f85094000
            dependency: com.apple.driver.AppleEFINVRAM(2.1)[F35A52E2-CF80-3BA9-92B5-25EFE216094F]@0xffffff7f860c4000
            dependency: com.apple.iokit.IOStorageFamily(2.1)[F27A8A2A-6662-3608-83BD-415037509E01]@0xffffff7f856e7000
            dependency: com.apple.iokit.IOReportFamily(31)[D2F2FBDF-4EE4-38BA-99F5-B699F886F413]@0xffffff7f8547a000

BSD process name corresponding to current thread: kernel_task
Boot args: -lilubeta kext-dev-mode=1 -wegbeta -alcbeta 

Mac OS version:
17G5019

Kernel version:
Darwin Kernel Version 17.7.0: Thu Dec 20 21:47:19 PST 2018; root:xnu-4570.71.22~1/RELEASE_X86_64
Kernel UUID: 4A5298BF-709E-37DF-B7F0-4298065CC266
Kernel slide:     0x0000000004600000
Kernel text base: 0xffffff8004800000
__HIB  text base: 0xffffff8004700000
System model name: MacBookPro14,3 (Mac-551B86E5744E2388)

System uptime in nanoseconds: 295162064397
last loaded kext at 248715542411: com.apple.filesystems.msdosfs    1.10 (addr 0xffffff7f88372000, size 69632)
loaded kexts:
com.nvidia.CUDA    1.1.0
com.nvidia.web.GeForceWeb    10.3.3
com.nvidia.web.NVDAGP100HalWeb    10.3.3
com.nvidia.web.NVDAResmanWeb    10.3.3
com.exvision.hdmiaudio    1.0
com.nvidia.NVDAStartupWeb    10.3.3
com.razer.common.razerhid    21.80
com.realtek.driver.RtWlanU    1830.20.b14
org.rehabman.voodoo.driver.PS2Mouse    1.8.30
org.rehabman.voodoo.driver.PS2Trackpad    1.8.30
org.rehabman.voodoo.driver.PS2Keyboard    1.8.30
com.insanelymac.AtherosE2200Ethernet    2.2.2
org.hwsensors.driver.LPCSensors    1800
org.hwsensors.driver.GPUSensors    1800
org.darkvoid.driver.IOElectrify    1.0.0
org.hwsensors.driver.ACPISensors    1800
org.rehabman.voodoo.driver.PS2Controller    1.8.30
org.rehabman.driver.AppleSmartBatteryManager    1.90.1
org.hwsensors.driver.SMMSensors    1800
org.rehabman.driver.VoodooTSCSync    1.5.0
org.hwsensors.driver.CPUSensors    1800
as.lvs1974.AirportBrcmFixup    1.1.9
org.tw.CodecCommander    2.7.1
as.vit9696.WhateverGreen    1.2.6
as.vit9696.Lilu    1.3.4
org.netkas.driver.FakeSMC    1800
com.rehabman.driver.USBInjectAll    0.7.1
com.apple.filesystems.msdosfs    1.10
com.apple.driver.AppleGraphicsDevicePolicy    3.20.14
com.apple.AGDCPluginDisplayMetrics    3.20.0
com.apple.filesystems.autofs    3.0
com.apple.filesystems.ntfs    3.13
com.apple.driver.AppleHV    1
com.apple.driver.AudioAUUC    1.70
com.apple.iokit.IOUserEthernet    1.0.1
com.apple.driver.AppleUpstreamUserClient    3.6.5
com.apple.iokit.IOBluetoothSerialManager    6.0.7f12
com.apple.driver.AppleMCCSControl    1.5.5
com.apple.driver.AppleHDAHardwareConfigDriver    282.10
com.apple.driver.pmtelemetry    1
com.apple.driver.AppleIntelKBLGraphics    10.3.6
com.apple.driver.AppleTyMCEDriver    1.0.3d2
com.apple.Dont_Steal_Mac_OS_X    7.0.0
com.apple.driver.AppleHDA    282.10
com.apple.nvidia.NVDAStartup    10.3.2
com.apple.driver.AppleIntelCFLGraphicsFramebuffer    10.3.6
com.apple.driver.AppleOSXWatchdog    1
com.apple.driver.ACPI_SMC_PlatformPlugin    1.0.0
com.apple.driver.AppleFIVRDriver    4.1.0
com.apple.driver.AppleIntelSlowAdaptiveClocking    4.0.0
com.apple.driver.AppleFileSystemDriver    3.0.1
com.apple.filesystems.hfs.kext    407.50.6
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless    1.0.0d1
com.apple.BootCache    40
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib    1.0.0
com.apple.AppleSystemPolicy    1.0
com.apple.filesystems.apfs    748.51.0
com.apple.driver.AppleAHCIPort    329.50.2
com.apple.driver.AppleACPIButtons    6.1
com.apple.driver.AppleACPIEC    6.1
com.apple.driver.AppleRTC    2.0
com.apple.driver.AppleHPET    1.8
com.apple.driver.AppleSMBIOS    2.1
com.apple.driver.AppleAPIC    1.7
com.apple.nke.applicationfirewall    183
com.apple.security.TMSafetyNet    8
com.apple.security.quarantine    3
com.apple.driver.AppleGraphicsControl    3.20.14
com.apple.iokit.IOAVBFamily    683.1
com.apple.plugin.IOgPTPPlugin    680.15
com.apple.iokit.IOEthernetAVBController    1.1.0
com.apple.kext.triggers    1.0
com.apple.driver.AppleSSE    1.0
com.apple.iokit.IOSerialFamily    11
com.apple.driver.AppleSMBusController    1.0.18d1
com.apple.driver.DspFuncLib    282.10
com.apple.kext.OSvKernDSPLib    526
com.apple.iokit.IONDRVSupport    519.21
com.apple.AppleGPUWrangler    3.20.0
com.apple.driver.AppleHDAController    282.10
com.apple.iokit.IOHDAFamily    282.10
com.apple.driver.AppleSMBusPCI    1.0.14d1
com.apple.AppleGraphicsDeviceControl    3.20.14
com.apple.iokit.IOAcceleratorFamily2    378.26
com.apple.iokit.IOGraphicsFamily    519.21
com.apple.iokit.IOSurface    211.15
com.apple.driver.IOPlatformPluginLegacy    1.0.0
com.apple.driver.IOPlatformPluginFamily    6.0.0d8
com.apple.iokit.IOSlowAdaptiveClockingFamily    1.0.0
com.apple.driver.usb.IOUSBHostHIDDevice    1.2
com.apple.iokit.IOBluetoothHostControllerUSBTransport    6.0.7f12
com.apple.iokit.IOBluetoothHostControllerTransport    6.0.7f12
com.apple.driver.IOBluetoothHIDDriver    6.0.7f12
com.apple.iokit.IOBluetoothFamily    6.0.7f12
com.apple.iokit.IOUSBHIDDriver    900.4.1
com.apple.driver.usb.cdc    5.0.0
com.apple.driver.usb.networking    5.0.0
com.apple.driver.usb.AppleUSBHostCompositeDevice    1.2
com.apple.filesystems.hfs.encodings.kext    1
com.apple.driver.usb.AppleUSBHostPacketFilter    1.0
com.apple.iokit.IOUSBFamily    900.4.1
com.apple.driver.AppleXsanScheme    3
com.apple.iokit.IOAHCIBlockStorage    301.40.2
com.apple.iokit.IONVMeFamily    2.1.0
com.apple.iokit.IOAHCIFamily    288
com.apple.driver.usb.AppleUSBXHCIPCI    1.2
com.apple.driver.usb.AppleUSBXHCI    1.2
com.apple.driver.AppleEFINVRAM    2.1
com.apple.driver.AppleEFIRuntime    2.1
com.apple.iokit.IOSMBusFamily    1.1
com.apple.iokit.IOHIDFamily    2.0.0
com.apple.security.sandbox    300.0
com.apple.kext.AppleMatch    1.0.0d1
com.apple.iokit.IOAudioFamily    206.5
com.apple.vecLib.kext    1.2.0
com.apple.driver.DiskImages    480.60.2
com.apple.driver.AppleFDEKeyStore    28.30
com.apple.driver.AppleEffaceableStorage    1.0
com.apple.driver.AppleKeyStore    2
com.apple.driver.AppleUSBTDM    439.70.3
com.apple.driver.AppleMobileFileIntegrity    1.0.5
com.apple.iokit.IOUSBMassStorageDriver    140.70.2
com.apple.iokit.IOSCSIBlockCommandsDevice    404.30.2
com.apple.iokit.IOSCSIArchitectureModelFamily    404.30.2
com.apple.iokit.IOStorageFamily    2.1
com.apple.driver.AppleCredentialManager    1.0
com.apple.driver.KernelRelayHost    1
com.apple.iokit.IOUSBHostFamily    1.2
com.apple.driver.usb.AppleUSBCommon    1.0
com.apple.driver.AppleBusPowerController    1.0
com.apple.driver.AppleSEPManager    1.0.1
com.apple.driver.IOSlaveProcessor    1
com.apple.iokit.IOTimeSyncFamily    680.15
com.apple.iokit.IONetworkingFamily    3.4
com.apple.iokit.IOReportFamily    31
com.apple.driver.AppleACPIPlatform    6.1
com.apple.driver.AppleSMC    3.1.9
com.apple.iokit.IOPCIFamily    2.9
com.apple.iokit.IOACPIFamily    1.4
com.apple.kec.pthread    1
com.apple.kec.Libm    1
com.apple.kec.corecrypto    1.0

EOF
Model: MacBookPro14,3, BootROM 185.0.0.0.0, 6 processors, Intel Core i7, 2.21 GHz, 32 GB, SMC 2.45f0
Graphics: NVIDIA GeForce GTX 1070, NVIDIA GeForce GTX 1070, PCIe
Memory Module: BANK 0/DIMM0, 16 GB, DDR4, 2667 MHz, SK Hynix, HMA82GS6CJR8N-VK
Memory Module: BANK 1/DIMM0, 16 GB, DDR4, 2667 MHz, SK Hynix, HMA82GS6CJR8N-VK
Bluetooth: Version 6.0.7f12, 3 services, 19 devices, 1 incoming serial ports
PCI Card: NVIDIA GeForce GTX 1070, Display Controller, Slot-1
Serial ATA Device: HGST HTS721010A9E630, 1 TB
USB Device: USB 3.1 Bus
USB Device: Bluetooth HCI
USB Device: Integrated_Webcam_FHD
USB Device: AW-ELC
USB Device: Razer Atheris - Mobile Gaming Mouse
USB Device: 802.11n NIC
Thunderbolt Bus: 
<EOM>

===========

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×