Jump to content
ITzTravelInTime

TINU: The bootable macOS installer creation tool - Mac app

314 posts in this topic

Recommended Posts

Advertisement
4 hours ago, al6042 said:

Just saw a similar initial display while using the VoodooTSSync Configurator.. ;)

 

 

Yes, but i have implemented the buttons in a different way and with some shadow effects, and also i am using a more minimal approach for the ui in  tinu

Share this post


Link to post
Share on other sites

Finally some updates about TINU, after a lot of work under the hood work, because of the bugs i found and also because of the design changements, i am close to the release of the 2.1 version and the open beta testing for tinu 3, so i am currently chegking everything and sending the software to some closed beta testers, and also i have done a collboration video about tinu on the youtube channel of Peter Paul Chato which will go online soon ( i will link it here ).

 

So don't worry, this project is still going on.

Share this post


Link to post
Share on other sites
37 minutes ago, Gigamaxx said:

Chato, I’ve been subscribed for a while.   Nice!

 

Yes, he really liked this tool, and we are going to continue doing stuff together.

 

for all the curious folks out there, here is a link to the video: https://youtu.be/GJnI1RwM1xs

 

Share this post


Link to post
Share on other sites
9 hours ago, Gigamaxx said:

You got to help him with that R9 280X, lol watching the video (3 hrs later for me) both of us said "it shoiuld be" at exactly the same time.  

 

Yes, but i remember that he got video acceleration on mojave and i told him that this card is supported for metal, maybe is just a missplacement of the system informations app.

Share this post


Link to post
Share on other sites
7 hours ago, ITzTravelInTime said:

 

Yes, but i remember that he got video acceleration on mojave and i told him that this card is supported for metal, maybe is just a missplacement of the system informations app.

Are you guys talking behind my back? Yes my R9 280X is showing metal support.

Edited by PPC

Share this post


Link to post
Share on other sites
1 hour ago, PPC said:

Are you guys talking behind my back? Yes my R9 280X is showing metal support.

 

Ehmmm ... no, we where just discussing about how great was my help :-D

1 hour ago, PPC said:

Are you guys talking behind my back? Yes my R9 280X is showing metal support.

 

But seriously the r9 280x is one of the best mac-compatible gfx cards out there

Share this post


Link to post
Share on other sites
38 minutes ago, ITzTravelInTime said:

 

Ehmmm ... no, we where just discussing about how great was my help :-D

 

But seriously the r9 280x is one of the best mac-compatible gfx cards out there

 

Aside from my R7 265 2gb, lol.    It lists as a R9 270x or HD7xxx.   It’s a cut down R9 270 I got for $130 years ago.   Mojave metal!

Share this post


Link to post
Share on other sites
5 hours ago, PPC said:

Are you guys talking behind my back? Yes my R9 280X is showing metal support.

OMG!! PPC!!! Love your channel! Welcome to Insanely Mac!! It says you just joined. How long did it take you to complete "the test" so you could join in the forums?*

 

ETA: And now I see you've made a comment over on camera conspiracies. Another favorite. Stay out of my head, PPC!

 

 

 

 

*they might not be doing that anymore.

Edited by passoporto

Share this post


Link to post
Share on other sites
1 hour ago, passoporto said:

OMG!! PPC!!! Love your channel! Welcome to Insanely Mac!! It says you just joined. How long did it take you to complete "the test" so you could join in the forums?*

 

ETA: And now I see you've made a comment over on camera conspiracies. Another favorite. Stay out of my head, PPC!

 

 

 

 

*they might not be doing that anymore.

Thanks. This is a great group. The organization of the content confuses me but I'll get it one day. I"m still going through the hazing process. I still have to attach a Vega64, fans at full throttle over my nipples for 15 minutes. Not looking forward to that.

Share this post


Link to post
Share on other sites
1 hour ago, errorexists said:

how to install clover efi, i am taking the efi from my efi/efi
image.png.426fcae5e8d9d14a4e551bc85395c53d.png

 

I am already working to imrpove that for the next TINU relese, but you should just open the exi folder and the efi folder must contan the folders: clover, clover/kexts, clover/kexts/others, clover/drivers64, clover/drivers64uefi, boot, and the files: clover/config.plist and also the 2 clover executables files.

Share this post


Link to post
Share on other sites
12 minutes ago, ITzTravelInTime said:

 

I am already working to imrpove that for the next TINU relese, but you should just open the exi folder and the efi folder must contan the folders: clover, clover/kexts, clover/kexts/others, clover/drivers64, clover/drivers64uefi, boot, and the files: clover/config.plist and also the 2 clover executables files.

 

I have tried couple ways an was using my efi folder from my efi/efi https://youtu.be/_VsN0TTE5DE

 

Share this post


Link to post
Share on other sites
27 minutes ago, errorexists said:

 

I have tried couple ways an was using my efi folder from my efi/efi https://youtu.be/_VsN0TTE5DE

 

 you should open the EFI folder which contains the boot and the clover folder and not any other folder or subfolder, and you have to make sure that the EFI folder does contain all the stuff that i said or other wise you are always going to get that message.

Share this post


Link to post
Share on other sites
27 minutes ago, ITzTravelInTime said:

 you should open the EFI folder which contains the boot and the clover folder and not any other folder or subfolder, and you have to make sure that the EFI folder does contain all the stuff that i said or other wise you are always going to get that message.

 

Seems like I too is having the same issue of not able to copy EFI folder. I am testing this on the latest public release.

 

Attached is the video link.

 

 

 

Share this post


Link to post
Share on other sites
10 minutes ago, onemanOSX said:

 

Seems like I too is having the same issue of not able to copy EFI folder. I am testing this on the latest public release.

 

Attached is the video link.

 

 

 

You have just to choose the EFI folder and not any other folder inside of it.

Share this post


Link to post
Share on other sites

That was what I was trying to do. I was merely showing that the EFI folder contains the boot folder and clover folder. Then I clicked the main EFI folder to continue.

 

Edit: I even tried choosing the EFI partition which of course as expected fails.

Edited by onemanOSX

Share this post


Link to post
Share on other sites
11 minutes ago, onemanOSX said:

That was what I was trying to do. I was merely showing that the EFI folder contains the boot folder and clover folder. Then I clicked the main EFI folder to continue.

 

Well, in the new version i am working on i have a more detailed info about that error, so when i will pulish it for pre-relese i sugegst you to try it.

 

And also in the video i see that your EFI folder is missing the drivers64 folder inside the clover folder, this folder is required in this verion of tinu, but it will no longer be required in the new version, so try to create an empty drivers64 folder inside your efi/clover folder and then try again.

Edited by ITzTravelInTime

Share this post


Link to post
Share on other sites
2 minutes ago, ITzTravelInTime said:

drivers64 folder inside the clover folder, this folder is required in this verion of tinu, but it will no longer be required in the new version

 

Thank you for the clarification. Yes, adding an empty drivers64 folder indeed enable me to proceed to the next step.

 

I will continue to test and see if installation is a success.

Share this post


Link to post
Share on other sites

On completion of USB writing, an error pops up.

 

1. Sorry, I did not capture a screenshot of it. But, its in the lines of "unable to copy custom folder/setting..."

2. I checked EFI folder on USB and its contents differs from the EFI that I am trying to copy from (I suppose this is expected as per the error above)

 

If you'd like a copy of the log, I will be glad to recreate. Cheers!

 

 

Share this post


Link to post
Share on other sites
Just now, onemanOSX said:

On completion of USB writing, an error pops up.

 

1. Sorry, I did not capture a screenshot of it. But, its in the lines of "unable to copy custom folder/setting..."

2. I checked EFI folder on USB and its contents differs from the EFI that I am trying to copy from (I suppose this is expected as per the error above)

 

If you'd like a copy of the log, I will be glad to recreate. Cheers!

 

 

 

yes, give me a copy of the log, that efi folder feature is still very buggy and experimental, that's why i am not advertising it, currelty the best way to have your efi folder installed on the usb drive is to do it yourself after the creation of the installer by tinu

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By BiggestDrugo
      Hi, I have an MSI 945gcm5 v2 and was wondering if it's possible to run Hackintosh High Sierra on this board? It will run Lion, but my guess is that the chipset and various other factors will prevent an upgrade to High Sierra. Any thoughts?
    • By plasticduck35
      I have a hackintosh running 10.13.5 (High Serria) that works except it doesn't shutdown properly and it doesn't seem to be going to sleep. 
       
      Here are some diagnostics that I gathered 
       
      Davids-MacBook-Air-2:~ davidozersky$ sudo pmset -g Password: System-wide power settings: Currently in use: hibernatemode 0 womp 0 networkoversleep 0 sleep 5 (sleep prevented by diskmanagementd, UserEventAgent, mds, diskarbitrationd, coreaudiod, mds_stores, Disk Utility) Sleep On Power Button 1 ttyskeepawake 1 hibernatefile /var/vm/sleepimage disksleep 10 displaysleep 5  
      And I've attached files from a RunMe utility app I've found online. 
       
       
      Any ideas? 
       
      Thank you, 
      David
      runmereport.ioreg
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Pro and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Pro, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8700k, 9600k, 9700k, 9900k
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install.
       
       
      HARDWARE USED
      • Intel I9 9900k 
      • Gigabyte AORUS Z390 PRO
      • Sapphire Nitro+ SE Vega56 ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • Coolermaster MASTERLIQUID ML360R RGB CPU Cooler
      • Samsung 970 EVO 1TB NVMe SSD macOS Mojave
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       
       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
       
       
      CLOVER  FOLDER
      Use this folder with fully patched DSDT
      Z390 Pro DSDT EFI.zip   (Updated 21 July 2019)
       
       
      ADDITIONAL DSDT's  (A big thanks to @MaLd0n for compiling these extra DSDT's)
      If your using a Vega 56/64 or Radion VII then use this DSDT (already installed in my EFI)
      DSDT.VEGA.VII.zip
      If your using a RX Series or Nvidia GPU then use this DSDT
      DSDT.RXxxx.NVIDIA.zip
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://olarila.com/forum/viewtopic.php?f=19&t=1131 
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      Clover
      Clover Configurator
      Kext Updater
       
       
      OPTIONAL DOWNLOADS
      AirportBrcmFixup.kext    (If your Wifi Card isn't working after installing my EFI then add the AirportBrcmFixup.kext to your clover kext folder and reboot)
      FakeSMC    (Can be used instead of VirtualSMC)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F10)
       
      • Enter BIOS → Press F12 → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • BIOS → Windows 8/10 Features → Other OS
      • BIOS → CSM Support → Enabled  (Can be set to disabled depending on what GPU you use)
       
      • MIT → Advanced Memory Settings  → Extreme Memory Profile (X.M.P) → Enabled  
       
      • Peripherals → Initial Display Output → PCIe 1 Slot
      • Peripherals → Trusted Computing → Security Device Support →  Disable
      • Peripherals → Intel(R)Bios Guard → Intel BIOS Guard Support →  Disable
      • Peripherals → USB Configuration → Legacy USB Support →  Enabled
      • Peripherals → USB Configuration → XHCI Hand-off →  Enabled
      • Peripherals → Network Stack Configuration → Network Stack →  Disabled
      • Peripherals → SATA And RST Configuration → SATA Mode Selection →  AHCI
       
      • Chipset → Vt-d → Enabled  (can be enabled or disabled, your choice)
      • Chipset → Internal Graphics → Disabled
      • Chipset → Audio Controller → Enabled
      • Chipset → Above 4G Decoding → Disabled 
       
      • Power → Platform Power Management → Enabled
      • Power → ErP → Enabled  (can be enabled or disabled, your choice)
      • Power → RC6 (Render Standby) → Disabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS
       

       

       

       

       

       

       

       

       

       

       

       

    • By Ethan Jarvis
      Hello,
       
      Here I am looking for the answer of new Mac OS Catalina features and what type of Mac will support this new Os??
×