Jump to content
ITzTravelInTime

TINU: The bootable macOS installer creation tool - Mac app

343 posts in this topic

Recommended Posts

Advertisement
4 hours ago, al6042 said:

Just saw a similar initial display while using the VoodooTSSync Configurator.. ;)

 

 

Yes, but i have implemented the buttons in a different way and with some shadow effects, and also i am using a more minimal approach for the ui in  tinu

Share this post


Link to post
Share on other sites

Finally some updates about TINU, after a lot of work under the hood work, because of the bugs i found and also because of the design changements, i am close to the release of the 2.1 version and the open beta testing for tinu 3, so i am currently chegking everything and sending the software to some closed beta testers, and also i have done a collboration video about tinu on the youtube channel of Peter Paul Chato which will go online soon ( i will link it here ).

 

So don't worry, this project is still going on.

Share this post


Link to post
Share on other sites
37 minutes ago, Gigamaxx said:

Chato, I’ve been subscribed for a while.   Nice!

 

Yes, he really liked this tool, and we are going to continue doing stuff together.

 

for all the curious folks out there, here is a link to the video: https://youtu.be/GJnI1RwM1xs

 

Share this post


Link to post
Share on other sites
9 hours ago, Gigamaxx said:

You got to help him with that R9 280X, lol watching the video (3 hrs later for me) both of us said "it shoiuld be" at exactly the same time.  

 

Yes, but i remember that he got video acceleration on mojave and i told him that this card is supported for metal, maybe is just a missplacement of the system informations app.

Share this post


Link to post
Share on other sites
7 hours ago, ITzTravelInTime said:

 

Yes, but i remember that he got video acceleration on mojave and i told him that this card is supported for metal, maybe is just a missplacement of the system informations app.

Are you guys talking behind my back? Yes my R9 280X is showing metal support.

Edited by PPC

Share this post


Link to post
Share on other sites
1 hour ago, PPC said:

Are you guys talking behind my back? Yes my R9 280X is showing metal support.

 

Ehmmm ... no, we where just discussing about how great was my help :-D

1 hour ago, PPC said:

Are you guys talking behind my back? Yes my R9 280X is showing metal support.

 

But seriously the r9 280x is one of the best mac-compatible gfx cards out there

Share this post


Link to post
Share on other sites
38 minutes ago, ITzTravelInTime said:

 

Ehmmm ... no, we where just discussing about how great was my help :-D

 

But seriously the r9 280x is one of the best mac-compatible gfx cards out there

 

Aside from my R7 265 2gb, lol.    It lists as a R9 270x or HD7xxx.   It’s a cut down R9 270 I got for $130 years ago.   Mojave metal!

Share this post


Link to post
Share on other sites
5 hours ago, PPC said:

Are you guys talking behind my back? Yes my R9 280X is showing metal support.

OMG!! PPC!!! Love your channel! Welcome to Insanely Mac!! It says you just joined. How long did it take you to complete "the test" so you could join in the forums?*

 

ETA: And now I see you've made a comment over on camera conspiracies. Another favorite. Stay out of my head, PPC!

 

 

 

 

*they might not be doing that anymore.

Edited by passoporto

Share this post


Link to post
Share on other sites
1 hour ago, passoporto said:

OMG!! PPC!!! Love your channel! Welcome to Insanely Mac!! It says you just joined. How long did it take you to complete "the test" so you could join in the forums?*

 

ETA: And now I see you've made a comment over on camera conspiracies. Another favorite. Stay out of my head, PPC!

 

 

 

 

*they might not be doing that anymore.

Thanks. This is a great group. The organization of the content confuses me but I'll get it one day. I"m still going through the hazing process. I still have to attach a Vega64, fans at full throttle over my nipples for 15 minutes. Not looking forward to that.

Share this post


Link to post
Share on other sites
1 hour ago, errorexists said:

how to install clover efi, i am taking the efi from my efi/efi
image.png.426fcae5e8d9d14a4e551bc85395c53d.png

 

I am already working to imrpove that for the next TINU relese, but you should just open the exi folder and the efi folder must contan the folders: clover, clover/kexts, clover/kexts/others, clover/drivers64, clover/drivers64uefi, boot, and the files: clover/config.plist and also the 2 clover executables files.

Share this post


Link to post
Share on other sites
12 minutes ago, ITzTravelInTime said:

 

I am already working to imrpove that for the next TINU relese, but you should just open the exi folder and the efi folder must contan the folders: clover, clover/kexts, clover/kexts/others, clover/drivers64, clover/drivers64uefi, boot, and the files: clover/config.plist and also the 2 clover executables files.

 

I have tried couple ways an was using my efi folder from my efi/efi https://youtu.be/_VsN0TTE5DE

 

Share this post


Link to post
Share on other sites
27 minutes ago, errorexists said:

 

I have tried couple ways an was using my efi folder from my efi/efi https://youtu.be/_VsN0TTE5DE

 

 you should open the EFI folder which contains the boot and the clover folder and not any other folder or subfolder, and you have to make sure that the EFI folder does contain all the stuff that i said or other wise you are always going to get that message.

Share this post


Link to post
Share on other sites
27 minutes ago, ITzTravelInTime said:

 you should open the EFI folder which contains the boot and the clover folder and not any other folder or subfolder, and you have to make sure that the EFI folder does contain all the stuff that i said or other wise you are always going to get that message.

 

Seems like I too is having the same issue of not able to copy EFI folder. I am testing this on the latest public release.

 

Attached is the video link.

 

 

 

Share this post


Link to post
Share on other sites
10 minutes ago, onemanOSX said:

 

Seems like I too is having the same issue of not able to copy EFI folder. I am testing this on the latest public release.

 

Attached is the video link.

 

 

 

You have just to choose the EFI folder and not any other folder inside of it.

Share this post


Link to post
Share on other sites

That was what I was trying to do. I was merely showing that the EFI folder contains the boot folder and clover folder. Then I clicked the main EFI folder to continue.

 

Edit: I even tried choosing the EFI partition which of course as expected fails.

Edited by onemanOSX

Share this post


Link to post
Share on other sites
11 minutes ago, onemanOSX said:

That was what I was trying to do. I was merely showing that the EFI folder contains the boot folder and clover folder. Then I clicked the main EFI folder to continue.

 

Well, in the new version i am working on i have a more detailed info about that error, so when i will pulish it for pre-relese i sugegst you to try it.

 

And also in the video i see that your EFI folder is missing the drivers64 folder inside the clover folder, this folder is required in this verion of tinu, but it will no longer be required in the new version, so try to create an empty drivers64 folder inside your efi/clover folder and then try again.

Edited by ITzTravelInTime

Share this post


Link to post
Share on other sites
2 minutes ago, ITzTravelInTime said:

drivers64 folder inside the clover folder, this folder is required in this verion of tinu, but it will no longer be required in the new version

 

Thank you for the clarification. Yes, adding an empty drivers64 folder indeed enable me to proceed to the next step.

 

I will continue to test and see if installation is a success.

Share this post


Link to post
Share on other sites

On completion of USB writing, an error pops up.

 

1. Sorry, I did not capture a screenshot of it. But, its in the lines of "unable to copy custom folder/setting..."

2. I checked EFI folder on USB and its contents differs from the EFI that I am trying to copy from (I suppose this is expected as per the error above)

 

If you'd like a copy of the log, I will be glad to recreate. Cheers!

 

 

Share this post


Link to post
Share on other sites
Just now, onemanOSX said:

On completion of USB writing, an error pops up.

 

1. Sorry, I did not capture a screenshot of it. But, its in the lines of "unable to copy custom folder/setting..."

2. I checked EFI folder on USB and its contents differs from the EFI that I am trying to copy from (I suppose this is expected as per the error above)

 

If you'd like a copy of the log, I will be glad to recreate. Cheers!

 

 

 

yes, give me a copy of the log, that efi folder feature is still very buggy and experimental, that's why i am not advertising it, currelty the best way to have your efi folder installed on the usb drive is to do it yourself after the creation of the installer by tinu

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By tonyx86
      **********************************************************************************
      In this thread, I have fully documented the installation of macOS Catalina on my HP EliteDesk 800 G4 Mini. It is a PERFECT HackMini8,1 and is running very well for me without any issues. I hope this documentation helps you to install macOS on your hack. Please leave feedback if you think there is anything I can improve and let me know if you have any questions.
      **********************************************************************************
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       

       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec Unsupported M.2 PCIe x1 2230 Intel Wi-Fi (currently disabled in BIOS).  I may replace this with Brcm, but am using only Ethernet (IntelMausi) for now.  
      macOS Installation
      See macOS installation steps here See Known Issues here for additional installation steps that may not yet be included in my attached config files See CLOVER (UEFI) installation later in this first post
      See BIOS configuration in attached BIOS configuration PDF document
      See EFI and /L/E kexts in attached EliteDesk.zip archive See how I developed my installation methodology here See references here See instructions here for installing two M.2 2280 NVMe SSDs and one SATA HD / SSD  
      What is not working
      Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card).  
      What is not tested
      USB c 3.1 port (I have partially tested the USB 3 functionality of the port and it seems to be working fine with the SSDT-UIAC.aml here) Microphone port  
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet Auto-sensing headphone jack automatically switches to internal speaker when headphones removed  
      Known Issues and their solutions - see here
       
      BIOS Version / Configuration
      Version: 02.11.01 Rev.A See attached BIOS configuration in PDF document "HP EliteDesk 800 G4 Mini BIOS Configuration.pdf" Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration
      Clover for UEFI booting only Install Clover in the ESP UEFI Drivers Recommended drivers DataHubDxe FSInject SMCHelper File System drivers ApfsDriverLoader VBoxHfs Memory fix drivers AptioMemoryFix Additional drivers NvmExpressDxe Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane (option not available when installing on USB thumb drive)  
      UHD 630 Framebuffer Patching
      See here and here  
      Current Versions
      Catalina 10.15.5.02 Clover (UEFI) r5119 Lilu.kext 1.4.5 WhateverGreen.kext 1.4.0 AppleALC.kext 1.5.0 IntelMausi 1.0.3 (Not IntelMausiEthernet)  
      Credits To be provided
       
      ScreenShots
       
       
      HP EliteDesk 800 G4 Mini BIOS Configuration.pdf
      EliteDesk800 G4 Mini - Rev 0.91.zip
    • By MaLd0n
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -Tutorial
      https://tinyurl.com/re2c9sz
       
      -Post Installation
      Paste EFI folder into EFI Partition in your SSD, reboot and extract one full dump with this app and post here!
      https://tinyurl.com/ybwr9kq3
      RunMe.app
      https://tinyurl.com/y9562hz7
       
      --DSDT PATCHES--
       
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--
       









































       
       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, headkaze, onemanosx, erroruser, Jenny David, Sampath007, Facebook Hackintosh community, Facebook Olarila community, SchmockLord, daliansky and many, many, many others!
       
      We're all here to have fun and learn from each other!
    • By MaLd0n
      ---USB---
      https://pikeralpha.wordpress.com/2016/07/13/simple-skylake-usb-fix-no-kexts-required/
       
      ---CLOVER FOLDER---
      https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/
       
       
      --MOBO
      GigaByte Z390 M Gaming



      --PROCESSOR
      Intel Core i9-9900K


      --COOLER
      CoolerMaster MasterLiquid ML120R RGB


      --MEMORY
      Corsair Dominator Platinum 16GB (2 x 8GB)


      --GPU
      Sapphiretech Radeon RX 590 8 GB GDDR5


       
      --SSD
      Samsung 970 EVO NVMe M2 Flash Drive


      --POWER SUPPLY
      EVGA 750 N1, 750W


      --WIRELESS
      TP-Link Archer T9E


      --BLUETOOTH
      Orico BTA-403


      --CASE
      Thermaltake View 21 Tempered Glass Edition


      --DSDT Patches--
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 10 ID -DMAC -REMOVE 22K LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -MIKEY -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -OPERATION REGION GPIO -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--





























      --BruceX--
       
      --USB-C-- test with SanDisk Ultra USB-STICK 128gb


       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
×