Jump to content

Asus P5W DH Deluxe thread for JAS 10.4.8

622 posts in this topic

Recommended Posts

I thought I would start an actual Asus P5W DH Deluxe thread for all us that have one so we can discuss issues it has with the new kernal in jas 10.4.8 release DVD and hopefully feed off each other and get some answers.


Here is where I'm at, let me know if anything is different for you.


10.4.8 clean install.


I can only use Semetex kernal, with the login window patch and the combo 10.4.8 update. If I install the USB fix in the install I don't have a keyboard or mouse, and if I install the Radeon x1000 fix it boots but has sever graphic problems.


Also with a clean install I have no sound, and I haven't been able to get it working. I also have no internet. Both nics show up but I can't get a DHCP address and manually assigning one doesn't fix anything. I haven't been able to quite figure that out. I did use a modified IOFamily kext that fixed the issue but I get an error everytime I boot saying the kext is unsupported.


My video, although definately not related to the motherboard, is also Fubar. I've tried the manual install of the borisbadenov method and I've also tried 3.2, 3.5 and 3.6 of the Neopheus installers. No go. It will boot but I get a lot of artifacts on the screen. Funny since in 10.4.7 with the old kernal the 3.2 version worked wonderfully all I had to do was use switchresx to get my widescreen resolution/refresh rate and everything worked great. I have a Sapphire x1900 xtx 512MB BTW.



So where I'm at:


After many reinstalls and different kernals/kexts etc. I've decided to go this route. I just did a fresh install of jas 10.4.6 and combo updated it to the 10.4.7 release (I had issues with the 10.4.8 combo update on the old kernal) next I'm going to use the combo update off the new installer and then manually install the new 10.4.8 kernal.


I want to see if it will accept my kext for the sound/video/network and if it does I'll write up an install guide and get it out to all P5W owners.


So what do I need from you:


Some support! Lol, no actually I just need you to report what did and didn't work for you, if you've found any fixes and the procedures for fixing the native install of 10.4.8 and anything else you think would be helpful.



So with that said lets work together and fix this thing, because we used to have one of the most compatable motherboards, but somehow with the 10.4.8 release our compatability just went right down the crapper.

Link to comment
Share on other sites

Using JaS' 10.4.8 DVD the result is a functioning OS, although sound and networking do not work. Copying IONetworkingFamily.kext from the 10.4.8 intel combo update resolves the network problem, and AppleAzaliaAudio.kext (with the correct vendor id for the 882) takes care of sound. Recent Semthex kernels return the system clock to correct speeds. Titan.kext allows my 7900gt to work perfect with dvi. I still have the odd time where I can't shutdown, and sometimes I need to reset the computer multiple times for it to boot properly (may be cold boot related). I've never had any USB problems.

Link to comment
Share on other sites

Where did you connect CD/DVD-ROM and SATA drive?

Always see the DVD drive as primary master and the first HD as secondary master...


Also your BIOS settings might be good to know and what BIOS version you have...


Installes fine the JaS 10.4.8 reseed but after reboot it bials out with the "HFS+ partition error"...



thx in advance


Link to comment
Share on other sites

get the following from here and install it, up to you to fix permissions after you've installed them:




for audio, get AppleAzaliaAudio.kext.zip, unzip and put the kext in your /System/Library/Extentions/ (remove old one first and remove/backup AppleHDA.kext


for network get IONetworkingFamily.kext.zip, unzip and put the kext in your /System/Library/Extentions/ (remove old one first)


fix permissions :


sudo chown -R root:wheel /System/Library/Extentions/AppleAzaliaAudio.kext

sudo chmod -R 755 /System/Library/Extentions/AppleAzaliaAudio.kext


sudo chown -R root:wheel /System/Library/Extentions/IONetworkingFamily.kext

sudo chmod -R 755 /System/Library/Extentions/IONetworkingFamily.kext


cleanup kext caches :


sudo rm /System/Libary/Extensions.kextcache

sudo rm /System/Library/Extensions.mkext


then unzip IOUSBFamily-261.4.2_Intel.pkg.zip and install the package.


reboot and everything should be working (audio, both ethernet ports, USB).

Link to comment
Share on other sites

Renard45, could you tell us what "fixtime.reg" in your signature means?


If it's what I'm thinking about (the bug that change the ours between OSs) I'm interested! I have a 3-boot here: Win XP Pro 32 bits, Win XP Pro 64 bits and Mac OS X 10.4.8.

Link to comment
Share on other sites

Anyone is experiencing problems with videos?

I tryed different players (VLC.DVX etc)but all have a speed problem (they run fast with strange voices).

Any advice?





you'll likely need to get the latest semthex kernel or manually set your fsb when you boot with fsb=266 or whatever its running at.


yes Viper.Br that's it!


i will reinstall jas 10.4.7 because I have many bugs with the new kernel


are you using the latest semthex kernel? 10.4.8 with semthex is so stable here for me on my p5w-dh. if not go grab it on irc.

Link to comment
Share on other sites

This solution worked perfectly for me!



Before with 10.4.7 I could only boot about 1 out of 7 times, now I bootup like a normal OS should! And as a bonus I now get full network, Firewire, USB and Sound!!




Now if I can only get Titan to work with my 7950gx2 I'd be golden!



Thanks everyone!!



Link to comment
Share on other sites

For P5W DH Deluxe use DaemonES latest kernel - http://applelife.ru/developer/ - minimum changes from original Apple kernel, only added FSB autodetection, EFI changed to BIOS, HPET used if MB support, RTC used if not, NX used if CPU support.

First install OS from JAS 10.4.7, update with 10.4.8 Combo, replace kernel(DaemonES latest) and AppleSMBIOS.kext(best from paulicat), remove or move AppleHDA.kext and add AppleAzaliaAudio.kext, reboot.

In BIOS set ACPI 2.0 to YES (HPET support), MAX CPUID Limit to Enable, Execute Disable Function to Enable (NX/XD)

All device work - sound, net, ide, sata, usb etc.

Link to comment
Share on other sites

i had audio output, input but still no mic (AC97 option in the bios) with the method by Callysto in this post:




with HD Audio option in the bios just output audio, no input and no mic


i want to say i deleted the AppleAzaliaAudio.kext from extensions folder for having audio like this.

Link to comment
Share on other sites

ZOleg thanks a lot i have a question where did you connect your sata hard disk to the orange port or the red port?

To red SATA ports - Intel ICH7, but if you set in BIOS JMicron SATA controller to AHCI mode, it should also work.

Link to comment
Share on other sites


  • Create New...