Jump to content

Kext issue?


Go to solution Solved by Hannah_09,
10 posts in this topic

Recommended Posts

So ive been using hackintosh's for a long time, originally with an old dell p4 where i used to run 10.4 anyhow ive always generally purchased hardware that is mostly hackintosh compatible, plus i own quite a few real macs, anyhow i use a hackintosh for my Kitchen PC and its been working perfect up until now


 


Specs:


Mac OS 10.11 El Capitan


UNI install


Core 2 Duo Q6600


intel desktop board dq965gf


Nvidia Gt 210


 


I am forced to run it on El Capitan instead of sierra as the Q6600 does not support SSE4.1 which if you didnt know is now requierred to run Sierra (Though if i cant get the audio working on this system im going to buy a Intel DQ45CB along with an Q8200 and try install sierra on that)


 


Im using it with an Apple Cinema Display and i love using the computer, it replaced my old Mac Pro 1,1 when its power supply decided to go bang on me, and i paid probably $95 for this little system, and everything works, including sleep! 


 


Except recently after a El capitan Security update got installed by mistake (blame my bf) the audio has stopped working, previously the only kext that worked to get audio working was VoodooHda version 2.8.4 as anything newer it never found a device and now not even 2.8.4 is picking up an audio device, ive done a {censored} ton of looking online about this problem but cant seem to find anything, and i really do not want to reinstall the whole OS. 


 


So this is my problem i hope one of you amazing talented people cant help me, cheers!


 

How and where are your add-on kexts installed? /S/L/E? /L/E? Or Clover EFI kexts folder if you're running Clover?

 

You could try to repair kexts permissions and rebuild your cache. 'can make wonders.

 

If audio remains the only thing not working, you can also consider one of those ultra cheap USB sound cards. They work OOB with all OS X/macOS versions (from Leopard to High Sierra).

Kext is installed in /S/L/E, ive tried repairing permissions and rebuilding, i am running clover on the computer though so i will try installed the kext in the Clover's EFI folder after school and ill report back on how well it works, also i will take a look at using AppleALC!


- Thanks

How and where are your add-on kexts installed? /S/L/E? /L/E? Or Clover EFI kexts folder if you're running Clover?

 

You could try to repair kexts permissions and rebuild your cache. 'can make wonders.

 

If audio remains the only thing not working, you can also consider one of those ultra cheap USB sound cards. They work OOB with all OS X/macOS versions (from Leopard to High Sierra).

 

I tried installing the kext again but this time into the Clover EFI kexts folder, both in other and 10.11 but still no luck, ive been using "Easy Kext Pro" to repair permissions and rebuild the cache, maybe its not working? could maybe explain to me or flick me a link on how to do it manually?

 

- Thanks, Hannah <3 

Did you try this

 

AppleALC

 

Hey thanks for the suggestion, just installed the kext now and verified thats its starting before AppleHDA but still no audio, possibly because it doesnt support my sound card?

Must be possible to do again as it was working previously, anymore suggestions?

 

-Thanks, Hannah <3

If audio remains the only thing not working, you can also consider one of those ultra cheap USB sound cards. They work OOB with all OS X/macOS versions (from Leopard to High Sierra).

 

Thats a good idea, except im pretty much skint on money atm xD i literally made this hackintosh out of pc parts that ive gotten from friends/dumps so it would be preferrable to have on board audio working :P

 

If you or anyone shouts me one i'll love you forever <3 

To rebuild your cache: http://forum.osxlatitude.com/index.php?/topic/9961-how-do-i-repair-permissions-and-rebuild-the-cache-yosemite-and-later/

 

Ok you're skint but when I said cheap, I really meant dead cheap! https://www.ebay.com/sch/i.html?_from=R40&_sacat=0&_nkw=USB+audio&_sop=15

Got on of those for a tad over 1€ a few years back: http://www.ebay.com/itm/Laptop-PC-Sound-Cards-7-1-Channel-Audio-Sound-Card-Adapter-3-D-USB-2-0-Tool-/252982013371?hash=item3ae6e72dbb:g:eSsAAOSwGJlZJS43 Cheap & cheerful but "does exactly what it says on the tin!"

 

By the way, just to be sure, you are running VoodooHDA with AppleHDADisabler, right? Built-in audio of this ancient motherboard appears to be STAC9227, so VoodooHDA is indeed your best shot.

To rebuild your cache: http://forum.osxlatitude.com/index.php?/topic/9961-how-do-i-repair-permissions-and-rebuild-the-cache-yosemite-and-later/

 

Ok you're skint but when I said cheap, I really meant dead cheap! https://www.ebay.com/sch/i.html?_from=R40&_sacat=0&_nkw=USB+audio&_sop=15

Got on of those for a tad over 1€ a few years back: http://www.ebay.com/itm/Laptop-PC-Sound-Cards-7-1-Channel-Audio-Sound-Card-Adapter-3-D-USB-2-0-Tool-/252982013371?hash=item3ae6e72dbb:g:eSsAAOSwGJlZJS43 Cheap & cheerful but "does exactly what it says on the tin!"

 

By the way, just to be sure, you are running VoodooHDA with AppleHDADisabler, right? Built-in audio of this ancient motherboard appears to be STAC9227, so VoodooHDA is indeed your best shot.

 

 

Oh damn that is cheap haha, but tbh no i havnt been?? Im at school atm so i cant prove my theory but i originally installed the latest version of VoodooHDA with m u l t i b e a s t which i presume enabled the AppleHDAdisabler and then afterwards i replaced it with the old version of Voodoohda, i see on the voodooHDA download there is a .pkg file, will that install the kext and the AppleHDAdisabler?

 

- Thanks, Hannah <3

Yup. Or grab the 2 x kexts only, copy them to /S/L/E, repair permissions and rebuild your cache.

 

 

Where about can i download just the kexts from?

Wait, nevermind i dont need to, using my real mac i created a Fake HDD image, which i installed the latest voodooHDA package onto and it has given me the AppleHDADisabler kext (Yay progress) so after school i will install these kexts onto my hackintosh along with the old voodoo 2.8.4 and see if that works!

 

yrlWgfk.png

  • Solution

SUCESS!! FINALLY!! 

 

Thank you so much for all the help!! it seems all i needed was that AppleHDADisabler.kext!! 

 

Silly me!! if there is anything i can ever do to thank you just let me know! Its now fully working!

 

1zYdIQU.jpg

  • Like 1
×
×
  • Create New...