Jump to content
macinsane

[SUCCESS] ASUS Prime B250M-C with i5 7500, AMD RX560, NVMe

13 posts in this topic

Recommended Posts

What works? Everything. Sleep/Wake, NVMe, Airport, Spotlight, AMD-graphics

Config:
ASUS Prime B250M-C µATX-board
Intel Core i5 7500 (Kaby Lake)
Gigabyte Radeon RX560 4GB
Airport-compatible PCIe-Card for Wifi and Bluetooth (BCM943602CS)
2 NVMe drives: Samsung P961 with 1 TB and 256 GB

Installed mac OS: 10.13.2
Clover: 4334

 

*Update 10.13.3*

Added new config.plist and ssdt for AMD injection (config_amd_ssdt_10133.zip). With this config and Intel IGPU activated you'll get Metal2 (macOS GPUFamily1 v3). What did I do? Had to fake Skylake graphics or to prevent apps like iMovie or FinalCut from crashing. With Kabylake kexts loaded and IGPU as secondary graphics card, the computer will hard reset whenever the Intel GPU is utilised. Only Skylake kexts and activated IGPU will give you working Metal2 for the RX560.  

 

*Update 10.13.2*

Since this update a new approach is advisable to get the RX560 up and running (works for 10.13.1 and GM as well). I've added a working SSDT and injector kext that gives you graphics and HDMI audio. Sleep works fine too if you add the DSDT I compiled.  

 

Credits go to @Toledo @Mork vom Ork and @Mieze because their work made this possible.

*Update* I've added NEW config.plist and DSDT. For proper graphics power management you have to activate onboard graphics in BIOS but make PCIE the primary display. Furthermore you have to inject ig-platform-id 0x59120003 and let Clover patch GFX0 to IGPU. This is the only way to avoid crashes of iMovie, FinalCut or slowdowns after video playback.

This may be the smoothest Hackintosh of my life. It is easier than Sierra install due to native support for most of the used hardware in High Sierra. Not much to do, using an up-to-date Clover version like 4184. Make sure you have apfs.efi in /Clover/drivers64UEFI/ on your EFI partition and that you delete EmuVariableUEFi.efi (downside: iMessage doesn't work without it). Somehow Rehabman's SSDT in /Clover/ACPI/patched helps avoiding crashes in iTunes.


Needed kexts (on your EFI into /Clover/kexts/Other): FakeSMC, IntelMausiEthernet for ethernet, USBInjectAll and XHCI-200-series-injector for USB, Lilu and AppleALC for audio, Whatevergreen for AMD graphics, IntelGraphicsFixup and AMD9xxxControllerPatcher.kext.

 

DSDT and SSDT go into EFI/Clover/ACPI/patched.

config.plist.zip

AMD9xxxControllerPatcher.kext.zip

SSDT-HDMI-AMD-PEG0.aml.zip

DSDT.aml.zip

config_amd_ssdt_10133.zip

Share this post


Link to post
Share on other sites
Advertisement

Hey there,

 

I'm considering buying the Radeon RX560. Can you tell me if it's fully supported / performing like you expected it to? Are there any issues or stuff not working?

Also, did you have to use another card / display port at any stage? I don't have onboard graphics, so I will have to do the entire installation and troubleshooting using the card.

 

Thanks.

Share this post


Link to post
Share on other sites

It should be fully supported and you'll only need whatevergreen.kext (and of course lilu.kext) to make it work. However, I still have activated the Intel graphics for iTunes support etc. Nearly every dedicated graphics card (nVidia and AMD) has DRM problems on Hackintoshes.

Share this post


Link to post
Share on other sites

Morning,

 

Would you be able to help me navigate a new install? I've managed to install High Sierra successfully using the Nvidia card. I thought it would be a straight swop apart from the new kexts, but I'm stuck in a permissions loop, so I probably have to do a new install. Problem is, NONE of my backup EFI folders are working, so I now have to start from scratch.

 

Thanks in advance.

Share this post


Link to post
Share on other sites

Ok, I reviewed your EFI folder and it is a mess ;) A lot of unnecessary kexts and patches in your config. If you have a similar hardware as I have (which I still don't know) just ditch everything in your EFI and fill it according to #1 post.

Share this post


Link to post
Share on other sites

Hey, can I ask should BCM94360CS2 working with pci-e x1 adapter with USB port on the mainboard?

 

edit: or maybe I should get the one like your BCM943602CS, also what is Broadcom 20702A3?. I can't find anywhere to buy it

Share this post


Link to post
Share on other sites

Hey There

I have a Gigabyte Z77X-UP-TH board running Radeon RX 560. I also have sleep wake issues, where the monitor on the DVI port wakes up but the one on the display port doesn't. I tried using the SSDT and it takes away the display port display and runs on one monitor. Any suggestions on how i can fix this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      Clover r4989 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4989 for VMware.zip". Mount Clover-v2.4k-4989-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By monw3d
      hey everybody
       
      as title said lilu causing very long boot 5-6 mins on SSD
      my EFI is up to date and set properly, only usb3 not working looking for kext
       
      OS 10.14.5
      my mobo p61a-d3 with i5 2400
      when -liluoff is used bood time is under 30 seconds
       
      i have tried lilu 1.2.6 to 1.3.3 same results
       
      how can i get lilu bootlog?
      i dont know how to solve this problem
       
      edit - usb3 fixed and working
    • By 22eme_arkane
      Hi everyone !
       
       I build a new os on High Sierra and i have problem with my Skarkoon RAID 5 - 5 bay, is unmounting, work fine in windows but not in Mac Os.
      I use a card eSata in chipset Marvell 88SE9215, and i have the kext 3-party eSata  but nothings change.
      I try with the AppleAHCIPort.kext v328, nothings change.
       
      Any solution ?
       
      Thanks a lot !
       
      Config : GA-Z68X-UB3-B3 // BIOS UEFI, Version: U1f //
    • By bummercheese
      I have what's been said to be a natively supported wifi card, but for the life of me I cannot get it working properly with High Sierra. It is detected in DPCIManager but the wifi symbol at the top is hollowed and I can't turn it on.
       
      Here's some basic info about my hackintosh. It's running an i7 9700k with an MSI Z390-A PRO, a GTX 1070, and it's SMBIOS is running as an iMac 18.1

      Someone else has posted here about this with an ac66, which I think is very similar and uses the same device number 43A0. But he didn't get his problem solved in the end. And I have looked up this problem in a million different ways, I haven't found a solution that works from any yet.
       
      I've tried a large amount of different kext patches, kexts (fakepciid, airportbrcmfixup, etc), changing fake ID, modifying kext info.plist files, and every combination of those, none have gotten it to properly work.
       
      I have gotten it to work in one way but it's so unstable that it's unusable. Using the IO80211family.kext from yosemite works, but then it will randomly freeze about 10-15 minutes in, and then it'll not boot 9/10 times, and when it will it'll freeze on the login or right after. It gives errors about out of date kext, only way get back in is by reinstalling. So I figure this method is unusable.
       
      I'm just stumped on why a supposed confirmed working out of box card doesn't just just work, even with every amount of tweaking and adding kexts. I'm in my 4th day of almost nonstop testing and researching on how to fix this, and I'm too stubborn and determined to just buy a different card. Any suggestions would be greatly appreciated. 
    • By gannok
      Hello and thanks for taking the time to read this, I can't seem to get past this screen, I've tried booting in verbose and safe mode to help diagnose the issue, but it keeps looking like the system is rejecting my CPU? am I forgetting something to do in the bootloader menu of clover on the drive? Kernel extensions? or the plist files? I've tried a lot of things. help would be much appreciated.

      Don't have access to download the Mojave installer and try that, but I assume it would be similar to this.

      I have included my EFI boot loader, and the error in hopes that it may help

      System build here

      Z370 Aorus Ultra Gaming Wifi
      i3-8100
      32GB ballistix ddr4
      RX560 4GB

      EFI.zip
×