Jump to content
Sign in to follow this  
Followers 0
unexpectedsense

Sin Audio en Sierra 10.12 - ZOTAC Nano ID61

4 posts in this topic

Recommended Posts

Estimados desde ya muchas gracias por cualquier aporte que puedan hacerme para intentar solucionar en este caso el AUDIO HDMI y si fuera posible las frontales de micrófono y auriculares.
Tengo corriendo Mac OS Sierra 10.12 en una ZOTAC NANO ID61 y va muy bien en el desempeño general y los gráficos aunque el video algo ralentizado.
La instalación inicialmente arrancó (siempre en SAFE MODE y hasta ahora mismo, de otra forma queda en la manzana eterna) sin red (el bluetooth funciona perfecto) y sin audio.
Em el caso de la red pude hacer funcionar la ethernet con la kext RealtekRTL8111.kext pero no directamente sino a través del paquete HoRNDIS-rel8.pkg.
Para el caso del wifi el DPCIManager me muestra Centrino Wireless-N 130 integrada que no he podido hacer funcionar pero no es prioridad ahora mismo puesto que tengo red.

Los datos de manual y algo mas son:

ZOTAC ZBOX nano ID61

Bios
• American Megatrends - Core Versión 4.6.4.0 - UEFI 2,1
Chipset
• Intel HM65
Onboard CPU
• Intel ® Celeron ® CPU 867 @1,30GHz
Onboard graphics
• Intel HD Graphics Family
• HDMI & DP output
Memory
• 8 GB SO-DIMMs DDR3-1333
Storage
• SATA 320 Gb
Network
• Gigabit (10/100/1000Mbps) LAN
• IEEE 802.3 compatible
WiFi/Bluetooth support
• Compliant with IEEE802.11b/g/n standard
• High speed wireless connection up to 150 Mbps • Fully qualited Bluetooth v3.0
Audio
• 2-channel high-definition audio • Jack-sensing compatible
• Optical SPDIF
Operating System support
• 32-bit and 64-bit support
IR receiver
• Support carrier frequencies 36k Hz


NOTA: En la Bios / Chipset /OnBoard Device Configuration, hay un item AZALIA con un sub item AZALIA INTERNAL HDMI CODEC que probé habilitado y desabilitado. Si lo desabilito desaparece en el DPCIManager. Habilitado aparece pero no el Codec ID.
* Por otro lado hay un item de la Bios /Advanced que es Sandybridge PPM Configuration que por default esta todo habilitado.


La guía que use en el intento de hacerlo funcionar:

https://github.com/toleda/audio_CloverHDMI/blob/master/README.md

Al ejecutar audio_cloverALC-120.command
La terminal muestra:

Last login: Wed Aug 16 04:05:36 on ttys000
Mac-mini-de-umac:~ umac$ /Users/umac/Downloads/audio_cloverHDMI-120_v1.0d.command ; exit;
 
Agreement
The audio_cloverHDMI script is for personal use only. Do not distribute
the patch, any or all of the files for any reason without permission.
The audio_cloverHDMI script is provided as is and without any warranty.
 
File: audio_cloverHDMI-120.command_v1.0d
Release Mode
EFI partition is mounted

No audio codec detected
No system files were changed
To save a Copy of this Terminal session: Terminal/Shell/Export Text As ...
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.

[Proceso completado]

------


Con MACIAsl agregue algunos repositorios de Toleda (audio hdmi hd 3000, zotac), pero no pude en ningun caso aplicar patches.
No se si he sido extenso en la descripción o me falta algun dato importante, disculpas por ello.

Adjunto:
Reporte DarwinDumper
config.plist
DPCIManager (pantalla)
DSDT.aml
IORegistryExplorer (pantalla)
Informe de Sistema (algunas pantallas)


Saludos y gracias desde ya.

config.plist.zipDarwinDumper_3.0.3_15.08_23.42.15_Macmini5,1_Clover_X64_4063_Sierra_16A323_umac.zipDSDT.aml.zippost-1822891-0-60880200-1502917679_thumb.pngpost-1822891-0-01523700-1502917725_thumb.pngpost-1822891-0-96057800-1502917739_thumb.pngpost-1822891-0-84598400-1502917761_thumb.pngpost-1822891-0-57792200-1502917794_thumb.pngpost-1822891-0-35952500-1502917820_thumb.png

Share this post


Link to post
Share on other sites
Advertisement

Sinceramente hace mucho que no toco las guías de Toleda pero vamos a ver que se puede hacer.

 

A simple vista te digo que el sistema de audio no te va a funcionar porque cargas el kext "net.osrom.kext.Disabler" (lo puedes ver en el ioreg, se desprende del dispositivo HDEF) que evita que se cargue el AppleHDA. No estoy seguro donde esta este kext  :rofl: pero buscalo en las carpetas /System/Library/Extensions y /Library/Extensions.

 

Mas allá de esto y como mencionas, te falta parchar el DSDT. Por ahora podes activar algunos parches DSDT de Clover, creo que con AddDTGP, FixHDA y AddHDMI debería bastar. Si no sabes como editar el config.plist te recomiendo la aplicación "Clover Configurator" así no lo editas a mano. Y para que entiendas mejor que hace cada opción del config.plist te dejo un link a la wiki de Clover.

 

Los kexts NullCPUPowerManagement VoodooPS2Controller y FakeSMC los tenés en 2 carpetas de kexts de Clover (EFI/CLOVER/kexts). Te recomiendo dejar los de Other y eliminar los demás. En 10.12 también tenés el AppleHDA completo, supongo que es una versión parchada pero desconozco qué tiene de distinto y no parece parte del método Toleda, este normalmente consiste en editar el AppleHDA del sistema si mal no recuerdo. De donde lo sacaste al kext? Y el kext HDAEnabler2.kext solo inyecta el layout de audio, cosa que ya estas haciendo con Clover actualmente así que tampoco te hace falta.

 

Aparte todo esto, no estoy seguro siquiera si es soportado el audio HDMI con tu video Intel Graphics de primera generación. Creo que ni la aceleración de video funciona.

Share this post


Link to post
Share on other sites

Buenas,

 

Te agradecería que me facilites la información de la pestaña PCI List del DCIPCIManger, ya que en el volcado de DarwinDumper no se han capturado los datos del informe LSPCI (DirectHW.kext not loaded). Necesito saber el vendorid de la tarjeta de sonido para poder indicarte el parche a aplicar. La informacion que muestras en DCIPCIManager se corresponde con el codec de audio de la tarjeta de video. Este codec no funcionará correctamente hasta que habilites la tarjeta de sonido de la placa base.

 

Referente a la tarjeta de video, el modelo que tienes se puede activar la aceleracion de video injectando el

lMEI en DSDT y habilitar el audio hdmi parcheando el

framebuffer e inyectado las propiedades de audio en el dispositivo.

 

Pásame el dato que falta, y te dare un respuesta completa con todas las posibles cosas que puedes hacer para que empieces a trastear.

 

Un saludo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      Install MacOS with Olarila Image, Step by Step, Install and Post Install  
      https://www.olarila.com/topic/5794-hackintosh-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Paste my EFI folder into EFI partition  EFI GA H110M-S2.zip     --Install Sierra/High Sierra and boot into system!   Post Installation   --Paste my EFI folder into EFI partition  EFI GA H110M-S2.zip     --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.GA H110M-S2.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By AppleCampus
      My computer was using Intel core i5-4210u ,My computer was using Intel core i5-4210u ,Sound card is cx20751/2,I use applealc inject id=3 successfully drive my onboard soundcard,but I found that HDMI Output is still no sound,how can i deal with it?
    • By Prasanth_1991
      I recently installed Hackintosh Sierra. I don't have dedicated graphics card so I just used Intel integrated graphics which is Intel HD 4600 but since the Mac OS Sierra graphics acceleration not supported by native VGA output I'm left out options. I tired many things but nothing works. It's 2020 I'm pretty sure many people probably have better solution for this, if yes please help me.   Details PC Spec  i7 4790k HD 4600 Motherboard Gigabyte B85M-D3H-A
×