Jump to content
dannymozzer_

Can't get graphics working on an EVGA GTX 960.

10 posts in this topic

Recommended Posts

Hi,

 

I recently got my Hackintosh setup with Sierra. The specs are:

 

Gigabyte Z170X Gaming 7 Motherboard

Intel Core i5 6500

8 GB DDR4 Memory

Simple HDD boot

EVGA GTX 960 (Problem)

 

It boots fine, but until I install any driver, (I've tried loads of versions), it won't boot. It just boots to verbose and stops, or sometimes, the screen will go black and it will restart. So basically, Graphics drivers really stop me from booting. But I need them because the performance of the OS is pretty bad because of it. (Sort of)

 

Can someone give me some guidance, or link me to an appropriate driver or something?

 

Thanks,

Daniel

Share this post


Link to post
Share on other sites
Advertisement

Hi,

 

I recently got my Hackintosh setup with Sierra. The specs are:

 

Gigabyte Z170X Gaming 7 Motherboard

Intel Core i5 6500

8 GB DDR4 Memory

Simple HDD boot

EVGA GTX 960 (Problem)

 

It boots fine, but until I install any driver, (I've tried loads of versions), it won't boot. It just boots to verbose and stops, or sometimes, the screen will go black and it will restart. So basically, Graphics drivers really stop me from booting. But I need them because the performance of the OS is pretty bad because of it. (Sort of)

 

Can someone give me some guidance, or link me to an appropriate driver or something?

 

Thanks,

Daniel

Upload EFI Folder

Share this post


Link to post
Share on other sites

Hi,

 

I recently got my Hackintosh setup with Sierra. The specs are:

 

Gigabyte Z170X Gaming 7 Motherboard

Intel Core i5 6500

8 GB DDR4 Memory

Simple HDD boot

EVGA GTX 960 (Problem)

 

It boots fine, but until I install any driver, (I've tried loads of versions), it won't boot. It just boots to verbose and stops, or sometimes, the screen will go black and it will restart. So basically, Graphics drivers really stop me from booting. But I need them because the performance of the OS is pretty bad because of it. (Sort of)

 

Can someone give me some guidance, or link me to an appropriate driver or something?

 

Thanks,

Daniel

Take a look at my guide for macOS Sierra on GA-Z170X-Gaming 5 under Graphics section it might help you solve your problem. The guide was tested on an EVGA 1070 and a Gigabyte GTX 960

 

But in a nutshell you'll either need to have Lilu.kext and nVidiaGraphicsFixup.kext in the following patch: /EFI/Clover/kext/10.12 or /EFI/Clover/kexts/Other

 

OR the following patch under "Kernel and Kext Patches" to avoid the black screen issue:

Name: com.apple.driver.AppleGraphicsDevicePolicy
Find: ba050000 00
Replace: ba000000 00
Comment: Disable board-id check to prevent no signal © lvs1974, Pike R. Alpha, vit9696

You might need to install EmuVaraiableUEFI.efi and RC Scripts installed for nvidia web driver to load successfully and you will also need the following flags:

 

Select these items: Under the "Boot" section: nada_drv=1 and under the "System Parameters" NvidiaWeb

 

here is the list of nvidia web drivers download the one that is compatible with there version of the macOS you are using.

 

Nvidia Web Driver updates for macOS Sierra (Thanks to @fantomas1 for the updated list)

 

Good Luck :)

Share this post


Link to post
Share on other sites

Take a look at my guide for macOS Sierra on GA-Z170X-Gaming 5 under Graphics section it might help you solve your problem. The guide was tested on an EVGA 1070 and a Gigabyte GTX 960

 

But in a nutshell you'll either need to have Lilu.kext and nVidiaGraphicsFixup.kext in the following patch: /EFI/Clover/kext/10.12 or /EFI/Clover/kexts/Other

 

OR the following patch under "Kernel and Kext Patches" to avoid the black screen issue:

Name: com.apple.driver.AppleGraphicsDevicePolicyFind: ba050000 00Replace: ba000000 00Comment: Disable board-id check to prevent no signal © lvs1974, Pike R. Alpha, vit9696
You might need to install EmuVaraiableUEFI.efi and RC Scripts installed for nvidia web driver to load successfully and you will also need the following flags:

 

Select these items: Under the "Boot" section: nada_drv=1 and under the "System Parameters" NvidiaWeb

 

here is the list of nvidia web drivers download the one that is compatible with there version of the macOS you are using.

 

Nvidia Web Driver updates for macOS Sierra (Thanks to @fantomas1 for the updated list)

 

Good Luck :)

Hi,

 

Thanks for your reply. I am able to boot with the Nvidia icon, and with the custom EFI clover folder you attached on your Gigabyte post.

 

But there is still no graphics performance, everything keeps having a weird blinds effect, and icons have glitching black squares, etc. its functional when not doing much, but it's a bit annoying.

 

But thank you, your post at least helped me boot. And it's in a native resolution too.

 

Edit: If I choose to boot using web drivers, it loads up to the first image attached (IMG_0618) and restarts. If I don't enable web drivers, it boots but I get the weird blinds effect, as shown in image 2. (IMG_0632)

post-2213942-0-54375800-1502446713_thumb.jpg

post-2213942-0-01724600-1502446762_thumb.jpg

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for your reply. I am able to boot with the Nvidia icon, and with the custom EFI clover folder you attached on your Gigabyte post.

 

But there is still no graphics performance, everything keeps having a weird blinds effect, and icons have glitching black squares, etc. its functional when not doing much, but it's a bit annoying.

 

But thank you, your post at least helped me boot. And it's in a native resolution too.

 

Edit: If I choose to boot using web drivers, it loads up to the first image attached (IMG_0618) and restarts. If I don't enable web drivers, it boots but I get the weird blinds effect, as shown in image 2. (IMG_0632)

Send me your config.plist remove serial number and MLB and I will take a loot at it.

In the second image you don't have acceleration which means that the web drivers are not loading. in the first image it's probably because of the iGPU/iGFX enabled. make sure you have your EVGA as the primary and disable the intel GFX and try again.

Share this post


Link to post
Share on other sites

Well as I stated, I've used the same Config.plist file that is in the "GA-Z170X-Gaming 5 Beta Release DSDT and SSDT Version.zip" that you attached on your tutorial. So there is nothing different that I changed except using "-v" to boot into verbose. Also, I followed your BIOS instructions and disabled the iGPU/iGFX. So at this point, this is why I'm confused. As I've followed loads of guides with the same stuff, and Graphics don't work right.

Share this post


Link to post
Share on other sites

Hi, I am having exactly same issue. Sierra 10.12.6 Motherboard Gigabyte Z68X-UD3H-B3, video: EVGA GTX 960... Tried web drivers, this fix: https://www.tonymacx86.com/threads/solved-gtx-960-issue-after-clean-install-of-sierra.203301/ and few other... Nothing seems to be working.

 

Were you able to resolve the issue?

 

Share this post


Link to post
Share on other sites
On 12/15/2018 at 8:53 PM, kosta11111 said:

Hi, I am having exactly same issue. Sierra 10.12.6 Motherboard Gigabyte Z68X-UD3H-B3, video: EVGA GTX 960... Tried web drivers, this fix: https://www.tonymacx86.com/threads/solved-gtx-960-issue-after-clean-install-of-sierra.203301/ and few other... Nothing seems to be working.

 

Were you able to resolve the issue?

 

 

If you still have problems. Try using a different output. 

 

I had thesame problem earlier in my hackintoshing and i found DVI on my gtx560 worked but it was slow as in 7fps in cinebench. When i connected to HDMI then everythings perfect. Gets me in 71fps

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Rohan20
      Opencore is running really really slow on Catalina 10.15.4. So It was running perfectly before I put the ssdt-pnlf for enabling Brightness control. it is running really slow and I verified my config with the sanity checker and its all correct. can someone please help. I am attaching my oc folder.

       
      https://www.dropbox.com/s/drkek0eaz19ina5/OC.zip?dl=0
       
    • By ayeshch
      Me (and many other people) experience eye-ache from new Macbooks (and windows machines).
       
      I have spent two years of trial-and-error and found that installing macOS Mavericks on my MacBook (pro 13 late 2013, Intel Iris 1536 MB) resolves the issue of eye ache completely. (it is believed that newer systems use harsher version of temporal dithering that causes of a certain group of indivisuals eye aches).

      I cannot stay at Mavericks because of software support and security issues, so the only thing is an issue now:

      How can I take drivers from Mavericks and install them on Catalina? (I tried replacing .kext in /System/Library/Extensions with old files but it didn't work).

      It would be so great if possible!

      Thank you
    • By Prasanth_1991
      I recently installed Hackintosh Sierra. I don't have dedicated graphics card so I just used Intel integrated graphics which is Intel HD 4600 but since the Mac OS Sierra graphics acceleration not supported by native VGA output I'm left out options. I tired many things but nothing works. It's 2020 I'm pretty sure many people probably have better solution for this, if yes please help me.   Details PC Spec  i7 4790k HD 4600 Motherboard Gigabyte B85M-D3H-A
    • By Sagnik Ganguly
      Hello I'm Sagnik Ganguly, I'm trying to dual boot macOS 10.14 and Windows 10 (already installed) on a PC with Legacy BIOS. I've two hard drives one in where the windows is installed and another which is converted to GPT to install macOS Mojave 10.14 with a partion of Mac OS Extended (Journal) or APFS but when I went to the Install Disk Selection page, I'm selecting the partition but it says "This version of macOS 10.14 cannot be installed on this computer." can you help me please? 
      P. S. My motherboard doesn't support UEFI. 
      I'm attaching some pictures of the screens.


    • By y010204025
      Disclaimer: All files of this article are from itpwd.com and rehabman ’s github.com

       
      After Testing:
       
      Graphics card: NVIDIA K1000M / K2000M / K2100M / K3000M / K3100M / K4000M / M1000M (ordinary TN1600x900 or 1920x1080), AMD W5170M / W7170M (DC2 or 4K), Intel HD4000 (ordinary TN1600x900 or 1920x1080) can be driven normally, but NVIDIA graphics card Brightness adjustment is disabled. AMD W5170m and w7170m are the best choices on 8570W and 8770W. The brightness can be adjusted normally and the graphics performance is very good. For WX7100m and WX4170m, the graphics card fans cannot be controlled, and other methods are required to control the fans. CPU: 3rd generation Intel Core i3, i5 and i7 (Ivy Bridge architecture, including all dual-core and quad-core. Celeron and Pentium are not supported), frequency conversion is normal. In general: If you have 8570W, 8770W, and hope you can get the best Hackintosh experience, it is recommended to replace the CPU with i7-3840QM / i7-3940XM, 8570W is recommended to choose W5170M, 8770W, and it is recommended to choose W7170M. In addition: If you want to have a 4K experience or perfect HIDPI, W5170m / W7170M supports 4K output, you can choose a suitable 4K screen to replace, but because 4K screens are mostly edp interface, and 8570W / 8770W motherboard is lvds interface, This requires a custom screen cable, which seems to be a difficult choice, but you can choose to do it yourself or buy it separately. In China, taobao.com is almighty and may be more suitable for you than eBay.
       
      EFI features:
      out of the box, the relevant hardware can be driven after the OS is installed, and it is easy to use without code operation.
      Supported models: HP EliteBook 8470p, 8570p, 8570w, 8770w (click the model for official specifications)
      Wireless network card: Recommended: BCM94360cd (requires ipex4 to ipex1,3 antenna 1300mbps), BCM94352HMB / DW1550 (2 antennas, 867mbps)
      Wireless characteristics: no white list, wireless network card with Bluetooth does not support the Bluetooth function of the wireless network card (also does not need to shield the pins), but the wireless normal use, you need the Bluetooth function to use this machine comes with Bluetooth:
      Clover version: 5103, keyboard mapping has been added Command key = Alt key, Option key = Win key
      Supported systems: macOS Mojave 10.14.6 (18G103)-macOS Catalina 10.15.x,
       
      Notes on known issues:
      1. The touchpad and the left and right keys under the touchpad are normal, the pointing stick and the left and right keys above the touchpad are temporarily unavailable (recommended to use the second generation of Apple Magic Trackpad)
      2. Indicator display problem (can be ignored, function is normal): Caps light is sometimes not switched in time, mute / wireless key may be yellow
      3.AMD graphics card / Intel nuclear display has supported sleep and 15 levels of brightness adjustment, NVIDIA has no
      4. If the AMD graphics card enters Huaping, refer to editing the Clover startup parameters, and add the Boot parameter radpg = 15 (the EFI file that has been configured with this parameter has been uploaded, refer to the following EFI-guided download link)
      5. Using the above NVIDIA graphics card with a normal TN screen 1600x900 or 1920x1080 can not enter the installation interface, please check whether the VBiOS of the graphics card is exclusively for HP, thank you for your test face K1000M
      6. Due to product design defects, the MSata positions of 8570w and 8770w cannot be used as boot disks, so EFI boot can only be placed on the main hard disk (turn the machine over and open the hard disk in the lower left corner of the cover, which is the main hard disk). Put on msata plate
      +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
      Hardware requirements:
      Model: 8470p, 8570p, 8570W, 8770W 1 or more, it is recommended to use another notebook for emergency Hard disk: It is recommended to choose an SSD hard disk of 240g or more. Samsung or Intel SATA hard disk is a good choice. Wireless card: BCM94352HMB, DW1550, BCM94360CD, miniPCIe slot U disk: 1 for 16g and above, another winPE emergency USB disk is recommended If you use a rescue USB flash drive, it means that you read this post carefully
       
      Make and install a USB flash drive:
      Get the mirror: please do it your way Making and installing a USB flash drive: macOS command line production is recommended, whether it is a real macOS model or a virtual machine (although this is not allowed to be discussed in many forums)Or you can choose to use TransMac or ether under Windows. This is not recommended, but it is simple enough for those new to Hackintosh. Make boot U disk: If you know how to put the boot into the installation U disk, unzip the EFI file and put it in the EFI partition, or you can choose a fat32 format U disk to store the EFI file separately Note: EFI is an unzipped folder, not a zip or ISO suffix file.
       
      BIOS settings From RehabMan
      To start, set BIOS to defaults.
      Then insure:
      UEFI boot is enabled (hybrid/with CSM for best result) secure boot is disabled disable fast boot IGPU graphics memory set to 64mb, if available disable the serial port via BIOS option, if available disable "LAN/WLAN switching", if available disable "Extended Idle Power States" if you find it under "Power Management Options" disable "Wake on LAN" and "Wake on USB" disable Firewire/IEEE 1394, if your laptop has it for Skylake and KabyLake laptop, enable "Launch Hotkeys without Fn keypress" Note: If you have a laptop with switchable graphics, leave it enabled. You can still use it on Windows, although the discrete card will be disabled when running OS X by the ACPI patches provided here. If you want to also disable it in Windows (via BIOS option), make sure you read about the DGPU option in your model specific SSDT (source is in SSDT-HACK.dsl), as in the scenario where the DGPU is disabled by BIOS, DGPU should be set to zero.
       
      Install:
      Please modify according to the above BIOS settings: Press F9 after booting, select the boot efi to file option, which is generally the last item. Enter your boot USB disk to find the location of cloverx64.efi, select cloverx64.efi, press Enter, and enter the clover boot interface. Select the location of the install entry and press Enter. Enter the macOS interface, use the disk tool to format the partition you need to install to hfs + or apfs format, do not choose the encryption option, this will make your efforts in vain. Note: The disk must be in gpt format, and the remaining EFI space is greater than 200M, 300mb + is recommended. If it is not, please try to modify it in WindowsPE environment. This may cause you to lose the Windows system boot and disk data. Please prepare for backup.
      After formatting the partition successfully, close the disk tool and select install, you will find the partition you installed, and follow the interface prompts. When the installation reaches a certain progress, it will restart. When restarting, select F9, enter from the boot U disk, select the disk partition where you installed macOS (no longer the U disk installation), the installation will continue, and it may restart 2 ~ 3 times Every time, you need F9 to select the boot. After entering the installation interface, except for the first installation, select the U disk, and then select the disk installation partition. Eventually you will enter the settings interface. After following the interface prompts, you will enter the macOS system interface. Remember the system password and turn off the Find my mac option.  
      Post install:
       
      After the installation is complete, you need to hang the EFI partition of the disk, copy the EFI file of the U disk to the EFI partition of the disk, so that you can directly use the disk to boot, otherwise you need to select the U disk to boot each time. The mount tool can choose cloverconfigurator. If after copying the EFI file to the disk, the computer cannot recognize your clover boot, you can use the custom boot option of bios: set the custom boot path to \efi\clover\cloverx64.efi, and set it as the first boot, Use bootice or easyUEFI to increase the clover boot option under Windows and set it as the first boot. If you do not have a wireless network card available temporarily, you can use the USB binding function of your Android phone to share the network. This may require the HoRndis driver. It is not recommended to use a US wireless network card. If you need Windows or Linux, you can install it normally. Be careful not to let Windows overwrite your boot files.  
      For other uses of macOS and brew, please pay attention to forums and other communities. Hackintosh is just the beginning.
       
      Finally, I would like to thank rehabman, vit9696 and others who contributed to Hackintosh. I also thank Cwen for his efforts to modify files and hardware tests. I hope that Hackintosh will be eternal.
       
      Please comply with the laws and regulations of your country or region. My description may not be clear or professional, but I think it is necessary. I think the existence of Hackintosh is everyone's technical hobby and experience macOS, not as a substitute for macOS cheap hardware.

      EFI_8x70_5103_W7170m_20200116 .zip
×