Jump to content

1,308 posts in this topic

Recommended Posts

On 8/9/2017 at 7:44 AM, MacNB said:

 

After downloading, you have to rename the file by removing .txt extension. That is, rename it to SSDT-290X.aml.

You can then open it with the dsdt editor.

@e14883362 You have marked my reply from over a year ago as "confused". What are you confused about ?

Share this post


Link to post
Share on other sites
Advertisement
47 minutes ago, MacNB said:

@e14883362 You have marked my reply from over a year ago as "confused". What are you confused about ?

Sorry, I just think this icon is very funny and accidentally clicked into it.

Share this post


Link to post
Share on other sites

I'm on 10.13.6 on MacPro5.1 SYMBIOS.

 

1. to get sound working on NvidiaGraphicsFixup, I only need Lilu+NvidiaGraphicsFixup. When using WhateverGreen, I need Lilu+WhateverGreen+AppleALC. Is this normal?

 

2. Is it possible to change the "GFX" assigned to the video card? it's originally S3F0. With WhateverGreen, it shows up as GFX0. Can I change it to GFX2?

 

Thanks a lot!

Share this post


Link to post
Share on other sites
7 minutes ago, mrjayviper said:

I'm on 10.13.6 on MacPro5.1 SYMBIOS.

 

1. to get sound working on NvidiaGraphicsFixup, I only need Lilu+NvidiaGraphicsFixup. When using WhateverGreen, I need Lilu+WhateverGreen+AppleALC. Is this normal?

 

2. Is it possible to change the "GFX" assigned to the video card? it's originally S3F0. With WhateverGreen, it shows up as GFX0. Can I change it to GFX2?

 

Thanks a lot!

 

Just try to change S3F0 to GFX2 to your DSDT / SSDT

 

 

Edited by Andres ZeroCross

Share this post


Link to post
Share on other sites

@vit9696 I keep noticing a WEG suggestion in verbose mode saying WEG IMEI device found is 0x1D3B and should change it to 0x1E3A, looked through your source code and found the section where it identifies the IMEI or BUS device and suggest this on Sandy Bridge or Ivy Bridge CPUs. Mind clarifying if I should change the device-id for my IMEI or BUS device?

Share this post


Link to post
Share on other sites
6 hours ago, Pavo said:

@vit9696 I keep noticing a WEG suggestion in verbose mode saying WEG IMEI device found is 0x1D3B and should change it to 0x1E3A, looked through your source code and found the section where it identifies the IMEI or BUS device and suggest this on Sandy Bridge or Ivy Bridge CPUs. Mind clarifying if I should change the device-id for my IMEI or BUS device?

@Pavo there is need to apply Rename HECI to IMEI in clover dsdt patch?

Share this post


Link to post
Share on other sites

whatevergreen can boot my hd630 w/o -disablegfxfirmware flag in HighSierra. but i need to manually add it again after i updated to Security Update 2018-002.

can this be fix?

Edited by ellaosx

Share this post


Link to post
Share on other sites
19 hours ago, Pavo said:

@vit9696 I keep noticing a WEG suggestion in verbose mode saying WEG IMEI device found is 0x1D3B and should change it to 0x1E3A, looked through your source code and found the section where it identifies the IMEI or BUS device and suggest this on Sandy Bridge or Ivy Bridge CPUs. Mind clarifying if I should change the device-id for my IMEI or BUS device?

IMEI, information about it should be present on the net.

 

@ellaosx will need logs here via liludump=60 in -liludbgall mode from /var/log/Lilu_.... file.

Edited by vit9696

Share this post


Link to post
Share on other sites

Hello,

 

Installed Mojave on Gigabyte Z97X UD3H, Samsung EVO 860, EVGA GT740. The GPU is native to Mojave but adding latest Lilu and Whatevergreen (in L/E or Clover/Kexts/Other, no difference), I'm unable to play iTunes movies... The two kexts are charged when I look in IORegistryExplorer. Clover is revision 4722 BTW. Tried to update to 10.14.1 without improvements. A problem maybe with native Kepler cards and Lilu/Whatevergreen?

 

I've tried an RX560 two weeks ago (returned it because of a weird white flash on the Apple bootscreen) and this one didn't need Lilu or WEG...

 

Going back to Sierra with my GTX950 but I'll investigate further next week-end with an external USB drive first.

 

Thanks,

 

Patrice

Edited by brousseau6933

Share this post


Link to post
Share on other sites
16 minutes ago, brousseau6933 said:

I've tried an RX560 two weeks ago (returned it because of a weird white flash on the Apple bootscreen) and this one didn't need Lilu or WEG...

The white flash is normal for RX 4xx/5xx GPUs on hacks.

Share this post


Link to post
Share on other sites
13 minutes ago, Pavo said:

The white flash is normal for RX 4xx/5xx GPUs on hacks.

Well, should had kept the RX560...:( Forgot to add that I use iMac 14,2 SMBIOS.

 

So, no clues anybody why Kepler even if native doesn't work with iTunes/Lilu/WEG?

 

I'll try with the Intel IGPU once I'll setup my external Mojave USB test disk.

 

Thanks again,

 

Patrice

Edited by brousseau6933

Share this post


Link to post
Share on other sites

Someone suggested in a French forum to set up the Intel IGPU. Does it mean I have to activate it in the BIOS (but let the GT 740 as first display) and inject it via Clover with correct ID?

 

Thanks,

 

Patrice

Share this post


Link to post
Share on other sites

Well, I'm at lost: on my second hack (i7 4770, GT 710, SMBIOS iMac 14,1 - Dell Optiplex 9020) Lilu and Whatevergreen in Clover/Kexts/Other with the GT 710... everything is fine playing DRM iTunes movies. The only differences vs the other hack (4790, GT 740) is the SMBIOS (iMac 14,1) and the DSDT (got it last year for the Dell at OSXLatitude) :

  Device (IGPU)
            {
                Name (_ADR, 0x00020000)  // _ADR: Address
                Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
                {
                    If (LEqual (Arg2, Zero))
                    {
                        Return (Buffer (One)
                        {
                             0x03                                           
                        })
                    }

                    Return (Package (0x04)
                    {
                        "AAPL,ig-platform-id",
                        Buffer (0x04)
                        {
                             0x03, 0x00, 0x22, 0x0D                        
                        },

                        "hda-gfx",
                        Buffer (0x0A)
                        {
                            "onboard-1"
                        }
                    })
                }
            }

and also:

               Device (GFX0)
                {
                    Name (_ADR, Zero)  // _ADR: Address
                    Name (_SUN, One)  // _SUN: Slot User Number
                    Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
                    {
                        If (LEqual (Arg2, Zero))
                        {
                            Return (Buffer (One)
                            {
                                 0x03                                           
                            })
                        }

                        Return (Package (0x0E)
                        {
                            "@0,connector-type",
                            Buffer (0x04)
                            {
                                 0x00, 0x08, 0x00, 0x00                        
                            },

                            "@1,connector-type",
                            Buffer (0x04)
                            {
                                 0x00, 0x08, 0x00, 0x00                        
                            },

                            "@2,connector-type",
                            Buffer (0x04)
                            {
                                 0x00, 0x08, 0x00, 0x00                        
                            },

                            "@3,connector-type",
                            Buffer (0x04)
                            {
                                 0x00, 0x08, 0x00, 0x00                        
                            },

                            "@4,connector-type",
                            Buffer (0x04)
                            {
                                 0x00, 0x08, 0x00, 0x00                        
                            },

                            "@5,connector-type",
                            Buffer (0x04)
                            {
                                 0x00, 0x08, 0x00, 0x00                        
                            },

                            "hda-gfx",
                            Buffer (0x0A)
                            {
                                "onboard-2"
                            }
                        })
                    }
                }

Maybe the fact that the NVidia GT 710 appears as "onboard", which is not the case on my i7 4790 (no DSDT at all)?

Share this post


Link to post
Share on other sites

I‘m using desktop HD4600 with lilu whatevergreen , smbios iMac 14,2 .

The external display shown as built-in display.

I can't use  "Brightness.Menulet" "MonitorControl" to control display brightness.

but I use "Monitorian" on windows it works well (Confirmed support for DDC/CI)

Do I need to modify the display to external or other methods?

Edited by bluemaP1E

Share this post


Link to post
Share on other sites
2 hours ago, bluemaP1E said:

I‘m using HD4600 with lilu whatevergreen , smbios 13,2 .

The external display shown as built-in display.

I can't use  "Brightness.Menulet" "MonitorControl" to control display brightness.

but I use "Monitorian" on windows it works well (Confirmed support for DDC/CI)

Do I need to modify the display to external or other methods?

 

Display external must be shown as External Display not Built-in Display

Share this post


Link to post
Share on other sites
On 10/25/2018 at 10:37 PM, buyjoey said:

Hi, anyone uses LG Ultrafine 5K Monitor with WEG? I am using GC-Alpine TH3 addin card for TH3 connected to my monitor. But when I use the Whatevergreen and Lilu (The latest versions) Display will be separated by two monitors. a Virtual 5K and another 2560x2880 (strange resolution) - I have to use another monitor as primary boot. If I use LG Ultrafine 5K as a primary monitor to boot, it shows me all black!! I am using a 4k monitor + LG 5k monitor.

 

LG Ultrafine 5K using TH3 connection by two dp1.2 ports to the Th3 is blackscreen on the boot with WEG + lilu. But it is working w/o WEG natively. Only the reason I want to use WEG is for iGPU. I want to use iGPU so I have to use WEG.

 

Is there anyway I can fix those two issues with WEG?

 

I am having the exact same problem on Mojave.

 

I got a GA-Z170x-Gaming 7

Titan Ridge

Vega64

Ultrafine 5k

 

Share this post


Link to post
Share on other sites

@vit9696 how to patch coredisplay for 4K Resolution with whatevergreen on IGPU?? Tried Lilu.kext + WhateverGreen (latest versions) with this scenario
1. boot with "-cdfon" = No result,, still stuck at IOLockscreenstate bla bla bla
2. Add properties to IGPU in Device - > Properties "enable-hdmi20", will same result too.
image.png.366dd0df73198aa0a19d400ee4f8759d.png

But if i use IntelGraphicsFixUp.kext,, then it will reach desktop screen

Edited by Andres ZeroCross

Share this post


Link to post
Share on other sites

Following about the GT740 and no DRM in iTunes:

 

I've bought an used RX 560 and it works without Lilu and Whatevergreen in 10.14.0... but it is broken in 10.14.1 and beta 3 of 10.14.2, with or without Lilu and WEG...

Share this post


Link to post
Share on other sites
31 minutes ago, vit9696 said:

@Andres ZeroCross, agdpmod… Readme is your friend.

Sorry for my understanding, agdpmod is abut External GPU Check,, I think it's solution for BlackScreen issue with Nvidia / AMD. So the old way is about patch AppleGraphicsDisplayPolicy.kext.

So the another function of agdpmod is for patch core display too and 4K Resolution of internal display???

Share this post


Link to post
Share on other sites
2 minutes ago, vit9696 said:

In different AGDP modes different resolutions may be supported. The fact that IGFX standalone without AGDP patches works fine is the key to the issue.


Ah ok,, so i need to try use "agdpmod=ignore"

Will test it and report, thanks before

Share this post


Link to post
Share on other sites

Hello,

 

First, thanks to the developper(s) of Lilu, Shiki, NvidiaGraphicsFixup, IntelGraphicsFixup and WEG. Without these, we couldn't be able to have functionnal Nvidia, Intel and AMD graphics on Hackintosh.

 

Now, here's my problem and I ask the developper of WEG about it, in case you could do something:

- Mojave 10.14.0, MSI Radeon RX560. No need for WEG as RX560 is supported OOB with the following: iTunes downloaded movies plays fine. As for encoding, I don't know 'cause I don't do any... In fact, if I inject WEG, iTunes crashes immediately... but I don't need it anyway! Lilu and WEG are loaded viewing IORegistryExplorer;

 

- Mojave 10.14.1, same card. iTunes DRM downloaded movies aren't playing anymore (black screen with play not moving). Only way to get previous behavior is to replace AppleGVA.framework in System/Library/PrivateFrameworks with the 10.14.0 version... Someone suggested another workaround, in form of an HEVC dummy kext but it doesn't help in my case. Thanks to this discussion here at InsanelyMac (Mojave 10.14.1 Breaks Radeon Hardware Decoding (no IGPU)): https://www.insanelymac.com/forum/topic/336278-mojave-10141-breaks-radeon-hardware-decoding-no-igpu/?tab=comments#comment-2651577

This time, Lilu and WEG injected (latest versions, 1.2.8 and 1.2.4) doesn't help. No more iTunes crash but no DRM neither! Lilu and WEG shown as loaded fine as per IORegistryExplorer.

 

 

So, as I do not like to use old kext or frameworks from previous OSX builds (I don't want to use the same framework for all the subsequent Mojave updates!!), I ask here if you could implement a way to maintain HEVC encoding and DRM encoding thru Lilu and WEG. BTW, tried 10.14.2 and it is still broken...

 

Here is the debug print of WEG 1.2.4 debug if it could help you:

 

Thanks,

 

Patrice

2018-12-04 13:05:14.684369-0500 0x73       Default     0x0                  0      0    kernel: (kernel) WhateverGreen:    init @ (DBG) WhateverGreen bootstrap DBG-124-2018-10-30
2018-12-04 13:05:14.687105-0500 0x73       Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) not enabling CAIL_DisableDrmdmaPowerGating

2018-12-04 13:05:14.697424-0500 0x73       Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) not enabling CAIL_DisableGfxCGPowerGating
2018-12-04 13:05:14.698842-0500 0x73       Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) not enabling CAIL_DisableUVDPowerGating
2018-12-04 13:05:14.700221-0500 0x73       Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) not enabling CAIL_DisableVCEPowerGating
2018-12-04 13:05:14.701599-0500 0x73       Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) not enabling CAIL_DisableDynamicGfxMGPowerGating
2018-12-04 13:05:14.703152-0500 0x73       Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) not enabling CAIL_DisableGmcPowerGating
2018-12-04 13:05:14.704530-0500 0x73       Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) not enabling CAIL_DisableAcpPowerGating
2018-12-04 13:05:14.705908-0500 0x73       Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) not enabling CAIL_DisableSAMUPowerGating
2018-12-04 13:05:14.707306-0500 0x73       Default     0x0                  0      0    kernel: (kernel) WhateverGreen:   shiki @ (DBG) will autodetect autodetect GPU 0 whitelist 0
2018-12-04 13:05:14.718787-0500 0x73       Default     0x0                  0      0    kernel: (kernel) WhateverGreen:   shiki @ (DBG) pre-config: online 0, bgra 0, compat 0, whitelist 0, id 0, stream 0

2018-12-04 13:05:17.221412-0500 0x1e9      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) non-apple-fw proceeding with devprops 1
2018-12-04 13:05:17.230735-0500 0x1e9      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:   iokit @ (DBG) getOSData device-id has 67FF value
2018-12-04 13:05:17.239886-0500 0x1e9      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:   iokit @ (DBG) getOSData revision-id has CF value
2018-12-04 13:05:17.249053-0500 0x1e9      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:   iokit @ (DBG) getOSData subsystem-vendor-id has 1462 value
2018-12-04 13:05:17.258399-0500 0x1e9      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:   iokit @ (DBG) getOSData subsystem-id has 8A91 value
2018-12-04 13:05:17.267692-0500 0x1e9      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) found existing built-in
2018-12-04 13:05:17.276761-0500 0x1e9      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) detecting policy
2018-12-04 13:05:17.285232-0500 0x1e9      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) board is Mac-27ADBB7B4CEE8E61
2018-12-04 13:05:17.293800-0500 0x1e9      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) disabling nvidia patches on model Mac-27ADBB7B4CEE8E61
2018-12-04 13:05:17.302851-0500 0x1e9      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) vinfo 1: 1080:1920 32:7680:1
2018-12-04 13:05:17.311232-0500 0x1e9      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) vinfo 2:  67:240 7680:1:0

2018-12-04 13:05:19.805949-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) starting controller

2018-12-04 13:05:19.810459-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) GetProperty discovered property merge request for aty_properties

2018-12-04 13:05:20.569066-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     con @ (DBG) 0 is type 00000400 (DP  ) flags 00000304 feat 0100 pri 0000 txmit 11 enc 02 hotplug 02 sense 01
2018-12-04 13:05:20.577614-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) translateAtomConnectorInfoV1 got sense id 01
2018-12-04 13:05:20.585217-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) translateAtomConnectorInfoV1 checking 2120 object id
2018-12-04 13:05:20.593033-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) autocorrectConnector use -raddvi to enable dvi autocorrection
2018-12-04 13:05:20.601093-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     con @ (DBG) 0 is type 00000800 (HDMI) flags 00000204 feat 0100 pri 0000 txmit 21 enc 03 hotplug 05 sense 04
2018-12-04 13:05:20.610008-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) translateAtomConnectorInfoV1 got sense id 04
2018-12-04 13:05:20.617887-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) translateAtomConnectorInfoV1 checking 2220 object id
2018-12-04 13:05:20.625901-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) autocorrectConnector use -raddvi to enable dvi autocorrection
2018-12-04 13:05:20.634123-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     con @ (DBG) 0 is type 00000004 (DVI ) flags 00000004 feat 0100 pri 0000 txmit 00 enc 00 hotplug 03 sense 05
2018-12-04 13:05:20.643079-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) translateAtomConnectorInfoV1 got sense id 05
2018-12-04 13:05:20.650986-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) translateAtomConnectorInfoV1 checking 211E object id
2018-12-04 13:05:20.658928-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) autocorrectConnector use -raddvi to enable dvi autocorrection
2018-12-04 13:05:20.667007-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) setting fb limit to 3
2018-12-04 13:05:20.674185-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) getConnectorInfo leaving unchaged priority
2018-12-04 13:05:20.681749-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) getConnectorsInfo resulting 3 connectors follow
2018-12-04 13:05:20.689314-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     con @ (DBG) 0 is type 00000400 (DP  ) flags 00000304 feat 0100 pri 0000 txmit 11 enc 02 hotplug 02 sense 01
2018-12-04 13:05:20.697897-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     con @ (DBG) 1 is type 00000800 (HDMI) flags 00000204 feat 0100 pri 0000 txmit 21 enc 03 hotplug 05 sense 04
2018-12-04 13:05:20.706297-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     con @ (DBG) 2 is type 00000004 (DVI ) flags 00000004 feat 0100 pri 0000 txmit 00 enc 00 hotplug 03 sense 05
2018-12-04 13:05:20.714537-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) SetProperty caught model 14 (Radeon RX 560)
2018-12-04 13:05:20.721784-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) SetProperty ignored setting model to Radeon RX 560

2018-12-04 13:05:20.748857-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) starting controller done 1
2018-12-04 13:05:20.755699-0500 0x5b3      Default     0x0                  0      0    kernel: (AMDSupport) Accelerator successfully registered with controller.
2018-12-04 13:05:20.756229-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) GetProperty got cail_properties 1, merging from GFX0
2018-12-04 13:05:20.763532-0500 0x5b3      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     rad @ (DBG) GetProperty discovered property merge request for cail_properties

2018-12-04 13:05:23.647767-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 1: 12288:1 0:0:32
2018-12-04 13:05:23.647770-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 2: 3:8 --------RRRRRRRRGGGGGGGGBBBBBBBB 350343339:0:0
2018-12-04 13:05:23.647773-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) this display has different mode
2018-12-04 13:05:23.647786-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 1: -5:1 8192:0:32
2018-12-04 13:05:23.647789-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 2: 3:8 --------RRRRRRRRGGGGGGGGBBBBBBBB 350343339:1920:1080
2018-12-04 13:05:23.647791-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) this display has different mode
2018-12-04 13:05:23.647797-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 1: 12288:1 0:0:32
2018-12-04 13:05:23.647800-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 2: 3:8 --------RRRRRRRRGGGGGGGGBBBBBBBB 350343339:0:0
2018-12-04 13:05:23.647802-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) this display has different mode
2018-12-04 13:05:23.682183-0500 0x5d5      Default     0x0                  0      0    kernel: kPEDisableScreen 1
2018-12-04 13:05:23.682474-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 1: -2147479552:1 8192:0:32
2018-12-04 13:05:23.682477-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 2: 3:8 --------RRRRRRRRGGGGGGGGBBBBBBBB 0:1920:1080
2018-12-04 13:05:23.682480-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) this display has different mode
2018-12-04 13:05:23.684266-0500 0x5d5      Default     0x0                  0      0    kernel: kPEEnableScreen 1
2018-12-04 13:05:23.693707-0500 0x5d5      Default     0x0                  0      0    kernel: kPEDisableScreen 1
2018-12-04 13:05:23.694026-0500 0x5d5      Default     0x0                  0      0    kernel: kPEEnableScreen 1
2018-12-04 13:05:23.754719-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 1: -2147479552:1 8192:0:32
2018-12-04 13:05:23.754723-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 2: 3:8 --------RRRRRRRRGGGGGGGGBBBBBBBB 0:1920:1080
2018-12-04 13:05:23.754730-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) this display has different mode
2018-12-04 13:05:23.754744-0500 0x5d5      Default     0x0                  0      0    kernel: kPEEnableScreen 1
2018-12-04 13:05:23.756225-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 1: -2147479552:1 8192:0:32
2018-12-04 13:05:23.756230-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 2: 3:8 --------RRRRRRRRGGGGGGGGBBBBBBBB 0:1920:1080
2018-12-04 13:05:23.756232-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) this display has different mode
2018-12-04 13:05:23.807024-0500 0x5d5      Default     0x0                  0      0    kernel: kPEDisableScreen 1
2018-12-04 13:05:23.807391-0500 0x5d5      Default     0x0                  0      0    kernel: kPEEnableScreen 1
2018-12-04 13:05:23.807631-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 1: -2147479552:1 7680:0:32
2018-12-04 13:05:23.807635-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 2: 3:8 --------RRRRRRRRGGGGGGGGBBBBBBBB 0:1920:1080
2018-12-04 13:05:23.807639-0500 0x5d5      Default     0x0                  0      0    kernel: kPEEnableScreen 1
2018-12-04 13:05:23.889958-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 1: -2147479552:2 7680:0:32
2018-12-04 13:05:23.889962-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 2: 3:10 --RRRRRRRRRRGGGGGGGGGGBBBBBBBBBB 0:1920:1080
2018-12-04 13:05:23.889967-0500 0x5d5      Default     0x0                  0      0    kernel: kPEEnableScreen 1
2018-12-04 13:05:23.892466-0500 0x5d5      Default     0x0                  0      0    kernel: kPEDisableScreen 1
2018-12-04 13:05:23.892648-0500 0x5d5      Default     0x0                  0      0    kernel: kPEEnableScreen 1

2018-12-04 13:05:45.031715-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 1: -2147479552:1 7680:0:32
2018-12-04 13:05:45.031722-0500 0x5d5      Default     0x0                  0      0    kernel: (kernel) WhateverGreen:     weg @ (DBG) fb info 2: 3:8 --------RRRRRRRRGGGGGGGGBBBBBBBB 0:1920:1080


 

Whatevergreen debug 2018-12-04.rtf

 

Edited by brousseau6933

Share this post


Link to post
Share on other sites

I get black screen after wake from Sleep in Mojave 10.14.2

My Specificaton
Processor : Intel i7 6700
IGPU : Intel HD 520 (use connector less framebuffer)
eGPU : Radeon RX580
Motherboard : Gigabyte Z170X Gaming 7
macOS Version : Mojave 10.14.2 Build 18C54

It wake from sleep with normal condition in previous mojave 10.14 and 10.14.1 include beta 10.14.2. But after update to public release 10.14.2 i get black screen after wake from sleep if i sleep for long time. If for short time, it wake normally from sleep.
I used Lilu.kext version 1.2.8 and WhateverGreen version 1.2.4 

Edited by Andres ZeroCross

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By rodrinico19
      Hola a todos, primero que nada estoy muy contento de a ver econtrado un foro de español sobre hackintosh.
      Mi problema consesite en que descargue unos drivers de esta pagina: https://github.com/chris1111/Wireless-USB-Adapter-Clover
      Seguí los pasos instale los kets en la carpeta EFI/CLOVER/OTHERS todo tal cual como dice ahi la instalación. luego segui los pasos de configurar la red dentro de configuracion del sistema etc.
      Lo cual el nombre me quedo en en0.
      El driver o kets funciona bien es reconocible por el S.O de hecho conecta la red, pero me dice que no tiene IP AUTO ASIGNADA Y LA OTRA QUE HAY UNA DESCONEXION A CADA RATO(como que desconectaras y conectaras el dispositvo usb a cada rato)
      Me gustaria que me ayuden con eso si es posible, Muchas Gracias!!
    • By gengstapo
      @Hervé
       
      Im having similar issue with my HS setup, dell latitute 3480, i5-7200U
      Once the hdmi plugged in, the laptop display went blank, only could see the external tv
      But, when i put my laptop to sleep & wake up again, both screen got display (hdmi still connected)
      Even the hdmi could be plugged off & in (after sleep), the laptop display is fine
       
      What could be the culprit?
      Dell’s MacBook Pro IORegistry.zip
      config.plist.zip
    • By NikTheNoob
      Hi,
       
      I'm rather new to Hackintosh and trying my first build with OpenCore on AMD, but I run into issues causing OpenCore to crash before even loading the macOS installer. As I'm not sure which one is causing the crash, I'm trying to resolve all of them and one of the error messages has to do with WhateverGreen, which I was able to see in this slow-mo loading video. Basically I'm getting an error that I'm running an unsupported processor, even though I think I was following this guide by the step.
      What could be causing this and what do I need to do to resolve it?
       
      CPU: AMD Ryzen 2700X
      MB: Gigabyte Aorus X470 Ultra Gaming
      Memory: 4x8 GB HyperX Predator, 3000 MHz Cl15
      Storage: Samsung Evo 970 Nvme 512 GB, Crucial MX500 500GB SATA
      GPU: MSI Radeon RX580 GamingX 8GB
×