Jump to content
Sign in to follow this  
MartinOrtizAmoroso

[Ayuda] Probook 640 g2 Sierra problemas on WIFI

4 posts in this topic

Recommended Posts

Hola gente, al fin logre instalar Sierra en mi HP probook 640 g2 con procesador I5 6200U, con tarjeta grafica intel hd520, todo funcionando correctamente, utilize el metodo de Tonymac para probooks, el audio, la grafica, el brillo esta funcionando correctamente, el problema radica en el WIFI, mi adaptador es el BCM943228Z el cual hasta lo que se no es compatible, quisiera pedirles ayuda, si es que alguien sabe como hacerlo funcionar o en locontrario que adaptador podria usa, que modelo seria compatible, ya que no es una opcion usar un usb ya que el computador solo tiene dos puertos, aparte tengo un problema con el ethernet, el cual si se desconecta el cable de red y se lo vuelve a conectar deja de funcionar, gracias de antemano.

Share this post


Link to post
Share on other sites
Advertisement

You have two options: BCM94352HMB/Azurewave AW-CE123H (802.11a/b/g/n/ac, 2x2 dual band + BT 4.0) and BCM943225HMB/Azurewave AW-NB290H (802.11b/g/n, 2x2 single band + BT 3.0). If you don't need 802.11ac, the second one will serve you well, there are plenty of it in eBay and it's cheap.

Share this post


Link to post
Share on other sites

Hola gente, al fin logre instalar Sierra en mi HP probook 640 g2 con procesador I5 6200U, con tarjeta grafica intel hd520, todo funcionando correctamente, utilize el metodo de Tonymac para probooks, el audio, la grafica, el brillo esta funcionando correctamente, el problema radica en el WIFI, mi adaptador es el BCM943228Z el cual hasta lo que se no es compatible, quisiera pedirles ayuda, si es que alguien sabe como hacerlo funcionar o en locontrario que adaptador podria usa, que modelo seria compatible, ya que no es una opcion usar un usb ya que el computador solo tiene dos puertos, aparte tengo un problema con el ethernet, el cual si se desconecta el cable de red y se lo vuelve a conectar deja de funcionar, gracias de antemano.

 

Buenas Martín,

 

Puedes probar un instalador que cree para el modelo BCM94352HMB/Azurewave AW-CE123H. Creo que puede ser compatible con tu modelo de tarjeta Wifi. Si te animas a probarlo, te agradecería que me comentes los resultados obtenidos.

 

Antes de instalar nada, te recomiendo que hagas una copia de la carpeta /System/Library/Extensións. En caso de problemas podrás revertir cualquier cambio efectuado.

 

Un saludo

Share this post


Link to post
Share on other sites

Buenas Martín,

 

Puedes probar un instalador que cree para el modelo BCM94352HMB/Azurewave AW-CE123H. Creo que puede ser compatible con tu modelo de tarjeta Wifi. Si te animas a probarlo, te agradecería que me comentes los resultados obtenidos.

 

Antes de instalar nada, te recomiendo que hagas una copia de la carpeta /System/Library/Extensións. En caso de problemas podrás revertir cualquier cambio efectuado.

 

Un saludo

Hola, perdon por la demora, me retire un tipo del hackintosh, hoy mismo voy reinstalar cierra en mi laptop, y claro voy a testear tu instalador, cualquier problema te lo enviare, muchas gracias de antemano.

You have two options: BCM94352HMB/Azurewave AW-CE123H (802.11a/b/g/n/ac, 2x2 dual band + BT 4.0) and BCM943225HMB/Azurewave AW-NB290H (802.11b/g/n, 2x2 single band + BT 3.0). If you don't need 802.11ac, the second one will serve you well, there are plenty of it in eBay and it's cheap.

 

I'm going to buy one of them, thank you very much

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By b31k
      Hello
      My system is
      Asus Z170-P Motherboard
      i5 6600K Processor
      NVIDIA GeForce GTX 1050 Ti 4095 MB
      Be-quiet 500W PSU
      Crucial 16 GB 2400 MHz DDR4

      BIOS:

      xHCI Handoff enable
      Serial Port disable
      SATA AHCI mode
      IOAPIC 24-119 Entries (enable y disable) two mode stuck

      I can not build a robust and stable system, The system Sierra is already installed but when I restart or shut down, I get the error Still waiting for root device error, but after too many reboot ( from 2 times to 9) start correctly or other times leave too minutes, with prohibited symbol and finally starts.
      Once started recognised correctly HDD.
      Also I tried with a new  EVO860 nvme SSD , but I have the same problem.
       
       
      I dont know because sometimes yes sometimes no, the system stuck in this error
      I add some information files and logs.
       
      sudo touch /System/Library/Extensions && sudo kextcache -u /
      kext-dev-mode allowing invalid signature -67030 0xFFFFFFFFFFFEFA2A for kext HackrNVMeFamily-10_12_6.kext
      kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC.kext
      kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext BrcmPatchRAM2.kext
      kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext BrcmFirmwareRepo.kext
        thank you.


       
      Solution by Rehabman;

      Extracting my native/clean DSDT using Clover F4.
      and check with diff DSDT file.

      My SystemMemory addresses in DSDT are mismatched:

      SPEEDY-NUCatched rehabman$ diff ../origin/ ../patched/|grep SystemMemory
      < OperationRegion (GNVS, SystemMemory, 0xC74EC000, 0x06D5)
      > OperationRegion (GNVS, SystemMemory, 0xC74FE000, 0x06D5)
      < OperationRegion (CPSB, SystemMemory, 0xC6CC0F98, 0x10)
      > OperationRegion (CPSB, SystemMemory, 0xC6CD2F98, 0x10)

      and other mistake in OperationRegion(PNVA,SystemMemory,PNVB,PNVL)

      < Name (PNVB, 0xC74F1018)
      > Name(PNVB,0xC7503018)

      My system after too many month , keep stable the still waiting error no appear again, it seems that the problem was with the memory addresses in my DSDT.
    • By murobro
      Hi. My notebook Acer Aspire E1-571 and my mac version High Sierra 10.13.4. My wifi card Qualcomm Atheros AR9485WB-EG. How to install this card is my Hackintosh. I am trying several methods and no luck. I find this post and do not want how to install this kext. I am a newbie. Please help me. I need a full tutorial.
       
    • By Jiji The Fox
      Hey, long time no post!
       
      Apologies if this has been answered, every time I search I get a timeout on the site and I can't seem to get the search to work
       
      I've been sitting pretty with Yosemite for a while , but a recent hardware upgrade (Audio interface) means I can jump from Yosemite. 

      I've successfully upgraded Clover, then the OS and for the most of it, it seems great. Everything works but the Graphics Driver (NVidia GeForce GTX670.)
       
      I can only boot into Mac if disable the NVIDIA drivers with the boot flag nv_disable=1  however that's not great I end up with one monitor working at 1024 x 768.
       
       
      I've updated the NVIDIA web drivers to the latest my build of sierra can take. 
      I have the boot flag for web driver to be enabled (can't remember off the top of my head.. I'm on the work pc, soon to be home)
       
      Any ideas would be grateful, I spent much of last night and morning on this.

      Many Thanks
       
      UPDATE: I've managed to load successfully, between a combination of changing the SMBIOS to MacBook 14,2 and loading lilukext with NVIDIAgraphicsfixer.
       
      Everything is the same as Yosemite, except I do not have HDMI audio or onboard sound. I do have a dedicated audio interface so I'm not at a true loss.
       
       
    • By zebity
      Hi Hypervisors,
       
      I have been working to move my Late 2009 Xserve MacOS Server onto Ubuntu 18.04 LTS QEMU/KVM based virtual machine using OVMF and Clover.
       
      After much effort and testing based on the following information from: Kraxel's, Kholia, Gordon Turner and Clover site:
      https://www.kraxel.org/blog/2017/09/running-macos-as-guest-in-kvm/
      https://github.com/kholia/OSX-KVM
      https://gist.github.com/gordonturner/2a2e5ecde5e7860b52e2
      https://clover-wiki.zetam.org/Home
       
      I have now managed to get OVMF/Clover boot and install of MacOS Sierra.
       
      I started with Ubuntu 16.04 initially but this required download and compile of QEMU to get update of machines to: pc-q35-2.9 or better, so I moved to Ubuntu 18.04, which has pc-q35.2.11 available as standard.
       
      So I am now working with standard Ubuntu 18.04 LTS based systems with following packages: kvm/qemu/libvirt/bridge-utils/ovmf/virt-manager
       
      As I want to use PCIe Passthrough for a number of PCIe card currently installed in the server (SmallTree 10GbE & Areca ARC-1883 SAS RAID) I set up my machine with linux kernel boot configuration (/etc/default/grub) of: 
      GRUB_CMDLINE_LINUX_DEFAULT="iommu=1 intel_iommu=on" (as my machine is intel VT-d based HW virtualisation)
       
      This resulted in creation of a number of iommu groups (see /sys/kernel/iommu_group directory for this and this posting for information: https://forum.level1techs.com/t/ubuntu-17-04-vfio-pcie-passthrough-kernel-update-4-14-rc1/119639 , noting that Ubuntu 18.04 LTS has kernel version: 4.15.0-22-generic so there is no need to do kernel update for iommu to work).
       
      Using bare minimal Clover config.plist:
       
       
      And following Clover UEFI drivers:
       
      I can boot MacOS, but it is very very slow... it sits on the apple boot logo for over a minutes before finally moving onto the progress bar.
      The other problem I have is that no PCI or Network devices appear in the "About This Mac" System Information Report and I cannot get any network connectivity from bridged E1000 network device.
       
      Here is my virtlib.xml dump for the virtual machine:
       

      Can any one advise of whether I need to update the CLOVER config.plist to add extra items in to allow network and PCI Passthrough to work.
       
      Thank you.
       
      Regards,
       
      Zebity
       
    • By MaLd0n
      Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell     Skylake, Kabylake and Coffeelake is here http://www.insanelymac.com/forum/topic/321872-guide-sierra-on-gigabyte-mobos-serie-200-kabylake-dsdt/   First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder CLOVER Install.zip   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder CLOVER Post Install.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
×