Jump to content
jnolla

Vega Frontier Edition on High Sierra

730 posts in this topic

Recommended Posts

24 minutes ago, okrasit said:

Nope, that's how apple & amd have designed it to behave. :rofl:

works in the SSDT if anyone else is curious, heres the code for the 1642mhz.

 

                            "PP_PhmSoftPowerPlayTable", 
                            Buffer (One)
                            {
                                /* 0000 */  0xB6, 0x02, 0x08, 0x01, 0x00, 0x5C, 0x00, 0xE1,
                                /* 0008 */  0x06, 0x00, 0x00, 0xEE, 0x2B, 0x00, 0x00, 0x1B,
                                /* 0010 */  0x00, 0x48, 0x00, 0x00, 0x00, 0x80, 0xA9, 0x03,
                                /* 0018 */  0x00, 0xF0, 0x49, 0x02, 0x00, 0x8E, 0x00, 0x08,
                                /* 0020 */  0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
                                /* 0028 */  0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x02, 0x01,
                                /* 0030 */  0x5C, 0x00, 0x4F, 0x02, 0x46, 0x02, 0x94, 0x00,
                                /* 0038 */  0x9E, 0x01, 0xBE, 0x00, 0x28, 0x01, 0x7A, 0x00,
                                /* 0040 */  0x8C, 0x00, 0xBC, 0x01, 0x00, 0x00, 0x00, 0x00,
                                /* 0048 */  0x72, 0x02, 0x00, 0x00, 0x90, 0x00, 0xA8, 0x02,
                                /* 0050 */  0x6D, 0x01, 0x43, 0x01, 0x97, 0x01, 0xF0, 0x49,
                                /* 0058 */  0x02, 0x00, 0x71, 0x02, 0x02, 0x02, 0x00, 0x00,
                                /* 0060 */  0x00, 0x00, 0x00, 0x00, 0x08, 0x00, 0x00, 0x00,
                                /* 0068 */  0x00, 0x00, 0x00, 0x00, 0x05, 0x00, 0x07, 0x00,
                                /* 0070 */  0x03, 0x00, 0x05, 0x00, 0x00, 0x00, 0x00, 0x00,
                                /* 0078 */  0x00, 0x00, 0x01, 0x08, 0x84, 0x03, 0x84, 0x03,
                                /* 0080 */  0xB6, 0x03, 0xE8, 0x03, 0x1A, 0x04, 0x4C, 0x04,
                                /* 0088 */  0x60, 0x04, 0x7E, 0x04, 0x01, 0x01, 0x33, 0x04,
                                /* 0090 */  0x01, 0x01, 0x84, 0x03, 0x00, 0x08, 0x60, 0xEA,
                                /* 0098 */  0x00, 0x00, 0x00, 0x40, 0x19, 0x01, 0x00, 0x01,
                                /* 00A0 */  0x80, 0x38, 0x01, 0x00, 0x02, 0xDC, 0x4A, 0x01,
                                /* 00A8 */  0x00, 0x03, 0x90, 0x5F, 0x01, 0x00, 0x04, 0x00,
                                /* 00B0 */  0x77, 0x01, 0x00, 0x05, 0x90, 0x91, 0x01, 0x00,
                                /* 00B8 */  0x06, 0x50, 0xBD, 0x01, 0x00, 0x07, 0x01, 0x08,
                                /* 00C0 */  0xD0, 0x4C, 0x01, 0x00, 0x00, 0x00, 0x80, 0x00,
                                /* 00C8 */  0x00, 0x00, 0x00, 0x00, 0x00, 0x44, 0x8D, 0x01,
                                /* 00D0 */  0x00, 0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
                                /* 00D8 */  0x00, 0x00, 0xDC, 0xC7, 0x01, 0x00, 0x02, 0x00,
                                /* 00E0 */  0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x98,
                                /* 00E8 */  0xFC, 0x01, 0x00, 0x03, 0x00, 0x00, 0x00, 0x00,
                                /* 00F0 */  0x00, 0x00, 0x00, 0x00, 0xD8, 0x1B, 0x02, 0x00,
                                /* 00F8 */  0x04, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
                                /* 0100 */  0x00, 0xF4, 0x40, 0x02, 0x00, 0x05, 0x00, 0x00,
                                /* 0108 */  0x00, 0x00, 0x01, 0x00, 0x00, 0x00, 0x1C, 0x64,
                                /* 0110 */  0x02, 0x00, 0x06, 0x00, 0x00, 0x00, 0x00, 0x01,
                                /* 0118 */  0x00, 0x00, 0x00, 0x68, 0x81, 0x02, 0x00, 0x07,
                                /* 0120 */  0x00, 0x00, 0x00, 0x00, 0x01, 0x00, 0x00, 0x00,
                                /* 0128 */  0x00, 0x05, 0x60, 0xEA, 0x00, 0x00, 0x00, 0x40,
                                /* 0130 */  0x19, 0x01, 0x00, 0x00, 0x80, 0x38, 0x01, 0x00,
                                /* 0138 */  0x00, 0xDC, 0x4A, 0x01, 0x00, 0x00, 0x90, 0x5F,
                                /* 0140 */  0x01, 0x00, 0x00, 0x00, 0x08, 0x28, 0x6E, 0x00,
                                /* 0148 */  0x00, 0x00, 0x2C, 0xC9, 0x00, 0x00, 0x01, 0xF8,
                                /* 0150 */  0x0B, 0x01, 0x00, 0x02, 0x80, 0x38, 0x01, 0x00,
                                /* 0158 */  0x03, 0x90, 0x5F, 0x01, 0x00, 0x04, 0xF4, 0x91,
                                /* 0160 */  0x01, 0x00, 0x05, 0xD0, 0xB0, 0x01, 0x00, 0x06,
                                /* 0168 */  0x38, 0xC1, 0x01, 0x00, 0x07, 0x00, 0x08, 0x6C,
                                /* 0170 */  0x39, 0x00, 0x00, 0x00, 0x24, 0x5E, 0x00, 0x00,
                                /* 0178 */  0x01, 0xFC, 0x85, 0x00, 0x00, 0x02, 0xAC, 0xBC,
                                /* 0180 */  0x00, 0x00, 0x03, 0x34, 0xD0, 0x00, 0x00, 0x04,
                                /* 0188 */  0x68, 0x6E, 0x01, 0x00, 0x05, 0x08, 0x97, 0x01,
                                /* 0190 */  0x00, 0x06, 0xB0, 0xAD, 0x01, 0x00, 0x07, 0x00,
                                /* 0198 */  0x01, 0x68, 0x3C, 0x01, 0x00, 0x00, 0x01, 0x04,
                                /* 01A0 */  0x3C, 0x41, 0x00, 0x00, 0x00, 0x00, 0x00, 0x50,
                                /* 01A8 */  0xC3, 0x00, 0x00, 0x00, 0x00, 0x00, 0x80, 0x38,
                                /* 01B0 */  0x01, 0x00, 0x02, 0x00, 0x00, 0x34, 0x98, 0x01,
                                /* 01B8 */  0x00, 0x04, 0x00, 0x00, 0x01, 0x08, 0x00, 0x98,
                                /* 01C0 */  0x85, 0x00, 0x00, 0x40, 0xB5, 0x00, 0x00, 0x60,
                                /* 01C8 */  0xEA, 0x00, 0x00, 0x50, 0xC3, 0x00, 0x00, 0x01,
                                /* 01D0 */  0x80, 0xBB, 0x00, 0x00, 0x60, 0xEA, 0x00, 0x00,
                                /* 01D8 */  0x94, 0x0B, 0x01, 0x00, 0x50, 0xC3, 0x00, 0x00,
                                /* 01E0 */  0x02, 0x00, 0xE1, 0x00, 0x00, 0x94, 0x0B, 0x01,
                                /* 01E8 */  0x00, 0x40, 0x19, 0x01, 0x00, 0x50, 0xC3, 0x00,
                                /* 01F0 */  0x00, 0x03, 0x78, 0xFF, 0x00, 0x00, 0x40, 0x19,
                                /* 01F8 */  0x01, 0x00, 0x88, 0x26, 0x01, 0x00, 0x50, 0xC3,
                                /* 0200 */  0x00, 0x00, 0x04, 0x40, 0x19, 0x01, 0x00, 0x80,
                                /* 0208 */  0x38, 0x01, 0x00, 0x80, 0x38, 0x01, 0x00, 0x50,
                                /* 0210 */  0xC3, 0x00, 0x00, 0x05, 0x80, 0x38, 0x01, 0x00,
                                /* 0218 */  0xDC, 0x4A, 0x01, 0x00, 0xDC, 0x4A, 0x01, 0x00,
                                /* 0220 */  0x50, 0xC3, 0x00, 0x00, 0x06, 0x00, 0x77, 0x01,
                                /* 0228 */  0x00, 0x00, 0x77, 0x01, 0x00, 0x90, 0x5F, 0x01,
                                /* 0230 */  0x00, 0x50, 0xC3, 0x00, 0x00, 0x07, 0x90, 0x91,
                                /* 0238 */  0x01, 0x00, 0x90, 0x91, 0x01, 0x00, 0x00, 0x77,
                                /* 0240 */  0x01, 0x00, 0x50, 0xC3, 0x00, 0x00, 0x01, 0x18,
                                /* 0248 */  0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x0B,
                                /* 0250 */  0x00, 0x00, 0xBC, 0x02, 0x48, 0x26, 0x46, 0x00,
                                /* 0258 */  0x0A, 0x00, 0x54, 0x03, 0x90, 0x01, 0x90, 0x01,
                                /* 0260 */  0x90, 0x01, 0x90, 0x01, 0x90, 0x01, 0x90, 0x01,
                                /* 0268 */  0x90, 0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x02,
                                /* 0270 */  0x04, 0x31, 0x07, 0x90, 0x01, 0x90, 0x01, 0x90,
                                /* 0278 */  0x01, 0x90, 0x01, 0x00, 0x00, 0x59, 0x00, 0x69,
                                /* 0280 */  0x00, 0x4A, 0x00, 0x4A, 0x00, 0x5F, 0x00, 0x73,
                                /* 0288 */  0x00, 0x73, 0x00, 0x64, 0x00, 0x40, 0x00, 0x90,
                                /* 0290 */  0x92, 0x97, 0x60, 0x96, 0x00, 0x90, 0x55, 0x00,
                                /* 0298 */  0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
                                /* 02A0 */  0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
                                /* 02A8 */  0x02, 0x02, 0xD4, 0x30, 0x00, 0x00, 0x02, 0x10,
                                /* 02B0 */  0x60, 0xEA, 0x00, 0x00, 0x02, 0x10             
                            }, 

                            "PP_DisablePowerContainment", 
                            Buffer (One)
                            {
                                 0x01                                           
                            }, 

 

Share this post


Link to post
Share on other sites
Advertisement

last question for you (i hate that i dont have windows access lol) instead of the fan ramping up to 100% can it go to ~80%... as is now it sounds like a jet engine is taking off next to me!

Share this post


Link to post
Share on other sites
11 minutes ago, Wackymac said:

last question for you (i hate that i dont have windows access lol) instead of the fan ramping up to 100% can it go to ~80%... as is now it sounds like a jet engine is taking off next to me!

/* 0250 */  0x00, 0x00, 0xBC, 0x02, 0x48, 0x26, 0x46, 0x00,

Try setting that 0x2648 to something lower, that's the max fan speed before throttling clocks. Yes, it's set way past the max rpm of the fan, to make the fan spool up faster. :lol:

I'd start with 0x1964 and continue from there on. :whistle:

The min speed is on the left and the temperature target on the right. :P

The clocks are there too somewhere, the base unit is 10kHz, so 1600MHz is 160000.

Edited by okrasit

Share this post


Link to post
Share on other sites
2 minutes ago, okrasit said:

/* 0250 */  0x00, 0x00, 0xBC, 0x02, 0x48, 0x26, 0x46, 0x00,

Try setting that 0x2648 to something lower, that's the max fan speed before throttling clocks. Yes, it's set way past the max rpm of the fan, to make the fan spool up faster. :lol:

I'd start with 0x1964 and continue from there on. :whistle:

 

am i understanding that correctly, your settings are for 9800rpm? and the ones you suggested are 6500rpm?

Share this post


Link to post
Share on other sites
4 minutes ago, Wackymac said:

am i understanding that correctly, your settings are for 9800rpm? and the ones you suggested are 6500rpm?

Yes, the premium apple logic somehow never runs the fan even near the max speed, for reasons unknown. :whistle:

But also, steeper curve. :thumbsup_anim:

 

Edited by okrasit

Share this post


Link to post
Share on other sites
1 minute ago, okrasit said:

Yes, the premium apple logic somehow never runs the fan even near the max speed, for reasons unknown. :whistle:

But also, steeper curve. :thumbsup_anim:

 

which ones the curve and which one is the rpm? or is it sort of together... i like the curve it has on the 0x1964... but still want the rpm a tad lower. (actually lowering the rpm dropped the temps by about 4* during luxmark LOL)

Share this post


Link to post
Share on other sites
1 hour ago, Wackymac said:

which ones the curve and which one is the rpm? or is it sort of together... i like the curve it has on the 0x1964... but still want the rpm a tad lower. (actually lowering the rpm dropped the temps by about 4* during luxmark LOL)

Yes, the curve is a product of the min&max&some apple factor. :whistle:

Edited by okrasit

Share this post


Link to post
Share on other sites

I am happy to report @okrasit that your setting with temperature target: 70C, Core: 1442MHz, Mem: 1045MHz, SOC: 1199MHz and the fan fix working great on my system.  

Is there any intent to make a clover patch with all prest you made. 

Sometimes LuxMark crashes is this just related to my system or it happing to you also?

 

uaV6yDF.png

 

 

Edited by MMido
updating image URL

Share this post


Link to post
Share on other sites
1 hour ago, MMido said:

I am happy to report @okrasit that your setting with temperature target: 70C, Core: 1442MHz, Mem: 1045MHz, SOC: 1199MHz and the fan fix working great on my system.  

Is there any intent to make a clover patch with all prest you made. 

Sometimes LuxMark crashes is this just related to system or it happing to you also?

No crashing here, with the 2 RX64 nor the 1 FE what I have. Could be the core/memory clock/voltage... 

And yes, Clover is the way to go!

 

Although, that 1600MHz/1150mV wasn't stable for me, Fortnite crashed the system. :lol:

Or the vrm’s ocp tripped... :whistle:

 

Edited by okrasit

Share this post


Link to post
Share on other sites

 Used the combination below to test my system everything seems alright no crashing I am on air-cooling.

Is there a way to monitor GPU temp in OSX?

V4Q4OUj

Core: 1642MHz/1150mV, Memory: 1045MHz/1075mV, SOC: 1199MHz, Temp target: 70, Idle fan: 700rpm

tgIIAQBcAOEGAADuKwAAGwBIAAAAgKkDAPBJAgCOAAgAAAAAAAAAAAAAAAAAAAIBXABPAkYClACeAb4AKAF6AIwAvAEAAAAAcgIAAJAAqAJtAUMBlwHwSQIAcQICAgAAAAAAAAgAAAAAAAAABQAHAAMABQAAAAAAAAABCIQDhAO2A+gDGgRMBGAEfgQBATMEAQGEAwAIYOoAAABAGQEAAYA4AQAC3EoBAAOQXwEABAB3AQAFkJEBAAZQvQEABwEI0EwBAAAAgAAAAAAAAESNAQABAAAAAAAAAADcxwEAAgAAAAAAAAAAmPwBAAMAAAAAAAAAANgbAgAEAAAAAAAAAAD0QAIABQAAAAABAAAAHGQCAAYAAAAAAQAAAGiBAgAHAAAAAAEAAAAABWDqAAAAQBkBAACAOAEAANxKAQAAkF8BAAAACChuAAAALMkAAAH4CwEAAoA4AQADkF8BAAT0kQEABdCwAQAGOMEBAAcACGw5AAAAJF4AAAH8hQAAAqy8AAADNNAAAARobgEABQiXAQAGsK0BAAcAAWg8AQAAAQQ8QQAAAAAAUMMAAAAAAIA4AQACAAA0mAEABAAAAQgAmIUAAEC1AABg6gAAUMMAAAGAuwAAYOoAAJQLAQBQwwAAAgDhAACUCwEAQBkBAFDDAAADeP8AAEAZAQCIJgEAUMMAAARAGQEAgDgBAIA4AQBQwwAABYA4AQDcSgEA3EoBAFDDAAAGAHcBAAB3AQCQXwEAUMMAAAeQkQEAkJEBAAB3AQBQwwAAARgAAAAAAAAACwAAvAJIJkYACgBUA5ABkAGQAZABkAGQAZABAAAAAAACBDEHkAGQAZABkAEAAFkAaQBKAEoAXwBzAHMAZABAAJCSl2CWAJBVAAAAAAAAAAAAAAAAAAAAAAACAtQwAAACEGDqAAACEA==
<key>PP_FuzzyFanControl</key>
<integer>0</integer>

Share this post


Link to post
Share on other sites
2 minutes ago, MMido said:

 Used the combination below to test my system everything seems alright no crashing I am on air-cooling.

Is there a way to monitor GPU temp in OSX?

 

ioreg -l |grep \"PerformanceStatistics\" | cut -d '{' -f  2 | tr '|' ',' | tr -d '}' | tr ',' '\n'|grep 'Temp'

:rofl:

 

Share this post


Link to post
Share on other sites
28 minutes ago, MMido said:

 Used the combination below to test my system everything seems alright no crashing I am on air-cooling.

Is there a way to monitor GPU temp in OSX?

V4Q4OUj

Core: 1642MHz/1150mV, Memory: 1045MHz/1075mV, SOC: 1199MHz, Temp target: 70, Idle fan: 700rpm


tgIIAQBcAOEGAADuKwAAGwBIAAAAgKkDAPBJAgCOAAgAAAAAAAAAAAAAAAAAAAIBXABPAkYClACeAb4AKAF6AIwAvAEAAAAAcgIAAJAAqAJtAUMBlwHwSQIAcQICAgAAAAAAAAgAAAAAAAAABQAHAAMABQAAAAAAAAABCIQDhAO2A+gDGgRMBGAEfgQBATMEAQGEAwAIYOoAAABAGQEAAYA4AQAC3EoBAAOQXwEABAB3AQAFkJEBAAZQvQEABwEI0EwBAAAAgAAAAAAAAESNAQABAAAAAAAAAADcxwEAAgAAAAAAAAAAmPwBAAMAAAAAAAAAANgbAgAEAAAAAAAAAAD0QAIABQAAAAABAAAAHGQCAAYAAAAAAQAAAGiBAgAHAAAAAAEAAAAABWDqAAAAQBkBAACAOAEAANxKAQAAkF8BAAAACChuAAAALMkAAAH4CwEAAoA4AQADkF8BAAT0kQEABdCwAQAGOMEBAAcACGw5AAAAJF4AAAH8hQAAAqy8AAADNNAAAARobgEABQiXAQAGsK0BAAcAAWg8AQAAAQQ8QQAAAAAAUMMAAAAAAIA4AQACAAA0mAEABAAAAQgAmIUAAEC1AABg6gAAUMMAAAGAuwAAYOoAAJQLAQBQwwAAAgDhAACUCwEAQBkBAFDDAAADeP8AAEAZAQCIJgEAUMMAAARAGQEAgDgBAIA4AQBQwwAABYA4AQDcSgEA3EoBAFDDAAAGAHcBAAB3AQCQXwEAUMMAAAeQkQEAkJEBAAB3AQBQwwAAARgAAAAAAAAACwAAvAJIJkYACgBUA5ABkAGQAZABkAGQAZABAAAAAAACBDEHkAGQAZABkAEAAFkAaQBKAEoAXwBzAHMAZABAAJCSl2CWAJBVAAAAAAAAAAAAAAAAAAAAAAACAtQwAAACEGDqAAACEA==

<key>PP_FuzzyFanControl</key>
<integer>0</integer>

are you running any SSDT on your system?

1 hour ago, okrasit said:

No crashing here, with the 2 RX64 nor the 1 FE what I have. Could be the core/memory clock/voltage... 

And yes, Clover is the way to go!

 

Although, that 1600MHz/1150mV wasn't stable for me, Fortnite crashed the system. :lol:

Or the vrm’s ocp tripped... :whistle:

 

i played around with clover today, and instantly decided it wasnt going to work. clover is only capable of doing a find and replace patch and since there is nothing to find..... it wont work, and even more than that it has to be the same character count.

 

Share this post


Link to post
Share on other sites
10 minutes ago, Wackymac said:

are you running any SSDT on your system?

 

No, I edit info. plist  file directly in the AMD10000Controller. kext , but in general I use a patched DSDT file.

Edited by MMido

Share this post


Link to post
Share on other sites
1 hour ago, MMido said:

No, I edit info. plist  file directly in the AMD10000Controller. kext , but in general I use a patched DSDT file.

do you have anything in the DSDT related to the Vega? the reason i ask is because you have 2000pts more than i do in luxmark, so im curious whats different.

Share this post


Link to post
Share on other sites
On 4/5/2018 at 1:09 PM, okrasit said:

You can easily verify with Luxmark, see if the clock frequency has changed. 

Also, try this: 


tgIIAQBcAOEGAADuKwAAGwBIAAAAgKkDAPBJAgCOAAgAAAAAAAAAAAAAAAAAAAIBXABPAkYClACeAb4AKAF6AIwAvAEAAAAAcgIAAJAAqAJtAUMBlwHwSQIAcQICAgAAAAAAAAgAAAAAAAAABQAHAAMABQAAAAAAAAABCIQDhAOEA4QDhAOEA7YDMwQBATMEAQGEAwAIYOoAAABAGQEAAYA4AQAC3EoBAAOQXwEABAB3AQAFkJEBAAZQvQEABwEI0EwBAAAAgAAAAAAAAByDAQABAAAAAAAAAABwpwEAAgAAAAAAAAAAiLwBAAMAAAAAAAAAADjBAQAEAAAAAAAAAACI1QEABQAAAAABAAAAmPwBAAYAAAAAAQAAAEgzAgAHAAAAAAEAAAAABWDqAAAAQBkBAACAOAEAANxKAQAAkF8BAAAACChuAAAALMkAAAH4CwEAAoA4AQADkF8BAAT0kQEABdCwAQAGOMEBAAcACGw5AAAAJF4AAAH8hQAAAqy8AAADNNAAAARobgEABQiXAQAGsK0BAAcAAWg8AQAAAQQ8QQAAAAAAUMMAAAAAAIA4AQACAAA0mAEABAAAAQgAmIUAAEC1AABg6gAAUMMAAAGAuwAAYOoAAJQLAQBQwwAAAgDhAACUCwEAQBkBAFDDAAADeP8AAEAZAQCIJgEAUMMAAARAGQEAgDgBAIA4AQBQwwAABYA4AQDcSgEA3EoBAFDDAAAGAHcBAAB3AQCQXwEAUMMAAAeQkQEAkJEBAAB3AQBQwwAAARgAAAAAAAAACwAAZAD8CEYACgBUA5ABkAGQAZABkAGQAZABAAAAAAACBDEH3ADcANwAkAEAAFkAaQBKAEoAXwBzAHMAZABAAJCSl2CWAJBVAAAAAAAAAAAAAAAAAAAAAAACAtQwAAACEGDqAAACEA==

100rpm to 2300rpm!

I did some googling and found that some people have had problems with "normal" kind of pwm fans on the LC. Maybe the pwm is inverted, so try this too if the one above doesn't work!


tgIIAQBcAOEGAADuKwAAGwBIAAAAgKkDAPBJAgCOAAgAAAAAAAAAAAAAAAAAAAIBXABPAkYClACeAb4AKAF6AIwAvAEAAAAAcgIAAJAAqAJtAUMBlwHwSQIAcQICAgAAAAAAAAgAAAAAAAAABQAHAAMABQAAAAAAAAABCIQDhAOEA4QDhAOEA7YDMwQBATMEAQGEAwAIYOoAAABAGQEAAYA4AQAC3EoBAAOQXwEABAB3AQAFkJEBAAZQvQEABwEI0EwBAAAAgAAAAAAAAByDAQABAAAAAAAAAABwpwEAAgAAAAAAAAAAiLwBAAMAAAAAAAAAADjBAQAEAAAAAAAAAACI1QEABQAAAAABAAAAmPwBAAYAAAAAAQAAAEgzAgAHAAAAAAEAAAAABWDqAAAAQBkBAACAOAEAANxKAQAAkF8BAAAACChuAAAALMkAAAH4CwEAAoA4AQADkF8BAAT0kQEABdCwAQAGOMEBAAcACGw5AAAAJF4AAAH8hQAAAqy8AAADNNAAAARobgEABQiXAQAGsK0BAAcAAWg8AQAAAQQ8QQAAAAAAUMMAAAAAAIA4AQACAAA0mAEABAAAAQgAmIUAAEC1AABg6gAAUMMAAAGAuwAAYOoAAJQLAQBQwwAAAgDhAACUCwEAQBkBAFDDAAADeP8AAEAZAQCIJgEAUMMAAARAGQEAgDgBAIA4AQBQwwAABYA4AQDcSgEA3EoBAFDDAAAGAHcBAAB3AQCQXwEAUMMAAAeQkQEAkJEBAAB3AQBQwwAAARgAAAAAAAAACwAA/AhkAEYACgBUA5ABkAGQAZABkAGQAZABAAAAAAACBDEH3ADcANwAkAEAAFkAaQBKAEoAXwBzAHMAZABAAJCSl2CWAJBVAAAAAAAAAAAAAAAAAAAAAAACAtQwAAACEGDqAAACEA==

 

Thanks for your input! 

Sadly, having tried all those different configs, I always get the same result: silent at boot and login, but a few minutes after, goes full blast :( 

I've been using the configs you posted for Liquid Cooled ones, but I'm now wondering if those are actually meant for custom liquid cooled cards. I own the FE Liquid Cooled , not a custom one. The only thing I did was replace the stock noisy fan for a Noctua Industrial. Don't really know if that makes any difference at all.

Anyway, thanks for your help!

Share this post


Link to post
Share on other sites
46 minutes ago, gabilopezb said:

Thanks for your input! 

Sadly, having tried all those different configs, I always get the same result: silent at boot and login, but a few minutes after, goes full blast :( 

I've been using the configs you posted for Liquid Cooled ones, but I'm now wondering if those are actually meant for custom liquid cooled cards. I own the FE Liquid Cooled , not a custom one. The only thing I did was replace the stock noisy fan for a Noctua Industrial. Don't really know if that makes any difference at all.

Anyway, thanks for your help!

How is it working with vanilla AMD10000Controller.kext ?

Share this post


Link to post
Share on other sites
3 hours ago, okrasit said:

How is it working with vanilla AMD10000Controller.kext ?

The same way as it does now. It’s like the patch does not affect the behavior of the fan at all 

Share this post


Link to post
Share on other sites
7 minutes ago, gabilopezb said:

The same way as it does now. It’s like the patch does not affect the behavior of the fan at all 

Exactly, it affects only the pump I'd guess. Can you check the temperatures & fan (pump) speed ?

ioreg -l |grep \"PerformanceStatistics\" | cut -d '{' -f  2 | tr '|' ',' | tr -d '}' | tr ',' '\n'|grep 'Temp\|Fan'

 

Edited by okrasit

Share this post


Link to post
Share on other sites
6 hours ago, okrasit said:

Exactly, it affects only the pump I'd guess. Can you check the temperatures & fan (pump) speed ?


ioreg -l |grep \"PerformanceStatistics\" | cut -d '{' -f  2 | tr '|' ',' | tr -d '}' | tr ',' '\n'|grep 'Temp\|Fan'

 

Hey, thanks again. Sorry for the delay. In the file attached you can see how the fan speed increases since the login and reaches the maximum of 1500ish and stays there. 

Screen Shot 2018-04-07 at 01.55.27.png

Share this post


Link to post
Share on other sites
On 4/5/2018 at 12:23 PM, okrasit said:

I'm using this:


<key>PP_PhmSoftPowerPlayTable</key>
<data>tgIIAQBcAOEGAADuKwAAGwBIAAAAgKkDAPBJAgCOAAgAAAAAAAAAAAAAAAAAAAIBXABPAkYClACeAb4AKAF6AIwAvAEAAAAAcgIAAJAAqAJtAUMBlwHwSQIAcQICAgAAAAAAAAgAAAAAAAAABQAHAAMABQAAAAAAAAABCIQDhAOEA4QDhAOEA7YDMwQBATMEAQGEAwAIYOoAAABAGQEAAYA4AQAC3EoBAAOQXwEABAB3AQAFkJEBAAZQvQEABwEI0EwBAAAAgAAAAAAAAByDAQABAAAAAAAAAABwpwEAAgAAAAAAAAAAiLwBAAMAAAAAAAAAADjBAQAEAAAAAAAAAACI1QEABQAAAAABAAAAmPwBAAYAAAAAAQAAAEgzAgAHAAAAAAEAAAAABWDqAAAAQBkBAACAOAEAANxKAQAAkF8BAAAACChuAAAALMkAAAH4CwEAAoA4AQADkF8BAAT0kQEABdCwAQAGOMEBAAcACGw5AAAAJF4AAAH8hQAAAqy8AAADNNAAAARobgEABQiXAQAGsK0BAAcAAWg8AQAAAQQ8QQAAAAAAUMMAAAAAAIA4AQACAAA0mAEABAAAAQgAmIUAAEC1AABg6gAAUMMAAAGAuwAAYOoAAJQLAQBQwwAAAgDhAACUCwEAQBkBAFDDAAADeP8AAEAZAQCIJgEAUMMAAARAGQEAgDgBAIA4AQBQwwAABYA4AQDcSgEA3EoBAFDDAAAGAHcBAAB3AQCQXwEAUMMAAAeQkQEAkJEBAAB3AQBQwwAAARgAAAAAAAAACwAAvAJIJkYACgBUA5ABkAGQAZABkAGQAZABAAAAAAACBDEH3ADcANwAkAEAAFkAaQBKAEoAXwBzAHMAZABAAJCSl2CWAJBVAAAAAAAAAAAAAAAAAAAAAAACAtQwAAACEGDqAAACEA==</data>
<key>PP_DisablePowerContainment</key>
<integer>1</integer>
<key>PP_FuzzyFanControl</key>
<integer>0</integer>

Temperature target: 70C, Core: 1442MHz, Mem: 1045MHz, SOC: 1199MHz.

Fan goes full blast on load but returns to 700rpm on idle (eventually, it takes a while :rofl:). 

I'll modify those higher clock versions with this fan fix later!

 

Hey, I've been testing with different profiles and monitoring with Ioreg. I just can't find where I'm going wrong. There is barely a minute of difference between all three screenshots I attach. Memory clock stays the same but core and fan speed are volatile af. I was doing nothing, just ioreg was open. 

By the way, I'm using the config you posted in the reply I'm quoting.

Screen Shot 2018-04-08 at 13.37.20.png

Screen Shot 2018-04-08 at 13.38.33.png

Screen Shot 2018-04-08 at 13.39.39.png

Share this post


Link to post
Share on other sites

Hi guys.
I'm not sure this is the right place for my question but I give it a try.
I'm running 10.13.4 High Sierra with a water cooled Sapphire RX Vega 64. My Cinebench score for this card is very low in High Sierra (75 fps) compared to Windows 10 (148 fps).
I did the same test with my old RX Vega 56 a couple of weeks ago and at that time I scored 122 fps on HS 10.13.3.

Any ideas?

Edited by obus

Share this post


Link to post
Share on other sites
On 4/15/2018 at 2:59 PM, obus said:

Hi guys.
I'm not sure this is the right place for my question but I give it a try.
I'm running 10.13.4 High Sierra with a water cooled Sapphire RX Vega 64. My Cinebench score for this card is very low in High Sierra (75 fps) compared to Windows 10 (148 fps).
I did the same test with my old RX Vega 56 a couple of weeks ago and at that time I scored 122 fps on HS 10.13.3.

Any ideas?

It's not a good benchmark, your fps will get capped to screen refresh rate in some situations, like an open browser window etc. :(

Share this post


Link to post
Share on other sites
9 hours ago, Wackymac said:

btw! @okrasit you should try and get your voltages lower, im currently running at 1700mhz/950mv on the core and 1150mhz/920mv on the hbm.

Just make sure it's stable in _every_ situation (play some Fortnite at 4k :D). :whistle:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×