Jump to content
jnolla

Vega Frontier Edition on High Sierra

729 posts in this topic

Recommended Posts

46 minutes ago, Pluskat5000Schiffe said:

 

I have a possible breaktrough... and you won't believe it... See this:

 

1613510335_Screenshot2018-11-12at15_54_24.png.575c7934ecb76f4095c08464356e153c.png

 

Thats wrong ... lol but it behaves much better than setting with 0 or 1 

With 0 I have toggling fan due 1630Mhz clock which stays there heats up the card and start the fans cools it down and turns the fans down all in 10 sec so very annoying.

With 1 I have 1200RPM steady in IDLE not working for me. 

With 3 yes three is works as it should. See attached PPT excel I used and Performance Statistics made during a Valley benchmark run (ended with 74fps).

Can you confirm 3 is a valid option or did I just opened pandora's box ;-). Does it make sense to tune the PowerPlayTable?

Thanks!

 

 

temps.txt

vega64-mac-pp_table-gen-V1.5.xlsx

DisableFanControl is a Boolean value, it is either 0=No or 1=yes, setting to anything other than those 2 values will make it use the default value of 0.

Share this post


Link to post
Share on other sites
Advertisement
11 minutes ago, Pavo said:

DisableFanControl is a Boolean value, it is either 0=No or 1=yes, setting to anything other than those 2 values will make it use the default value of 0.

 

Yes man i know. I already double checked it. There is a difference. I will check it tonight once more...

 

Share this post


Link to post
Share on other sites

I never tested this. Let me try it on my card :D
You changed the wrong value tho. I was talking about my PPT generator.

Edited by CMMChris

Share this post


Link to post
Share on other sites

Yup, "DisableFanControl = 3" fixes the fan spin-up issue after load. Fans now retain their speed for a while and then start the spin down process. @Pluskat5000Schiffe you are my hero! I guess this is a bug, but it works well.

Share this post


Link to post
Share on other sites
6 hours ago, CMMChris said:

Yup, "DisableFanControl = 3" fixes the fan spin-up issue after load. Fans now retain their speed for a while and then start the spin down process. @Pluskat5000Schiffe you are my hero! I guess this is a bug, but it works well.

I'm so glad that I yes I lol fixed the fan issue for once and for all hahaha well lets hope it!

 

8 hours ago, Pavo said:

DisableFanControl is a Boolean value, it is either 0=No or 1=yes, setting to anything other than those 2 values will make it use the default value of 0.

See above it looks its not a boolean. CMMChris acked it works for him too.

Edited by Pluskat5000Schiffe

Share this post


Link to post
Share on other sites

Well I was too optimistic still good news though. I tried to reproduce the behaviour without PP_DisableFanControl and without PP_DisablePowerContainment  in my clover / device / properties. I found out that with the default power settings the card turns the fans to Idle too. The GPU core clock remains at 1630MHz which heats up the GPU fast and heats it up beyond 57 degrees Celsius starting the fans to spin up. The fans cools the GPU down quick because there is no load but this hole heating up cooling down spinning up spinning down takes place in 10sec. So that's really annoying. Lowering the PowerLimits keeps the clocks down after load. The result is that the card stops its fans right after quitting GPU load. And keep the clocks at about 270Mhz / 500Mhz memory. Temps remain 39 deg. Celsius. I think it's still not perfect.  

Screenshot 2018-11-13 at 02.20.08.png

Screenshot 2018-11-13 at 02.21.14.png

Share this post


Link to post
Share on other sites

Fans spinning down after load is what should happen when using a PPT. However, most cards start to spin up to full speed after the card is under load before the start to spin down. This phenomenon disappears with DisableFanControl = 3. I am using DisableFanControll = 1 tho. My card is almost silent at the base 1200 RPM and it keeps the temps low.

 

Regarding the power limit I don't know why your clocks behave abnormal under load when you apply a higher limit. I run my card with 300W power limit and have no issues with that.

Share this post


Link to post
Share on other sites

Hi. I noticed that if I add kext or PPT 4k resolution will not work in 60hz. Fans will stay low but screen will only display in 30hz or lower. Do you have that problem too ?

Didn't try with DisableFanControl, can someone help with what to put where, address devices ... Thanks

Edited by guliwwer

Share this post


Link to post
Share on other sites
On 11/12/2018 at 4:57 PM, Pavo said:

DisableFanControl is a Boolean value

Where is it defined as such? I can't find it and all PP_Values are integers in the 7/8/9/95/10 kexts?

I've looked at the linux driver but I've yet to find the reference to it.

Share this post


Link to post
Share on other sites
On 10/26/2018 at 1:59 PM, hugeschnauzer said:

 

I've tried both methods..

crashes again in FCPX... :-(

In Unigine tests i see rpm changes 

 

The console error i get is:

 (com.apple.DumpGPURestart): Service only ran for 1 seconds. Pushing respawn out by 9 seconds.

 

 

Oh interesting I have this error also! But only if I'm running Dual Monitors. If I run one monitor, FCPX doesn't crash! 

Share this post


Link to post
Share on other sites
On 11/14/2018 at 10:53 PM, guliwwer said:

Hi. I noticed that if I add kext or PPT 4k resolution will not work in 60hz. Fans will stay low but screen will only display in 30hz or lower. Do you have that problem too ?

Didn't try with DisableFanControl, can someone help with what to put where, address devices ... Thanks

HDMI or DP? I have DP no 30Hz just 60Hz (Dell P2715Q) 30Hz is horrible. 

Share this post


Link to post
Share on other sites
15 hours ago, CMMChris said:

You mean video acceleration? That's a known issue.

Yes , about video acceleration I say ... Thank you ... No patch for this issue ? ...In 14.2 beta 3 video acceleration has returned by wonder...

edit:

I read about apps built using OpenGL and OpenCL will continue to run in macOS 10.14, but these legacy technologies are deprecated in macOS 10.14. FCPX is one of this apps. Recently was update to 10.4.4 version . And havent support for metal or metal2 .

Edited by corint1

Share this post


Link to post
Share on other sites
On 11/22/2018 at 10:30 PM, TheShadowKnows said:

 

Will this work for Vega 64?

Yes... but seems that is for High Sierra only...take care!!

Share this post


Link to post
Share on other sites

hi.  about to run some tests to try and get rid of the remaining coil whine (I assume it's coil whine) on my ASRock Phantom 64 and have a quick question.

 

After I make my adjustments in vega64-mac-pp_table-gen-V1.5.xlsx and convert the Hex to Base64, is this the only field I need to update in the info.plist for VegaTab_64.kext using Xcode?

 

Information Property List\IOKitPersonalities\Controller\aty_properties\PP_PhmSoftPowerPlayTable (type Data)

 

thanks!

Share this post


Link to post
Share on other sites
On 11/12/2018 at 5:09 PM, Pluskat5000Schiffe said:

 

I have a possible breaktrough... and you won't believe it... See this:

 

1613510335_Screenshot2018-11-12at15_54_24.png.575c7934ecb76f4095c08464356e153c.png

 

Thats wrong ... lol but it behaves much better than setting with 0 or 1 

With 0 I have toggling fan due 1630Mhz clock which stays there heats up the card and start the fans cools it down and turns the fans down all in 10 sec so very annoying.

With 1 I have 1200RPM steady in IDLE not working for me. 

With 3 yes three is works as it should. See attached PPT excel I used and Performance Statistics made during a Valley benchmark run (ended with 74fps).

Can you confirm 3 is a valid option or did I just opened pandora's box ;-). Does it make sense to tune the PowerPlayTable?

Thanks!

 

 

temps.txt

vega64-mac-pp_table-gen-V1.5.xlsx

 

hi, i have sapphire vega 56 nitro, on windows fan start cooling after 50-55°

 

power play table for my vega 56 get from here

 

this method not working, the fan don’t spin down after 50° on Luxmark Benchmark(they turn on and keep cooling).

 

some body know how to fix it?

 

 

powerplay.png

Properties.plist

Edited by mjslap

Share this post


Link to post
Share on other sites
10 hours ago, CMMChris said:

Set DisableFanControl = 1

 

after 5 minutes without load, the temperature about 51-55°, fans working on medium speed.

i think power table Vega56pulse are not correct.

in the Windows driver, these tables exist? where i can find him?

Screen Shot 2018-12-03 at 10.07.35 AM.png

Share this post


Link to post
Share on other sites

If your card is too loud with disablefancontrol you need to use a macOS compatible PowerPlayTable. The Windows PowerPlayTable that you used is not compatible because macOS uses different parameters for fan control than Windows. You can try generating a PowerPlayTable with my Excel sheet. I guess it should work for V56 as well. Make sure to adjust clocks and voltage accordingly.

Share this post


Link to post
Share on other sites
32 minutes ago, CMMChris said:

If your card is too loud with disablefancontrol you need to use a macOS compatible PowerPlayTable. The Windows PowerPlayTable that you used is not compatible because macOS uses different parameters for fan control than Windows. You can try generating a PowerPlayTable with my Excel sheet. I guess it should work for V56 as well. Make sure to adjust clocks and voltage accordingly.

 

thanx for information,

 

i have some question.

 

i use second bios on my card, with 165W power limit, P-States i put from WattTool(Windows) - is it correct?

i don't understand where i can fin other parameters? I would like the fans to stop after cooling below 50°.

 

apple is driving me crazy...

Annotation 2018-12-03 140232.jpg

Share this post


Link to post
Share on other sites
  • Accoustic Limit RPM is lowest Fan Speed on macOS (100 = off)
  • Throttling RPM is maximum Fan Speed on macOS
  • Fan Stop Temperature is useless on macOS
  • Fan Start Temperature sets the temperature the fan starts spinning up
  • Target Temp controls the fan curve (setting this higher makes the fan spin up slower, setting it lower makes it spin up faster)
  • Max Temp is the value that controls thermal throttling

You need to remove DisableFanControl in order for the PowerPlayTable fan control to work.

If controlling your card with a proper PowerPlayTable does not work either, your card isn't entirely compatible with macOS (despite what Apple claims). This actually is very likely since the same is the case with the Sapphire Vega 64 Nitro card.

 

In that case the only thing left to try is removing the PowerPlayTable and / or DisableFanControl value and set those parameters:
PP_ZeroRPMStartTemperature
PP_ZeroRPMStopTemperature

 

Good luck!

Share this post


Link to post
Share on other sites

Im using a ASUS Vega 64 ROG Strix on 10.13.6 (with latest security update) I still have issue that once fans start going they don't stop.

 

I think ive tried everything in this thread. (probably a few times each) 

 

Ive tried Injecting the powerplay table in to Clover and in to RadeonVegaLowFanSpeed.Kext

 

I can modify clock etc. so the tables are working ok. Although i dont think any of the Fan control stuff is making any differnce.. like MAX RPM etc.  just no matter what i set once the fan goes it just wont stop... its like a jet taking off.

 

one other anomaly... somewhere along the way the terminal command to show fan speed, core clock etc. has stopped showing me fan speed info. maybe its related?

 

 

any other ideas or stuff to check? or anyone with this card would like to share their clover?

 

Thanks!!

 

 

 

 

Edited by Philterino

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×