Jump to content
jnolla

Vega Frontier Edition on High Sierra

727 posts in this topic

Recommended Posts

 

Things just keep getting better   :w00t: 

 
I have installed 2 x GC-Alpine Ridge. They are both connected to a single AMD VEGA. One of them has 2 DP inputs and the other only 1. I have 2 LG Ultrafine 5k displays running. One is at full 5k, and the other is scaled. Both are running off a single thunderbolt cable. Given that my MB only has one TB header, only one has audio, video, and controls. I'll be picking up a second AMD VEGA with the hopes of having both displays running at 5k.
 

 

 

What about black screen on boot is still remain?

Share this post


Link to post
Share on other sites
Advertisement

 

Things just keep getting better   :w00t: 

 
I have installed 2 x GC-Alpine Ridge. They are both connected to a single AMD VEGA. One of them has 2 DP inputs and the other only 1. I have 2 LG Ultrafine 5k displays running. One is at full 5k, and the other is scaled. Both are running off a single thunderbolt cable. Given that my MB only has one TB header, only one has audio, video, and controls. I'll be picking up a second AMD VEGA with the hopes of having both displays running at 5k.
 

 

 

Thanks jnolla!  I bought the Vega Frontier Edition and it works in High Sierra OOTB, no helper, no iGPU just like you said!  

 

A question for you.  For me I also noticed that AirPlay also works OOTB.  Did you notice that too?  Is that because of Vega or some other reason?

 

Thanks!

Share this post


Link to post
Share on other sites

What about black screen on boot is still remain?

 

Boot to black is fixed.  With Vega Frontier Edition I can see the BIOS, Clover, and the kernel.

Share this post


Link to post
Share on other sites

Some OpenGL and Metal benchmarks.

Values are nearly identical to the R9Nano - which would be ok if the clock would be the same - which isn't.

Under Windows the Luxmark values are about 1.5 as high.

 

OpenGL benchmarks crash/hang under HS.

 

attachicon.gifVega.jpg

Brumbaer, thanks for running these benchmarks!

 

I also have Vega Frontier Edition.

 

However, LuxMark v3.1 and Geekbench 4.0.1, 4.1.0 and 4.1.1 all fail for me under macOs 10.13 17A315i (public beta 3).

 

Does LuxMark or Geekbench still work for you in public beta 3?

 

Thanks!

Share this post


Link to post
Share on other sites

Thanks jnolla!  I bought the Vega Frontier Edition and it works in High Sierra OOTB, no helper, no iGPU just like you said!  

 

A question for you.  For me I also noticed that AirPlay also works OOTB.  Did you notice that too?  Is that because of Vega or some other reason?

 

Thanks!

 

Congratulations! I'm not really sure if it's Vega related or not, but AirPlay works OOTB for me as well.

RX Vega is coming at lower price points! This will be a no brainer :)

https://hothardware.com/news/asus-radeon-rx-vega-64-four-air-water-cooled-models

Share this post


Link to post
Share on other sites

Hi,

I was wondering if it's possible to copy these kexts to Sierra and how I would do that properly. The 10000 series kexts point to a few other kexts right?

I ask because I've got a successful hack with i9 7900 and the x299, but only on Sierra. My Vega turns up next week and I'm thinking of ways I can get it all working!

 

Can someone here look at "about this mac", extensions, and tell me which GPU kexts are loaded with a vega card?

Thanks!

Share this post


Link to post
Share on other sites

Can't say whether I tested under DP2 or DP3, but the tests don't run under DP4 anymore.

 

 

Thanks for the reply Brumbaer!!

 

I noticed in DP5, Vega OpenCL benchmarks work again.  I received a similar score as you for LuxMark, but only 157,000 for Geekbench Compute. 

 

Is your DP5 Vega Geekbench score lower as well?

Share this post


Link to post
Share on other sites

Thanks for the reply Brumbaer!!

 

I noticed in DP5, Vega OpenCL benchmarks work again.  I received a similar score as you for LuxMark, but only 157,000 for Geekbench Compute. 

 

Is your DP5 Vega Geekbench score lower as well?

My geekbench and luxmark scores on DP5:

post-1564334-0-62564100-1502152268_thumb.png

post-1564334-0-11875100-1502152283_thumb.png

Share this post


Link to post
Share on other sites

 

Outstanding!  Thanks surfinchina!!

 

Any luck with 3 or 4 monitor configurations?  My Vega system has trouble beyond 1 DisplayPort and 1 HDMI (2 monitors).

Share this post


Link to post
Share on other sites

Outstanding!  Thanks surfinchina!!

 

Any luck with 3 or 4 monitor configurations?  My Vega system has trouble beyond 1 DisplayPort and 1 HDMI (2 monitors).

 

I have all 3 DP working with 5k displays. See above.

Share this post


Link to post
Share on other sites

A tiny bit off topic,

I've noticed that all my GPUs run hot in OS x. Actually the Vega seems not too bad.

 

But anyway, I pre-ordered the EK waterblock for it yesterday :P

Release date is 18th Aug.

Share this post


Link to post
Share on other sites

Jnolla - did you say you're considering buying a second Vega for dual GPU?  

 

If you do, please let us know how that works out?  I'm considering doing that as well.

 

Edit: I ordered a second Vega.  (and a power supply)

Share this post


Link to post
Share on other sites

This is exciting stuff. I just got my RX Vega 64 yesterday so I'll probably attempt a High Sierra install on my 1800x this weekend.

 

Edit: I'm not actually clear if HS can be installed yet. Seems there's a kernel for 10.12 but haven't found info for 10.13.

Share this post


Link to post
Share on other sites

This is exciting stuff. I just got my RX Vega 64 yesterday so I'll probably attempt a High Sierra install on my 1800x this weekend.

 

Edit: I'm not actually clear if HS can be installed yet. Seems there's a kernel for 10.12 but haven't found info for 10.13.

 

Not yet, Sierra 12.6 is the limit for Ryzen for now.    

 

I picked up another RX Vega 64 8gb.  Dual RX Vega 64s on my Pentium G3258, 2 cores for 2 GPUs.

Jnolla - did you say you're considering buying a second Vega for dual GPU?  

 

If you do, please let us know how that works out?  I'm considering doing that as well.

 

Edit: I ordered a second Vega.  (and a power supply)

 

It works for haswell processors, I doubt it will for Skylake and newer as the RX 4xx series cannot on Skylake or KabyLake.

post-1753549-0-74779700-1503103762_thumb.png

Share this post


Link to post
Share on other sites

 

It works for haswell processors, I doubt it will for Skylake and newer as the RX 4xx series cannot on Skylake or KabyLake.

 

OK thanks Gigamaxx!  (That's so helpful I wish I could like it twice)

 

I have all three, thanks to your post I'll be prepared to try them all.  

 

I bought Dual Frontier Edition.  

 

I have both cards today but I'm waiting until Thursday for delivery of the PSU direct from Corsair (I had difficulty locating it for purchase).

Share this post


Link to post
Share on other sites

OK thanks Gigamaxx!  (That's so helpful I wish I could like it twice)

 

I have all three, thanks to your post I'll be prepared to try them all.  

 

I bought Dual Frontier Edition.  

 

I have both cards today but I'm waiting until Thursday for delivery of the PSU direct from Corsair (I had difficulty locating it for purchase).

LOL! You got two of these? That's great, that's what I want to do. I love that people (like yourself) like to push limits like I do. That's amazing. Let me know how your build goes with using both of those cards together and how they perform. When you get a chance watch my latest video on my ULTRABEAST build:

 

Share this post


Link to post
Share on other sites

A bunch of posts ago I mentioned freezes on the GPU requiring reboots or re-logins. Didn't happen on the fury or nano, but are bad on the vega.

I found the solution! Some apps - eg google chrome and (my app) Archicad, you need to disable hardware acceleration.

Share this post


Link to post
Share on other sites

A bunch of posts ago I mentioned freezes on the GPU requiring reboots or re-logins. Didn't happen on the fury or nano, but are bad on the vega.

I found the solution! Some apps - eg google chrome and (my app) Archicad, you need to disable hardware acceleration.

Good to know. It's too bad that my current setup is still jacked up. But that's okay I can always sell the parts on eBay. No big loss, except the time put into this... and MAN did I put in a LOT OF TIME!!! As long as a solution can happen that's fine with me. Thanks for letting me know about this when I start my build. By the way you too got the top of the line Gigabyte board. Nice board. I'm going to get this one myself as well.

Share this post


Link to post
Share on other sites

Good to know. It's too bad that my current setup is still jacked up. But that's okay I can always sell the parts on eBay. No big loss, except the time put into this... and MAN did I put in a LOT OF TIME!!! As long as a solution can happen that's fine with me. Thanks for letting me know about this when I start my build. By the way you too got the top of the line Gigabyte board. Nice board. I'm going to get this one myself as well.

 

The sound from the USB DACs alone is worth it :)

Running my old school valve amp with mission speakers :P

Overclocks are great too with the 2x8 pin CPU power.

Share this post


Link to post
Share on other sites

Well I just returned my Asus Extreme IX board, i7 7700K CPU, and I'm going to keep the 64GB of G.Skill Trident 3600 MHz RAM (as that will work with this board). Looking forward to making this happen. So what files do you think that I need to start using to install everything? Thanks for so far for your help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×