Jump to content
jnolla

Vega Frontier Edition on High Sierra

696 posts in this topic

Recommended Posts

3 hours ago, okrasit said:

Try this:


tgIIAQBcAOEGAADuKwAAGwBIAAAAgKkDAPBJAgCOAAgAAAAAAAAAAAAAAAAAAAIBXABPAkYClACeAb4AKAF6AIwAvAEAAAAAcgIAAJAAqAJtAUMBlwHwSQIAcQICAgAAAAAAAAgAAAAAAAAABQAHAAMABQAAAAAAAAABCIQDhAOEA4QDhAOEA7YDTAQBAUwEAQGEAwAIYOoAAABAGQEAAYA4AQAC3EoBAAOQXwEABAB3AQAFkJEBAAZQvQEABwEI0EwBAAAAgAAAAAAAAByDAQABAAAAAAAAAABwpwEAAgAAAAAAAAAAiLwBAAMAAAAAAAAAADjBAQAEAAAAAAAAAACI1QEABQAAAAABAAAAmPwBAAYAAAAAAQAAAMBRAgAHAAAAAAEAAAAABWDqAAAAQBkBAACAOAEAANxKAQAAkF8BAAAACChuAAAALMkAAAH4CwEAAoA4AQADkF8BAAT0kQEABdCwAQAGOMEBAAcACGw5AAAAJF4AAAH8hQAAAqy8AAADNNAAAARobgEABQiXAQAGsK0BAAcAAWg8AQAAAQQ8QQAAAAAAUMMAAAAAAIA4AQACAAA0mAEABAAAAQgAmIUAAEC1AABg6gAAUMMAAAGAuwAAYOoAAJQLAQBQwwAAAgDhAACUCwEAQBkBAFDDAAADeP8AAEAZAQCIJgEAUMMAAARAGQEAgDgBAIA4AQBQwwAABYA4AQDcSgEA3EoBAFDDAAAGAHcBAAB3AQCQXwEAUMMAAAeQkQEAkJEBAAB3AQBQwwAAARgAAAAAAAAACwAAvAJIJiUACgBUA5ABkAGQAZABkAGQAZABAAAAAAACBDEH3ADcANwAkAEAAFkAaQBKAEoAXwBzAHMAZABAAJCSl2CWAJBVAAAAAAAAAAAAAAAAAAAAAAACAtQwAAACEGDqAAACEA==

 

Not since Google switched to VP9 codec :wacko:

 

okrasit, are you could post config for this patch? like 1630....

Share this post


Link to post
Share on other sites
Advertisement

@okrasit Thanks! I meanwhile fixed it myself though. Created an undervolted custom config with VGTab and 1500MHz max clock that runs stable on my machine. Gets me a solid 185k score in Geekbench and 29k score in Luxmark. Also, coil whine is completely gone. Sweet! Here is my code if anyone wants to try:

 

Quote

B6020801 005C00E1 060000EE 2B00001B 00480000 0080A903 00F04902 00640008 00000000 00000000 00000000 00000201 5C004F02 46029400 9E01BE00 28017A00 8C00BC01 00000000 72020000 9000A802 6D014301 9701F049 02007102 02020000 00000000 08000000 00000000 05000700 03000500 00000000 00000108 20038403 B603E803 01041A04 33044C04 01013804 01018403 000860EA 00000040 19010001 80380100 02DC4A01 0003905F 01000400 77010005 90910100 066CB001 00070108 80380100 00008000 00000000 00905F01 00010000 00000000 0000A086 01000200 00000000 000000B0 AD010003 00000000 00000000 C0D40100 04000000 00000000 00D0FB01 00050000 00000100 0000E022 02000600 00000001 000000F0 49020007 00000000 01000000 000560EA 00000040 19010000 80380100 00DC4A01 0000905F 01000000 08286E00 00002CC9 000001F8 0B010002 80380100 03905F01 0004F491 010005D0 B0010006 C0D40100 0700086C 39000000 245E0000 01FC8500 0002ACBC 00000334 D0000004 686E0100 05089701 0006ECA3 01000700 01683C01 00000104 3C410000 00000050 C3000000 00008038 01000200 00247101 00040000 01080098 85000040 B5000060 EA000050 C3000001 80BB0000 60EA0000 940B0100 50C30000 0200E100 00940B01 00401901 0050C300 000378FF 00004019 01008826 010050C3 00000440 19010080 38010080 38010050 C3000005 80380100 DC4A0100 DC4A0100 50C30000 06007701 00007701 00905F01 0050C300 00079091 01009091 01000077 010050C3 00000118 00000000 0000000B E412BC02 60093700 0A005403 90019001 90019001 90019001 90010000 00000002 043107DC 00DC00DC 002C0100 00590069 004A004A 005F0073 00730064 00400090 92976096 00905500 00000000 00000000 00000000 00000000 0202D430 00000210 60EA0000 0210

 

I am using Clover now to inject the settings. Much more convenient than Kext edits / injectors:

699381881_Bildschirmfoto2018-10-01um11_37_52.thumb.png.a09787402f1cd41e999f2c4ec07ef094.png

Share this post


Link to post
Share on other sites

Great my friend!!! :thumbsup_anim: :thumbsup_anim: and are you not have lags ?

Could you post how settings is...clock, memory, etc...

Edited by max.1974

Share this post


Link to post
Share on other sites

Settings are:
GPU Clock: 800 / 900 / 1000 / 1100 / 1200 / 1300 / 1400 / 1500
GPU Voltage: 800 / 900 / 950 / 1000 / 1025 / 1050 / 1075 / 1100
HBM2 Clock: 167 / 500 / 800 / 945
HBM2 Voltage: 1080

Fan Idle: 700
Fan Target: 2400
Fan Minimum: 400
Fan Maximum: 4900

Target Temperatur: 55°C
Power Adjustment Range: 100%

 

Little issue I have: I can only put the code in my clover config.plist with Xcode. When I save the file using Clover Configurator, it changes the Hex values for some reason and it will not work anymore. Anyone knows why it does this?

Share this post


Link to post
Share on other sites

has anyone experienced issues after a few hours of up time? my geek bench metal scores drop from 210 000 down to 160 000 only after a few hours of the machine being idle.

Share this post


Link to post
Share on other sites

Did you try use PlistEdit Pro? When im use in Clover, not happens this issue..

 

Tks for reply Chris, what's settings are you using? That from okrasit not stop fan issue... VGTab works for you? :)  

Share this post


Link to post
Share on other sites
11 minutes ago, Wackymac said:

has anyone experienced issues after a few hours of up time? my geek bench metal scores drop from 210 000 down to 160 000 only after a few hours of the machine being idle.

 

You need show how is your hardware (signature) and what the macOS that you are using...:brr:

Edited by max.1974

Share this post


Link to post
Share on other sites
18 minutes ago, max.1974 said:

Did you try use PlistEdit Pro? When im use in Clover, not happens this issue..

 

Tks for reply Chris, what's settings are you using? That from okrasit not stop fan issue... VGTab works for you? :)  

 

Settings are posted above. Regarding PlistEdit Pro: Why should I use it? Xcode works fine. My issue is with Clover Configurator. When I use it to edit my Clover config.plist it screws up the PowerPlay Table Hex code. As an example, the code I posted above that works for me, gets changed to this after saving the config.plist with Clover Configurator:
 

Quote

B6020801 005C00E1 060000EE 2B00001B 00048000 00080A90 300F0490 20064000 08000000 00000000 00000000 00000002 0105C004 F0246029 4009E01B E0028017 A0008C00 BC010000 00007202 00009000 A80206D0 14301970 1F049020 07102020 20000000 00000008 00000000 00000005 00070000 30005000 00000000 00001082 00384003 B603E803 01041A04 33044C04 01013804 00101840 3000860E A0000004 01901000 01803801 0002DC4A 01000390 5F010004 00077010 00590910 100066CB 00100070 10088038 01000000 80000000 00000090 5F010000 10000000 00000000 0A086010 00200000 00000000 0000B0AD 01000300 00000000 0000000C 0D401000 40000000 00000000 00D0FB01 00050000 00000100 0000E022 00200060 00000000 1000000F 04902000 07000000 00010000 00000560 EA000000 40019010 00080380 10000DC4 A0100009 050F0100 00000828 6E000000 2CC90000 01F800B0 10002803 80100039 05F01000 4F490101 0005D0B0 010006C0 D4010007 00086C03 90000002 45E00000 1FC85000 002ACB0C 00000334 D0000004 686E0100 05089701 00006ECA 30100070 001683C0 10000010 043C4100 00000000 50C30000 00000080 38001000 20000247 10100040 00001080 09088500 0040B500 0060EA00 0050C300 0001080B B000060E A0000940 B010050C 30000002 00E10000 940B0100 40190100 50C30000 00378FF0 00040190 10088260 10050C03 00000440 19010080 38010080 38010050 0C300000 58038010 0DC4A010 0DC4A010 0050C300 00060077 01000077 0100905F 0100050C 30000079 09101009 09101000 07070100 50C30000 01180000 00000000 000B0E41 2BC02600 937000A0 05403900 19000190 01900190 01900190 01000000 00000200 43107DC0 0DC00DC0 02C01000 05900609 004A004A 005F0073 00730064 00400090 09297609 60090550 00000000 00000000 00000000 00000000 000202D4 30000002 10060EA0 000021 

 

With Xcode the Hex values remain unchanged.

Edited by CMMChris

Share this post


Link to post
Share on other sites
52 minutes ago, max.1974 said:

 

You need show how is your hardware (signature) and what the macOS that you are using...:brr:

 my appologies Vega Fe, and i had the same issue with 10.13.6 as well as 10.14

Share this post


Link to post
Share on other sites

@Wackymac Try lowering your clocks and voltage. Just play with VGTab until you find a good setting for your card. I guess this should fix your issue because it sounds like thermal throttling to me.

Share this post


Link to post
Share on other sites
1 minute ago, CMMChris said:

@Wackymac Try lowering your clocks and voltage. Just play with VGTab until you find a good setting for your card. I guess this should fix your issue because it sounds like thermal throttling to me. 

i doubt its thermal throttling because its got a custom waterblock on it. also as soon as i restart the machine the score goes back up...

Share this post


Link to post
Share on other sites
4 hours ago, CMMChris said:

Settings are:
GPU Clock: 800 / 900 / 1000 / 1100 / 1200 / 1300 / 1400 / 1500
GPU Voltage: 800 / 900 / 950 / 1000 / 1025 / 1050 / 1075 / 1100
HBM2 Clock: 167 / 500 / 800 / 945
HBM2 Voltage: 1080

Fan Idle: 700
Fan Target: 2400
Fan Minimum: 400
Fan Maximum: 4900

Target Temperatur: 55°C
Power Adjustment Range: 100%

 

Little issue I have: I can only put the code in my clover config.plist with Xcode. When I save the file using Clover Configurator, it changes the Hex values for some reason and it will not work anymore. Anyone knows why it does this?

 

Could you possibly provide what these setting look like in Xcode or config.plist?

 

Thanks

 

Share this post


Link to post
Share on other sites
10 hours ago, Wackymac said:

 my appologies Vega Fe, and i had the same issue with 10.13.6 as well as 10.14

 

@Wackymac I recommend that you use my both kexts, because the settings is for Vega FE. 

 

Im think that settings is progressive to use with VGTab-en.app .... use in curve..... :|

 

GPU Clock: 800 / 900 / 1000 / 1100 / 1200 / 1300 / 1400 / 1500
GPU Voltage: 800 / 900 / 950 / 1000 / 1025 / 1050 / 1075 / 1100
HBM2 Clock: 167 / 500 / 800 / 945
HBM2 Voltage: 1080

Fan Idle: 700
Fan Target: 2400
Fan Minimum: 400
Fan Maximum: 4900

Target Temperatur: 55°C
Power Adjustment Range: 100%

 

Edited by max.1974

Share this post


Link to post
Share on other sites

hi, man. Here is the kext from @wyhtc  I use,  and maybe fits for me ! But I want to change the fans idle setting, it's hot and getting up until to the temp target, fans rolls up.

 

Original setting

Core: 1442MHz/1075mV ,Memory: 1045MHz/1075mV,Temp target: 57,Idle fan: 700rpm.

 

Wanting

Core: 1442MHz/1075mV ,Memory: 1045MHz/1075mV,Temp target: 45,Idle fan: 1000rpm.

 

Anyone will help me how to do this, I would be so grateful for you ! 

With Best wish.

 

XFX Vega 64 Air Cooling

RadeonVegaLowFansSpeed.kext.zip

Edited by darkkart

Share this post


Link to post
Share on other sites

Sorry im not know how to do this... but you can see youtube videos using Wattman for windows, and use regedit to get this. In the posts above, okrasit post many settings...;)

Edited by max.1974

Share this post


Link to post
Share on other sites

Finaly im find a away...looks good colors, clears fonts, perfect videos, high scores, and stable fan and temperature...

 

"Fan Speed(%)"=41

"Fan Speed(RPM)"=2010

"Temperature(C)"=34

 

But my card is Air Cooler...works like a charm!!! Mojave was perfect too!!! :startreck:

 

On 7/1/2018 at 7:16 AM, oswaldini said:

For custom water cooled ones:

Core: 1642MHz/1150mV, Memory: 1045MHz/1075mV, SOC: 1199MHz, Temp target: 75, Idle fan: 1000rpm

 

2114235190_CapturadeTela2018-10-03s01_37_23.thumb.png.ae4fe1fcaf6cc26d72768655c9cc711a.png

 

 

1290558078_CapturadeTela2018-10-03s01_58_12.thumb.png.d5b92effba5e2e573acbfd8439642202.png

 

Edited by max.1974

Share this post


Link to post
Share on other sites
On 7/1/2018 at 7:16 AM, oswaldini said:

For custom water cooled ones:

Core: 1642MHz/1150mV, Memory: 1045MHz/1075mV, SOC: 1199MHz, Temp target: 75, Idle fan: 1000rpm

 

Hi my friend @Moviemakergr :thumbsup_anim:

 

Im use this kexts and works like charm, very good performance...im edit with okrasit values...codes...

 

AMD MOD HS 1642MHZ 1000 RPM.zip  High Sierra 10.13.6 (17G65)

 

AMD10000Controller.kext - Mojave beta 1 mod.zip Mojave beta 1 

 

Just modified / add only PP_PhmSoftPowerPlayTable on info.plist...:pirate:

 

Quote

B6020801 005C00E1 060000EE 2B00001B 00480000 0080A903 00F04902 008E0008 00000000 00000000 00000000 00000201 5C004F02 46029400 9E01BE00 28017A00 8C00BC01 00000000 72020000 9000A802 6D014301 9701F049 02007102 02020000 00000000 08000000 00000000 05000700 03000500 00000000 00000108 84038403 B603E803 1A044C04 60047E04 01013304 01018403 000860EA 00000040 19010001 80380100 02DC4A01 0003905F 01000400 77010005 90910100 0650BD01 00070108 D04C0100 00008000 00000000 00448D01 00010000 00000000 0000DCC7 01000200 00000000 00000098 FC010003 00000000 00000000 D81B0200 04000000 00000000 00F44002 00050000 00000100 00001C64 02000600 00000001 00000068 81020007 00000000 01000000 000560EA 00000040 19010000 80380100 00DC4A01 0000905F 01000000 08286E00 00002CC9 000001F8 0B010002 80380100 03905F01 0004F491 010005D0 B0010006 38C10100 0700086C 39000000 245E0000 01FC8500 0002ACBC 00000334 D0000004 686E0100 05089701 0006B0AD 01000700 01683C01 00000104 3C410000 00000050 C3000000 00008038 01000200 00349801 00040000 01080098 85000040 B5000060 EA000050 C3000001 80BB0000 60EA0000 940B0100 50C30000 0200E100 00940B01 00401901 0050C300 000378FF 00004019 01008826 010050C3 00000440 19010080 38010080 38010050 C3000005 80380100 DC4A0100 DC4A0100 50C30000 06007701 00007701 00905F01 0050C300 00079091 01009091 01000077 010050C3 00000118 00000000 0000000B E412D007 24134B00 0A005403 90019001 90019001 90019001 90010000 00000002 04310790 01900190 01900100 00590069 004A004A 005F0073 00730064 00400090 92976096 00905500 00000000 00000000 00000000 00000000 0202D430 00000210 60EA0000 0210

 

 

or Text mode:

 

Quote

<key>PP_PhmSoftPowerPlayTable</key>
                <data>
                tgIIAQBcAOEGAADuKwAAGwBIAAAAgKkDAPBJAgCOAAgA
                AAAAAAAAAAAAAAAAAAIBXABPAkYClACeAb4AKAF6AIwA
                vAEAAAAAcgIAAJAAqAJtAUMBlwHwSQIAcQICAgAAAAAA
                AAgAAAAAAAAABQAHAAMABQAAAAAAAAABCIQDhAO2A+gD
                GgRMBGAEfgQBATMEAQGEAwAIYOoAAABAGQEAAYA4AQAC
                3EoBAAOQXwEABAB3AQAFkJEBAAZQvQEABwEI0EwBAAAA
                gAAAAAAAAESNAQABAAAAAAAAAADcxwEAAgAAAAAAAAAA
                mPwBAAMAAAAAAAAAANgbAgAEAAAAAAAAAAD0QAIABQAA
                AAABAAAAHGQCAAYAAAAAAQAAAGiBAgAHAAAAAAEAAAAA
                BWDqAAAAQBkBAACAOAEAANxKAQAAkF8BAAAACChuAAAA
                LMkAAAH4CwEAAoA4AQADkF8BAAT0kQEABdCwAQAGOMEB
                AAcACGw5AAAAJF4AAAH8hQAAAqy8AAADNNAAAARobgEA
                BQiXAQAGsK0BAAcAAWg8AQAAAQQ8QQAAAAAAUMMAAAAA
                AIA4AQACAAA0mAEABAAAAQgAmIUAAEC1AABg6gAAUMMA
                AAGAuwAAYOoAAJQLAQBQwwAAAgDhAACUCwEAQBkBAFDD
                AAADeP8AAEAZAQCIJgEAUMMAAARAGQEAgDgBAIA4AQBQ
                wwAABYA4AQDcSgEA3EoBAFDDAAAGAHcBAAB3AQCQXwEA
                UMMAAAeQkQEAkJEBAAB3AQBQwwAAARgAAAAAAAAAC+QS
                0AckE0sACgBUA5ABkAGQAZABkAGQAZABAAAAAAACBDEH
                kAGQAZABkAEAAFkAaQBKAEoAXwBzAHMAZABAAJCSl2CW
                AJBVAAAAAAAAAAAAAAAAAAAAAAACAtQwAAACEGDqAAAC
                EA==
                </data>

 

Edited by max.1974

Share this post


Link to post
Share on other sites
12 minutes ago, max.1974 said:

 

Hi my friend @Moviemakergr :thumbsup_anim:

 

Im use this kexts and works like charm, very good performance...im edit with okrasit values...codes...

 

AMD MOD HS 1642MHZ 1000 RPM.zip  High Sierra 10.13.6 (17G65)

 

AMD10000Controller.kext - Mojave beta 1 mod.zip Mojave beta 1 

 

Just modified / add only PP_PhmSoftPowerPlayTable on info.plist...:pirate:

 

 

 

or Text mode:

 

 

Are u platinum member, :star_smile:

Thanks bro..

Why u steel on High sierra and mojave beta 1 ?

Mojave works like charm ..

Share this post


Link to post
Share on other sites
50 minutes ago, Moviemakergr said:

Are u platinum member, :star_smile:

Thanks bro..

Why u steel on High sierra and mojave beta 1 ?

Mojave works like charm ..

 

So many thanks bro!! In my job I need some apps that works much better in High Sierra, like e-token to digital signature... this Mojave beta 1 is out after Mojave GM (first release 24 se t2018) ... Developer Program  :D :thanks_speechbubble:

 

https://www.insanelymac.com/forum/topic/334319-macos-1014-mojave-betas-dps/?do=findComment&comment=2638502

 

By the way... just out right now beta 2... use SWUSwitcher to set your Mac to receive news betas...:moil::rofl:

 

66130984_CapturadeTela2018-10-03s13_36_32.png.dcdfc26b4f4d748a7155127bb25713da.png

 

 

973013526_CapturadeTela2018-10-03s13_35_23.thumb.png.ffcdb6b4175c3f4f84942229c32d450b.png

 

 

 

SWUSwitcher.zip

Edited by max.1974

Share this post


Link to post
Share on other sites
14 minutes ago, max.1974 said:

 

So many thanks bro!! In my job I need some apps that works much better in Mojave... this Mojave beta 1 is out after Mojave GM (first release 24 se t2018) ... Developer Program  :D :thanks_speechbubble:

 

 

aaaa.. ok ,

Not working for me on 10.14 just loose Ql/Cl..

Thanks.

Share this post


Link to post
Share on other sites

Does anybody know the core and memory voltage of Sapphire NITRO+ Vega 64?

Currently, I'm able to get 30K score on LuxMark but the fan is running at 2k rpm constantly. 

If I have exact specs, I'd like to try variable fan speed control with VGTab-en.app.

 

Is anyone using Sapphire NITRO+ Vega 64 successfully?

 

 

 

 

 

Share this post


Link to post
Share on other sites
On 9/27/2018 at 10:24 PM, max.1974 said:

 

Its almost same BIOS my friend, so try this kext that im post. That gave me quiet fans, and good bench scores...

Back up your kext, install with Kext Utility, and run this command in Terminal after kext finish to install:

 

sudo touch /System/Library/Extensions && sudo kextcache -u /

 

Restart/Reboot...

Enjoy...:wink_anim:

 

MOD AMD 10000 10.14 GM.zip

 

PS: The VGTab-en.app to me is completely fake... kkkkkk  its a Joke for someone who created...not change the settings...doesnt matter what I do...

 

Look at this BIOS settings its for XFX...

 

https://www.techpowerup.com/vgabios/200858/200858 

 

 

 

 

Max,

 

Thanks for sharing this file. You saved my life. 

Even the graphics card is not the same as yours, it works charmingly so far. Mine is Sapphire RX Vega 64 Nitro+. 

 

BTW, can I ask what's the different setting between GM and Beta 1?

Share this post


Link to post
Share on other sites
6 hours ago, flyfree said:

Max,

 

Thanks for sharing this file. You saved my life. 

Even the graphics card is not the same as yours, it works charmingly so far. Mine is Sapphire RX Vega 64 Nitro+. 

 

BTW, can I ask what's the different setting between GM and Beta 1?

 

Hi my friend @flyfree sorry late, im was in travel at work!!!

 

So glad to help you. :D.. about the differences, About GM, im felling more performance in beta 1 or 2. But if the GM was nice for you, im think that you not need upgrade... a little bit more power and fan issue persist little bit too in betas 1 and 2... GM is good but, not so good (to me) for Amd10000controller.kext. First posts is better quiet and good scores. The last so more loud ... but im hang on... kkkkk :boxing:

 

You can change only PP_PhmSoftPowerPlayTable (copy and past in info.plist) in any kext AMD10000 version...works for all Vega RX 64 controller :guitar:

 

Good know that help you!!! :thumbsup_anim:   So enjoy my friend!!!

Many thanks !! 

 

:drool:

Edited by max.1974

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×