Jump to content

8 posts in this topic

Recommended Posts

Hello, i am in need of help.

I have a Lenovo Y520 i7 7700hq with working hd630 intel hd graphics.

I have only 2 things to make for the best hackintosh experience on this laptop:

-sleep(i will detail after)

-Backlight buttons

 

SLEEP: the laptop sleeps, but when i wake it, it wakes on login screen and reboots after 1 second. I know it's from the hd630, but it s there any solution? i can post a log or something if anyone can help!

BACKLIGHT BUTTONS: the problem is that backlight control works from display settings. but Brightness from keyboard doesn't work. it is there any way i can map the acpi buttons?

 

Thank you very much.

Share this post


Link to post
Share on other sites
Advertisement

BACKLIGHT BUTTONS: the problem is that backlight control works from display settings. but Brightness from keyboard doesn't work. it is there any way i can map the acpi buttons?

Try Fn+P and Fn+K

Share this post


Link to post
Share on other sites

ptcptc, i've recently bought that laptop, would you be so kind to post/send me your EFI/CLOVER folder (config.plist, kexts....) and tell me how do you enabled sound/trackpad etc successfully?

 

i can boot osx right now, with integrated graphics OK (not so difficult with lilu+intelgraphics) but no working sound, trackpad, sleep etc... i'm currently trying to patch DSDTs.

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Hello, i am in need of help.

I have a Lenovo Y520 i7 7700hq with working hd630 intel hd graphics.

I have only 2 things to make for the best hackintosh experience on this laptop:

-sleep(i will detail after)

-Backlight buttons

 

SLEEP: the laptop sleeps, but when i wake it, it wakes on login screen and reboots after 1 second. I know it's from the hd630, but it s there any solution? i can post a log or something if anyone can help!

BACKLIGHT BUTTONS: the problem is that backlight control works from display settings. but Brightness from keyboard doesn't work. it is there any way i can map the acpi buttons?

 

Thank you very much.

ptcptc, i've recently bought that laptop, would you be so kind to post/send me your EFI/CLOVER folder (config.plist, kexts....) and tell me how do you enabled sound/trackpad etc successfully?

 

i can boot osx right now, with integrated graphics OK (not so difficult with lilu+intelgraphics) but no working sound, trackpad, sleep etc... i'm currently trying to patch DSDTs.

 

Thanks in advance!

Share this post


Link to post
Share on other sites
The Lenovo Legion Y520 is working with Hackintoh?
Yup, but it' s a liitle bit difficult.


Sented by Tapatalk in my Android SM-G930S

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By jamesxxx1997
      Hi everyone~
      My machine is thinkpad x1 yoga 2018 , uhd620 , WQHD resolution , with macos 10.14.6 installed.
       
      My efi patch seems to have some problems related improper graphic patch.
      1. The screen sometimes have flickers , especially on safari browser.
      2. Sometimes kernel panic happens after wake from sleep , black screen then reboot.
      3. I cannot enable specific resolution(1920*1080) in hidpi , using hackintool or FixEDID+DarwinDumper
       
      Any help is appreciated , thanks~
       
       
       
      28525.zip
    • By plasticduck35
      I have a hackintosh running 10.13.5 (High Serria) that works except it doesn't shutdown properly and it doesn't seem to be going to sleep. 
       
      Here are some diagnostics that I gathered 
       
      Davids-MacBook-Air-2:~ davidozersky$ sudo pmset -g Password: System-wide power settings: Currently in use: hibernatemode 0 womp 0 networkoversleep 0 sleep 5 (sleep prevented by diskmanagementd, UserEventAgent, mds, diskarbitrationd, coreaudiod, mds_stores, Disk Utility) Sleep On Power Button 1 ttyskeepawake 1 hibernatefile /var/vm/sleepimage disksleep 10 displaysleep 5  
      And I've attached files from a RunMe utility app I've found online. 
       
       
      Any ideas? 
       
      Thank you, 
      David
      runmereport.ioreg
    • By WeBeRiO
      Hi all! I have a Asus h110s1 with a i5-7400 working.

      Only no wake up from sleep, screen black and reboot.

      Is posible fix this problem? No is model UHD.

      Thank U.-
×