Jump to content

440 posts in this topic

Recommended Posts

----------------------------------------------

 

A question for you, how do I install Nvidia web driver for Mac OS Sierra "standard" 10.12.5 on the new high Sierra beta?

Share this post


Link to post
Share on other sites
Advertisement
clover v4081

clover with 

 

<key>FirmwareFeatures</key>

<string>0xe907f537</string>

 

How to do this step help me

Share this post


Link to post
Share on other sites

 

clover v4081
clover with 
 
<key>FirmwareFeatures</key>
<string>0xe907f537</string>
 
How to do this step help me

 

You need to put it in your SMBIOS section

Share this post


Link to post
Share on other sites

ok, i will try the new clover when i can, is there an official download link?

did you set ff in smbios?

Share this post


Link to post
Share on other sites

did you set ff in smbios?

i have the version r4081 of clover that works just fine with the firmware features parameter in place, but i will try to see if the new version r4084 of clover works without that parameter in the smbios

Share this post


Link to post
Share on other sites

i have the version r4081 of clover that works just fine with the firmware features parameter in place, but i will try to see if the new version r4084 of clover works without that parameter in the smbios

no need firmware feature by using r4084...i am waiting for webdriver update

Share this post


Link to post
Share on other sites

no need firmware feature by using r4084...i am waiting for webdriver update

yes, i am waiting for the web drivers too, since i am using a gtx 960 in my machine, for clover i want to see with my eyes if it works, also some mine friend are telling me that on particular systems it is working fine, like x99 or kabylake (there is still the need to verify if now they works without particular fixes, since now at lest kabylake, should be supported by default), i will also do tests on my socket 775 machine to see how it runs on my core 2 duo e8400, because apple has not deprecated them yet, and probably, because the new iMac pro seems to use socket 2066, we will have support for x299 in this new version of mac os

Share this post


Link to post
Share on other sites

yes, i am waiting for the web drivers too, since i am using a gtx 960 in my machine, for clover i want to see with my eyes if it works, also some mine friend are telling me that on particular systems it is working fine, like x99 or kabylake (there is still the need to verify if now they works without particular fixes, since now at lest kabylake, should be supported by default), i will also do tests on my socket 775 machine to see how it runs on my core 2 duo e8400, because apple has not deprecated them yet, and probably, because the new iMac pro seems to use socket 2066, we will have support for x299 in this new version of mac os

i also use gtx960..but i have not installed high sierra..i am not sure if setting firmware feature by using r4084

Share this post


Link to post
Share on other sites

i also use gtx960..but i have not installed high sierra..i am not sure if setting firmware feature by using r4084

first try without it then try with it if without doesn't works

Share this post


Link to post
Share on other sites

I still can't get it to work. I can get past the installer but during the second install phase it always fails at verifying the firmware. I tried using the recovery partition to apply the patched prelinked kernel but DiskUtil doesn't see the hidden install partition that my computer boots from for the second install. I even tried doing single user mode so I could copy the file from there but a) the partition doesn't see the .IABootFiles folder and B) it doesn't do anything if I copy the patched prelinkedkernel to /System/Library/PreLinkedKernel/prelinkedkernel. Any suggestions?

 

Edit: Basicially it looks like when the second install starts, it mounts the Base System.dmg located in my /macOS Install Data/BaseSystem.dmg which is read-only. That directory has no .IABootFiles directory which is why I can't find it when I boot using Single User mode. There must be another way to inject the patched kernel.

 

are you using a fusion drive?

Share this post


Link to post
Share on other sites

update: installing without the usb key, just with the app and then booting the installer from the target partition worked for me with the new clover version and by replacing the kernel cache

Share this post


Link to post
Share on other sites

Ok so I am on Clover r4084 and copied the apfs to drivers64uefi but I can not get past the second install with the same unable to verify the firmware error message. I didn't add the firmware features info to SMBIOS because people said on r4084 you don't need that and from reading these comments, isn't that just for APFS? Please help.

Share this post


Link to post
Share on other sites

Ok so I am on Clover r4084 and copied the apfs to drivers64uefi but I can not get past the second install with the same unable to verify the firmware error message. I didn't add the firmware features info to SMBIOS because people said on r4084 you don't need that and from reading these comments, isn't that just for APFS? Please help.

no, it works for me, but i am using firmware features, i think you should use that

Share this post


Link to post
Share on other sites

@Andrw0380...oh..need ff in r4084?


no, it works for me, but i am using firmware features, i think you should use that

add  firmware features of   0xe907f537?

Share this post


Link to post
Share on other sites

Having problems - duh, why else would I be posting. I have no idea what I am doing, apparently...
 

I have Clover 4084 installed on my 10.12.6 system. 

I have a fusion drive with 10.12.6 installed. I am a dev and downloaded the 10.13 beta from the site. I have another pair of drives I would like to make into a High Sierra fusion drive.
 

I have tried a USB method to install on the new HD - 

I have tried launching the App from my 10.12.6 system and installing on the new HD.

I have tried launching the App from my 10.12.6 system and installing on the new SSD.

I have tried making a fusion drive with the new HD and SSD and installing via launching the app on 10.12.6

I have tried enabling APFS and not.
I have tried formatting with case sensitive and not case sensitive Journaled HFS with GUID partition.
I have tried installing Clover before, at each step and after install 10.13 on the various targets.
I have added apfs.efi into drivers64UEFI (and driversx64UEFI - although I expect that was a typo in the posts mentioning that spelling).
I have removed apfs.efi from the clover install.
I have tried enabling convert to apfs in the installer, and not enabling the conversion.

I am pulling my hair out, and I am certain I am doing something very STUPID, but...

(Edited: Changed version of Clover to 4084)

Clover 4084 (booted from my 10.12.6 install) does not recognize the target drive (in any of the above installs/configurations) as bootable, and does not list it as an option on the clover boot screen, only my 10.12.6 drive is listed. My BIOS can see the drive, but if I remove all the other drives it is not bootable, it is just seen as existing by BIOS. In MacOS 10.12.6 the target drive is not displayed in the "Startup disk" option in preferences.

Can someone point me in the right direction? What am I doing or not doing?

Share this post


Link to post
Share on other sites

no, it works for me, but i am using firmware features, i think you should use that

 

 

@Andrw0380...oh..need ff in r4084?

add  firmware features of   0xe907f537?

Thanks I will try later on today as I have work. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      Install MacOS with Olarila Image, Step by Step, Install and Post Install  
      https://www.olarila.com/topic/5794-hackintosh-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Paste my EFI folder into EFI partition  EFI GA H110M-S2.zip     --Install Sierra/High Sierra and boot into system!   Post Installation   --Paste my EFI folder into EFI partition  EFI GA H110M-S2.zip     --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.GA H110M-S2.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By cixque
      CLOVER.zipCLOVER.zipDell Venue 11 Pro 7140
      ------------
      Specification
       
       
      Intel Core M 5Y71
       
      Intel HD Graphics 5300
       
      Intel Broadwell-U motherboard
       
      8GB Ram
       
      256GB SSD
       
      Dell DW1850e WWAN + GNSS GPS
       
      Intel Wireless 7265 + Intel Bluetooth
       
      NFC
       
       
      …..
       
       
       
       
       
      Mojave 10.14.6
       
      What works
      Native Power Manager (Generate Plugin type) Full Graphics with QE/CL Brightness (Add PNLF in Config.plist or DSDT Patch) — (Brightness slide bar) Touch Screen, and Pen (DSDT Patch + Voodoo I2C, I2CHID satellite KEXT) HDMI output with hot plug (Lilu + WhateverGreen) HDMI Audio with hot plug (Lilu + AppleALC) no Layout-id needed Front and Rear Cameras MicroSD slot - O2 Micro (I use Adding Arbitrary under Devices in Config file Method) Ref, Post #6 by Jake Jo https://osxlatitude.com/forums/topic/7346-applesdxc-driverdsdt-patch-for-o2-micro-sd-card-readers/ Battery Indicator (ACPIbattery by Rehabman) ——>To utilise both battery, SSDT (by Rehabman) is needed in order to combine 2 batteries as one.
      Travel Keyboard Dell K12a001 (USBinjectall KEXT) Native Keyboard keys (Brightness, volume keys) WWAN card Dell DW1850e (OOB) Bluetooth -------------------
       
      What doesn’t work
       
       
      Sleep Wake — I have no idea how to fix it as it is required DSDT patch I guess. GPS NFC Audio ---> Realtek I2S Audio (PG0.35 for DELL)
       
      In DSDT entries is HDAUDIO\\FUNC_01&VEN_10EC&DEV_0282&SUBSYS_00000000&REV_1000\ Which indicates ALC282
       
      Audio ALC3263 (As it shown in BIOS) - Broadwell rt286 - Card1/Codec#0 (Utilised in I2S Mode) there is nowhere in BIOS to change to HDA mode). Drop OEM HDA and Fix HDA don’t do anything, still show 3 HDMI Audio outputs. If there is a DSDT patch to force HDA Audio mode, Please do enlighten me.
      As a result Internal Speaker, Internal Mic, and Headphone Jack doesn’t work.
       
      Touchpad on Travel Keyboard Dell K12a001 (Should work with DSDT Patch with pin configuration) I have no idea how. Obviously, Intel Wireless 7265 AC. For experimental purpose. https://github.com/daliansky/XiaoMi-Pro-Hackintosh/issues/330 — Knock yourself out. I managed to get it work for awhile but the real problem is kernel panic so I gave up. Ordering compatible card instead. ------------------
       
      Config.plist got it from Rehabman laptop config.
       
       
      BIOS version A20
       
      Enable:
       
      - Legacy Boot Rom
       
      Disable:
       
      - Secure Boot
       
      - TPM 2.0
       
      - Vt-d
       
      ------------
       
      SMBIOS - I use MacBook8,1. —- MacBookAir7,1-7,2 (Min Freq is at 1.2 GHz) MacBookPro12,1 Min Freq is at 800 Mhz and it is the default this cpu should be. Again, there is a way to set it right somewhere in this forum.
       
      ------------
       
      -->> DSDT Windows 8 patch
       
      System sees only one I2C Controller which control Touch Screen.
      Touch Screen registers as Magic Trackpad 2.
      Pen as Mouse
       
      -->> DSDT Windows 8.1 Patch
       
      System sees two I2C Controllers which control Touch Screen and Accelerometer.
      Touch Screen registers as Magic Trackpad 2.
      Pen as Mouse
       
      OOO>>> With Windows 8.1 patch which it should run with this one because it can see more of HID devices and controllers.
       
      Problem is Accelerometer (SHUB).
      Device can automatically rotate screen as it should be BUT it flips the screen wildly even with slightly movement. It stops only when device stays completely still. Eventually it breaks internal screen graphic. It becomes grabble. I restored internal screen graphic by connecting it to external monitor and set rotation of external screen to 0 degree. Then it is back to normal. (I guess it conflict with rotation setting) I disable SHUB in DSDT.
       
      ---------------------
       
      During Installation process Full Graphic acceleration can be activated straight away by Lilu and Whatevergreen. AppStore, iMessage and, FaceTime activate by NullEthernet and SSDT by Rehabman USBInjectAll needed for keyboard and other usb peripherals. Use other tool to keep certain ports active as Rehabman mention this KEXT is not good for a long run. Please do Correct me if I did something worng. Or any suggestions to make this thing runs better.
      CLOVER.zip
      IOReg_SysReport.zip
    • By Simon's InsaneMac
      Hi, I'm kind of lost when scrolling to Clover Configurator, so I decided to use an EFI from the web and just configure the most basic stuff. But that sadly didn't work, im always getting the attached screen IMG_0054.HEIC (and I don't know whether all the errors are listed, as I can't scroll). 
      Anyways I thought it'd be better to do a custom setup. Can anyone give me some help with what to choose in the settings? Here's my rig:
      i7 8700k
      Asus z370-G (Rog Strix)
      gtx 1060 6gb
      samsung ssd (SATA)
      WD hard drive
       
      Your help would be much appreciated!
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Pro and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Pro, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware using Catalina 10.15.3
       
      CPU's
      8700k, 9600k, 9700k, 9900k
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install.
       
       
      HARDWARE USED
      • Intel I9 9900k 
      • Gigabyte AORUS Z390 PRO
      • Sapphire Nitro+ SE Vega56 (connected to monitor with DisplayPort)
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit. 
      • CoolerMaster MASTERLIQUID ML360R RGB CPU Cooler
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       

       
       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar
       
       
      CLOVER  FOLDER
      Use this folder with fully patched DSDT
      Current EFI 
      Updated 26/03/2020
      PLEASE NOTE - You MUST update to the latest EFI before updating to 10.15.4 or you may find your unable to update.
       
      Clover EFI Update - 26/03/2020 - Use with Bios revision F12d Only or Replace with the older F11 DSDT if you don't want to update the bios
      Clover Z390 Pro Vega Navi EFI 260320.zip - Vega, Navi (5700, 5700XT), Radeon VII DSDT EFI
      Clover Z390 Pro Polaris EFI 260320.zip - R5XX Polaris DSDT EFI
       
       
      PLEASE NOTE - Please flash your motherboard bios to revision F12d to use my current EFI. It’s a major rework of the bios and vital changes have been made to the layout and power tables. New DSDTs have been created and installed into the new EFI’s but will not work correctly with any other bios revision.
       
       
      Latest Gigabyte Z390 PRO BIOS (F12d)
      mb_bios_z390-aorus-pro_f12d.zip
       
       
      CFG Unlock (MSR) F12d BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      DSDT's & Older EFI’s (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      Alternative EFI - N-D-K Fork of OpenCore (05/03/2019)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      Clover
      Clover Configurator
      Kext Updater
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      FakeSMC    (Can be used instead of VirtualSMC)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F12d)
      • Enter BIOS → Press F12 → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Disabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup 
       
       
      SCREENSHOTS

       
       

       

       

       

       

       

       

       

       

       

       
       
       
×