Jump to content

440 posts in this topic

Recommended Posts

 

 

defaults write com.apple.finder AppleShowAllFiles NO

 

You don't have to do this in Sierra anymore. Just hit CMD + SHIFT + . (Dot) in any Finder window to switch instantly. 

 

Topic related updates about apfs.efi: 

 

http://enterprisemac.bruienne.com/2017-02-27-apfs-boot-quickpost/

https://twitter.com/TylerLoch/status/834096046800257024

Share this post


Link to post
Share on other sites
Advertisement

Please someone update to 10.13 with AFPS or without it, maybe it's okay without updating the clover ?!

I downloaded the 10.13 but I don't know update it or not!


I've another question, did apple fix the notification center background color when the dark menu and dock is enabled is white either ?!

I wanted it to be like 10.11, when it was black :)

Share this post


Link to post
Share on other sites

I did not follow this tutorial, but I was stuck at the same point. I went back to language chooser and continued and it worked. Sometimes it takes a little time to load up I guess

 

I too was stuck at this point and after following this advice, I was able to proceed with my installation.

 

When you try to do the second step of the installation process, do not boot form the installation volume yet, you have to use anther working copy of Mac OS to cange the prelinked kernel in .IABootFiles on the target installation volume, so you can boot to it and continue with tìinstallation.

 

When unhiding all files after completing the 1st part of the installation, I could not locate a IABootFiles folder on my target volume.

Share this post


Link to post
Share on other sites

i got in the installer on my hp Probook 4530s but it disk utility just sits on loading..nothing more and its laggy as heck and my wifi nor ps2 kexts'll work.

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

I too was stuck at this point and after following this advice, I was able to proceed with my installation.

 

When unhiding all files after completing the 1st part of the installation, I could not locate a IABootFiles folder on my target volume.

yes I am experimenting too, the guide will be updated

Share this post


Link to post
Share on other sites

I still can't get it to work. I can get past the installer but during the second install phase it always fails at verifying the firmware. I tried using the recovery partition to apply the patched prelinked kernel but DiskUtil doesn't see the hidden install partition that my computer boots from for the second install. I even tried doing single user mode so I could copy the file from there but a) the partition doesn't see the .IABootFiles folder and B) it doesn't do anything if I copy the patched prelinkedkernel to /System/Library/PreLinkedKernel/prelinkedkernel. Any suggestions?

 

Edit: Basicially it looks like when the second install starts, it mounts the Base System.dmg located in my /macOS Install Data/BaseSystem.dmg which is read-only. That directory has no .IABootFiles directory which is why I can't find it when I boot using Single User mode. There must be another way to inject the patched kernel.

Share this post


Link to post
Share on other sites

Im install from my hard drive too, but after 2 minutes just shutdown !! 

Some light about it?

 

Tks for everything!!!

Share this post


Link to post
Share on other sites

For today I gave up. I basically tried everything. I can not make my pendrive boot. I updated the Clover to 4081, I used this http://www.insanelymac.com/forum/topic/284656-clover-general-discussion/page-657?do=findComment&comment=2436885

I updated both the pendrive and the HDD. I tried using igpu, but I did not succeed. Now I tried using nv_disable = 1 and stopped on a gray screen with a small US flag at the top. http://i.imgur.com/W2OEOD5.jpg

I honestly do not know what's wrong so I'll expect to come up some other way before trying again. 

Share this post


Link to post
Share on other sites
Does anyone know what error this is, and can you help me?
I already installed "Clover_v2.4k_r4081.pkg", it already replaces the "prelinkedkernel", but I can not get out of that part.
 

 

Share this post


Link to post
Share on other sites

from a working hackintosh(10.12.5) to a clean SSD

im installing from the DL image  macOS 10.13 Beta

 

1) Download developer profile (free) LINK

2) Open terminal 

sudo /System/Library/PrivateFrameworks/Seeding.framework/Versions/A/Resources/seedutil enroll DeveloperSeed

3) Paste command and give password

4) macappstores://itunes.apple.com/app/id1209167288 open this link in safari

5) Click Download

 

 

 

after DL  image in applications

 

 

open with show package Content

 

Applications/Install  macOS 10.13 Beta

open Contents

open SharedSupport

open InstallESD.dmg. skip verify

open Packages

open Core

 

its installing now on SSD Mac OS Extended (Journaled)

after install i boot with working SSD 10.12.5 and i install a recent Fakesmc.kext on SSD 10.13

Mac OS 10.13 beta is booting with clover imac14,2 from SSD 10.12.5 and some boot options

 

only video Nvidia GT 740 is not going further with webdrivers working

 

all is going fast and smooth with clover 3974

only video now

Share this post


Link to post
Share on other sites

Open Core?

Within InstallESD.dmg there's a folder named packages. There's an installer package named Core.pkg

 

post-1502423-0-73626400-1496831854_thumb.png

Share this post


Link to post
Share on other sites

Core is what you clicked to install it? Cause you said to open core

click core

Share this post


Link to post
Share on other sites

I have created an USB Stick by "sudo /Applications/Install\ macOS\ 10.13\ beta.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ 10.13\ beta.app --noiteraction" and Clover r4081 is on it. I added "apfs.efi" in UEFI64 driver folder and "fakesmc.kext" (April Version) to /Kexts/Other/...

 

Reaching Setup works. But when I open Disk Utility it's just spinnig up forever an showas no Disks. I was able, by open terminal and do "diskutil list" to show up my disks in Disk Utility. After a very long time. But thats all. I can't delete my Disk. Install is not working either.

 

Any Idea?

Share this post


Link to post
Share on other sites

Hi all. I grabbed a copy of 10.13 and I created a USB installer with Terminal + Clover. With clover version r4077 I had a kernel panic but r4081 fixed this issue. However, now it hangs here like FakeSMC isn't loading. Any ideas?

post-1096856-0-71793900-1496846306_thumb.jpg

post-1096856-0-26422900-1496846314_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Simon's InsaneMac
      Hi, I'm kind of lost when scrolling to Clover Configurator, so I decided to use an EFI from the web and just configure the most basic stuff. But that sadly didn't work, im always getting the attached screen IMG_0054.HEIC (and I don't know whether all the errors are listed, as I can't scroll). 
      Anyways I thought it'd be better to do a custom setup. Can anyone give me some help with what to choose in the settings? Here's my rig:
      i7 8700k
      Asus z370-G (Rog Strix)
      gtx 1060 6gb
      samsung ssd (SATA)
      WD hard drive
       
      Your help would be much appreciated!
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Pro and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Pro, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware using Catalina 10.15.3
       
      CPU's
      8700k, 9600k, 9700k, 9900k
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install.
       
       
      HARDWARE USED
      • Intel I9 9900k 
      • Gigabyte AORUS Z390 PRO
      • Sapphire Nitro+ SE Vega56 (connected to monitor with DisplayPort)
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit. 
      • CoolerMaster MASTERLIQUID ML360R RGB CPU Cooler
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       

       
       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar
       
       
      CLOVER  FOLDER
      Use this folder with fully patched DSDT
      Current EFI 
      Updated 26/03/2020
      PLEASE NOTE - You MUST update to the latest EFI before updating to 10.15.4 or you may find your unable to update.
       
      Clover EFI Update - 26/03/2020 - Use with Bios revision F12d Only or Replace with the older F11 DSDT if you don't want to update the bios
      Clover Z390 Pro Vega Navi EFI 260320.zip - Vega, Navi (5700, 5700XT), Radeon VII DSDT EFI
      Clover Z390 Pro Polaris EFI 260320.zip - R5XX Polaris DSDT EFI
       
       
      PLEASE NOTE - Please flash your motherboard bios to revision F12d to use my current EFI. It’s a major rework of the bios and vital changes have been made to the layout and power tables. New DSDTs have been created and installed into the new EFI’s but will not work correctly with any other bios revision.
       
       
      Latest Gigabyte Z390 PRO BIOS (F12d)
      mb_bios_z390-aorus-pro_f12d.zip
       
       
      CFG Unlock (MSR) F12d BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      DSDT's & Older EFI’s (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      Alternative EFI - N-D-K Fork of OpenCore (05/03/2019)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      Clover
      Clover Configurator
      Kext Updater
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      FakeSMC    (Can be used instead of VirtualSMC)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F12d)
      • Enter BIOS → Press F12 → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Disabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup 
       
       
      SCREENSHOTS

       
       

       

       

       

       

       

       

       

       

       

       
       
       
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Master and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Master using bios revision F11c, 9900k with a 5700 XT but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8600K, 8700, 8700K, 9600K, 9700K, 9900K, 9900KS
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install. (glasgood put the guide together for the Z390 Pro but the two boards are so alike that you can follow this guide with no problems at all using the Z390 Master)
       
       
      HARDWARE USED
      • Intel I9 9900k @5.2Ghz
      • Gigabyte AORUS Z390 MASTER
      • Sapphire Reference RX 5700 XT ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 32GB @3600mhz (2 x 16GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • EK Custom Liquid Cooling Loop
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar (only works using the iMac19,1 EFI and with your igpu Enabled)

       
      EFI FOLDERS  
      please note - You must flash your Z390 MASTER bios to revision F11c to use any of these EFI's, The DSDT is not designed for any other Bios revision
      mb_bios_z390-aorus-master_f11c.zip - Aorus Z390 Master Bios F11c 
       
      Current EFIs 
      Updated 26/03/2020
      PLEASE NOTE - You MUST update to the latest Clover EFI before updating to 10.15.4 or you may find your unable to update.
       
      Clover EFI Updated 26/03/20 - Use with Bios revision F11c Only or Replace with the older F10 DSDT if you don't want to update the bios
      Clover Z390 Master Vega Navi EFI 260320.zip - Vega, Navi (5700, 5700XT), Radeon VII DSDT EFI
      Clover Z390 Master Polaris EFI 260320.zip - R5XX Polaris DSDT EFI
       
       
      CFG Unlock (MSR) F11c BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      ADDITIONAL DSDT's & Older EFI’s (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      Alternative EFI - OpenCore No DSDT and Done the way OpenCore intended it (03/03/2020)
       

      Alternative EFI 2 - N-D-K Fork of OpenCore (03/03/2020)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      mb_bios_z390-aorus-master_f10
      Clover
      Clover Configurator
      Kext Updater
      RepairPermissions
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F11C)
       
      • Enter BIOS → Press Delete → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Win 8/10WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Wifi -> Disabled
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Disabled
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS

       
       

       

       

       

       

       

       

    • By Rohan20
      Opencore is running really really slow on Catalina 10.15.4. So It was running perfectly before I put the ssdt-pnlf for enabling Brightness control. it is running really slow and I verified my config with the sanity checker and its all correct. can someone please help. I am attaching my oc folder.

       
      https://www.dropbox.com/s/drkek0eaz19ina5/OC.zip?dl=0
       
    • By tlefko
      Description
      This esentially an ultra-simplistic version that is stable without the use of a deploy or complicated file installations and copies. Highly recommend using DW1560 wifi card, killer wifi isn't supported. This does include a copy of Clover, which of course I take no credit for. I am only responsible for minor changes in files and plists, as well as placement and instructions throughout the guide (as well as the work used from previous projects). Many files and ideas are sourced from @maz-1, @syscl, and my previous guides Granted, many files are similar or the same but there is significantly less of them and/or they are predeployed into spots where they will work just as well, even if not as efficient on bootup. Esentially, this guide is designed to provide a perfectly working setup with little knowledge of the topic and without optimization (because often they can break things). Most patches on the main plist use patches implemented by him as well. ****This guide does work excellently however and will provide you with a near perfect setup for Catalina for your XPS 9350, and is currently my daily driver as I struggled using the referenced users files as well.
      Styling
      This guide is designed to be literally as thorough as possible to appeal to those who really don't understand many of the things in @maz-1's guide or some of the other users as they assume you would already understand this information. It does not cover complex topics like undervolting etc etc Notes
      Never tested USB C except for charging, works great no issues with sleep, wakeup. power management is defaulted as I found with @maz-1 it had issues when on battery switching from AC USB devices eject on sleep (not really an issue) Haven't implemented a Bluetooth solution into this yet, as I don't really use it -- will be added ASAP (I believe KILLER WIFI will NOT work, must use one of the supported chipsets (DW1560 is excellent) BIOS Setup
      Set all SATA operation as AHCI Disable Secure Boot, Fast Boot For Coil Whine improvement disable C-States Enable UEFI Booting Recommended: Clean Install (Preinstall steps)
      Format a USB (16GB) as Journaled and then proceed to download the latest Catalina Installer Patcher Application Download the latest Catalina installer from within the Patcher App, and select to download a new copy and install to your USB device Download the clover configurator application and mount the EFI of the USB partition, then copy the contents of the Files linked above to the EFI Folder within the EFI partition. ** This is because the App Store installers will often not download a full installer, just an truncated version that downloads the installer files from the interent while installing. Thus, they're not bootable from a USB as they're not complete. That is why you should use this method to make sure the installer is usable for bootable media.
      Install Steps
      Simply use F12 to boot from the USB device, and select the USB Device and then boot from the Install mac OS partition. I have defaulted the installer to boot into verbose mode so I can easily see the errors you guys are seeing if you encounter them. If everything goes well, you can disable these from the boot arguments selection of Clover Configurator Boot into the USB Device, and follow the steps to format your SSD from the installer to install Mac OS Catalina. NOTE THE TRACKPAD WILL NOT FUNCTION AT THIS POINT, BUT THE TOUCHSCREEN WILL. This is caused by the way the installer handles Kext loading but because the touchscreen is being loaded via usb and the keyboard in a different method (which I can explain in detail if you'd like, the install will be possible. Do not be alarmed if the installer takes a long time to boot into, this is expected Once you have done this step, use F12 to select the USB and boot into the installer from the SSD in the options menu. (you cannot boot natively yet as the EFI isn't copied into the SSD yet. Setup computer as normal, touchpad, brightness, etc, should all be functioning at this point. Same with wifi. Then, you should using Clover configurator copy the contents of the USB EFI into the EFI folder of your SSD EFI partition (in the folder) Now we will add this as a native boot option. Setup computer as normal, touchpad, brightness, etc, should all be functioning at this point. Same with wifi. Then, you should using Clover configurator copy the contents of the USB EFI into the EFI folder of your SSD EFI partition (in the folder) Now will we add this as a boot entry so you can always boot from this natively without the USB. Boot Entry Setup
      Boot into the BIOS of the computer, then navigate to the Boot setup (or entries (not sure what it is called exactly, but it will be a list of the options your computer selects to boot) Click add new, and make sure the USB isn't plugged in. Select the only option that is avaiable, and in FS0 navigate to Boot/BOOTx64. Add this as an entry, then select this as whatever priority you would like. Credits
      Credit Hackintosher.com for basic patches (although @syscl) covered some Credit to @Rehabman Credit to @syscl Kexts, and his contributers (@maz-1) Messages and Facetime
      Using Clover Configuator generate your own Serials, Board Numbers, MLB There are various guides online to do this and as default they're set to essentially Null (Fakeserial) This is fairly straightforward and there is lots of documentation, just don't open these apps until you've done this properly. Finished!
      Congratulations, there really aren't any more steps that are required. Feel free to contact me with any questions. Files can be downloaded here, and issues and help requests can be said here or opened into the GitHub page. Please @ me for a faster response on this page, as I am not that attentive, also, feel free to PM me.  Github: https://github.com/tlefko/XPS13-9350-Catalina Thanks for reading! Files.zip
×