Jump to content

440 posts in this topic

Recommended Posts

Now shows Clover version 4106 on that Chinese language site, linked previously.

If the program was written by English speaking authors, shouldn't there be an English language site for these latest builds, even if they're "unofficial"?

A "Clover beta build blog", or something like that?

Share this post


Link to post
Share on other sites
Advertisement

What did you install after core.pkg?

I just installed clover but on rebooting there was no hdd in the boot menu. I made it active and bootable in Mac terminal but was still not showing in boot menu after rebooting again

Share this post


Link to post
Share on other sites

I just installed clover but on rebooting there was no hdd in the boot menu. I made it active and bootable in Mac terminal but was still not showing in boot menu after rebooting again

Have you copied boot.efi to CoreServices?

 

Sent from my XT1060 using Tapatalk

Share this post


Link to post
Share on other sites

I just installed clover but on rebooting there was no hdd in the boot menu. I made it active and bootable in Mac terminal but was still not showing in boot menu after rebooting again

You need to add a file to the /System/Library/CoreServices/ called boot.efi on the install you are trying to boot from. This had me stumped for quite a while. You can get a copy of the file from any working system. 

Share this post


Link to post
Share on other sites

Just in case it helps someone, (X99 with 5960x, R9 Nano and Quadro K2000 helper)

I'm booting to 10.12 on the 960 evo and 10.13 on the 850 evo with the same EFI.

No graphics acceleration in 10.13.

 

I used the latest clover 4084.

Removed VoodooTSCSync.kext and NullCPUPowerManagement.kext to make it boot.

The nvme hacked kext is in s/l/e on the 10.12 so not used in 10.13, although I can see the 960 evo in 10.13.

I have 2 kext folders in clover - 10.12 and 10.13 which are identical except for the 2 above kexts.

 

I'm no programming geek, but it sort of looks like AMDRadeonX4500HWServices.kext which is the accelerator for the Nano, is not functional. They might not have tested it yet.

The purpose of this for me was really to get an EFI that works for 10.12 and 10.13 anyway, so that I can install high sierra later, when it's finished.

 

It was a completely vanilla install with no new kexts in 10.13 s/l/e, install over 10.12.3 from the desktop with a double click. Little Snitch is the only software that won't work.

 

 

Are you changing your CPUID on your config?

Share this post


Link to post
Share on other sites

Hi, my install its very simple, im think the Clover arguments is the "secret".

 

Im using many arguments, and I can install High Sierra in APFS so easy.

 

Im finally get terminal command work and make a usb.

 

25/06/2017 - Edit: Using Clover 4097 now!! So please, don't forget to delete "other" folder in EFI/CLOVER/kexts

hi.friend.why to delete "other" folder in EFI/CLOVER/kexts

Share this post


Link to post
Share on other sites

my thinkpad w530 run sierra 12.6 smoothly.. and enable nivida 1000m through dsdt...but it goes greay screen after first progress bar finishes...what is wrong?

Share this post


Link to post
Share on other sites

hi.friend.why to delete "other" folder in EFI/CLOVER/kexts

 

Hi xtddd, in another post, a great advanced user to this forum, @artur_pt said to me for deleted because the last build of Clover is already for 10.13, and caches maybe cause Kernel Panic. Its in Portuguese but you can check here: http://www.insanelymac.com/forum/topic/324222-macos-1013-betas-dps-disponiveis/?p=2450603 

 

But im using other only to put ALC kext because to me resolved conflict audio with Sierra install in another partition. 

 

Best Regards!! 

Share this post


Link to post
Share on other sites

You need to add a file to the /System/Library/CoreServices/ called boot.efi on the install you are trying to boot from. This had me stumped for quite a while. You can get a copy

of the file from any working system.

Thanks guys that worked great

Share this post


Link to post
Share on other sites

I have successfully got 10.13 installed on the following MSI Z270 Gaming M5, i7-7700k, Samsung 960 EVO NVMe M.2 SSD (direct install), EVGA GeForce 1080 TI. I had many issues like having to use an old usb2 hub to get past "waiting on root device". I have not put the final touches on the machine so there are a few things that still do not work:

 

Nvida wed drivers not installed so I can't adjust the graphics

Bluetooth shows to work but not detecting anything

iMessages

Mail

Sound

AirDrop (not sure if this is because a BlueTooth issue)

I have not tested out other features yet. 

 

The install fails when the disk was formatted using AFS - I had to use the older HFS.  I did not try converting to AFS during the install. 

 

I am using this BlueTooth / Wi-Fi card

 

Currently I can only boot from the Clover on USB into the harddrive. 

Share this post


Link to post
Share on other sites

I see Apple Developer 10.13 Beta 3 is available. I think I am holding off until I see some success comments and how - either App Store or HandyScripts.

EDIT: OKay, I HATE waiting, so I edited the script myself - If you are using the developer seed, duplicate the install_1013_DP2_17A291m.sh script rename it install_1013_17A306f.sh and then change line 106 to read: key="091-21707".

Running the script when it finishes it will report failure. Restart your computer and DO NOT interrupt it during the restart. My went black for about 15 minutes (cursor still responding). I waited until all disk activity ceased. Then reset the computer. Booted from Clover, and it restarted itself once. Then everything is fine. 

 

Very nervous making. I hope this updating becomes a little smoother.

 

 

 

post-1378633-0-57323300-1499777567_thumb.png

Share this post


Link to post
Share on other sites

Are you changing your CPUID on your config?

Hi, sorry for the late reply.

No. I'm using the same config.plist for both. Although it does give me some weird unknown CPU thing, but it still runs with speedsteps and overclocking. Same benchmarks etc.

Share this post


Link to post
Share on other sites

This is not looking good for me. Dev beta 3 appears to be installed okay, but I am getting very high CPU usage frequently and occasional random crashes - mostly when interacting with Safari, but that could just be coincidence. I think it has to do with the high CPU usage I am seeing. 

Anyone else have beta 3 install and seeing the same problem? Or is this just me (I hope so!)

 

TIA,

Frank

Share this post


Link to post
Share on other sites

This is not looking good for me. Dev beta 3 appears to be installed okay, but I am getting very high CPU usage frequently and occasional random crashes - mostly when interacting with Safari, but that could just be coincidence. I think it has to do with the high CPU usage I am seeing. 

 

Anyone else have beta 3 install and seeing the same problem? Or is this just me (I hope so!)

 

TIA,

Frank

 

I have noticed some Safari bugs and crashes, but power seems good.    Skylake i5 6500, RX 480 with HDMI Audio.    Heres a before update and after.

post-1753549-0-49826200-1499821832_thumb.png

post-1753549-0-83064400-1499821861_thumb.png

Share this post


Link to post
Share on other sites

No reboot for me, just freeze up and I close it open it up again and its good.    It doesn't get a crash report error, it just freezes up or slows so bad I have to close it.    

 

Are you using HFS or APFS?

Share this post


Link to post
Share on other sites

I see Apple Developer 10.13 Beta 3 is available. I think I am holding off until I see some success comments and how - either App Store or HandyScripts.

 

EDIT: OKay, I HATE waiting, so I edited the script myself - If you are using the developer seed, duplicate the install_1013_DP2_17A291m.sh script rename it install_1013_17A306f.sh and then change line 106 to read: key="091-21707".

 

Running the script when it finishes it will report failure. Restart your computer and DO NOT interrupt it during the restart. My went black for about 15 minutes (cursor still responding). I waited until all disk activity ceased. Then reset the computer. Booted from Clover, and it restarted itself once. Then everything is fine.

 

Very nervous making. I hope this updating becomes a little smoother.

Can u pass the script

 

Sent from my XT1562 using Tapatalk

Share this post


Link to post
Share on other sites

Dec_Brain, Here is the modified script. I do not  know if this will work for everyone, and for me it says it failed after the installation, but then rebooting works and it shows the correct build for beta 3 - use at your own risk.

This site would not let me upload a .sh file, so I changed the file type to .txt, in order to use it you will need to change the file type to .sh or copy and paste the contents into a terminal window.

 

Frank


No reboot for me, just freeze up and I close it open it up again and its good.    It doesn't get a crash report error, it just freezes up or slows so bad I have to close it.    

 

Are you using HFS or APFS?

I am running HFS Fusion drive (250 gb SSD and 1 TB HD), I tried APFS and had problems with TimeMachine, so I reinstalled with HFS and have had no problems with that now.

install_1013_DP2_17A306f.txt

Share this post


Link to post
Share on other sites

I have been using Chrome instead of Safari for an hour now with no problems. We will see if that is the issue in Beta 3!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By RogerDodger93
      Salve a tutti ragazzi,
      Mi sono appena iscritto e innanzi tutto vorrei esprimere la mia gratitudine per l'aiuto offerto. Il mio problema come da titolo riguarda il mio Pavilion Power 15 più precisamente il modello cb015nl. Ho notato che c'era un altro topic su un modello simile ma immagino che anche se i modelli sono simili non è detto che siano compatibili quindi ne ho creato uno per il mio modello. Per arrivare al dunque, sono riuscito ad installare con successo Mojave 10.14 ma ho riscontrato diversi problemi una volta avviato l'OS. Quello che non riesco a far funzionare è l'indicatore della batteria, il power managment (Stop non funziona e la luminosità), la porta ethernet e credo che la scheda wifi sia incompatibile, le gesture del trackpad, e l'audio che con una scheda audio esterna funziona a meraviglia e l'ultimo grosso problema è che non riesco a far partire clover senza la usb di installazione, ho installato clover bootoader sull'hd dove ho mojave ma niente senza la usb mi parte il bootloader di hp/windows. Premetto che sono partito con una copia di mojave scaricata dall'appstore. Vi allego il report di HackInfo sperando che possa essere d'aiuto per il troubleshooting
      HackInfo_Report.zip
    • By spec3
      ciao, 
       
      ho un problema con un monitor Dell p2715q 4k, funziona bene a prima vista, ma quando lavoro su programmi piu' pesanti, ho qualche problemino , del tipo che su certe azioni risulta rallentato a livello grafico. Invece se ridimensionato il monitor alla risoluzione nativa (3840x2160), sembra che questo problema sparisca. In pratica ho problemi solo nelle dimensioni intermedie. sapete se si puo' fare qualcosa? Il problema credo sia dovuto al monitor e non alla scheda video, perche' su un monitor full hd non ho problemi di rallentamento. 
       
      Per ora sto usando solo Lilu e wahtervergreen , senza questi il monitor nemmeno si accende.
       
      Se avete idee sono bene accette, 
       
      Grazie!
       
    • By ITzTravelInTime
      Hi guys, this thread is to show you a new and open source app, created by me, that I called TINU:
       
      The name means: TINU Is Not #####, the U refers to a popular software that is used to create macOS hackintosh installers (that for good reasons is banned on this forum), but the aim of the name is to explain that this app is a totally different thing from that software and works in a totally different way.
       
      This app basically is a graphical interface for the createinstallmedia executable that is inside the macOS and Mac OS X installer apps, it is capable to create a bootable installer completely vanilla like what you do using the command line method, and also this method is recommended by apple itself. In addition to this, this app provvides to you simplicity and flexybility, and lets you to avoid most of the steps needed with every other app.
       
      TINU allows you to create easily a bootable macOS installer without messing around with command line stuff and without using disk utility, all you need to do is use the app and then install clover on the usb drive once TINU has finished or leave it as is if you want to use it on a real Mac.
       
      Features:
      - Simple-to-use UI that allows you to easily start the bootable macOS installer creation process.
      - It can work with every macOS installer app that has the createinstallmedia executable inside its resources folder (including also beta and newly released installers).
      - You can use any erasable volume that is at least 7 GB of size (if the volume's drive is not in GUID format, TINU will re-format it accordingly).
      - Can work with the Mac OS recovery system, so you can create a bootable macOS installer from the macOS installer itself or from the macOS recovery partition, and you can use TINU to install macOS, too.
      - 100% clean: The bootable macOS installers created with this tool are vanilla, just as if you created them using the command line "createinstallmedia" method in Terminal.
      - Open Source: You can verify what this program does on your computer and you can create your own version by downloading and playing with the source code.
      - Does not require any special preparations. Just open the program, make sure you have a USB drive plugged in and have a macOS installer app on your disk.
      - No need to use Disk Utility. TINU can format your drive or partition for you.
      - Integrated EFI partition mounter tool.
      - Uses recent, modern, APIs and SDKs and the Swift 3 language.
      - Transparent graphics style available (type alt-S or choose from the menu bar: View -> Use transparent style).
      - Works using the latest versions of macOS and will also support newer Mac installers out of the box without requiring an update.
      - Offers advanced features to customize your bootable macOS installer.
       
      Features that are planned for future versions:
      - Install and configure [Clover](https://sourceforge.net/projects/cloverefiboot/).
      - Install kexts into Clover's kexts folder.
      - Clover drivers customization
      - Use custom DSDT in Clover
      - Integrated pre-made Clover config templates database from a remote and open repository.
      - Support for other languages, at least Italian.
       
      # Requirements:
      - A computer that runs Mac OS X Yosemite or a more recent version (Mac OS X El Capitan is required to use TINU in a macOS recovery or installer).
      - A drive or a free partition (on a drive which already supports GUID) of least 7 GB that you want to turn into a macOS/Mac OS X installer.
      - A copy of a macOS/Mac OS X installer app (Maveriks or newer versions are supported) in the /Applications folder or in the root of any storage drive on your machine (excepted the drive or volume you want to turn into your macOS install media).
       
      Download:
      https://github.com/ITzTravelInTime/TINU/releases

      Frequently asked questions:
      https://github.com/ITzTravelInTime/TINU/wiki/FAQs
       
      Useful links:
      Thread (english) on insanelymac.com:
      - http://www.insanelymac.com/forum/topic/326959-tinu-the-macos-installer-creator-app-mac-app/
      Thread (italian) on insanelymac.com:
      - https://www.insanelymac.com/forum/topic/333261-tinu-app-per-creare-chiavette-di-installazione-di-macos-thread-in-italiano/
      Thread (english-german) on hackintosh-forum.de:
      - https://www.hackintosh-forum.de/index.php/Thread/33630-TINU/
      Post on Reddit:
      - https://www.reddit.com/r/hackintosh/comments/a1h61d/tinu_vanilla_bootable_macos_installer_creation/
      Facebook hackintosh help and beta testing (Italian only):
      - https://www.facebook.com/groups/Italia.hackintosh/?fref=ts
      Contact me (project creator):
      - Insanelymac.com profile: http://www.insanelymac.com/forum/user/1390153-itztravelintime/
      - email: piecaruso97@gmail.com
       
      Note that:
      - This software is under GNU GPL v3 license so any new branch/mod/third party release must be open source and under the same license
      - I (project creator) assume no responsibility for any use of this app and this source code, and also for any kind of hardware and software damage to any computer and any device or peripheral that may come from this app or source code during it's use and outside it's usage
      - I (project creator) do not guarantee support to you, this is only an open source project, not a product released by a company!
      - This project is born only for educational and demonstrative purposes, it's not intended to be used for commercial purposes and it will never be, don't use source code from this project to create apps or software for that aim.
      - This is a no-profit project, born only to let people to create macOS install medias in a more simple way and also to learn how to create this kind of apps.
       
      Credits:
      - Apple for macos and installer apps and scripts
      - People that helped me a lot:
      Francesco Perchiazzi, Nicola Tomarelli, Roberto Sciortino, Raffaele Sonnessa, Ermanno Nicoletti, Tommaso Dimatore, Michele Vitiello Bonaventura, Massimiliano Faralli, Davide Dessì, Giorgio Dall'Aglio, Peter Paul Chato.   
      - Special thanks to Italian Hackintosh group!! for help (https://www.facebook.com/groups/Italia.hackintosh/?fref=ts)
      - Thomas Tempelmann for help with the UI
      - Pietro Caruso (ITzTravelInTime) for creating, maintaing and developing this project
       
       
         
    • By fusion71au
      Clover r4799 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4799 for VMware.zip". Mount Clover-v2.4k-4799-X64 by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
×