Jump to content
About Just Joined group Read more... ×
fantomas

Nvidia Web Driver updates for macOS High Sierra (UPDATE Sept 25, 2020)

2,165 posts in this topic

Recommended Posts

44 minutes ago, TimeLord04 said:

As far as I know, this is NOT doable on Real Macintoshes - ONLY on Hackintoshes.

Ok I think I'm doomed then becasue I just have a real Mac !

Thank you for your help tho :)

Share this post


Link to post
Share on other sites
Advertisement
Posted (edited)

Re: older OS X/macOS versions, try the links provided in this post; All tested by myself not that long ago. And yes, of course you'll have to do a complete re-installation from scratch; 'goes without saying...

 

Download, say, High Sierra, create your USB installer using the createinstallmedia line command and proceed with a fresh installation of macOS. You should then be Ok to install the nVidia Web Driver.

 

Let's halt the off-topic here; open up your own dedicated thread if you need further assistance on the matter.

Edited by Hervé

Share this post


Link to post
Share on other sites
Posted (edited)

cannot install nvdia web drivers. it says: Mac OS X version is not compatible. i have 10.3.6 high sierra installed.

 

I have installed cuda cudadriver_418.163_macos which is the last one for high sierra.

 

and tried to install WebDriver-387.10.10.10.40.134

 

have tried earlier versions of web drivers not work as well.

 

help me pls :)

 

ps: i have solved the problem with installing 387.10.10.10.40.135 !!!

 

 

Link is here:

https://www.nvidia.com/content/DriverDownload-March2009/confirmation.php?url=/Mac/Quadro_Certified/387.10.10.10.40.135/WebDriver-387.10.10.10.40.135.pkg&lang=us&type=GeForce

 

Edited by yellowhulk

Share this post


Link to post
Share on other sites

5-13-2020 at 2:16 PM - PDT

 

[Update:]

 

Received used (Mac Flashed)-Gigabyte GTX-770 4GB Card from a friend.

Installed the 770 into Daedalus-MacPro 5,1 Mid-2010 System.  Removed

Mac-GTX-970 4GB Card and Secondary EVGA GTX-1050 2GB Card from

Daedalus.

 

Tomorrow, will move the GTX-970 4GB Card to Hackintosh-Andromeda to

replace the damaged MacVidCards' GTX-1070 8GB Card.  This will give

Andromeda a FULLY working Mac Flashed Primary GPU and keep the

Secondary EVGA GTX-1050 2GB Card.

 

Now, (even though NOT needed), the NVIDIA Web Drivers are STILL

Installed on Daedalus.  I WILL be removing them, and the CUDA Driver

in preparation to move Daedalus to Mojave 10.14.6.

 

The damaged 1070 is going to a friend's Hackintosh.  He knows it's

damaged, and doesn't care.  He's NOT going to be Gaming, NOR

Number Crunching like I was.  He may, in addition to taking the

1070 8GB Card, take the EVGA GTX-1050 just pulled from Daedalus.

 

These steps will keep Hackintosh-Andromeda running at peak performance,

while I save up for a MacVidCards' Sapphire Radeon Pulse RX-580 8GB Card.

That will replace both the GTX-970 and 1050 in Andromeda and allow me to

Upgrade Andromeda to Mojave 10.14.6.  (May take me 6 Mos. to a year to

get the RX-580.)

 

Continued Good Luck to all here.  I plan to be OFF of NVIDIA Web Drivers

in a year's time.

 

 

TimeLord04

Share this post


Link to post
Share on other sites

Not sure this really is the right place for this story... Kinda getting completely off-topic.

Share this post


Link to post
Share on other sites
Posted (edited)

nVidia don't provide Web Drivers for OS X/macOS beta versions/builds...

Edited by Hervé

Share this post


Link to post
Share on other sites

5-20-2020 at 12:04 PM - PDT

 

[Hackintosh-Andromeda Update:]

 

FINALLY had time, yesterday, and got the Mac Flashed PNY GTX-970 4GB Card Installed

into Andromeda.  This replaces the defective MacVidCards' GTX-1070 8GB Card.

 

I may pull out the EVGA GTX-1050 2GB Secondary Card from Andromeda, as I am no

longer doing Number Crunching on MacOS on the Hackintosh.

 

NVIDIA Web Driver 387.10.10.10.40.135 seems to have picked up the change in the

Cards.  In BOINC, (as that Number Crunching Program is STILL Installed), the 970

IS being assigned OpenCL, BUT later in the Event Log the Individual Number Crunching

Projects 'CLAIM' that the 970 'Does NOT Support OpenCL' and further states

'GPU Missing'.  Concerned that OpenGL might also have been affected, I Launched

StarCraft:Remastered, that runs fine - NO Error Messages from the Battle.net Launcher.

 

So, I believe that Andromeda is working the way I need her to, for now.  NO real

issues to report.

 

 

TimeLord04

Share this post


Link to post
Share on other sites
Posted (edited)

Do you thing its possible to make my old Gainward GeForce GTX 285 work with high sierra ? I managed to boot in 10.13.4 and 10.13.6 with 'nv_disable' flag (Ga ex58UD3R) but i can't make Graphics Card work . I tried Web Drivers from the first post with webdrivers enabled in smbios(macpro 5,1), CUDA, inject Nvidia and so many combinations that i can't really recall but nothing.

Did anyone manage to do it ?

 

Thanks

Edited by iceage2609

Share this post


Link to post
Share on other sites

5-26-2020 at 3:36 PM - PDT

 

Security Update 2020-003 10.13.6 has JUST released.

 

As always, we need to wait, now, for NVIDIA to release new Web Drivers.

 

 

TimeLord04

Share this post


Link to post
Share on other sites
5 hours ago, iceage2609 said:

Do you thing its possible to make my old Gainward GeForce GTX 285 work with high sierra ? I managed to boot in 10.13.4 and 10.13.6 with 'nv_disable' flag (Ga ex58UD3R) but i can't make Graphics Card work . I tried Web Drivers from the first post with webdrivers enabled in smbios(macpro 5,1), CUDA, inject Nvidia and so many combinations that i can't really recall but nothing.

Did anyone manage to do it ?

 

Thanks

 

5-26-2020 at 3:43 PM - PDT

 

@iceage2609,

 

The GTX-285 is Fermi or Pre-Fermi.  I have an OLD GTX-275, and was told that these

Cards are NOT MacOS compatible.  You should Upgrade and pick up a used GTX-760,

which is Native to MacOS, or IF you need CUDA Driver access - this USUALLY requires

the Web Driver too so I'd look at Maxwell and Pascal Cards.  (EVGA GTX-750TI SC, GTX-8x0,

GTX-9x0, GTX-10x0 Cards.  IF you can find any of these Pre-Flashed with Mac EFI, then

you WILL be able to get Boot Screen to show on Power Up of the System.)

 

 

TimeLord04

Share this post


Link to post
Share on other sites
Posted (edited)

5-26-2020 at 8:36 PM - PDT

 

[Update on Daedalus-Mac Pro 5,1 - Mid 2010 System:]

 

Removed NVIDIA Web Drivers, removed CUDA Driver. Moved BOINC App from

Applications' Folder to Trash.

 

Ran Security Update 2020-003 - 17G13033.

 

Daedalus now Updated to High Sierra 10.13.6 - (17G13033).

 

NO Issues to report.

 

[EDIT:]  8:57 PM - PDT - Waiting for New NVIDIA Web Drivers to Update Hackintosh-Andromeda.

 

 

TimeLord04

Edited by TimeLord04
Added Pertinent Information.

Share this post


Link to post
Share on other sites

hey TimeLord04

 

i also made this update a few minutes ago. After this i use a patch for my nvidia web driver.

the patch just change the required MacOS build number...after a reboot the diver is loading without any problem.

I think nividia itself...would do nothing else than this tiny change in his driver and release it under a new driver version.

 

just give it a try

 

 

nvidia web driver patch.zip

Share this post


Link to post
Share on other sites
2 hours ago, SmoothMC said:

hey TimeLord04

 

i also made this update a few minutes ago. After this i use a patch for my nvidia web driver.

the patch just change the required MacOS build number...after a reboot the diver is loading without any problem.

I think nividia itself...would do nothing else than this tiny change in his driver and release it under a new driver version.

 

just give it a try

 

 

nvidia web driver patch.zip

5-27-2020 at 7:56 AM - PDT

 

@SmoothMC,

 

This conversation has been had MANY times by MANY people....  I CHOOSE to use the Proper NVIDIA Web Driver

Release for EACH OS Release.  While some MAY choose to Patch PRIOR Web Drivers, THIS IS NOT recommended

practice.  There are REASONS for EACH Web Driver Release.

 

There was one SPECIFIC Driver in the past that was Recalled, and STILL people Patched this FAULTY Driver to run

on OSes it SHOULD NOT have been running on.

 

Therefore, NO, I will WAIT for the Specific Release by NVIDIA.

 

 

TimeLord04

Share this post


Link to post
Share on other sites
Posted (edited)

@iceage2609, GTX 285 is Tesla 2.0 and would be expected to work natively:
https://forums.macrumors.com/threads/macos-high-sierra-10-13-unsupported-macs-thread.2048478/page-73?post=25158814#post-25158814

https://forums.macrumors.com/threads/macos-high-sierra-10-13-unsupported-macs-thread.2048478/page-74?post=25162452#post-25162452

 

Regardless, it is in the list of cards supported by the Web Driver:

https://www.nvidia.com/Download/driverResults.aspx/142158/en

 

Make sure you actually boot with the Web Driver enabled id you've installed it.

Edited by Hervé

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, Hervé said:

Thanks for answering... Hmmm that's strange, if so it had to work natively but i didin't manage to do it. I am pretty sure i used inject Nvidia YES (and NO) without any kind of drivers or any flag but nothing happened ( natively supported card should have booted without any configuration ,right?), then download the Web drivers for 10.13.4 from the first post (config.plist webrivers enabled...nope) , CUDA with a downloading patcher tool ...nothing :-( Only with nv_disable=1 i am booting in my 10.13.4 partition. 

I don't know if its making any difference ,but my card is not exactly the one you posted, but i think this one GTX 285 ( 1 DVI-1HDMI-1VGA)

So i am gonna give it a try tomorrow again and let you know. Just one question, install High Sierra in the new partition, boot with nv_disable=1 and then install the Webdrivers from your post, get into EFI config.plist remove nv_disable=1 flag, remove Inject Nvidia and i guess inject Intel as well and add 

<key>NvidiaWeb</key>

<true/> and then reboot?

Edited by iceage2609

Share this post


Link to post
Share on other sites

I suggest you open up a dedicated thread for your trouble rather than somehow pollute this one.

Share this post


Link to post
Share on other sites
Posted (edited)

5-28-2020 at 1:41 PM - PDT

 

Well, we're on the second day past the Security Release, and still no Web Driver Update

from NVIDIA....  Are they just behind schedule, or are they choosing to, now, just

completely abandon even High Sierra Support...???...

 

I will give this another day, and then will be researching 'cheap' potentially available

Kepler Cards to keep Hackintosh-Andromeda functioning while I save for a Sapphire

Radeon Pulse RX-580 8GB Card from MacVidCards.

 

Trying to keep a positive spin on this, though.  I hope they're just short handed and

behind on releasing a new Web Driver for us all.

 

 

TimeLord04

Edited by TimeLord04
Correcting Grammar.

Share this post


Link to post
Share on other sites
31 minutes ago, iCanaro said:

new webdriver High Sierra 10.13.6 17G13033 https://images.nvidia.com/mac/pkg/387/WebDriver-387.10.10.10.40.136.pkg

 

2019601474_Schermata2020-05-29alle01_04_39.png.6f5df54517d39e5176ced80eccc413ca.png

5-28-2020 at 4:15 PM - PDT

 

@iCanaro,

 

Thank you for this!  I'm glad they finally released the new Web Driver.

 

I will Update Hackintosh-Andromeda now.:)

 

 

TimeLord04

Share this post


Link to post
Share on other sites

5-28-2020 at 7:40 PM - PDT

 

Well, Update to (17G13033) and Web Driver (.136) went smooth and fast.

(About 20 Minutes for the Update and 3 Minutes for the Web Driver.)

The extra time was taken up by trying to Reload 56 Tabs in Firefox, then

dinner, and evening news....  Finally got back here now to Post.

 

No Issues in Update.  Still have half my Tabs to Reload in Firefox.

 

 

TimeLord04

Share this post


Link to post
Share on other sites

Is there by any chance any way to fix the lag issues, on the desktop and the general ui? I'm running the latest web driver and the card is detected just fine in the OS and games as well. 

My Specs

Asrock B365 Pro 4

Core i5 9400f

GTX 1070 TI 8GB

SMBIOS: iMac Pro 1,1

Mac OS High Sierra 10.13.6 (17G13033)

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By fantomas
      Hi InsanelyMacaholics   

      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS Sierra.
       
      10.12.6
      Nvidia Web Driver - 378.05.05.25f19 --> build 16G2136 (thanks to BreBo) New!
      Nvidia Web Driver - 378.05.05.25f18 --> build 16G2028 (thanks to Riley Freeman)
      Nvidia Web Driver - 378.05.05.25f16 --> build 16G2016 (thanks to Cyberdevs)
      Nvidia Web Driver - 378.05.05.25f15 --> build 16G1918 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f14 --> build 16G1917 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f13 --> build 16G1815 (thanks to flowrider)
      Nvidia Web Driver - 378.05.05.25f12 --> build 16G1710 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f11 --> build 16G1618 (thanks to Frank Nitty)
      Nvidia Web Driver - 378.05.05.25f10 --> build 16G1510 (thanks to BreBo) 
      Nvidia Web Driver - 378.05.05.25f09 --> build 16G1408 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f08 --> build 16G1314 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f07 --> build 16G1314 (thanks to haring)
      Nvidia Web Driver - 378.05.05.25f06 --> build 16G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 378.05.05.25f04 --> build 16G1114 (thanks to lukazm)
      Nvidia Web Driver - 378.05.05.25f03 --> build 16G1036 (thanks to Gradou)
      Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to Badruzeus)
       
       
      10.12.5
      Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)
       
       
      10.12.4
      Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)
      Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr)  Pascal support!!!
      Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)
       
       
      10.12.3

      Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)
       
       
      10.12.2
      Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)
      Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)
      Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)
       
       
      10.12.1
      Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).
      Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)
       
       
      10.12.0
      Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)
       
       
      GM
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)
       
       
      DP/PB
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun) 
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun)
      Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)
       
    • By fantomas
      hi people  
       
      you can use this thread to link / talk about of the future Nvidia Web Driver updates for El Capitan
       
      10.11.6
      Nvidia Web Driver - 346.03.15f16 --> build 15G22010 (thanks to BreBo)  New!
      Nvidia Web Driver - 346.03.15f15 --> build 15G21013 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.15f14 --> build 15G20015 (thanks to DMCrimson)
      Nvidia Web Driver - 346.03.15f13 --> build 15G20015 (thanks to Louvier)
      Nvidia Web Driver - 346.03.15f12 --> build 15G19009 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f11 --> build 15G18013 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f10 --> build 15G17023 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f09 --> build 15G1611 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f08 --> build 15G1510 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f07 --> build 15G1421 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f06 --> build 15G1217 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f05 --> build 15G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f04 --> build 15G1108 (see this post)
      Nvidia Web Driver - 346.03.15f03 --> build 15G1004 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f02 --> build 15G31 (thanks to Moviemakergr)
      Nvidia Web Driver - 346.03.15f01 --> build 15G31 (thanks to WeBeRiO)
      [uPDATE_3]Nvidia Web Driver - 346.03.15b01 --> build 15G24b (thanks to DMCrimson)
       
      10.11.5
      Nvidia Web Driver - 346.03.10f02 --> build 15F34 (thanks to marcozardi)
      Nvidia Web Driver - 346.03.10f01 --> build 15F34 (thanks to WeBeRiO)
      [uPDATE_2] Nvidia Web Driver - 346.03.10b01 --> build 15F31a (see this post)
       
      10.11.4
      Nvidia Web Driver - 346.03.06f01 --> build 15E65 (see this post)
      Nvidia Web Driver - 346.03.06b01 --> build 15E (see this post)
       
      10.11.3
      Nvidia Web Driver - 346.03.05f02 --> second release for build 15D21 (thanks to Fljagd)
      Nvidia Web Driver - 346.03.05f01  --> build 15D21 (see this post)
      Nvidia Web Driver - 346.03.05b02 --> build 15D (see this post)
       
      10.11.2
      Nvidia Web Driver - 346.03.04f02 --> second public release (see this post)
      Nvidia Web Driver - 346.03.04f01 --> build 15C50 (see this post)  
      Nvidia Web Driver - 346.03.04b02 --> build 15C48a (see this post) 
      Nvidia Web Driver - 346.03.04b01 --> build 15C47a (see this post)
       
      10.11.1
      Nvidia Web Driver - 346.03.03f02 --> second public release (see this post) 
      Nvidia Web Driver - 346.03.03f01 --> build 15B42 (thanks to jperkins909)
       
      10.11.0
      Nvidia Web Driver - 346.03.02f02 --> build 15A284 (thanks to MTWomg)
      Nvidia Web Driver - 346.03.02f01 --> build 15A284 (see this post)
       
      DP
      Nvidia Web Driver - 346.03.01b07 --> GM/DB/PB6/DB7/PB5 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.01b06 --> build 15A (thanks to MTWomg) 
    • By ivanmacx85
      NVIDIA ha rilasciato i driver grafici per macOS High Sierra 10.13

      Questi driver sono attualmente l’unico metodo per ottenere l’accelerazione grafica delle schede:

      -Pascal   GTX 1050, 1050 Ti, 1060, 1070, 1080, 1080 Ti, TITAN Xp
      -Maxwell GTX 750, 750 Ti, 950, 960, 970, 980, 980 Ti, TITAN X


       
      Per disinstallare i vecchi WebDriver attenersi alla seguente procedura: 

      1.) Aprire l'NVIDIA Driver Manager nella voce della barra dei menu.

      2.) Fare clic sull'icona del lucchetto e immettere la password dell'amministratore.

      3.) Fare clic sul pulsante disinstallazione.

      4.) Fare clic su disinstalla e continuare con la disinstallazione. Riavviare il sistema come indicato

      5.) Installare la versione originale del kext AppleGraphicsControl.kext (solo se lo avevate modificato in precedenza) in / S / L / E / tramite Kext Utility

      Ignorate questi passaggi se venite da un'installazione pulita di High Sierra


      Per installare il nuovo pacchetto WebDriver NVIDIA 10.13 distribuito ufficialmente, procedere come segue:

      1.) Scaricare e installare il pacchetto NVIDIA WebDriver HighSierra 10.13.pkg Durante l'installazione comparirà un messaggio di errore, ignoratelo e continuare l'installazione finché non vi verrà richiesto di riavviare il sistema.

      2.) Solo per chi ha smbios iMac 15,1 - iMac 17,1 - MacPro 6.1 Prima di riavviare mettere nella cartella kext other NVWebDriverLibValFix.kext.zip, NvidiaGraphicsFixup.kext.zip e Lilu.kext per evitare il problema dello schermo nero dopo l'avvio del sistema
       
      3.) In alcuni casi è necessario impostare nel file .config il SIP (CsrActiveConfig) su 0x3

      4.) Ora riavviate il sistema. Al momento dell'avvio del sistema, avrete il WebDriver Nvidia completamente funzionante con supporto OpenGL e Metal 2


    • By spec3
      ciao, 
       
      Ho appena acquistato una GTX 980, ho due partizioni , una con Sierra . e una con Yosemite, su Sierra ho installato i Web driver , messo webdriver al config.plist e tutto funziona a dovere. In Yosemite ho fatto la stessa cosa, al riavvio  non sono  piu  riuscito ad entrare nel sistema operativo, ovviamente ho usato le versioni dedicate per ogni sistema operativo a meno che non mi sia confuso e ho installato i driver sbagliati. Per rientrare ho provato di tutto, safe mode, staccando l'nvidia , provando ad entrare con l'intel integrata, provato a cambiare SMBIOS dalla partizione di Sierra.
       
      Come posso rientrare nel sistema? ce un modo per eliminare i driver manualmente da un altra partizione?
       
      grazie

    • By imatefx
      I have a nvidia gt425M on my asus n53jq laptop almost everything is working correctly audio , lan , wifi
      even display is detected , I was not using nvidia web driviers on el capitan
       
      Only some windows and desktop background are distorted the resolution is 1920x1080, 
      The Video ram is 1024 MB but the "About mac" window shows only 1023 MB 
       

       
      Can someone help me out.
×