Jump to content
fantomas

Nvidia Web Driver updates for macOS High Sierra (UPDATE Jan 29, 2020)

2,093 posts in this topic

Recommended Posts

Advertisement
2 hours ago, hungrywallet said:

What's the latest nVIDIA GPU that works on High Sierra?

Any Pascal Card:  GTX-10x0

 

 

TimeLord04

Share this post


Link to post
Share on other sites
Posted (edited)

I recently downgraded from Mojave to High Sierra (by first installing the original Mavericks with cmd+opt+shift+R then upgrading to High sierra from there). My intention is to be running Daz Studio and utilizing CUDA with my Nvidia GTX 680, on my Mac Pro 2013 through my Sonnet breakaway box and TB2 -> TB3 adapter. Not the finest card but better than CPU-only rendering. I had this setup working previously, with Daz studio recognizing the card as a CUDA device. However, after 2 days of trying to get this to work, I am having issues:

 

1. The eGPU disconnect icon does not appear in the menu.

2. The GPU is not recognized in the Displays window of About This Mac. Connecting a display after hotplugging the Thunderbolt to the external GPU results in no signal being output, and no additional monitor being added to the Displays preference pane. Connecting a display before hotplugging results in a red screen and a kernel panic.

3. The card is displayed in the Graphics tab of System Profiler. Purge-wrangler reports a successful patch. Nvidia web drivers detect the GPU and install successfully. CUDA drivers install successfully but then CUDA does not work.

4. CUDA driver system preference pane displays there is an update required, but there is no update available.

5. Security update 2020-01 is safe, according to the recent posts on this forum. It is installed, but CUDA does not seem to be happy with my installation.

 

With all the above issues, Daz studio is not seeing the device as a CUDA rendering device.

 

What could be the issue here? Thank you for your time.

Screen Shot 2020-03-14 at 3.08.27 PM.png

Screen Shot 2020-03-14 at 3.08.33 PM.png

Screen Shot 2020-03-14 at 3.08.38 PM.png

Screen Shot 2020-03-14 at 3.08.46 PM.png

Screen Shot 2020-03-14 at 3.08.52 PM.png

Screen Shot 2020-03-14 at 3.09.10 PM.png

Screen Shot 2020-03-14 at 3.10.27 PM.png

Screen Shot 2020-03-14 at 3.11.23 PM.png

Edited by MegaworM
clarification

Share this post


Link to post
Share on other sites

@MegaworM,

 

The GPU you are using, (GTX-680), IS NATIVE to

MacOS.  The Web Driver IS NOT REQUIRED for you.

 

Notice in the CUDA Driver Info. that the GPU Driver

Version that it is looking for is 355.11.10.10.40.102

NOT the Web Driver 387.10.10.10.40.134 which you

have installed!  This is what the "Update Required"

is referring to, NOT that the CUDA Driver needs

updating.  See also the "No newer CUDA Driver

available" statement that supports that the

CUDA Driver 418.163 IS the current CUDA

Driver.

 

The 355.11.10.10.40.102 NVIDIA Driver that is

being mentioned IS the MacOS Default Driver

that 'should' be used for your GTX-680.  You

still CAN use the Web Driver, if you choose, but

it may be best to Uninstall the Web Driver in favor

of the stock MacOS Driver for your Card.  CUDA

Driver 418.163 can be left alone and remain

installed.

 

 

TimeLord04

Share this post


Link to post
Share on other sites
Posted (edited)
23 hours ago, TimeLord04 said:

@MegaworM,

 

The GPU you are using, (GTX-680), IS NATIVE to

MacOS.  The Web Driver IS NOT REQUIRED for you.

 

Notice in the CUDA Driver Info. that the GPU Driver

Version that it is looking for is 355.11.10.10.40.102

NOT the Web Driver 387.10.10.10.40.134 which you

have installed!  This is what the "Update Required"

is referring to, NOT that the CUDA Driver needs

updating.  See also the "No newer CUDA Driver

available" statement that supports that the

CUDA Driver 418.163 IS the current CUDA

Driver.

 

The 355.11.10.10.40.102 NVIDIA Driver that is

being mentioned IS the MacOS Default Driver

that 'should' be used for your GTX-680.  You

still CAN use the Web Driver, if you choose, but

it may be best to Uninstall the Web Driver in favor

of the stock MacOS Driver for your Card.  CUDA

Driver 418.163 can be left alone and remain

installed.

 

 

TimeLord04

This is not my experience. I started with no web driver installed in the first place. I only installed it because CUDA would not work AND it is included in the guide at https://www.daz3d.com/forums/discussion/309986/tut-making-cuda-drivers-work-on-your-mac-and-render-much-faster-with-gpu and here https://www.daz3d.com/forums/discussion/comment/4708656/ and here https://egpu.io/forums/pro-applications/egpu-to-work-with-iray-render/.

 

All those setups feature screenshots with both nvidia and cuda drivers installed and specify to install the 387 nvidia drivers and the 418 cuda drivers. Then they show the GPU as displaying for a render device in DAZ.

 

Now as I see your reply I already have a system state with CUDA installed, and no web driver was ever installed yet on this system state, and still no GPU showing in DAZ studio. So where do I go from here? As you can see the nvidia web driver is not even installed. I am using the macos drivers and have the updated driver, but its still saying update required, so doesn't that mean the update required message is referring to some other issue?

Screen Shot 2020-03-16 at 6.58.27 AM.png

Screen Shot 2020-03-16 at 6.58.30 AM.png

Screen Shot 2020-03-16 at 7.07.22 AM.png

Edited by MegaworM

Share this post


Link to post
Share on other sites

@MegaworM,

 

The GTX-680 is a Kepler Card.  This is why it worked

in Mojave.  Maxwell and Pascal Cards are NOT able

to work in ANYTHING above High Sierra.

 

Maxwell:  GTX-750TI SC/8x0/9x0 Cards

 

Pascal:  GTX-10x0 Cards

 

Turing:  GTX-16x0/RTX-20x0 Cards  <-- (Will NEVER work in MacOS)

 

Maxwell and Pascal Cards REQUIRE NVIDIA Web

Drivers to run in MacOS.  As Noted a couple of pages

back, people with the 750M Card, (also Kepler), were

having GREAT difficulty using the 750M WITH Web

Drivers.  Going back to their Pre and Post Web Driver

Installation Pictures - Pre Web Driver, the 'About This

Mac' Info. DID show the 750M listed in High Sierra.

Their Post Web Driver Installation DID NOT show

their 750M.  Hence the Web Driver was NOT

recommended.  Hence why I've recommended to

you that you remove it.

 

@Hervé even stated that for Kepler, (Native), Cards,

(which he uses himself), that the Web Driver is NOT

NECESSARY for Kepler Cards.  So, why you have

problems both WITH AND WITHOUT the Web Driver

goes above my head.

 

Someone like @Hervé, or @fantomas, or @chris1111

that has more Web Driver experience will need to

chime in here.

 

 

TimeLord04

Share this post


Link to post
Share on other sites
Posted (edited)

Check your High Sierra build number, update to the latest build and, once that is done, install (or update) the Web Driver that matches your final HiSie build. Nothing more to it really...

Edited by Hervé

Share this post


Link to post
Share on other sites
Posted (edited)
13 hours ago, Hervé said:

Check your High Sierra build number, update to the latest build and, once that is done, install (or update) the Web Driver that matches your final HiSie build. Nothing more to it really...

 

I finally got it working. I was not aware but I was stuck on a build that was not supported by nvidia. And it told me there was no updates until I ran the script at dosdudes website to enable more software updates. So now I have the most up to date macos build and everything is working as normal. Thank you for helping me navigate this issue!

Screen Shot 2020-03-16 at 10.35.33 PM.png

Edited by MegaworM

Share this post


Link to post
Share on other sites
Posted (edited)

Security update 2020-002. New 10.13.6 build 17G12034:

 

HiSie_17G12034.jpg.7bbbbaee37e8686fae8ce4ce0293f95e.jpg

 

Let's wait for the Web Driver update...

 

Edited by Hervé

Share this post


Link to post
Share on other sites
9 hours ago, Hervé said:

Security update 2020-002. New 10.13.6 build 17G12034:

 

HiSie_17G12034.jpg.7bbbbaee37e8686fae8ce4ce0293f95e.jpg

 

Let's wait for the Web Driver update...

 

hi Hervé. i see that you still use High Sierra. what GPU you have? connected over? HDMI? DVI? DP? Thanks

Share this post


Link to post
Share on other sites
Posted (edited)

Your request is completely off-topic but if you want those details, look here. If you wish to discuss this further, please open a separate thread in order not to pollute this one.

Edited by Hervé

Share this post


Link to post
Share on other sites

Yesterday i also updated my macos to 10.13.6 (17G12034), now i also have to wait for the driver. The mac is working now but without the driver and can´t detect the GPU correct.

I have installed two gtx 1080 ti.

 

I hope the driver came in the next days, because in aftereffect i have now big troubles.

Share this post


Link to post
Share on other sites

hello,

warning with macOS 10.13.6 (17G12034) because not run

i wait 135 :)

 

3 minutes ago, regiso said:

hello,

warning with macOS 10.13.6 (17G12034) because not run

i wait 135 :)

 

i have not look very thanks for 135 :)

 

Share this post


Link to post
Share on other sites
Posted (edited)

3-29-2020 at 2:51 PM - PDT

 

Got back from my trip to IL yesterday.  Just powered up Hackintosh-Andromeda.

Performed Update to 10.13.6 - (17G12034) and Web Driver 387.10.10.10.40.135.

 

No issues to report.  SETI@Home is ENDING after 20+ Years of Scientific Number Crunching.

I will be Crunching the last few of my Work Units tonight.

 

 

TimeLord04

 

[EDIT:]

 

I will Update the Mac Pro 5,1 - Daedalus tomorrow.

 

 

TimeLord04

Edited by TimeLord04
Updated Info for Mac Pro-5,1.

Share this post


Link to post
Share on other sites

3-31-2020 at 5:00 PM - PDT

 

[UPDATE:]

 

On Hackintosh-Andromeda, I've been struggling for the PAST TWO DAYS

regarding Compute Issues on my two NVIDIA GPUs.  ALL GPU Compute

Work is FAILING.

 

At this time, I believe that the new NVIDIA Web Driver 387.10.10.10.40.135

MAY have caused the issue.  I need OTHER Number Crunchers to confirm.

 

The new Driver is causing the CUDA Driver to FAIL in CUDA Crunching.

On SETI@Home work, (ending today), I get "Best Pulse = 0" Results which

then come to an "Invalid" Compute Record at SETI@Home.  For OpenCL work,

directly in the (.135) Driver, at Collatz Conjecture ALL work ends in "Compute

Error".

 

Either BOTH my Cards' Compute Cores have FAILED at the same time.  (After the

computer being OFF for 10 Days.  Then Updating MacOS to (17G12034), and the

new (.135) Driver.)  Or the (.135) Driver is DEFECTIVE!

 

At this time, I'm choosing NOT to Update the Mac Pro 5,1 System to (17G12034)

NOR to Driver 387.10.10.10.40.135.

 

With SETI@Home is ENDING after 20+ Years of Scientific Number Crunching, I will

NOT be able to get New Units from them on the Mac Pro 5,1 to cross check the

Driver Issue.

 

Good Luck everyone.

 

 

TimeLord04

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fantomas
      Hi InsanelyMacaholics   

      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS Sierra.
       
      10.12.6
      Nvidia Web Driver - 378.05.05.25f19 --> build 16G2136 (thanks to BreBo) New!
      Nvidia Web Driver - 378.05.05.25f18 --> build 16G2028 (thanks to Riley Freeman)
      Nvidia Web Driver - 378.05.05.25f16 --> build 16G2016 (thanks to Cyberdevs)
      Nvidia Web Driver - 378.05.05.25f15 --> build 16G1918 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f14 --> build 16G1917 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f13 --> build 16G1815 (thanks to flowrider)
      Nvidia Web Driver - 378.05.05.25f12 --> build 16G1710 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f11 --> build 16G1618 (thanks to Frank Nitty)
      Nvidia Web Driver - 378.05.05.25f10 --> build 16G1510 (thanks to BreBo) 
      Nvidia Web Driver - 378.05.05.25f09 --> build 16G1408 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f08 --> build 16G1314 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f07 --> build 16G1314 (thanks to haring)
      Nvidia Web Driver - 378.05.05.25f06 --> build 16G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 378.05.05.25f04 --> build 16G1114 (thanks to lukazm)
      Nvidia Web Driver - 378.05.05.25f03 --> build 16G1036 (thanks to Gradou)
      Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to Badruzeus)
       
       
      10.12.5
      Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)
       
       
      10.12.4
      Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)
      Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr)  Pascal support!!!
      Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)
       
       
      10.12.3

      Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)
       
       
      10.12.2
      Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)
      Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)
      Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)
       
       
      10.12.1
      Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).
      Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)
       
       
      10.12.0
      Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)
       
       
      GM
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)
       
       
      DP/PB
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun) 
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun)
      Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)
       
    • By fantomas
      hi people  
       
      you can use this thread to link / talk about of the future Nvidia Web Driver updates for El Capitan
       
      10.11.6
      Nvidia Web Driver - 346.03.15f16 --> build 15G22010 (thanks to BreBo)  New!
      Nvidia Web Driver - 346.03.15f15 --> build 15G21013 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.15f14 --> build 15G20015 (thanks to DMCrimson)
      Nvidia Web Driver - 346.03.15f13 --> build 15G20015 (thanks to Louvier)
      Nvidia Web Driver - 346.03.15f12 --> build 15G19009 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f11 --> build 15G18013 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f10 --> build 15G17023 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f09 --> build 15G1611 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f08 --> build 15G1510 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f07 --> build 15G1421 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f06 --> build 15G1217 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f05 --> build 15G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f04 --> build 15G1108 (see this post)
      Nvidia Web Driver - 346.03.15f03 --> build 15G1004 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f02 --> build 15G31 (thanks to Moviemakergr)
      Nvidia Web Driver - 346.03.15f01 --> build 15G31 (thanks to WeBeRiO)
      [uPDATE_3]Nvidia Web Driver - 346.03.15b01 --> build 15G24b (thanks to DMCrimson)
       
      10.11.5
      Nvidia Web Driver - 346.03.10f02 --> build 15F34 (thanks to marcozardi)
      Nvidia Web Driver - 346.03.10f01 --> build 15F34 (thanks to WeBeRiO)
      [uPDATE_2] Nvidia Web Driver - 346.03.10b01 --> build 15F31a (see this post)
       
      10.11.4
      Nvidia Web Driver - 346.03.06f01 --> build 15E65 (see this post)
      Nvidia Web Driver - 346.03.06b01 --> build 15E (see this post)
       
      10.11.3
      Nvidia Web Driver - 346.03.05f02 --> second release for build 15D21 (thanks to Fljagd)
      Nvidia Web Driver - 346.03.05f01  --> build 15D21 (see this post)
      Nvidia Web Driver - 346.03.05b02 --> build 15D (see this post)
       
      10.11.2
      Nvidia Web Driver - 346.03.04f02 --> second public release (see this post)
      Nvidia Web Driver - 346.03.04f01 --> build 15C50 (see this post)  
      Nvidia Web Driver - 346.03.04b02 --> build 15C48a (see this post) 
      Nvidia Web Driver - 346.03.04b01 --> build 15C47a (see this post)
       
      10.11.1
      Nvidia Web Driver - 346.03.03f02 --> second public release (see this post) 
      Nvidia Web Driver - 346.03.03f01 --> build 15B42 (thanks to jperkins909)
       
      10.11.0
      Nvidia Web Driver - 346.03.02f02 --> build 15A284 (thanks to MTWomg)
      Nvidia Web Driver - 346.03.02f01 --> build 15A284 (see this post)
       
      DP
      Nvidia Web Driver - 346.03.01b07 --> GM/DB/PB6/DB7/PB5 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.01b06 --> build 15A (thanks to MTWomg) 
    • By ivanmacx85
      NVIDIA ha rilasciato i driver grafici per macOS High Sierra 10.13

      Questi driver sono attualmente l’unico metodo per ottenere l’accelerazione grafica delle schede:

      -Pascal   GTX 1050, 1050 Ti, 1060, 1070, 1080, 1080 Ti, TITAN Xp
      -Maxwell GTX 750, 750 Ti, 950, 960, 970, 980, 980 Ti, TITAN X


       
      Per disinstallare i vecchi WebDriver attenersi alla seguente procedura: 

      1.) Aprire l'NVIDIA Driver Manager nella voce della barra dei menu.

      2.) Fare clic sull'icona del lucchetto e immettere la password dell'amministratore.

      3.) Fare clic sul pulsante disinstallazione.

      4.) Fare clic su disinstalla e continuare con la disinstallazione. Riavviare il sistema come indicato

      5.) Installare la versione originale del kext AppleGraphicsControl.kext (solo se lo avevate modificato in precedenza) in / S / L / E / tramite Kext Utility

      Ignorate questi passaggi se venite da un'installazione pulita di High Sierra


      Per installare il nuovo pacchetto WebDriver NVIDIA 10.13 distribuito ufficialmente, procedere come segue:

      1.) Scaricare e installare il pacchetto NVIDIA WebDriver HighSierra 10.13.pkg Durante l'installazione comparirà un messaggio di errore, ignoratelo e continuare l'installazione finché non vi verrà richiesto di riavviare il sistema.

      2.) Solo per chi ha smbios iMac 15,1 - iMac 17,1 - MacPro 6.1 Prima di riavviare mettere nella cartella kext other NVWebDriverLibValFix.kext.zip, NvidiaGraphicsFixup.kext.zip e Lilu.kext per evitare il problema dello schermo nero dopo l'avvio del sistema
       
      3.) In alcuni casi è necessario impostare nel file .config il SIP (CsrActiveConfig) su 0x3

      4.) Ora riavviate il sistema. Al momento dell'avvio del sistema, avrete il WebDriver Nvidia completamente funzionante con supporto OpenGL e Metal 2


    • By spec3
      ciao, 
       
      Ho appena acquistato una GTX 980, ho due partizioni , una con Sierra . e una con Yosemite, su Sierra ho installato i Web driver , messo webdriver al config.plist e tutto funziona a dovere. In Yosemite ho fatto la stessa cosa, al riavvio  non sono  piu  riuscito ad entrare nel sistema operativo, ovviamente ho usato le versioni dedicate per ogni sistema operativo a meno che non mi sia confuso e ho installato i driver sbagliati. Per rientrare ho provato di tutto, safe mode, staccando l'nvidia , provando ad entrare con l'intel integrata, provato a cambiare SMBIOS dalla partizione di Sierra.
       
      Come posso rientrare nel sistema? ce un modo per eliminare i driver manualmente da un altra partizione?
       
      grazie

    • By imatefx
      I have a nvidia gt425M on my asus n53jq laptop almost everything is working correctly audio , lan , wifi
      even display is detected , I was not using nvidia web driviers on el capitan
       
      Only some windows and desktop background are distorted the resolution is 1920x1080, 
      The Video ram is 1024 MB but the "About mac" window shows only 1023 MB 
       

       
      Can someone help me out.
×