Jump to content
fantomas1

Nvidia Web Driver updates for macOS High Sierra (UPDATE Feb 28, 2019)

1,840 posts in this topic

Recommended Posts

Advertisement

My rig boots to black screen even with Lilu.kext 1.1.7 and NvidiaGraphicsFixup.kext 1.1.3.

The same case, I use iMac 17,1 with lilu & nvidiafixup, got blackscreen and can't also boot with nv_disable=1 anymore

werid thing! i install it with smbios imac142 and then change into macpro6.1.. i will try 

I hope iMac 14,2 will work, update me if you can, thanks in advance because I don't know how to change to iMac 14,2 in windows :D

Share this post


Link to post
Share on other sites

Downloaded driver with nvidia panel

During installation it gives one error and installation continue normally

After system reboots I can't login

tried nv_disable=1 (system reboots before login)

with nvidiaweb unflagged in clover I have a loop with a flashing message iog console user (similar not exactly this text)

I think it is a policy problem. I have to find @PMHeart dummy kext she did for policy..in my case it was the only way to avoid black screen policy problem

Share this post


Link to post
Share on other sites

What happens when you use the NVWebDriverLibValFix kext?

 

https://github.com/mologie/NVWebDriverLibValFix

 

Specifically, check your system log for errors relating to Library Validation.  It's working for me and I have that kext installed.

 

Awesome.., it works on my Fermi GF119 (10de:1050)..!!! NVWebDriverLibValFix.kext is the answer under 10.13 (17A365).

 

U8tg4TJ.png

 

 

But on my case, I also use this Kext to Patch to avoid blackscreen issue (not really sure if it's a same way as NvidiaGraphicsFixup though):

 

 

<dict>
    <key>Comment</key>
    <string>Disable board-id check to prevent no signal (c) lvs1974, Pike R. Alpha, vit9696</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>
    ugUAAAA=
    </data>
    <key>Name</key>
    <string>com.apple.driver.AppleGraphicsDevicePolicy</string>
    <key>Replace</key>
    <data>
    ugAAAAA=
    </data>
</dict> 

 

 

 

U may also try with different FakeSMC versions, yes.. previously the WebDriver prevented this to load (for unknown reason) and gotta stuck on Waiting on DSMOS...

Here I'm using v6.26.1440 (still need some tests to confirm).

 

After Web Driver install succeeded, I also run these commands as usual:

sudo nvram -c && sudo purge && sudo rm -f /System/Library/Caches/com.apple.kext.caches/Startup/kernelcache && sudo touch /System/Library/Extensions && sudo kextcache -u / && sudo update_dyld_shared_cache -force 

.. then reboot ur mach and voila.., it works!!! Thanks again @Asgorath  :thumbsup_anim:

 

#EDIT: Forgot to mention that I'm using Clover v2.4k r4220 Legacy and MBP10,1 SMBios.

#EDIT2: I'm running 10.13 with HFS+, IDK if under APFS since (AFAIK) Preboot volume also needs tobe touched;

U may also try install WebDriver with SIP enabled. (on my case it' s disabled).

FakeSMC.kext_v6.26.1440.zip

Share this post


Link to post
Share on other sites

New now officially released macOS High Sierra 10.13 Nvidia Web Driver just works flawless!

 

Departing from the previous 10.12.6 Web Driver workaround I performed the following steps.

 

To uninstall the 10.12.6  NVIDIA Web Driver and the NVIDIA Driver Manager, follow the steps below: 

1.) Open the NVIDIA Driver Manager in the menu bar item.

2.) Click on the padlock icon and enter your Administrator password.

3.) Click the Open Uninstaller button.

4.) Click Uninstall and continue with the de-installation. Reboot your system as indicated

 

5.) Install the native vanilla macOS High Sierra 10.13 AppleGraphicsControl.kext with the appropriate permission in /S/L/E/ by means of Kext Utility.

 

To install the new officially distributed Nvidida 10.13 Web Driver Package, perform the following steps:

 

1.) Download and install the Nvidia 10.13 Web Driver Package. Ignore the error message during installation and proceed with the Web Driver Installation until you are asked to reboot the system. Don't reboot the system yet as requested!

 

2.) Download, unzip and run the AGDPfix.app attached below to avoid the black screen problem on reboot. Be patient, it takes some time to apply the fix. Once the fix has been successfully applied, you will get another notification to reboot your system.

 

3.) Now reboot the system. On system startup you should have a fully working 10.13 Nvidia Web Driver with OpenGL and Metal 2 support!

AGDPfix.app.zip

post-1362934-0-47024900-1506488556_thumb.png

post-1362934-0-68019300-1506488589_thumb.png

Share this post


Link to post
Share on other sites

 

5.) Install the native vanilla macOS High Sierra 10.13 AppleGraphicsControl.kext with the appropriate permission in /S/L/E/ by means of Kext Utility.

 

Hello, I don't understand this step............ If I have installed already 10.13, isn't this "AppleGraphicsControl.kext" already loaded ? If not, where do I get it ?

Thanks

Share this post


Link to post
Share on other sites

Hello, I don't understand this step............ If I have installed already 10.13, isn't this "AppleGraphicsControl.kext" already loaded ? If not, where do I get it ?

Thanks

 

This step is not required if you did not use the 10.12.6 Web Driver Workaround before under 10.13 or you just performed a macOS 10.13 clean install.

In this case, you can skip all points related to the removal of the 10.12.6 Web Driver Workaround! 

Share this post


Link to post
Share on other sites

Great to see Nvidia delivered on release day.

 

I upgraded a clone of my Sierra partition to HS, the webdriver update popped up to install it.

 

After some more updates to lilu and AppleALC and Clover of course, I had a fully working system.  :thumbsup_anim:

Share this post


Link to post
Share on other sites

New now officially released macOS High Sierra 10.13 Nvidia Web Driver just works flawless!

 

Departing from the previous 10.12.6 Web Driver workaround I performed the following steps.

 

 

To uninstall the 10.12.6 NVIDIA Web Driver and the NVIDIA Driver Manager, follow the steps below:

 

 

1.) Open the NVIDIA Driver Manager in the menu bar item.

 

 

2.) Click on the padlock icon and enter your Administrator password.

 

 

3.) Click the Open Uninstaller button.

 

 

4.) Click Uninstall and continue with the de-installation. Reboot your system as indicated

 

 

5.) Install the native vanilla macOS High Sierra 10.13 AppleGraphicsControl.kext with the appropriate permission in /S/L/E/ by means of Kext Utility.

 

To install the new officially distributed Nvidida 10.13 Web Driver Package, perform the following steps:

 

1.) Download and install the Nvidia 10.13 Web Driver Package. Ignore the error message during installation and proceed with the Web Driver Installation until you are asked to reboot the system. Don't reboot the system yet as requested!

 

2.) Download, unzip and run the AGDPfix.app attached below to avoid the black screen problem on reboot. Be patient, it takes some time to apply the fix. Once the fix has been successfully applied, you will get another notification to reboot your system.

 

3.) Now reboot the system. On system startup you should have a fully working 10.13 Nvidia Web Driver with OpenGL and Metal 2 support!

This worked for me. Installed new driver, ran ADGP fix rebooted and all good.

Didn't need to remove old work around as I wasn't using it.

 

Edit: reinstalled original AppleGraphicControl kext with kext Utility, rebuilt kext cache, rebooted and still had display. I did add NVWebDriverLibValFix though.

 

post-1083558-0-41596000-1506502196_thumb.png

Share this post


Link to post
Share on other sites

for now I am not be able to have my rig working

I am patching manually policy and use old dummykext but no joy at this stage

Are AppleGraphicsDeviceControl and AppleGraphicsDevicePolicy *.kext both loaded by system? I mean, it maybe better to keep our SLE vanilla for this reason (if we're able to); strange is I didn't even touch AGDP to make it works (keeping signature as vanilla), but only using NVWebDriverLibValFix from my EFI. I also not using NvidiaGraphicsFixup yet, and how about try using different "Board-id" or following this workarround:)

 

#EDIT: Oops, I just realized that MBP10,1 board-id is already set to "none" by AGDP.. so there's no reason for me to touch it. For another SMBios'es it maybe by using AGDPFix for solution, sorry.

Share this post


Link to post
Share on other sites

I got a black screen with cursor on my Nvidia 1060GTX I Have last Nvidia web drivers, and also lily and Nvidia graphics fix, but also if I delete the Nvidia fix nothing changes, any tip to fix this please?

Share this post


Link to post
Share on other sites

Thank you 

I am happy....not true at all because I have success only with a dirty installation over 10.12.6

I have used same way to patch policy I ever used manually plus kextutility

 

If I have time I will try again a clean installation

 

 

Are AppleGraphicsDeviceControl and AppleGraphicsDevicePolicy *.kext both loaded by system? I mean, it maybe better to keep our SLE vanilla for this reason (if we're able to); strange is I didn't even touch AGDP to make it works (keeping signature as vanilla), but only using NVWebDriverLibValFix from my EFI. I also not using NvidiaGraphicsFixup yet, and how about try using different "Board-id" or following this workarround:)

 

#EDIT: Oops, I just realized that MBP10,1 board-id is already set to "none" by AGDP.. so there's no reason for me to touch it. For another SMBios'es it maybe by using AGDPFix for solution, sorry.

 


ah..for now very poor performance..but I have many confusion in my patches..so it is my fault because in HS GM my cpu was performance as usually


ah ah ah big problem new cuda is not good...

post-468967-0-16034500-1506503559_thumb.png

post-468967-0-66581500-1506503865_thumb.png

Share this post


Link to post
Share on other sites

I installed lastest web drivers, but when the system boot, it will reboot every time i try (even with nv_disable=1)... It's the first time i install osx on this computer (SMbios imac 18.1)...

I tried nvdagraphicsfixup and NVWebDriverLibValFix but nothing... What can i do? Thanks

Share this post


Link to post
Share on other sites

I installed lastest web drivers, but when the system boot, it will reboot every time i try (even with nv_disable=1)... It's the first time i install osx on this computer (SMbios imac 18.1)...

I tried nvdagraphicsfixup and NVWebDriverLibValFix but nothing... What can i do? Thanks

Make sure you have latest Lilu.kext and EmuVariableUefi-64 in Drivers64UEFI

 

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

Make sure you have latest Lilu.kext and EmuVariableUefi-64 in Drivers64UEFI

 

Sent from my SM-G930F using Tapatalk

Thanks! I was missing EmuVariableUefi-64! Now works perfectly

 

Inviato dal mio MI 5 utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Black screen after installing new High Sierra NVIDIA driver and applying AGDP fix on new install of High Sierra. I have also installed LILU and NvidiaGraphicsFixup. My card is GTX 970. iMac 17.1. The system seems to hand over to the Nvidia card, and monitor shows a signal is being received, but screen is black. With the black screen problem in Sierra, the monitor screen was black but this was because no signal was being received. This is a different problem.
Any suggestions will be welcome.

Share this post


Link to post
Share on other sites

i got black screen using gtx 750ti and no signal on gtx 960 using a gtx 650 i got the system that goes black screen and then reships new lines in -v log, i am using all the same settings i use to get top work web drivers in sierra, including use web drivers check and also nvda_drv=1 boot arg, i am also using all the needed drivers in drivers 64 uefi, and i am trying with 2 testing partitions, one with apfs and one without

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By fantomas1
      Hi InsanelyMacaholics   

      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS Sierra.
       
      10.12.6
      Nvidia Web Driver - 378.05.05.25f13 --> build 16G1815 (thanks to flowrider) New!
      Nvidia Web Driver - 378.05.05.25f12 --> build 16G1710 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f11 --> build 16G1618 (thanks to Frank Nitty)
      Nvidia Web Driver - 378.05.05.25f10 --> build 16G1510 (thanks to BreBo) 
      Nvidia Web Driver - 378.05.05.25f09 --> build 16G1408 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f08 --> build 16G1314 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f07 --> build 16G1314 (thanks to haring)
      Nvidia Web Driver - 378.05.05.25f06 --> build 16G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 378.05.05.25f04 --> build 16G1114 (thanks to lukazm)
      Nvidia Web Driver - 378.05.05.25f03 --> build 16G1036 (thanks to Gradou)
      Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to Badruzeus)
       
       
      10.12.5
      Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)
       
       
      10.12.4
      Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)
      Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr)  Pascal support!!!
      Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)
       
       
      10.12.3

      Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)
       
       
      10.12.2
      Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)
      Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)
      Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)
       
       
      10.12.1
      Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).
      Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)
       
       
      10.12.0
      Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)
       
       
      GM
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)
       
       
      DP/PB
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun) 
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun)
      Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)
       
    • By fantomas1
      hi people  
       
      you can use this thread to link / talk about of the future Nvidia Web Driver updates for El Capitan
       
      10.11.6
      Nvidia Web Driver - 346.03.15f16 --> build 15G22010 (thanks to BreBo)  New!
      Nvidia Web Driver - 346.03.15f15 --> build 15G21013 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.15f14 --> build 15G20015 (thanks to DMCrimson)
      Nvidia Web Driver - 346.03.15f13 --> build 15G20015 (thanks to Louvier)
      Nvidia Web Driver - 346.03.15f12 --> build 15G19009 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f11 --> build 15G18013 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f10 --> build 15G17023 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f09 --> build 15G1611 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f08 --> build 15G1510 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f07 --> build 15G1421 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f06 --> build 15G1217 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f05 --> build 15G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f04 --> build 15G1108 (see this post)
      Nvidia Web Driver - 346.03.15f03 --> build 15G1004 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f02 --> build 15G31 (thanks to Moviemakergr)
      Nvidia Web Driver - 346.03.15f01 --> build 15G31 (thanks to WeBeRiO)
      [uPDATE_3]Nvidia Web Driver - 346.03.15b01 --> build 15G24b (thanks to DMCrimson)
       
      10.11.5
      Nvidia Web Driver - 346.03.10f02 --> build 15F34 (thanks to marcozardi)
      Nvidia Web Driver - 346.03.10f01 --> build 15F34 (thanks to WeBeRiO)
      [uPDATE_2] Nvidia Web Driver - 346.03.10b01 --> build 15F31a (see this post)
       
      10.11.4
      Nvidia Web Driver - 346.03.06f01 --> build 15E65 (see this post)
      Nvidia Web Driver - 346.03.06b01 --> build 15E (see this post)
       
      10.11.3
      Nvidia Web Driver - 346.03.05f02 --> second release for build 15D21 (thanks to Fljagd)
      Nvidia Web Driver - 346.03.05f01  --> build 15D21 (see this post)
      Nvidia Web Driver - 346.03.05b02 --> build 15D (see this post)
       
      10.11.2
      Nvidia Web Driver - 346.03.04f02 --> second public release (see this post)
      Nvidia Web Driver - 346.03.04f01 --> build 15C50 (see this post)  
      Nvidia Web Driver - 346.03.04b02 --> build 15C48a (see this post) 
      Nvidia Web Driver - 346.03.04b01 --> build 15C47a (see this post)
       
      10.11.1
      Nvidia Web Driver - 346.03.03f02 --> second public release (see this post) 
      Nvidia Web Driver - 346.03.03f01 --> build 15B42 (thanks to jperkins909)
       
      10.11.0
      Nvidia Web Driver - 346.03.02f02 --> build 15A284 (thanks to MTWomg)
      Nvidia Web Driver - 346.03.02f01 --> build 15A284 (see this post)
       
      DP
      Nvidia Web Driver - 346.03.01b07 --> GM/DB/PB6/DB7/PB5 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.01b06 --> build 15A (thanks to MTWomg) 
    • By ivanmacx85
      NVIDIA ha rilasciato i driver grafici per macOS High Sierra 10.13

      Questi driver sono attualmente l’unico metodo per ottenere l’accelerazione grafica delle schede:

      -Pascal   GTX 1050, 1050 Ti, 1060, 1070, 1080, 1080 Ti, TITAN Xp
      -Maxwell GTX 750, 750 Ti, 950, 960, 970, 980, 980 Ti, TITAN X


       
      Per disinstallare i vecchi WebDriver attenersi alla seguente procedura: 

      1.) Aprire l'NVIDIA Driver Manager nella voce della barra dei menu.

      2.) Fare clic sull'icona del lucchetto e immettere la password dell'amministratore.

      3.) Fare clic sul pulsante disinstallazione.

      4.) Fare clic su disinstalla e continuare con la disinstallazione. Riavviare il sistema come indicato

      5.) Installare la versione originale del kext AppleGraphicsControl.kext (solo se lo avevate modificato in precedenza) in / S / L / E / tramite Kext Utility

      Ignorate questi passaggi se venite da un'installazione pulita di High Sierra


      Per installare il nuovo pacchetto WebDriver NVIDIA 10.13 distribuito ufficialmente, procedere come segue:

      1.) Scaricare e installare il pacchetto NVIDIA WebDriver HighSierra 10.13.pkg Durante l'installazione comparirà un messaggio di errore, ignoratelo e continuare l'installazione finché non vi verrà richiesto di riavviare il sistema.

      2.) Solo per chi ha smbios iMac 15,1 - iMac 17,1 - MacPro 6.1 Prima di riavviare mettere nella cartella kext other NVWebDriverLibValFix.kext.zip, NvidiaGraphicsFixup.kext.zip e Lilu.kext per evitare il problema dello schermo nero dopo l'avvio del sistema
       
      3.) In alcuni casi è necessario impostare nel file .config il SIP (CsrActiveConfig) su 0x3

      4.) Ora riavviate il sistema. Al momento dell'avvio del sistema, avrete il WebDriver Nvidia completamente funzionante con supporto OpenGL e Metal 2


    • By spec3
      ciao, 
       
      Ho appena acquistato una GTX 980, ho due partizioni , una con Sierra . e una con Yosemite, su Sierra ho installato i Web driver , messo webdriver al config.plist e tutto funziona a dovere. In Yosemite ho fatto la stessa cosa, al riavvio  non sono  piu  riuscito ad entrare nel sistema operativo, ovviamente ho usato le versioni dedicate per ogni sistema operativo a meno che non mi sia confuso e ho installato i driver sbagliati. Per rientrare ho provato di tutto, safe mode, staccando l'nvidia , provando ad entrare con l'intel integrata, provato a cambiare SMBIOS dalla partizione di Sierra.
       
      Come posso rientrare nel sistema? ce un modo per eliminare i driver manualmente da un altra partizione?
       
      grazie

    • By imatefx
      I have a nvidia gt425M on my asus n53jq laptop almost everything is working correctly audio , lan , wifi
      even display is detected , I was not using nvidia web driviers on el capitan
       
      Only some windows and desktop background are distorted the resolution is 1920x1080, 
      The Video ram is 1024 MB but the "About mac" window shows only 1023 MB 
       

       
      Can someone help me out.
×