Jump to content
fantomas1

Nvidia Web Driver updates for macOS High Sierra (UPDATE December 7, 2018)

1,769 posts in this topic

Recommended Posts

Guys,

im confused, is NVDA Startup supposed to load when Webdrivers are loaded?

I can see both startup loaded on my hack, see picture

Also how can I check if Webdrivers are loaded correctly?

Screen Shot 2018-04-18 at 18.14.19.png

Share this post


Link to post
Share on other sites
Advertisement

I don't know hot to enable this {censored} nvidia drivers on my system.

I've installed latest drivers and it always boots in compatible mode (Default macOS Graphics Driver) instead of NVIDIA Web Driver.

I tried to switch different OsxAptioFix efis, tried to boot with or without NvidiaGraphicsFixup (1.2.6).

I have <key>NvidiaWeb</key><true/> in my config.

What i'm doing wrong? Guys, help please.

 

My system: H110M PRO VD, GTX 1060, macOS 10.13.4.

Share this post


Link to post
Share on other sites

I've been seeing more and more reports that the major issues with the 387 drivers have been fixed in the latest release, so it's probably worth trying to run without the NvidiaGraphicsFixup kext to confirm.  If the drivers have been fixed (or even just changed) there's no telling what the hack in that kext will do if you try and use it with the new drivers.

Share this post


Link to post
Share on other sites
6 hours ago, Moviemakergr said:

thank you , but is not usefull ... dont boot ... rest in black screen and nothing happening ... only bios reset help to boot again ...

Share this post


Link to post
Share on other sites

I have an issue with the 387.10.10.10.30.106 driver - Firefox stops rendering pages after some time. There was no such issue with the 387.10.10.10.25.160 driver.

Share this post


Link to post
Share on other sites
I've been seeing more and more reports that the major issues with the 387 drivers have been fixed in the latest release, so it's probably worth trying to run without the NvidiaGraphicsFixup kext to confirm.  If the drivers have been fixed (or even just changed) there's no telling what the hack in that kext will do if you try and use it with the new drivers.

I built NvidiaGraphicsFixUp.kext 1.2.7 (doesn't have lag fix in it) from source and can confirm no more lag with 387.10.10.10.30.106 on 10.13.5 beta 2.

 

Sent from my SM-G930F using Tapatalk

 

 

 

Share this post


Link to post
Share on other sites

did the 387.10.10.10.30.106  Nividia update on my 10.3.4 MacOs version and no more lag

 

Finaly!

Share this post


Link to post
Share on other sites
19 minutes ago, himac59 said:

did the 387.10.10.10.30.106  Nividia update on my 10.3.4 MacOs version and no more lag

 

Finaly!

w/o NvidiaGraphicsFixup?

Share this post


Link to post
Share on other sites
11 hours ago, arabesc said:

I have an issue with the 387.10.10.10.30.106 driver - Firefox stops rendering pages after some time. There was no such issue with the 387.10.10.10.25.160 driver.

Make sure your Intel Graphics runs in connector-less mode.

Share this post


Link to post
Share on other sites

Finding the new driver works well (without the fix kext installed), although not perfect.

i played a WMV video file in VLC last night and had weird graphical breaks across the screen (like something hit glass at a specific point and breaking in pieces). Have a 5 sec video demonstrating it but it’s apparently too big to attach.

Share this post


Link to post
Share on other sites
Posted (edited)

Using YACReaderLibrary for a while suddenly all the comic covers were corrupt, and now so is Safari.

 

NvFeHZb.png

Which on screen now looks like on my screen

IThWXRb.jpg

(swapped to mobile safari as Mac now messed up)

Edited by tarasis

Share this post


Link to post
Share on other sites
8 hours ago, SavageAUS said:

I built NvidiaGraphicsFixUp.kext 1.2.7 (doesn't have lag fix in it) from source and can confirm no more lag with 387.10.10.10.30.106 on 10.13.5 beta 2.

 

Sent from my SM-G930F using Tapatalk

 

 

 

Also good here with 1.2.6 and ngfxsubmit=0.

Share this post


Link to post
Share on other sites
4 hours ago, tarasis said:

Using YACReaderLibrary for a while suddenly all the comic covers were corrupt, and now so is Safari.

 

NvFeHZb.png

Which on screen now looks like on my screen

IThWXRb.jpg

(swapped to mobile safari as Mac now messed up)

thats art. I like it

Share this post


Link to post
Share on other sites
4 hours ago, tarasis said:

Which on screen now looks like on my screen

Are you sure that web driver is loaded and active? I have similar artifacts when default driver is working.

Share this post


Link to post
Share on other sites
3 hours ago, arabesc said:

Are you sure that web driver is loaded and active? I have similar artifacts when default driver is working.

Seems to be 

[21:36][rob@iMac:~]$ kextstat | grep nvidia
  118    2 0xffffff7f80c1a000 0x679000   0x679000   com.nvidia.web.NVDAResmanWeb (10.3.1) 8E2AB3E3-4EE5-3F90-B6D8-54CEB8595A5F <110 101 100 12 7 5 4 3 1>
  119    0 0xffffff7f815be000 0x1a7000   0x1a7000   com.nvidia.web.NVDAGP100HalWeb (10.3.1) 0CDFBF48-5CD7-3C97-A083-A7E179C25654 <118 12 4 3>
  122    0 0xffffff7f81942000 0xa8000    0xa8000    com.nvidia.web.GeForceWeb (10.3.1) B4761F6B-66C5-3512-BD13-2CCC7BCC1868 <121 118 101 100 12 7 5 4 3 1>
  160    0 0xffffff7f81a46000 0x2000     0x2000     com.nvidia.CUDA (1.1.0) 4329B052-6C8A-3900-8E83-744487AEDEF1 <4 1>

 

3 hours ago, MICKHAEL said:

thats art. I like it

Yeah on the covers it was quite pretty, didn't mind it there, but once it spread to the desktop and browser it was pretty ugly and hard to work with.

Share this post


Link to post
Share on other sites
3 hours ago, tarasis said:

Seems to be 


[21:36][rob@iMac:~]$ kextstat | grep nvidia
  118    2 0xffffff7f80c1a000 0x679000   0x679000   com.nvidia.web.NVDAResmanWeb (10.3.1) 8E2AB3E3-4EE5-3F90-B6D8-54CEB8595A5F <110 101 100 12 7 5 4 3 1>
  119    0 0xffffff7f815be000 0x1a7000   0x1a7000   com.nvidia.web.NVDAGP100HalWeb (10.3.1) 0CDFBF48-5CD7-3C97-A083-A7E179C25654 <118 12 4 3>
  122    0 0xffffff7f81942000 0xa8000    0xa8000    com.nvidia.web.GeForceWeb (10.3.1) B4761F6B-66C5-3512-BD13-2CCC7BCC1868 <121 118 101 100 12 7 5 4 3 1>
  160    0 0xffffff7f81a46000 0x2000     0x2000     com.nvidia.CUDA (1.1.0) 4329B052-6C8A-3900-8E83-744487AEDEF1 <4 1>

 

Yeah on the covers it was quite pretty, didn't mind it there, but once it spread to the desktop and browser it was pretty ugly and hard to work with.

From one of your post I saw that you are not using the new kexts? Did you install latest Nvidiagraphicsfixup and lilu?

Those are mine if you want to test.

Lilu ver 1.2.3 & Nvidiablabla.. ver 1.2.6

 

Kexts.zip

Share this post


Link to post
Share on other sites
Posted (edited)

Is that a correct Nvidia startup??

 

Mac-Pro:~ kobi$ kextstat | grep nvidia

  102    0 0xffffff7f81866000 0x3000     0x3000     com.nvidia.NVDAStartupWeb (10.3.1) AD2D7E86-4977-3447-BC96-D3C6EA88EEA8 <12 4 3>

  121    0 0xffffff7f83fb6000 0x3000     0x3000     com.apple.nvidia.NVDAStartup (10.3.0) 7F5D85C5-F712-3348-B5F0-77D6EF95E071 <12 4 3>

  145    2 0xffffff7f80b90000 0x679000   0x679000   com.nvidia.web.NVDAResmanWeb (10.3.1) 8E2AB3E3-4EE5-3F90-B6D8-54CEB8595A5F <133 111 109 12 7 5 4 3 1>

  146    0 0xffffff7f81966000 0x15e000   0x15e000   com.nvidia.web.NVDAGK100HalWeb (10.3.1) BC0C27F0-12AF-36CA-AC52-ACD84F718B30 <145 12 4 3>

  147    0 0xffffff7f8171e000 0xa8000    0xa8000    com.nvidia.web.GeForceWeb (10.3.1) B4761F6B-66C5-3512-BD13-2CCC7BCC1868 <145 133 113 109 12 7 5 4 3 1>

  161    0 0xffffff7f81822000 0x2000     0x2000     com.nvidia.CUDA (1.1.0) 4329B052-6C8A-3900-8E83-744487AEDEF1 <4 1>

 

Why "com.apple.nvidia.NVDAStartup" is loading? is that supposed to be load when Nvidia Webdrivers are loaded?

 

it docent matter , disable Apple NVDAStartup but my system crashing when using AE plugins such as Mocha and others, also crashing in general when using HW acceleration by the GPU...

When using Apple drivers everything seems to work fine no crashing however no acceleration from GPU...

Edited by ergot

Share this post


Link to post
Share on other sites
12 hours ago, Peke said:

From one of your post I saw that you are not using the new kexts? Did you install latest Nvidiagraphicsfixup and lilu?

Those are mine if you want to test.

Lilu ver 1.2.3 & Nvidiablabla.. ver 1.2.6

Cheers, I had Lilu ver 1.2.3 there but had removed NvidiaGraphicsFixup as people were reporting it working well without it. I'll give 1.2.6 and 1.2.7 a try.

Note since I rebooted, the problems hasn't cropped up again yet BUT I didn't try recreating the problem again.

Share this post


Link to post
Share on other sites
Posted (edited)

UPDATE: in 30.106 I still get system crashes in FCPX (forced reboot) *if* I have my 6700k's iGPU enabled in the BIOS. If I disable it in the BIOS, it seems the graphical render artifacts in FCPX are gone, the crashes are gone (at least in the first 10 minutes of testing), and the stutter when playing back 2.5k video is gone. This is great! This system appears to be usable again for me. Again, I'm running dual 1080 Ti cards in an SLI config. This is a huge improvement from what I was seeing in 30.103. Thanks, nvidia devs!

 

UPDATE2: I am still seeing graphical artifacts in the timeline in FCPX. My playback indicator (vertical red line) shows up multiple times as it scrubs along the timeline. It's failing to erase itself. Also, highlighting a clip is unreliable. Part or none of the clip will be highlighted in yellow when I click on it. However, these are relatively minor issues and I can work around them.

Edited by createthis

Share this post


Link to post
Share on other sites
On 19-4-2018 at 7:43 AM, ellaosx said:

w/o NvidiaGraphicsFixup?

yes

w/o

Share this post


Link to post
Share on other sites

Is a multi-Monitor setup now possible without NvidiaGraphicsFixup, if you're using a newer SMBIOS then iMac14,2 and don't patch the APDP?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fantomas1
      Hi InsanelyMacaholics   

      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS Sierra.
       
      10.12.6
      Nvidia Web Driver - 378.05.05.25f12 --> build 16G1710 (thanks to BreBo) New!
      Nvidia Web Driver - 378.05.05.25f11 --> build 16G1618 (thanks to Frank Nitty)
      Nvidia Web Driver - 378.05.05.25f10 --> build 16G1510 (thanks to BreBo) 
      Nvidia Web Driver - 378.05.05.25f09 --> build 16G1408 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f08 --> build 16G1314 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f07 --> build 16G1314 (thanks to haring)
      Nvidia Web Driver - 378.05.05.25f06 --> build 16G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 378.05.05.25f04 --> build 16G1114 (thanks to lukazm)
      Nvidia Web Driver - 378.05.05.25f03 --> build 16G1036 (thanks to Gradou)
      Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to Badruzeus)
       
       
      10.12.5
      Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)
       
       
      10.12.4
      Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)
      Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr)  Pascal support!!!
      Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)
       
       
      10.12.3

      Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)
       
       
      10.12.2
      Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)
      Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)
      Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)
       
       
      10.12.1
      Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).
      Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)
       
       
      10.12.0
      Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)
       
       
      GM
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)
       
       
      DP/PB
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun) 
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun)
      Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)
       
    • By fantomas1
      hi people  
       
      you can use this thread to link / talk about of the future Nvidia Web Driver updates for El Capitan
       
      10.11.6
      Nvidia Web Driver - 346.03.15f16 --> build 15G22010 (thanks to BreBo)  New!
      Nvidia Web Driver - 346.03.15f15 --> build 15G21013 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.15f14 --> build 15G20015 (thanks to DMCrimson)
      Nvidia Web Driver - 346.03.15f13 --> build 15G20015 (thanks to Louvier)
      Nvidia Web Driver - 346.03.15f12 --> build 15G19009 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f11 --> build 15G18013 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f10 --> build 15G17023 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f09 --> build 15G1611 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f08 --> build 15G1510 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f07 --> build 15G1421 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f06 --> build 15G1217 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f05 --> build 15G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f04 --> build 15G1108 (see this post)
      Nvidia Web Driver - 346.03.15f03 --> build 15G1004 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f02 --> build 15G31 (thanks to Moviemakergr)
      Nvidia Web Driver - 346.03.15f01 --> build 15G31 (thanks to WeBeRiO)
      [uPDATE_3]Nvidia Web Driver - 346.03.15b01 --> build 15G24b (thanks to DMCrimson)
       
      10.11.5
      Nvidia Web Driver - 346.03.10f02 --> build 15F34 (thanks to marcozardi)
      Nvidia Web Driver - 346.03.10f01 --> build 15F34 (thanks to WeBeRiO)
      [uPDATE_2] Nvidia Web Driver - 346.03.10b01 --> build 15F31a (see this post)
       
      10.11.4
      Nvidia Web Driver - 346.03.06f01 --> build 15E65 (see this post)
      Nvidia Web Driver - 346.03.06b01 --> build 15E (see this post)
       
      10.11.3
      Nvidia Web Driver - 346.03.05f02 --> second release for build 15D21 (thanks to Fljagd)
      Nvidia Web Driver - 346.03.05f01  --> build 15D21 (see this post)
      Nvidia Web Driver - 346.03.05b02 --> build 15D (see this post)
       
      10.11.2
      Nvidia Web Driver - 346.03.04f02 --> second public release (see this post)
      Nvidia Web Driver - 346.03.04f01 --> build 15C50 (see this post)  
      Nvidia Web Driver - 346.03.04b02 --> build 15C48a (see this post) 
      Nvidia Web Driver - 346.03.04b01 --> build 15C47a (see this post)
       
      10.11.1
      Nvidia Web Driver - 346.03.03f02 --> second public release (see this post) 
      Nvidia Web Driver - 346.03.03f01 --> build 15B42 (thanks to jperkins909)
       
      10.11.0
      Nvidia Web Driver - 346.03.02f02 --> build 15A284 (thanks to MTWomg)
      Nvidia Web Driver - 346.03.02f01 --> build 15A284 (see this post)
       
      DP
      Nvidia Web Driver - 346.03.01b07 --> GM/DB/PB6/DB7/PB5 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.01b06 --> build 15A (thanks to MTWomg) 
    • By ivanmacx85
      NVIDIA ha rilasciato i driver grafici per macOS High Sierra 10.13

      Questi driver sono attualmente l’unico metodo per ottenere l’accelerazione grafica delle schede:

      -Pascal   GTX 1050, 1050 Ti, 1060, 1070, 1080, 1080 Ti, TITAN Xp
      -Maxwell GTX 750, 750 Ti, 950, 960, 970, 980, 980 Ti, TITAN X


       
      Per disinstallare i vecchi WebDriver attenersi alla seguente procedura: 

      1.) Aprire l'NVIDIA Driver Manager nella voce della barra dei menu.

      2.) Fare clic sull'icona del lucchetto e immettere la password dell'amministratore.

      3.) Fare clic sul pulsante disinstallazione.

      4.) Fare clic su disinstalla e continuare con la disinstallazione. Riavviare il sistema come indicato

      5.) Installare la versione originale del kext AppleGraphicsControl.kext (solo se lo avevate modificato in precedenza) in / S / L / E / tramite Kext Utility

      Ignorate questi passaggi se venite da un'installazione pulita di High Sierra


      Per installare il nuovo pacchetto WebDriver NVIDIA 10.13 distribuito ufficialmente, procedere come segue:

      1.) Scaricare e installare il pacchetto NVIDIA WebDriver HighSierra 10.13.pkg Durante l'installazione comparirà un messaggio di errore, ignoratelo e continuare l'installazione finché non vi verrà richiesto di riavviare il sistema.

      2.) Solo per chi ha smbios iMac 15,1 - iMac 17,1 - MacPro 6.1 Prima di riavviare mettere nella cartella kext other NVWebDriverLibValFix.kext.zip, NvidiaGraphicsFixup.kext.zip e Lilu.kext per evitare il problema dello schermo nero dopo l'avvio del sistema
       
      3.) In alcuni casi è necessario impostare nel file .config il SIP (CsrActiveConfig) su 0x3

      4.) Ora riavviate il sistema. Al momento dell'avvio del sistema, avrete il WebDriver Nvidia completamente funzionante con supporto OpenGL e Metal 2


    • By spec3
      ciao, 
       
      Ho appena acquistato una GTX 980, ho due partizioni , una con Sierra . e una con Yosemite, su Sierra ho installato i Web driver , messo webdriver al config.plist e tutto funziona a dovere. In Yosemite ho fatto la stessa cosa, al riavvio  non sono  piu  riuscito ad entrare nel sistema operativo, ovviamente ho usato le versioni dedicate per ogni sistema operativo a meno che non mi sia confuso e ho installato i driver sbagliati. Per rientrare ho provato di tutto, safe mode, staccando l'nvidia , provando ad entrare con l'intel integrata, provato a cambiare SMBIOS dalla partizione di Sierra.
       
      Come posso rientrare nel sistema? ce un modo per eliminare i driver manualmente da un altra partizione?
       
      grazie

    • By imatefx
      I have a nvidia gt425M on my asus n53jq laptop almost everything is working correctly audio , lan , wifi
      even display is detected , I was not using nvidia web driviers on el capitan
       
      Only some windows and desktop background are distorted the resolution is 1920x1080, 
      The Video ram is 1024 MB but the "About mac" window shows only 1023 MB 
       

       
      Can someone help me out.
×