Jump to content
fantomas1

Nvidia Web Driver updates for macOS High Sierra (UPDATE December 7, 2018)

1,769 posts in this topic

Recommended Posts

I’ll post when I’d get back

Do these scores look normal? Well except cinebench

 

Depend's on your graphics card, but I would say YES.. 

Share this post


Link to post
Share on other sites
Advertisement

i just noticed that my pcie width length ix only at 8x

your is at 16x any ideas?

i only have one card installed it should be at 16x 

Share this post


Link to post
Share on other sites

i just noticed that my pcie width length ix only at 8x

your is at 16x any ideas?

i only have one card installed it should be at 16x 

 

The GPU is in slot 1 which support x16? Please check your manual!  

Share this post


Link to post
Share on other sites

It’s 16x but only running at 8x weird

This is my metal scores

How’s your opengl test

 

Great that you can confirm a Metal score clearly above 215.000!  For my OpenGL see #846.. Everything looks very consistent and confirms my previous results! Full Metal 2 support with Nvidia 10.13.1 Web Driver!

Difference between Metal 1 and Metal 2: more than 100.000 scores (>200%)!  

Share this post


Link to post
Share on other sites

Great that you can confirm a Metal score clearly above 215.000!  For my OpenGL see #846.. Everything looks very consistent and confirms my previous results! Full Metal 2 support with Nvidia 10.13.1 Web Driver!

Difference between Metal 1 and Metal 2: more than 100.000 scores (>200%)!  

have you 2 options ? metal1 and metal2 ?  i have just one ...metal ...in geekbench 4.2

Share this post


Link to post
Share on other sites

Hi,

 

I have problems with my new EVGA GTX1060 and 2 monitors on mixed connection DVI / Display Port. The GPU has 1 DVI and 3 display ports.

Boot runs complete, but ends in black screens. This is not a black screen issue, the system is not running in the end. Perhaps after a while a reboot would occur, I did not wait very long.

 

What works:

2 Monitors on Display Ports, but then 1 monitor is recognized as NTSC/television - this is the main problem

1 monitor, DVI or Display Port

Boot with DVI monitor, plug in second monitor in Display Port after boot runs fine.

 

Installed:

OS X 13.1, latest NVIDIA Drivers

Lilu 1.2.1, NvidiaGraphicsFixup 1.2.1, Clover r4289

 

Tried:

Check NvidiaWeb

nvda_drv=1

EmuvariableUEFI

 

I dont know what is easier: Solve boot problem or solve NTSC/television problem. Any suggestions somebody?

Thanks in advance.

Share this post


Link to post
Share on other sites

have you 2 options ? metal1 and metal2 ?  i have just one ...metal ...in geekbench 4.2

 

Why 2 options ?... Did you ever read the previous posts? The message was the follwing:

 

Apparently in all previous version of the Nvidia Web Driver there was no support for Metal 2 (just Metal 1 so far). Now with the 10.13.1 Web Driver, this has changed! Full support of Metal 2 for supposedly all Pascal and Maxwell Nvidia Graphics cards!

 

The previous posts above are not about different options for Geekbench 4.2.0 Metal Benchmarks! In case of Metal 1 support, the Geekbench Metal Scores have been in the order of 90.000. Now with Metal 2 support, the scores exceed 200.000 by far. 

 

That's all... 

 

I hope you finally caught the message and idea... 

Share this post


Link to post
Share on other sites

Sorry for the noob question but what is the

Nvidia Payload Packager for exactly?

I have a gtx 979 i7 4970 and I was able to update via App Store from 10.12.6 to 10.13.1

Then it it told me there was a update for nvidia web divers I updated that way and everything seems okay so far

The only thing is that it dropped some FPS from cinebench from 90s to 70s but it also enabled metal 2

Thanks

Share this post


Link to post
Share on other sites

Sorry for the noob question but what is the

Nvidia Payload Packager for exactly?

I have a gtx 979 i7 4970 and I was able to update via App Store from 10.12.6 to 10.13.1

Then it it told me there was a update for nvidia web divers I updated that way and everything seems okay so far

The only thing is that it dropped some FPS from cinebench from 90s to 70s but it also enabled metal 2

Thanks

It's to extract the files in the Nvidia package, modify and repack the files for use with macOS beta's.

 

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

It's to extract the files in the Nvidia package, modify and repack the files for use with macOS beta's.

 

Sent from my SM-G930F using Tapatalk

Okay thank you for response!

Share this post


Link to post
Share on other sites

Hi,

I've a Mac 6.1 (not an Hack) with Nvidia 980 Ti.

Yesterday I've update my Sierra to High Sierra 10.13.1.

 

I've update also the Web Drivers with the latest version ..107.

I've the black screen when reboot the Mac with Nvidia.

I hear the bong, but the screen remain black !!!
 

I've tried the PRAM reset ... nothing.

 

Please help me  :-(((

Share this post


Link to post
Share on other sites

Huge jump in Metal Scores.

 

 

@d5aqoep

 

sorry for a Off-Topic Question.. but may i ask you why you are using IMac 18.3 and not 17.1 ?

Is it because performance better on 18.3 Or? (I thought for i7 6700K the iMac 17.1 would be better choice?)

Share this post


Link to post
Share on other sites

If you boot in safe mode does it work? 

 

Hi PPCnostalgic, what do you mean exactly.

Can you explain me the steps, so I cannot wrong ?

Thanks.

 

Share this post


Link to post
Share on other sites

Huge jump in Metal Scores.

 

 

@d5aqoep

 

sorry for a Off-Topic Question.. but may i ask you why you are using IMac 18.3 and not 17.1 ?

Is it because performance better on 18.3 Or? (I thought for i7 6700K the iMac 17.1 would be better choice?)

 

I am using 18.3 because I love higher numbers (purely for the lulz) 17.1 or 18.3 made no difference on my system. I just make sure that CPU idles at 0.8 Ghz and Maxes out at 4.2 Ghz. This was happening with iMac 18.3 profile so left it at that. For both I have to use lilu and graphics fixup kexts.

 

BTW I am using GTX 1080ti and have also purchased a licensed copy of GeekBench. It was on 50% discounted price so buying it was no-brainer.

I send an email to developers complaining about their high software prices and then they usually send 30-50% one-time discount coupons. This strategy has worked well so far.

Share this post


Link to post
Share on other sites

 

 

I am using 18.3 because I love higher numbers (purely for the lulz) 17.1 or 18.3 made no difference on my system. I just make sure that CPU idles at 0.8 Ghz and Maxes out at 4.2 Ghz. This was happening with iMac 18.3 profile so left it at that. For both I have to use lilu and graphics fixup kexts.

 

BTW I am using GTX 1080ti and have also purchased a licensed copy of GeekBench. It was on 50% discounted price so buying it was no-brainer.

I send an email to developers complaining about their high software prices and then they usually send 30-50% one-time discount coupons. This strategy has worked well so far.

I use 17,1 on my i7-6700k and never see intel power gadget go above 4ghz.

 

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

why nvidia does not have the compatibility list for the 10xx series ? in any WebDriver for any osx version ?

 

and how I can not pass more than 80000 in tests no matter what I do? I have a 1050 ti and does not want more than 80000? how is it possible for some to go, and to others not?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   1 member

  • Similar Content

    • By fantomas1
      Hi InsanelyMacaholics   

      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS Sierra.
       
      10.12.6
      Nvidia Web Driver - 378.05.05.25f12 --> build 16G1710 (thanks to BreBo) New!
      Nvidia Web Driver - 378.05.05.25f11 --> build 16G1618 (thanks to Frank Nitty)
      Nvidia Web Driver - 378.05.05.25f10 --> build 16G1510 (thanks to BreBo) 
      Nvidia Web Driver - 378.05.05.25f09 --> build 16G1408 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f08 --> build 16G1314 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f07 --> build 16G1314 (thanks to haring)
      Nvidia Web Driver - 378.05.05.25f06 --> build 16G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 378.05.05.25f04 --> build 16G1114 (thanks to lukazm)
      Nvidia Web Driver - 378.05.05.25f03 --> build 16G1036 (thanks to Gradou)
      Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to Badruzeus)
       
       
      10.12.5
      Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)
       
       
      10.12.4
      Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)
      Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr)  Pascal support!!!
      Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)
       
       
      10.12.3

      Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)
       
       
      10.12.2
      Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)
      Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)
      Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)
       
       
      10.12.1
      Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).
      Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)
       
       
      10.12.0
      Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)
       
       
      GM
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)
       
       
      DP/PB
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun) 
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun)
      Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)
       
    • By fantomas1
      hi people  
       
      you can use this thread to link / talk about of the future Nvidia Web Driver updates for El Capitan
       
      10.11.6
      Nvidia Web Driver - 346.03.15f16 --> build 15G22010 (thanks to BreBo)  New!
      Nvidia Web Driver - 346.03.15f15 --> build 15G21013 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.15f14 --> build 15G20015 (thanks to DMCrimson)
      Nvidia Web Driver - 346.03.15f13 --> build 15G20015 (thanks to Louvier)
      Nvidia Web Driver - 346.03.15f12 --> build 15G19009 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f11 --> build 15G18013 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f10 --> build 15G17023 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f09 --> build 15G1611 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f08 --> build 15G1510 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f07 --> build 15G1421 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f06 --> build 15G1217 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f05 --> build 15G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f04 --> build 15G1108 (see this post)
      Nvidia Web Driver - 346.03.15f03 --> build 15G1004 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f02 --> build 15G31 (thanks to Moviemakergr)
      Nvidia Web Driver - 346.03.15f01 --> build 15G31 (thanks to WeBeRiO)
      [uPDATE_3]Nvidia Web Driver - 346.03.15b01 --> build 15G24b (thanks to DMCrimson)
       
      10.11.5
      Nvidia Web Driver - 346.03.10f02 --> build 15F34 (thanks to marcozardi)
      Nvidia Web Driver - 346.03.10f01 --> build 15F34 (thanks to WeBeRiO)
      [uPDATE_2] Nvidia Web Driver - 346.03.10b01 --> build 15F31a (see this post)
       
      10.11.4
      Nvidia Web Driver - 346.03.06f01 --> build 15E65 (see this post)
      Nvidia Web Driver - 346.03.06b01 --> build 15E (see this post)
       
      10.11.3
      Nvidia Web Driver - 346.03.05f02 --> second release for build 15D21 (thanks to Fljagd)
      Nvidia Web Driver - 346.03.05f01  --> build 15D21 (see this post)
      Nvidia Web Driver - 346.03.05b02 --> build 15D (see this post)
       
      10.11.2
      Nvidia Web Driver - 346.03.04f02 --> second public release (see this post)
      Nvidia Web Driver - 346.03.04f01 --> build 15C50 (see this post)  
      Nvidia Web Driver - 346.03.04b02 --> build 15C48a (see this post) 
      Nvidia Web Driver - 346.03.04b01 --> build 15C47a (see this post)
       
      10.11.1
      Nvidia Web Driver - 346.03.03f02 --> second public release (see this post) 
      Nvidia Web Driver - 346.03.03f01 --> build 15B42 (thanks to jperkins909)
       
      10.11.0
      Nvidia Web Driver - 346.03.02f02 --> build 15A284 (thanks to MTWomg)
      Nvidia Web Driver - 346.03.02f01 --> build 15A284 (see this post)
       
      DP
      Nvidia Web Driver - 346.03.01b07 --> GM/DB/PB6/DB7/PB5 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.01b06 --> build 15A (thanks to MTWomg) 
    • By ivanmacx85
      NVIDIA ha rilasciato i driver grafici per macOS High Sierra 10.13

      Questi driver sono attualmente l’unico metodo per ottenere l’accelerazione grafica delle schede:

      -Pascal   GTX 1050, 1050 Ti, 1060, 1070, 1080, 1080 Ti, TITAN Xp
      -Maxwell GTX 750, 750 Ti, 950, 960, 970, 980, 980 Ti, TITAN X


       
      Per disinstallare i vecchi WebDriver attenersi alla seguente procedura: 

      1.) Aprire l'NVIDIA Driver Manager nella voce della barra dei menu.

      2.) Fare clic sull'icona del lucchetto e immettere la password dell'amministratore.

      3.) Fare clic sul pulsante disinstallazione.

      4.) Fare clic su disinstalla e continuare con la disinstallazione. Riavviare il sistema come indicato

      5.) Installare la versione originale del kext AppleGraphicsControl.kext (solo se lo avevate modificato in precedenza) in / S / L / E / tramite Kext Utility

      Ignorate questi passaggi se venite da un'installazione pulita di High Sierra


      Per installare il nuovo pacchetto WebDriver NVIDIA 10.13 distribuito ufficialmente, procedere come segue:

      1.) Scaricare e installare il pacchetto NVIDIA WebDriver HighSierra 10.13.pkg Durante l'installazione comparirà un messaggio di errore, ignoratelo e continuare l'installazione finché non vi verrà richiesto di riavviare il sistema.

      2.) Solo per chi ha smbios iMac 15,1 - iMac 17,1 - MacPro 6.1 Prima di riavviare mettere nella cartella kext other NVWebDriverLibValFix.kext.zip, NvidiaGraphicsFixup.kext.zip e Lilu.kext per evitare il problema dello schermo nero dopo l'avvio del sistema
       
      3.) In alcuni casi è necessario impostare nel file .config il SIP (CsrActiveConfig) su 0x3

      4.) Ora riavviate il sistema. Al momento dell'avvio del sistema, avrete il WebDriver Nvidia completamente funzionante con supporto OpenGL e Metal 2


    • By spec3
      ciao, 
       
      Ho appena acquistato una GTX 980, ho due partizioni , una con Sierra . e una con Yosemite, su Sierra ho installato i Web driver , messo webdriver al config.plist e tutto funziona a dovere. In Yosemite ho fatto la stessa cosa, al riavvio  non sono  piu  riuscito ad entrare nel sistema operativo, ovviamente ho usato le versioni dedicate per ogni sistema operativo a meno che non mi sia confuso e ho installato i driver sbagliati. Per rientrare ho provato di tutto, safe mode, staccando l'nvidia , provando ad entrare con l'intel integrata, provato a cambiare SMBIOS dalla partizione di Sierra.
       
      Come posso rientrare nel sistema? ce un modo per eliminare i driver manualmente da un altra partizione?
       
      grazie

    • By imatefx
      I have a nvidia gt425M on my asus n53jq laptop almost everything is working correctly audio , lan , wifi
      even display is detected , I was not using nvidia web driviers on el capitan
       
      Only some windows and desktop background are distorted the resolution is 1920x1080, 
      The Video ram is 1024 MB but the "About mac" window shows only 1023 MB 
       

       
      Can someone help me out.
×