Jump to content
fantomas1

Nvidia Web Driver updates for macOS High Sierra (UPDATE 11/03/2018)

1,753 posts in this topic

Recommended Posts

Advertisement

Big question as far as I’m concerned is whether we’ll see interface performance improvements on-par with what I’ve been seeing on native Mac hardware with Apple-tested Metal support. I believe Metal support was added in NVIDIA’s Web Drivers a little while ago, but I wonder if that’ll be the stumbling block in seeing new beta drivers for these developer previews.

Share this post


Link to post
Share on other sites

10.13 NVIDIA 660   boot failure        -v  reboot           Clover     nv_disable=1  Successful startup

 

 

 

 

      Kernel Extensions in backtrace:
         com.apple.iokit.IOGraphicsFamily(516.28)[4850AEE9-AB7B-3F9B-ABC4-8B218016F6A8]@0xffffff7f863ff000->0xffffff7f86441fff
            dependency: com.apple.iokit.IOPCIFamily(2.9)[CD25C5B3-4E10-3F20-8C36-C4BD6803ED60]@0xffffff7f86094000
         com.apple.nvidia.driver.NVDAResman(10.2.2)[31F1CA86-E625-320E-A6DC-46FF7FC3943B]@0xffffff7f8646a000->0xffffff7f86750fff
            dependency: com.apple.iokit.IOPCIFamily(2.9)[CD25C5B3-4E10-3F20-8C36-C4BD6803ED60]@0xffffff7f86094000
            dependency: com.apple.iokit.IONDRVSupport(516.28)[3EA927A7-90EC-356A-A07E-B7E4246E5C40]@0xffffff7f8644e000
            dependency: com.apple.iokit.IOGraphicsFamily(516.28)[4850AEE9-AB7B-3F9B-ABC4-8B218016F6A8]@0xffffff7f863ff000
            dependency: com.apple.AppleGraphicsDeviceControl(3.15.26)[DD390B93-7A57-3981-B709-CE0EE9127B5C]@0xffffff7f8645e000
         com.apple.iokit.IOAcceleratorFamily2(348.5)[D748F500-65D8-30C4-AA70-2D245E7851C9]@0xffffff7f86827000->0xffffff7f868b8fff
            dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[441A112D-E54F-3B2C-82A9-9FE928BBE7F9]@0xffffff7f86812000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[CD25C5B3-4E10-3F20-8C36-C4BD6803ED60]@0xffffff7f86094000
            dependency: com.apple.iokit.IOGraphicsFamily(516.28)[4850AEE9-AB7B-3F9B-ABC4-8B218016F6A8]@0xffffff7f863ff000
         com.apple.GeForce(10.2.2)[0D8C53A6-A9AC-3DB9-8DA0-FF9477799500]@0xffffff7f868c8000->0xffffff7f86962fff
            dependency: com.apple.iokit.IOPCIFamily(2.9)[CD25C5B3-4E10-3F20-8C36-C4BD6803ED60]@0xffffff7f86094000
            dependency: com.apple.iokit.IONDRVSupport(516.28)[3EA927A7-90EC-356A-A07E-B7E4246E5C40]@0xffffff7f8644e000
            dependency: com.apple.nvidia.driver.NVDAResman(10.2.2)[31F1CA86-E625-320E-A6DC-46FF7FC3943B]@0xffffff7f8646a000
            dependency: com.apple.iokit.IOGraphicsFamily(516.28)[4850AEE9-AB7B-3F9B-ABC4-8B218016F6A8]@0xffffff7f863ff000
            dependency: com.apple.iokit.IOAcceleratorFamily2(348.5)[D748F500-65D8-30C4-AA70-2D245E7851C9]@0xffffff7f86827000

Share this post


Link to post
Share on other sites

Getting a black screen with mouse cursor I can interact with. This is with an internal NVIDIA Quadro 1000M that worked oob until Sierra. Booting in safe mode (-x) works with full resolution but no acceleration. Any help appreciated :worried_anim:

Share this post


Link to post
Share on other sites

How did you do it?

 

Nvidia driver Updater did the job again!|

 

Yeah, I'm curious.  I can't edit the NVDAStartup.kext for the life of me.  The required OS is blank and the app is saying I don't have that kext

Share this post


Link to post
Share on other sites

config1 to none in MacPro6.1 related part (I use a Mac Pro 6.1 smbios)

this with original 10.13 beta kext in my case does not work

 

so I have used my old 10.12.5 kext (installed with kext utility)

It is working with dual monitor but acceleration is not present

Share this post


Link to post
Share on other sites

does not work..please send NVDAStartupWeb.kext AppleGraphicsControl.kext (thank you very much)

Share this post


Link to post
Share on other sites

I put 17A

 

That's the thing...it says that the kext doesn't exist, so I can't edit it.  When I try to manually edit, I can't.  And I can't change permissions on the file...

Share this post


Link to post
Share on other sites

I will try to explain what I did...I am testing like you and I am not an expert or coder at all..I like to try things:-)

 

so:

I have a working system with 10.12.5 installed

I have downloaded 10.13 beta from apple store

to have it working I have to use clover 4081 (thanks to sherlocks)

I have also to change my cpu kernel patch (thank to PMHeart and Matthew82 to point me in right direction)

I installed from 10.12.5 to a clean disk launching Install macOS 10.13 Beta from application

then when all process is finished I have transferred all my setting from 10.12.5 to 10.13 beta with migration assistant

in this way I have cuda and nvidiadriver installed but not working

I patched with 17A and NVIDIA® WebDriver Updater app

then I have modified AppleGraphicsControl.kext in the same way I do from time

in this way apple policy produce a black screen

if I change inside new kext applegraphiccontrol kext/contents/plugin this file: AppleGraphicsDevicePolicy.kext with an old and patched 10.12.5 one...I have two monitors working and nvidiaweb drivers loaded fine

but poor performance...

so someone could understand how to have performance if possible..or we have to wait nvdia for a correct driver...

 

I can't explain better in English..sorry! :-)


here you go

does not work..please send NVDAStartupWeb.kext AppleGraphicsControl.kext (thank you very much)

 

Archive 2.zip

Share this post


Link to post
Share on other sites

I will try to explain what I did...I am testing like you and I am not an expert or coder at all..I like to try things:-)

 

so:

I have a working system with 10.12.5 installed

I have downloaded 10.13 beta from apple store

to have it working I have to use clover 4081 (thanks to sherlocks)

I have also to change my cpu kernel patch (thank to PMHeart and Matthew82 to point me in right direction)

I installed from 10.12.5 to a clean disk launching Install macOS 10.13 Beta from application

then when all process is finished I have transferred all my setting from 10.12.5 to 10.13 beta with migration assistant

in this way I have cuda and nvidiadriver installed but not working

I patched with 17A and NVIDIA® WebDriver Updater app

then I have modified AppleGraphicsControl.kext in the same way I do from time

in this way apple policy produce a black screen

if I change inside new kext applegraphiccontrol kext/contents/plugin this file: AppleGraphicsDevicePolicy.kext with an old and patched 10.12.5 one...I have two monitors working and nvidiaweb drivers loaded fine

but poor performance...

so someone could understand how to have performance if possible..or we have to wait nvdia for a correct driver...

 

I can't explain better in English..sorry! :-)

here you go

 

Out of curiosity, did you upgrade to APFS? or leave it as HFS?

Share this post


Link to post
Share on other sites

For quick report, my NVIDIA GeForce GT 520M (10de:1050 / GF119) using 10.13's Native NVDA* && Ge* got only a working Cursor with Black Screen and never reach Desktop. But, I think it' s way better than previously WindowServer crash under 10.12.x. Too bad, I then use 10.12.5's CoreDisplay binary framework and it "just works". :lol:

Still waiting for Web Driver under 10.13, but I'm not sure NVIDIA would release it soon for macOS Beta. << I think it would be same on G610 or GT520 which is also GF119. FYi, I'm using Clover v2.4k r4084 and GFX0 Graphics personalities on DSDT (or InjectNvidia=True).

post-826765-0-98025800-1496920388_thumb.png

Share this post


Link to post
Share on other sites

For quick report, my NVIDIA GeForce GT 520M (10de:1050 / GF119) using 10.13's Native NVDA* && Ge* got only a working Cursor with Black Screen and never reach Desktop. But, I think it' s way better than previously WindowServer crash under 10.12.x. Too bad, I then use 10.12.5's CoreDisplay binary framework and it "just works". :lol:

Still waiting for Web Driver under 10.13, but I'm not sure NVIDIA would release it soon for macOS Beta. << I think it would be same on G610 or GT520 which is also GF119. FYi, I'm using Clover v2.4k r4084 and GFX0 Graphics personalities on DSDT (or InjectNvidia=True).

did you set firmware feature in smbios?

Share this post


Link to post
Share on other sites

did you set firmware feature in smbios?

 

Yes, but I'm not sure it makes a sense since I installed it using OTF method (from another partition), simply prepare an empty HFS+ Partition, run "Core.pkg" on ".../InstallESD.dmg/Packages" to that Partition. Mount "BaseSystem.dmg" then Copy "boot.efi" located on ".../System/Library/CoreServices" to same path under Target Partition. Reboot ur mach, customize Lang, User etc.. and we're ready to go. That is.  :) 

 

#EDIT: No longer using FirmwareFeature with Clover r4084

Share this post


Link to post
Share on other sites

I will try to explain what I did...I am testing like you and I am not an expert or coder at all..I like to try things:-)

 

so:

I have a working system with 10.12.5 installed

I have downloaded 10.13 beta from apple store

to have it working I have to use clover 4081 (thanks to sherlocks)

I have also to change my cpu kernel patch (thank to PMHeart and Matthew82 to point me in right direction)

I installed from 10.12.5 to a clean disk launching Install macOS 10.13 Beta from application

then when all process is finished I have transferred all my setting from 10.12.5 to 10.13 beta with migration assistant

in this way I have cuda and nvidiadriver installed but not working

I patched with 17A and NVIDIA® WebDriver Updater app

then I have modified AppleGraphicsControl.kext in the same way I do from time

in this way apple policy produce a black screen

if I change inside new kext applegraphiccontrol kext/contents/plugin this file: AppleGraphicsDevicePolicy.kext with an old and patched 10.12.5 one...I have two monitors working and nvidiaweb drivers loaded fine

but poor performance...

so someone could understand how to have performance if possible..or we have to wait nvdia for a correct driver...

 

I can't explain better in English..sorry! :-)

here you go

I did excacly as you did , without modyfying AppleGraphicsDevicePolicy and I get black screen with nv_drv=1 , but full resolution(without QE/CI) using nv_disable=1

Share this post


Link to post
Share on other sites

guys, how do I "force" the installer of the web driver for Mac OS 10.12.5 to work on 10.13?

I don't want to migrate data from old partitions of Sierra 

Share this post


Link to post
Share on other sites

guys, how do I "force" the installer of the web driver for Mac OS 10.12.5 to work on 10.13?

I don't want to migrate data from old partitions of Sierra 

The installer checks the build number of your macOS. You can edit the build number within the installer package (with Flat Package Editor for example, or you can unpack the .pkg through terminal, edit the file and repack the .pkg again), which will let you run the installer.

But the Nvidia drive manager app also checks the build number (and thus won't load the Nvidia drivers, but gives you the error that your macOS version is incompatible). 

It might be possible to edit the buildnumber check within the app too, but then I'm still not sure if the kexts will be compatible with 10.13

 

Within the Distribution file you'll find this, which you'll need to change corresponding to your current build of macOS:

 

var supportedOSVer = "10.12.5";
var supportedOSBuildVer = "16F73";
var targetBuild = system.version.ProductBuildVersion; 
var result = compareBuildVersions(targetBuild, supportedOSBuildVer);

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fantomas1
      Hi InsanelyMacaholics   

      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS Sierra.
       
      10.12.6
      Nvidia Web Driver - 378.05.05.25f11 --> build 16G1618 (thanks to Frank Nitty) New!
      Nvidia Web Driver - 378.05.05.25f10 --> build 16G1510 (thanks to BreBo) 
      Nvidia Web Driver - 378.05.05.25f09 --> build 16G1408 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f08 --> build 16G1314 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f07 --> build 16G1314 (thanks to haring)
      Nvidia Web Driver - 378.05.05.25f06 --> build 16G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 378.05.05.25f04 --> build 16G1114 (thanks to lukazm)
      Nvidia Web Driver - 378.05.05.25f03 --> build 16G1036 (thanks to Gradou)
      Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to Badruzeus)
       
       
      10.12.5
      Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)
       
       
      10.12.4
      Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)
      Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr)  Pascal support!!!
      Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)
       
       
      10.12.3

      Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)
       
       
      10.12.2
      Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)
      Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)
      Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)
       
       
      10.12.1
      Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).
      Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)
       
       
      10.12.0
      Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)
       
       
      GM
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)
       
       
      DP/PB
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun) 
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun)
      Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)
       
    • By fantomas1
      hi people  
       
      you can use this thread to link / talk about of the future Nvidia Web Driver updates for El Capitan
       
      10.11.6
      Nvidia Web Driver - 346.03.15f16 --> build 15G22010 (thanks to BreBo)  New!
      Nvidia Web Driver - 346.03.15f15 --> build 15G21013 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.15f14 --> build 15G20015 (thanks to DMCrimson)
      Nvidia Web Driver - 346.03.15f13 --> build 15G20015 (thanks to Louvier)
      Nvidia Web Driver - 346.03.15f12 --> build 15G19009 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f11 --> build 15G18013 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f10 --> build 15G17023 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f09 --> build 15G1611 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f08 --> build 15G1510 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f07 --> build 15G1421 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f06 --> build 15G1217 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f05 --> build 15G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f04 --> build 15G1108 (see this post)
      Nvidia Web Driver - 346.03.15f03 --> build 15G1004 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f02 --> build 15G31 (thanks to Moviemakergr)
      Nvidia Web Driver - 346.03.15f01 --> build 15G31 (thanks to WeBeRiO)
      [uPDATE_3]Nvidia Web Driver - 346.03.15b01 --> build 15G24b (thanks to DMCrimson)
       
      10.11.5
      Nvidia Web Driver - 346.03.10f02 --> build 15F34 (thanks to marcozardi)
      Nvidia Web Driver - 346.03.10f01 --> build 15F34 (thanks to WeBeRiO)
      [uPDATE_2] Nvidia Web Driver - 346.03.10b01 --> build 15F31a (see this post)
       
      10.11.4
      Nvidia Web Driver - 346.03.06f01 --> build 15E65 (see this post)
      Nvidia Web Driver - 346.03.06b01 --> build 15E (see this post)
       
      10.11.3
      Nvidia Web Driver - 346.03.05f02 --> second release for build 15D21 (thanks to Fljagd)
      Nvidia Web Driver - 346.03.05f01  --> build 15D21 (see this post)
      Nvidia Web Driver - 346.03.05b02 --> build 15D (see this post)
       
      10.11.2
      Nvidia Web Driver - 346.03.04f02 --> second public release (see this post)
      Nvidia Web Driver - 346.03.04f01 --> build 15C50 (see this post)  
      Nvidia Web Driver - 346.03.04b02 --> build 15C48a (see this post) 
      Nvidia Web Driver - 346.03.04b01 --> build 15C47a (see this post)
       
      10.11.1
      Nvidia Web Driver - 346.03.03f02 --> second public release (see this post) 
      Nvidia Web Driver - 346.03.03f01 --> build 15B42 (thanks to jperkins909)
       
      10.11.0
      Nvidia Web Driver - 346.03.02f02 --> build 15A284 (thanks to MTWomg)
      Nvidia Web Driver - 346.03.02f01 --> build 15A284 (see this post)
       
      DP
      Nvidia Web Driver - 346.03.01b07 --> GM/DB/PB6/DB7/PB5 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.01b06 --> build 15A (thanks to MTWomg) 
    • By ivanmacx85
      NVIDIA ha rilasciato i driver grafici per macOS High Sierra 10.13

      Questi driver sono attualmente l’unico metodo per ottenere l’accelerazione grafica delle schede:

      -Pascal   GTX 1050, 1050 Ti, 1060, 1070, 1080, 1080 Ti, TITAN Xp
      -Maxwell GTX 750, 750 Ti, 950, 960, 970, 980, 980 Ti, TITAN X


       
      Per disinstallare i vecchi WebDriver attenersi alla seguente procedura: 

      1.) Aprire l'NVIDIA Driver Manager nella voce della barra dei menu.

      2.) Fare clic sull'icona del lucchetto e immettere la password dell'amministratore.

      3.) Fare clic sul pulsante disinstallazione.

      4.) Fare clic su disinstalla e continuare con la disinstallazione. Riavviare il sistema come indicato

      5.) Installare la versione originale del kext AppleGraphicsControl.kext (solo se lo avevate modificato in precedenza) in / S / L / E / tramite Kext Utility

      Ignorate questi passaggi se venite da un'installazione pulita di High Sierra


      Per installare il nuovo pacchetto WebDriver NVIDIA 10.13 distribuito ufficialmente, procedere come segue:

      1.) Scaricare e installare il pacchetto NVIDIA WebDriver HighSierra 10.13.pkg Durante l'installazione comparirà un messaggio di errore, ignoratelo e continuare l'installazione finché non vi verrà richiesto di riavviare il sistema.

      2.) Solo per chi ha smbios iMac 15,1 - iMac 17,1 - MacPro 6.1 Prima di riavviare mettere nella cartella kext other NVWebDriverLibValFix.kext.zip, NvidiaGraphicsFixup.kext.zip e Lilu.kext per evitare il problema dello schermo nero dopo l'avvio del sistema
       
      3.) In alcuni casi è necessario impostare nel file .config il SIP (CsrActiveConfig) su 0x3

      4.) Ora riavviate il sistema. Al momento dell'avvio del sistema, avrete il WebDriver Nvidia completamente funzionante con supporto OpenGL e Metal 2


    • By spec3
      ciao, 
       
      Ho appena acquistato una GTX 980, ho due partizioni , una con Sierra . e una con Yosemite, su Sierra ho installato i Web driver , messo webdriver al config.plist e tutto funziona a dovere. In Yosemite ho fatto la stessa cosa, al riavvio  non sono  piu  riuscito ad entrare nel sistema operativo, ovviamente ho usato le versioni dedicate per ogni sistema operativo a meno che non mi sia confuso e ho installato i driver sbagliati. Per rientrare ho provato di tutto, safe mode, staccando l'nvidia , provando ad entrare con l'intel integrata, provato a cambiare SMBIOS dalla partizione di Sierra.
       
      Come posso rientrare nel sistema? ce un modo per eliminare i driver manualmente da un altra partizione?
       
      grazie

    • By imatefx
      I have a nvidia gt425M on my asus n53jq laptop almost everything is working correctly audio , lan , wifi
      even display is detected , I was not using nvidia web driviers on el capitan
       
      Only some windows and desktop background are distorted the resolution is 1920x1080, 
      The Video ram is 1024 MB but the "About mac" window shows only 1023 MB 
       

       
      Can someone help me out.
×