Jump to content
fantomas1

Nvidia Web Driver updates for macOS High Sierra (UPDATE 08/30/2018)

1,717 posts in this topic

Recommended Posts

Advertisement

My native MacPro 5.1 with a 1050TI doesn't respond even after i use the uninstall function in the NVidia prefpane. And what happend next will choke you (hihihi)....it doesn't work. It even doesn't work after a reinstall of the 387.10.10.1040.105 . I need to go back in time with a Timemachine-Backup to get my smooth running system back.

I use a regular NVidia to boot into a functional, but old system. After the systems awakening i use apples Bonjour Desktopsharing with my laptop to check the "Use Webdriver" instead of the casual one.

Share this post


Link to post
Share on other sites

For me the 108 driver works great, I did notice that it poped up a kext block security alert when installing this version and so I had to go to Security Center and unblock it, even though I unblocked the NVIDIA kexts before. I also re-created the kext cache and prelinked kernel before rebooting from the NVIDIA installer but I am not sure that it is needed.

Share this post


Link to post
Share on other sites

I have a native MacPro 5.1 with a GeForce GTX 970, and after the update, I too am just getting a black screen when the video drivers load. I tried uninstalling the new version and installing a previous one, but it didn't fix the problem. If anyone has a solution, that would be great, since apparently there's an issue with my Time Machine backup, too. I'm limping along with an older video card in the meantime.

Share this post


Link to post
Share on other sites

From Recovery/Terminal (Macintosh HD - your disk name)

# v="/Volumes/Macintosh HD"

 

# cd "$v"/Library/Extensions
# rm -rf GeForce*
# rm -rf NVDA*
# touch .
# cd "$v"/System/Library/Extensions
# rm -rf GeForce*Web*
# touch .

 

# kextcache -u "$v"
# reboot

 

From Desktop

 

$ sudo su
# cd /Library/Extensions
# rm -rf GeForce*
# rm -rf NVDA*
# touch .
# cd /System/Library/Extensions
# rm -rf GeForce*Web*
# rm -rf NVDA*Web*
# touch .
# kextcache -u /
# exit
$ reboot

 

Reinstall previous drivers that worked.

Share this post


Link to post
Share on other sites

Newest update for 10.13.6 wrecked my 2014 MBP. Installed and now if I try to use any adobe programs it gives me a black screen and I have to hard reset the laptop to get anywhere. Had to uninstall webdriver completely and now I'm back to rendering with OpenCL again instead of CUDA. I'm terrible at using time machine on my laptop too so I don't have a recent backup to go back to - any help? Or do we just wait for Nvidia to come out with a fix? 

Edited by sam.red

Share this post


Link to post
Share on other sites
55 minutes ago, sam.red said:

Newest update for 10.13.6 wrecked my 2014 MBP. Installed and now if I try to use any adobe programs it gives me a black screen and I have to hard reset the laptop to get anywhere. Had to uninstall webdriver completely and now I'm back to rendering with OpenCL again instead of CUDA. I'm terrible at using time machine on my laptop too so I don't have a recent backup to go back to - any help? Or do we just wait for Nvidia to come out with a fix? 

Also update - I tried contacting Nvidia, they said to uninstall and then reinstall the 105 version, but I did that and even after resetting my PRAM it still gave me the black screen. Not sure what to do, they said they're working on a fix but until then I guess I'm stuck using the horrible built in GPU that MBP's come with? 

Share this post


Link to post
Share on other sites

Hi guys

 

I'm working on web driver on HS 10.13.6 too.

But I have a strange problem when I set the inject Nvidia flag in clover bootloader the web driver works but it's temporary.

I set the inject Nvidia flag in both config.plist in EFI folder mounted with clover configuration and /Volumes/Mac name/EFI but it doesn't work. Can anyone tell me where the problem is? and which config.plist in which EFI folder the clover bootloader relates to? 

Share this post


Link to post
Share on other sites
On 9/5/2018 at 1:46 PM, iAli said:

Thnx anyway.

Problem solved. Now HS 10.13.6 fully working with sound and vga.

 

 

You are the best!!! This fixed my system after tearing my hair out for 5 days! Awesome!!!! Thanks so much! 

HighSierra-10.13.6-nvidia.jpg

Share this post


Link to post
Share on other sites
7 hours ago, Badruzeus said:

And.. this is a sign of what?

Screenshot 17.png

 

Your screenshot says 387.10.10.10.40.105, not 387.10.10.15.15.108   ^_^

 

Here's the link from Nvidia official website - Try to download it.  :P  Also, check the link from OP, the same thing. Like I said, they definitely removed it from the catalog.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By fantomas1
      Hi InsanelyMacaholics   

      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS Sierra.
       
      10.12.6
      Nvidia Web Driver - 378.02.02.25f10 --> build 16G1510 (thanks to BreBo)  New!
      Nvidia Web Driver - 378.02.02.25f09 --> build 16G1408 (thanks to BreBo)
      Nvidia Web Driver - 378.02.02.25f08 --> build 16G1314 (thanks to BreBo)
      Nvidia Web Driver - 378.02.02.25f07 --> build 16G1314 (thanks to haring)
      Nvidia Web Driver - 378.05.05.25f06 --> build 16G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 378.05.05.25f04 --> build 16G1114 (thanks to lukazm)
      Nvidia Web Driver - 378.05.05.25f03 --> build 16G1036 (thanks to Gradou)
      Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to Badruzeus)
       
       
      10.12.5
      Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)
       
       
      10.12.4
      Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)
      Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr)  Pascal support!!!
      Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)
       
       
      10.12.3

      Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)
       
       
      10.12.2
      Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)
      Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)
      Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)
       
       
      10.12.1
      Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).
      Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)
       
       
      10.12.0
      Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)
       
       
      GM
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)
       
       
      DP/PB
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun) 
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun)
      Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)
       
    • By fantomas1
      hi people  
       
      you can use this thread to link / talk about of the future Nvidia Web Driver updates for El Capitan
       
      10.11.6
      Nvidia Web Driver - 346.03.15f16 --> build 15G22010 (thanks to BreBo)  New!
      Nvidia Web Driver - 346.03.15f15 --> build 15G21013 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.15f14 --> build 15G20015 (thanks to DMCrimson)
      Nvidia Web Driver - 346.03.15f13 --> build 15G20015 (thanks to Louvier)
      Nvidia Web Driver - 346.03.15f12 --> build 15G19009 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f11 --> build 15G18013 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f10 --> build 15G17023 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f09 --> build 15G1611 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f08 --> build 15G1510 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f07 --> build 15G1421 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f06 --> build 15G1217 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f05 --> build 15G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f04 --> build 15G1108 (see this post)
      Nvidia Web Driver - 346.03.15f03 --> build 15G1004 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f02 --> build 15G31 (thanks to Moviemakergr)
      Nvidia Web Driver - 346.03.15f01 --> build 15G31 (thanks to WeBeRiO)
      [uPDATE_3]Nvidia Web Driver - 346.03.15b01 --> build 15G24b (thanks to DMCrimson)
       
      10.11.5
      Nvidia Web Driver - 346.03.10f02 --> build 15F34 (thanks to marcozardi)
      Nvidia Web Driver - 346.03.10f01 --> build 15F34 (thanks to WeBeRiO)
      [uPDATE_2] Nvidia Web Driver - 346.03.10b01 --> build 15F31a (see this post)
       
      10.11.4
      Nvidia Web Driver - 346.03.06f01 --> build 15E65 (see this post)
      Nvidia Web Driver - 346.03.06b01 --> build 15E (see this post)
       
      10.11.3
      Nvidia Web Driver - 346.03.05f02 --> second release for build 15D21 (thanks to Fljagd)
      Nvidia Web Driver - 346.03.05f01  --> build 15D21 (see this post)
      Nvidia Web Driver - 346.03.05b02 --> build 15D (see this post)
       
      10.11.2
      Nvidia Web Driver - 346.03.04f02 --> second public release (see this post)
      Nvidia Web Driver - 346.03.04f01 --> build 15C50 (see this post)  
      Nvidia Web Driver - 346.03.04b02 --> build 15C48a (see this post) 
      Nvidia Web Driver - 346.03.04b01 --> build 15C47a (see this post)
       
      10.11.1
      Nvidia Web Driver - 346.03.03f02 --> second public release (see this post) 
      Nvidia Web Driver - 346.03.03f01 --> build 15B42 (thanks to jperkins909)
       
      10.11.0
      Nvidia Web Driver - 346.03.02f02 --> build 15A284 (thanks to MTWomg)
      Nvidia Web Driver - 346.03.02f01 --> build 15A284 (see this post)
       
      DP
      Nvidia Web Driver - 346.03.01b07 --> GM/DB/PB6/DB7/PB5 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.01b06 --> build 15A (thanks to MTWomg) 
    • By ivanmacx85
      NVIDIA ha rilasciato i driver grafici per macOS High Sierra 10.13

      Questi driver sono attualmente l’unico metodo per ottenere l’accelerazione grafica delle schede:

      -Pascal   GTX 1050, 1050 Ti, 1060, 1070, 1080, 1080 Ti, TITAN Xp
      -Maxwell GTX 750, 750 Ti, 950, 960, 970, 980, 980 Ti, TITAN X


       
      Per disinstallare i vecchi WebDriver attenersi alla seguente procedura: 

      1.) Aprire l'NVIDIA Driver Manager nella voce della barra dei menu.

      2.) Fare clic sull'icona del lucchetto e immettere la password dell'amministratore.

      3.) Fare clic sul pulsante disinstallazione.

      4.) Fare clic su disinstalla e continuare con la disinstallazione. Riavviare il sistema come indicato

      5.) Installare la versione originale del kext AppleGraphicsControl.kext (solo se lo avevate modificato in precedenza) in / S / L / E / tramite Kext Utility

      Ignorate questi passaggi se venite da un'installazione pulita di High Sierra


      Per installare il nuovo pacchetto WebDriver NVIDIA 10.13 distribuito ufficialmente, procedere come segue:

      1.) Scaricare e installare il pacchetto NVIDIA WebDriver HighSierra 10.13.pkg Durante l'installazione comparirà un messaggio di errore, ignoratelo e continuare l'installazione finché non vi verrà richiesto di riavviare il sistema.

      2.) Solo per chi ha smbios iMac 15,1 - iMac 17,1 - MacPro 6.1 Prima di riavviare mettere nella cartella kext other NVWebDriverLibValFix.kext.zip, NvidiaGraphicsFixup.kext.zip e Lilu.kext per evitare il problema dello schermo nero dopo l'avvio del sistema
       
      3.) In alcuni casi è necessario impostare nel file .config il SIP (CsrActiveConfig) su 0x3

      4.) Ora riavviate il sistema. Al momento dell'avvio del sistema, avrete il WebDriver Nvidia completamente funzionante con supporto OpenGL e Metal 2


    • By spec3
      ciao, 
       
      Ho appena acquistato una GTX 980, ho due partizioni , una con Sierra . e una con Yosemite, su Sierra ho installato i Web driver , messo webdriver al config.plist e tutto funziona a dovere. In Yosemite ho fatto la stessa cosa, al riavvio  non sono  piu  riuscito ad entrare nel sistema operativo, ovviamente ho usato le versioni dedicate per ogni sistema operativo a meno che non mi sia confuso e ho installato i driver sbagliati. Per rientrare ho provato di tutto, safe mode, staccando l'nvidia , provando ad entrare con l'intel integrata, provato a cambiare SMBIOS dalla partizione di Sierra.
       
      Come posso rientrare nel sistema? ce un modo per eliminare i driver manualmente da un altra partizione?
       
      grazie

    • By imatefx
      I have a nvidia gt425M on my asus n53jq laptop almost everything is working correctly audio , lan , wifi
      even display is detected , I was not using nvidia web driviers on el capitan
       
      Only some windows and desktop background are distorted the resolution is 1920x1080, 
      The Video ram is 1024 MB but the "About mac" window shows only 1023 MB 
       

       
      Can someone help me out.
×