Jump to content
fantomas1

Nvidia Web Driver updates for macOS High Sierra (UPDATE 08/30/2018)

1,728 posts in this topic

Recommended Posts

@chris1111, pretty awesome scripts.

 

I took what chris1111 had and made it a automated process now. It will now automatically change the Distribution version setting to match the macOS system version that the script is ran on. Tell me what you guys think, credit to Chris1111 to for the unpackaging and repackaging scripts.

Thank you  @Pavo

I have done another one little bit more complex for extract the payload in the nividia package

the guys  have a possibility to edit the Distribution, Script ,  kext and repackaging the all thing

I just test for 5 time now in test disk successfully.

I clean the packages and post tonight with a readme

Share this post


Link to post
Share on other sites
Advertisement

Thank you  @Pavo

I have done another one little bit more complex for extract the payload in the nividia package

the guys  have a possibility to edit the Distribution, Script ,  kext and repackaging the all thing

I just test for 5 time now in test disk successfully.

I clean the packages and post tonight with a readme

Just wondering, what about the payload is interesting in changing?

Share this post


Link to post
Share on other sites

This is Obsolete use This New ➥ Nvidia Payload Packager

 

 

Here the Nvidia Payload-Packager

To do this I am using three tools

1- pax.gz archives

2- productbuild

3- pkgbuild

 

nvidia10.png

 

For Unpack and Repack the Package after editing ( Ditribution,  Payload and Scripts )

It's up to you to choose what you want

 

Follow instruction in the Video

View in full screen for better look

Let me know if this works well for you

Enjoy!

 

Troubleshooting : if you made a mistake by dropping your file or if you forget a few things, the script will not work.

You must clean up the folders and restart the process.

 

Video 

 

See also how to remove Unnecessary flag for SIP in preinstall script

that's what I think. Install 10 time for test with 

<key>CsrActiveConfig</key>

<string>0x3E7</string>   :rolleyes:
 

sans_t12.jpg

@fantomas1 tel me if you approve?

if not remove the File

thanks

Edit**

NEW Readme attaching with a link Video

Nvidia Payload-Packager.zip

Readme.pdf.zip

Share this post


Link to post
Share on other sites

@chris111

Have you a method to unpack and repack payload file?

It could be fine and useful

i have find a ppbx file but i cant solve it in any way

 

This is done  :P

Share this post


Link to post
Share on other sites

Hey bro, I just installed update for High Sierra, i also installed new web driver but i didn't install nvidialibvar kext.

Now i can't boot into HS.

If I boot with nv_disable=1, i get boot loop at "IOconsole user..."

If I boot with nvda_drv=1, i get blackscreen.

Can anyone help me to boot into HS, plz.

Share this post


Link to post
Share on other sites

you can try to boot in your system with -s or booting or in recovery mode and delete with terminal command Nvidia kext

or if you have another booting OSX or windows you can copy latest nvidiagraphicfixup kext in clover/kext/other

Edited by fabiosun

Share this post


Link to post
Share on other sites

you can try to boot in your system with -s or booting or in recovery mode and delete with terminal command Nvidia kext

or if you have another booting OSX or windows you can copy latest nvidiagraphicfixup kext in clover/kext/other

Thanks so much. It works.

I didn't know that nvidiafixup was upgrade to a newer version :D

Share this post


Link to post
Share on other sites

Here the Nvidia Payload-Packager

To do this I am using three tools

1- pax.gz archives

2- productbuild

3- pkgbuild

 

nvidia10.png

 

For Unpack and Repack the Package after editing ( Ditribution, Payload and Scripts )

It's up to you to choose what you want

 

Follow instruction in the Video

View in full screen for better look

Let me know if this works well for you

Enjoy!

 

Troubleshooting : if you made a mistake by dropping your file or if you forget a few things, the script will not work.

You must clean up the folders and restart the process.

 

Video

 

See also how to remove Unnecessary flag for SIP in preinstall script

that's what I think. Install 10 time for test with

<key>CsrActiveConfig</key>

<string>0x3E7</string> :rolleyes:

 

 

sans_t12.jpg

@fantomas1 tel me if you approve?

if not remove the File

thanks

Edit**

NEW Readme attaching with a link Video

Now yes! ?

This time the installation process occurred successfully and without any error.

I did not have to change SIP (I use 0×67).

I do not need to use any nvidiafix.kext, nor emuvariable64.

I just use Lilu for the sound to work. Without Lilu I have no sound.

Thanks to those who understand the subject!

Now I love my MacPro again ?

post-1313347-0-09087100-1508427017_thumb.png

post-1313347-0-69015000-1508427025_thumb.png

post-1313347-0-02567900-1508444023_thumb.png

post-1313347-0-20620900-1508444041_thumb.png

Share this post


Link to post
Share on other sites

My Zotac Geforce  GT 1030 needs  NVWebDriverLibValFix.kext in Library/Extensions

With the Packager I install my kext with my Payload   :) No installation  with permission, all is in the Package  :angel:

post-951341-0-30732800-1508430354_thumb.png

Share this post


Link to post
Share on other sites

Hi Chris1111

kext above that one are loaded? (Nvidia stuff I mean)

 

 

My Zotac Geforce  GT 1030 needs  NVWebDriverLibValFix.kext in Library/Extensions

With the Packager I install my kext with my Payload   :) No installation  with permission, all is in the Package  :angel:

Share this post


Link to post
Share on other sites

Hi Chris1111

kext above that one are loaded? (Nvidia stuff I mean)

All kext is loading by the Packages with Root permission

You can loading any kext in LE or SLE with the Package  B)

Share this post


Link to post
Share on other sites

look this pictures and the previous one

for both driver is working well but in first pictures some kexts are not loaded

My kexts are all load  :)

 

what image you speak?

Share this post


Link to post
Share on other sites

I would like to see your image in the part where you can see loaded (YES or NO) in extension loaded

I have attached two different images first one with sip @0x67

latest one with sip @0x66 (no untrusted kext allow)

And weird thing in that condition more Nvidia kext are loaded


it is not your good script related (I hope it is clear)

your scripts are good! :-)


Systeminformation/Software/extensions Under about This Mac

Share this post


Link to post
Share on other sites

Here the Nvidia Payload-Packager

To do this I am using three tools

1- pax.gz archives

2- productbuild

3- pkgbuild

 

nvidia10.png

 

 

Chris1111, I have taken this again and fully automated the process, let me know if you run into any issues

[flash=]

Nvidia WebDriver:Payload Repackager.zip

Share this post


Link to post
Share on other sites

I would like to see your image in the part where you can see loaded (YES or NO) in extension loaded

I have attached two different images first one with sip @0x67

latest one with sip @0x66 (no untrusted kext allow)

And weird thing in that condition more Nvidia kext are loaded

it is not your good script related (I hope it is clear)

your scripts are good! :-)

Systeminformation/Software/extensions Under about This Mac

I used SIP  0x3E7

The package only installs what it is requested, if you modify things or your system does not work perfectly ?

All my test is in the new fresh install, you can not go wrong

Chris1111, I have taken this again and fully automated the process, let me know if you run into any issues

[flash=]

Great Job man  B)  New things better look , more easy  :)

Share this post


Link to post
Share on other sites

I have Intel HD 630. Nvidia onboard but I am on laptop, so its optimum. We all know optimum does not work regardless. Anywayz, all through Sierra my graphics acceleration worked. After upgrading to High Sierra (10.13), it worked. Now that these new 10.13.1 beta releases are out, I get stuck with on the boot screen at  "IOconsole user...gIOLockscreenstate" <-(something like that) and can not boot into macos to login or anything. It looks like it is trying too as screen dims a little, but will not load to show graphic acceleration (or graphics period) as it has been doing in previous versions. Did something change since 10.13.1 beta update 2 graphic wise or something? 59168680 will not work. I have the latest apfs, intelgraphicsfixup, luli, coredisplay and the - boot tags. I'm on Dell XPS 15 9560 4k laptop.  

Share this post


Link to post
Share on other sites

My Zotac Geforce  GT 1030 needs  NVWebDriverLibValFix.kext in Library/Extensions

With the Packager I install my kext with my Payload   :) No installation  with permission, all is in the Package  :angel:

Yep, my GT 1030 also needed  NVWebDriverLibValFix.kext in /Library/Extensions.

Even in Sierra , to avoid black windows (no content) for iBooks or Little Snitch Networkmonitor.

 

But be warned: 

Using newer LILU (1.20+) and NvidiaGraphicFixup.kext (newest, which includes NVWebDriverLibValFix function) you MUST delete NVWebDriverLibValFix.kext  from  /Library/Extensions first before reboot. Otherwise next reboot fails in reboot loop!!

Share this post


Link to post
Share on other sites

 

But be warned: 

Using newer LILU (1.20+) and NvidiaGraphicFixup.kext (newest, which includes NVWebDriverLibValFix function) you MUST delete NVWebDriverLibValFix.kext  from  /Library/Extensions first before reboot. Otherwise next reboot fails in reboot loop!!

 

Thank you for this information MITCH !

 

I confirm this issue on my rig with GTX970 with latest webdrivers and Cuda drivers

 

:D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fantomas1
      Hi InsanelyMacaholics   

      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS Sierra.
       
      10.12.6
      Nvidia Web Driver - 378.02.02.25f10 --> build 16G1510 (thanks to BreBo)  New!
      Nvidia Web Driver - 378.02.02.25f09 --> build 16G1408 (thanks to BreBo)
      Nvidia Web Driver - 378.02.02.25f08 --> build 16G1314 (thanks to BreBo)
      Nvidia Web Driver - 378.02.02.25f07 --> build 16G1314 (thanks to haring)
      Nvidia Web Driver - 378.05.05.25f06 --> build 16G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 378.05.05.25f04 --> build 16G1114 (thanks to lukazm)
      Nvidia Web Driver - 378.05.05.25f03 --> build 16G1036 (thanks to Gradou)
      Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to Badruzeus)
       
       
      10.12.5
      Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)
       
       
      10.12.4
      Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)
      Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr)  Pascal support!!!
      Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)
       
       
      10.12.3

      Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)
       
       
      10.12.2
      Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)
      Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)
      Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)
       
       
      10.12.1
      Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).
      Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)
       
       
      10.12.0
      Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)
       
       
      GM
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)
       
       
      DP/PB
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun) 
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun)
      Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)
       
    • By fantomas1
      hi people  
       
      you can use this thread to link / talk about of the future Nvidia Web Driver updates for El Capitan
       
      10.11.6
      Nvidia Web Driver - 346.03.15f16 --> build 15G22010 (thanks to BreBo)  New!
      Nvidia Web Driver - 346.03.15f15 --> build 15G21013 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.15f14 --> build 15G20015 (thanks to DMCrimson)
      Nvidia Web Driver - 346.03.15f13 --> build 15G20015 (thanks to Louvier)
      Nvidia Web Driver - 346.03.15f12 --> build 15G19009 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f11 --> build 15G18013 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f10 --> build 15G17023 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f09 --> build 15G1611 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f08 --> build 15G1510 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f07 --> build 15G1421 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f06 --> build 15G1217 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f05 --> build 15G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f04 --> build 15G1108 (see this post)
      Nvidia Web Driver - 346.03.15f03 --> build 15G1004 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f02 --> build 15G31 (thanks to Moviemakergr)
      Nvidia Web Driver - 346.03.15f01 --> build 15G31 (thanks to WeBeRiO)
      [uPDATE_3]Nvidia Web Driver - 346.03.15b01 --> build 15G24b (thanks to DMCrimson)
       
      10.11.5
      Nvidia Web Driver - 346.03.10f02 --> build 15F34 (thanks to marcozardi)
      Nvidia Web Driver - 346.03.10f01 --> build 15F34 (thanks to WeBeRiO)
      [uPDATE_2] Nvidia Web Driver - 346.03.10b01 --> build 15F31a (see this post)
       
      10.11.4
      Nvidia Web Driver - 346.03.06f01 --> build 15E65 (see this post)
      Nvidia Web Driver - 346.03.06b01 --> build 15E (see this post)
       
      10.11.3
      Nvidia Web Driver - 346.03.05f02 --> second release for build 15D21 (thanks to Fljagd)
      Nvidia Web Driver - 346.03.05f01  --> build 15D21 (see this post)
      Nvidia Web Driver - 346.03.05b02 --> build 15D (see this post)
       
      10.11.2
      Nvidia Web Driver - 346.03.04f02 --> second public release (see this post)
      Nvidia Web Driver - 346.03.04f01 --> build 15C50 (see this post)  
      Nvidia Web Driver - 346.03.04b02 --> build 15C48a (see this post) 
      Nvidia Web Driver - 346.03.04b01 --> build 15C47a (see this post)
       
      10.11.1
      Nvidia Web Driver - 346.03.03f02 --> second public release (see this post) 
      Nvidia Web Driver - 346.03.03f01 --> build 15B42 (thanks to jperkins909)
       
      10.11.0
      Nvidia Web Driver - 346.03.02f02 --> build 15A284 (thanks to MTWomg)
      Nvidia Web Driver - 346.03.02f01 --> build 15A284 (see this post)
       
      DP
      Nvidia Web Driver - 346.03.01b07 --> GM/DB/PB6/DB7/PB5 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.01b06 --> build 15A (thanks to MTWomg) 
    • By ivanmacx85
      NVIDIA ha rilasciato i driver grafici per macOS High Sierra 10.13

      Questi driver sono attualmente l’unico metodo per ottenere l’accelerazione grafica delle schede:

      -Pascal   GTX 1050, 1050 Ti, 1060, 1070, 1080, 1080 Ti, TITAN Xp
      -Maxwell GTX 750, 750 Ti, 950, 960, 970, 980, 980 Ti, TITAN X


       
      Per disinstallare i vecchi WebDriver attenersi alla seguente procedura: 

      1.) Aprire l'NVIDIA Driver Manager nella voce della barra dei menu.

      2.) Fare clic sull'icona del lucchetto e immettere la password dell'amministratore.

      3.) Fare clic sul pulsante disinstallazione.

      4.) Fare clic su disinstalla e continuare con la disinstallazione. Riavviare il sistema come indicato

      5.) Installare la versione originale del kext AppleGraphicsControl.kext (solo se lo avevate modificato in precedenza) in / S / L / E / tramite Kext Utility

      Ignorate questi passaggi se venite da un'installazione pulita di High Sierra


      Per installare il nuovo pacchetto WebDriver NVIDIA 10.13 distribuito ufficialmente, procedere come segue:

      1.) Scaricare e installare il pacchetto NVIDIA WebDriver HighSierra 10.13.pkg Durante l'installazione comparirà un messaggio di errore, ignoratelo e continuare l'installazione finché non vi verrà richiesto di riavviare il sistema.

      2.) Solo per chi ha smbios iMac 15,1 - iMac 17,1 - MacPro 6.1 Prima di riavviare mettere nella cartella kext other NVWebDriverLibValFix.kext.zip, NvidiaGraphicsFixup.kext.zip e Lilu.kext per evitare il problema dello schermo nero dopo l'avvio del sistema
       
      3.) In alcuni casi è necessario impostare nel file .config il SIP (CsrActiveConfig) su 0x3

      4.) Ora riavviate il sistema. Al momento dell'avvio del sistema, avrete il WebDriver Nvidia completamente funzionante con supporto OpenGL e Metal 2


    • By spec3
      ciao, 
       
      Ho appena acquistato una GTX 980, ho due partizioni , una con Sierra . e una con Yosemite, su Sierra ho installato i Web driver , messo webdriver al config.plist e tutto funziona a dovere. In Yosemite ho fatto la stessa cosa, al riavvio  non sono  piu  riuscito ad entrare nel sistema operativo, ovviamente ho usato le versioni dedicate per ogni sistema operativo a meno che non mi sia confuso e ho installato i driver sbagliati. Per rientrare ho provato di tutto, safe mode, staccando l'nvidia , provando ad entrare con l'intel integrata, provato a cambiare SMBIOS dalla partizione di Sierra.
       
      Come posso rientrare nel sistema? ce un modo per eliminare i driver manualmente da un altra partizione?
       
      grazie

    • By imatefx
      I have a nvidia gt425M on my asus n53jq laptop almost everything is working correctly audio , lan , wifi
      even display is detected , I was not using nvidia web driviers on el capitan
       
      Only some windows and desktop background are distorted the resolution is 1920x1080, 
      The Video ram is 1024 MB but the "About mac" window shows only 1023 MB 
       

       
      Can someone help me out.
×