Jump to content
fantomas1

[pre-release] macOS High Sierra

3,845 posts in this topic

Recommended Posts

please confirm
shasum /Applications/Install*OS*.app/Contents/SharedSupport/InstallESD.dmg

dc9e81f0ba874b23ed62a084ac63702bedebc8cd

Share this post


Link to post
Share on other sites
Advertisement

please confirm

shasum /Applications/Install*OS*.app/Contents/SharedSupport/InstallESD.dmg

dc9e81f0ba874b23ed62a084ac63702bedebc8cd

kvMp7BH.png

Share this post


Link to post
Share on other sites

please confirm

shasum /Applications/Install*OS*.app/Contents/SharedSupport/InstallESD.dmg

dc9e81f0ba874b23ed62a084ac63702bedebc8cd

shasum /Applications/Install*OS*.app/Contents/SharedSupport/InstallESD.dmg
dc9e81f0ba874b23ed62a084ac63702bedebc8cd  /Applications/Install macOS 10.13 Beta.app/Contents/SharedSupport/InstallESD.dmg

Share this post


Link to post
Share on other sites

please confirm

shasum /Applications/Install*OS*.app/Contents/SharedSupport/InstallESD.dmg

dc9e81f0ba874b23ed62a084ac63702bedebc8cd

Mac-Pro-Mateusz:~ mateuszjachym$ shasum /Applications/Install*OS*.app/Contents/SharedSupport/InstallESD.dmg
dc9e81f0ba874b23ed62a084ac63702bedebc8cd  /Applications/Install macOS 10.13 Beta.app/Contents/SharedSupport/InstallESD.dmg

Share this post


Link to post
Share on other sites

please confirm

shasum /Applications/Install*OS*.app/Contents/SharedSupport/InstallESD.dmg

dc9e81f0ba874b23ed62a084ac63702bedebc8cd

Optiplex-van-Rico:~ rico$ shasum /Applications/Install*OS*.app/Contents/SharedSupport/InstallESD.dmg
47504144b692798f4713873c5383d8e6755e97f1  /Applications/Install macOS 10.13 Beta.app/Contents/SharedSupport/InstallESD.dmg
I feel special now

Share this post


Link to post
Share on other sites

FINALLY   :thumbsup_anim:  :hysterical:  :w00t:  :D

Got IT  B)

And its the real Installer, not the ready HD.dmg  B)  ;)

Boot -x for the first boot but now I try not -x 

and let you wath append  :D

 

1_copy10.jpg

HOW?!?! I managed to install 10.13 to my HD but Clover doesn't recognize it

Share this post


Link to post
Share on other sites

Yeah a simple DMG that you can restore on your SSD/HDD 

and it

 

Yeah a simple DMG that you can restore on your SSD/HDD 

it's 10.13?>

Share this post


Link to post
Share on other sites

I am triyng to instal from the installer, it says about 22 minutes to go, then it stops with a message I can't instal in this hardware and other things firmware related

 

FINALLY   :thumbsup_anim:  :hysterical:  :w00t:  :D

Got IT  B)

And its the real Installer, not the ready HD.dmg  B)  ;)

Boot -x for the first boot but now I try not -x 

and let you wath append  :D

 

1_copy11.jpg

Share this post


Link to post
Share on other sites

FINALLY   :thumbsup_anim:  :hysterical:  :w00t:  :D

Got IT  B)

And its the real Installer, not the ready HD.dmg  B)  ;)

Boot -x for the first boot but now I try not -x 

and let you wath append  :D

 

1_copy11.jpg

As I was installing macOS High Sierra on my MacBook Air I noticed that during the installation process right after first reboot, it updated my Firmware, I tried booting with -x flag and it didn't work!

 

I think we need to find a way to bypass the firmware check. :rofl:

Share this post


Link to post
Share on other sites

Kext Inject not working I need to boot -x with my Create Install media installer to the Sierra High drive

Share this post


Link to post
Share on other sites

First of all, if you tried to modify firmwarefeaturesmask inside clover, you should not forget about smbios Type 128 table, which also includes such information (firmwarefeatures / firmwarefeaturesmask).

I mean you should modify both DatahubCPU.c and smbios.c

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By h2onions
      Hey all,
       
      First Hackintosh that I think I have completed! I've been working on it on and off for a month, but just grinded it this past weekend. I just have a small QOL issue. I have posted in the r/Hackintosh reddit, but have not gotten a reply to this specific issue, but did for other issues I was having. I also posted at tonymacx86 and was getting replies for other issues I was having, but got banned because I said, "used VM, but didn't work" in my OP I think ...
       
      I followed a PC vanilla guide from r/Hackintosh that I found as I did not have an Apple system. One monitor connected to a GTX 1080, CPU: i7-8700, Coffee Lake. Motherboard is Alienware specific 0VDT73, with chipset Z370.
       
      The issue is every time High Sierra boots up and gets to the login screen, my keyboard and mouse do not work. I only have to reseat both and then they work the whole time until I restart. They are both plugged into USB2.0 ports. I do have Lilu, WhateverGreen, USBInjectAll, and VoodooPS2 installed in my /Library/Extensions folder using #####. Mouse and Keyboard work fine each time I boot to Clover (USB). Any ideas?
       
      Thank you!
      Working: NVIDIA using (One) DisplayPort, USB3.0 (rear), USB-C (rear), USB2.0 (rear), Audio, Ethernet
       
      EDIT: Did some more testing, and it looks like my Keyboard works fine after each reboot, the only issue is that my mouse has to continuously be reseated. Any ideas? Could it just be the mouse?It's an old Inland USB mouse: 337451
    • By Badruzeus
      "The all-new 2019 version of the graphic design software suite is compatible with not only Windows but also Mac, complete with support for Dark Mode on macOS Mojave and the Touch Bar on the latest MacBook Pro models, providing quick access to layout settings, text controls, and more." ~ macrumors
       
      More details: https://www.coreldraw.com/en/product/coreldraw/mac/
    • By Utku
      Hi guys, I have a big problem for VT -x. I tried any things for example: dark=0 or already bios option is virtualization is enable. I don't understand this problem.
       
      Thanks guys!! And yes I have intel Q8400 quad core cpu, motherboard is Asus asus p5g41c-m lx.
       


    • By plasticworld
      After a long run, I successfully upgraded High Sierra to mojave 10.14 on an intel 5 series chipset MotherBoard.
       
      MotherBoard: H55ms2
      RAM: 6GB
      GPU1: Saphire AMD RX 460
      GPU2: Nvidia 8400GS
      Storage: 500 GB HDD WD Green.
       
      The requirement:
      1) macOS pre mojave.
      2) macOS mojave installer from Apple store.
      3) Empty partition or USB to upgrade from.
      4) Un-mout all unused dmgs.
      5) GPT/GUID HDD.
       
      HOWOT:
      1) Prepare an empty partition or USB with at least 6 GB.
      2) Format the partition or USB with GUID partition table and HFS+ partition with a name BootablePartition.
      3) Go to /Application/Install macOS Mojave.app.
      4) Show Package Contents.
      5) Go to Contents/SharedSupport you will find BaseSystem.dmg.
      6) Double click on BaseSystem.dmg to mount.
      7) From Disk Utilty click on your partition or the USB that you prepared from number (2).
      8) Click on restore, and chose OS X Base System (BaseSystem.dmg image), then restore it to that partition or USB.
      9) After restoring rename the partition back to BootablePartition.
      9) Run this command:
      rm -rfv /Volumes/BootablePartition/System/Installation/Packages 10) Create a new folder instead of the broken link and name it Packages, run this command:
      mkdir -v /Volumes/BootablePartition/System/Installation/Packages 11) Go back to /Application/Install macOS Mojave.app and repeat number 2.
      12) Go to Contents/SharedSupport you will find InstallESD.dmg.
      13) Mount InstallESD.dmg.
      14) Run this command:
      cp -v /Volumes/InstallESD/Packages/OSInstall.mpkg /Volumes/BootablePartition/System/Installation/Packages/ 15) Download the latest clover from https://sourceforge.net/projects/cloverefiboot/
      16) Install clover on your USB BootablePartition or in a different USB to boot from it. delete all your CLOVER/kext/10.xx and keep others, make sure you don't have any extra kext rather than FakeSMC.kext in the other folder.
      in my case I used FakeSMC.kext and my lan kext RealtekRTL8111.kext.
      17) known Problems in my build: 
      If I updated directly from the apple store the installer in clover will boot with a cross circle sign.
      The FIX is to add this to Clover KextToPatch Thanks to @sunKi http://www.insanelymac.com/forum/topic/327488-macos-high-sierra-final-release-is-out-17a365/page-10?do=findComment&comment=2505086 this fix is still working for me in mojave.
      <key>KextsToPatch</key> <array> <dict> <key>Comment</key> <string>fix IO error ICH10 for 10.13, credit SunKi</string> <key>Disabled</key> <false/> <key>Find</key> <data> RYX2D5XCiciD4P5mhcl4D4TSdQs= </data> <key>Name</key> <string>AppleAHCIPort</string> <key>Replace</key> <data> iciD4P5mhckPmMFBCMyQkJCQdQs= </data> </dict> <dict> <key>Comment</key> <string>fix hotplug ICH10 for 10.13, credit SunKi</string> <key>Disabled</key> <false/> <key>Find</key> <data> icglQGACAD1AIAAAdQyB4b9///+Ji1EBAAA= </data> <key>Name</key> <string>AppleAHCIPort</string> <key>Replace</key> <data> kJCQkJCQkJCQkJCQkJCQkJCQkJCQkJCQkJA= </data> </dict> <dict> <key>Comment</key> <string>External icons patch</string> <key>Disabled</key> <false/> <key>Find</key> <data> RXh0ZXJuYWw= </data> <key>Name</key> <string>AppleAHCIPort</string> <key>Replace</key> <data> SW50ZXJuYWw= </data> </dict> </array> 18) make sure you have apfs.efi copy it from /Volumes/BootablePartition/usr/standalone/i386/apfs.efi to your EFI/CLOVER/drivers64/ and EFI/CLOVER/drivers64UEFI/.
      19) SMBIOS mac model that I use is iMac13,2.
      20) Go to /Application/Install macOS Mojave.app click on it and chose to install to your macOS Mojave partition.
      21) Reboot.
      22) From clover chose BootablePartion.
      23) If everything is okie BootablePartition will boot to install macOS mojave, wait wait wait till it finish it might take to 1 hour just wait it will reach the auto reboot soon .
      24) Boot to your old macOS Hight Sierra that will be your mojave partition now and enjoy.
       
      POST Install:
      1) audio: 
      a) Download Lilu.kext and AppleALC.kext or build them from source (which I did).
      b) place them in your /EFI/CLOVER/kext/others/
      c) add your audio layout in clover/Devices dict options in my case it's ALC888B which has the layout of 1:
      <key>Audio</key> <dict> <key>Inject</key> <string>1</string> </dict> d) I had to add beta args to clover/Boot dict, argument (-lilubeta -alcbeta):
       
      <key>Arguments</key> <string>-lilubeta -alcbeta</string> 2) Add number 14 KextsToPath array to your clover as well.

      Anything else is working for me I didn't need any extra clover kext so far, I tried whatevergreen.kext to fire up my rx 460 without the helper card but no success, So I am just sticking with booting from Nvidia as a first GPU from my motherboard configuration then swap the cables after choosing my macOS partion from clover.
       
      After upgrading my HFS+ High Sierra partition converted to APFS, no know problem so far.

      Happy build and more info about the partitioning method with a more detailed instructions in this post that I used to update my Sierra to High Sierra
       
      Special thanks to crazybirdy, sunKi and all of you out there that make this happens.
    • By NoEnd
      Hi team,
       
      I have tried to update to security update 2019-001 multiple time with no luck, today I've booted the update with -verbose and attached videos shows the details.
       
      Appreciate your help
       
      Thanks
      Untitled.mov
×