Jump to content
fantomas

[pre-release] macOS High Sierra

3,823 posts in this topic

Recommended Posts

I can't not access the install screen although I use your cloverx64 file.

Which kext are you using? And how about your config/DSDT/Patchs ?

nothing special, FakeSMC thats it

DSDT Yes I used DSDT for my Graphics card

Share this post


Link to post
Share on other sites
Advertisement

The problem is after boot!  :)  :yes:

Yup!

 

It won't start the second stage of the installation!

 

System reboots!

 

I'm reformatted the drive with macOS Extended journaled to see if it makes any difference!

Share this post


Link to post
Share on other sites
00F4h: 31 31 33 2D 44 30 30 30 31 41 30 2E 30 30 39 00  113-D0001A0.009. 
0104h: 45 4C 4C 45 53 4D 45 52 45 00 50 43 49 5F 45 58  ELLESMERE.PCI_EX 
0114h: 50 52 45 53 53 00 47 44 44 52 35 00 0D 0A 45 4C  PRESS.GDDR5...EL 
0124h: 4C 45 53 4D 45 52 45 20 58 54 20 41 30 20 47 44  LESMERE XT A0 GD 
0134h: 44 52 35 20 32 35 36 4D 78 33 32 20 38 47 42 20  DR5 256Mx32 8GB  
0144h: 33 30 30 65 2F 31 37 35 30 6D 20 20 20 20 20 20  300e/1750m       
0154h: 20 20 20 20 20 20 20 20 20 20 20 20 20 20 20 20                   
0164h: 20 20 20 20 20 20 20 20 20 20 0D 0A 00 0D 0A 20            .....  
0174h: 0D 0A 00 28 43 29 20 31 39 38 38 2D 32 30 31 30  ...(C) 1988-2010 
0184h: 2C 20 41 64 76 61 6E 63 65 64 20 4D 69 63 72 6F  , Advanced Micro 
0194h: 20 44 65 76 69 63 65 73 2C 20 49 6E 63 2E 00 41   Devices, Inc..A 
01A4h: 54 4F 4D 42 49 4F 53 42 4B 2D 41 4D 44 20 56 45  TOMBIOSBK-AMD VE 
01B4h: 52 30 31 35 2E 30 35 30 2E 30 30 30 2E 30 30 30  R015.050.000.000 
01C4h: 2E 30 30 30 30 30 30 00 44 30 30 30 31 41 30 2E  .000000.D0001A0. 
01D4h: 30 30 39 20 00 31 32 36 35 31 39 32 20 00 33 34  009 .1265192 .34 
01E4h: 34 39 34 37 20 20 00 20 20 20 20 20 20 20 20 00  4947  .        . 
01F4h: 46 41 4C 43 4F 4E 5F 45 4C 4C 45 53 4D 45 52 45  FALCON_ELLESMERE 
0204h: 4D 5F 58 54 41 5F 50 4F 52 54 41 47 45 5F 41 30  M_XTA_PORTAGE_A0 
0214h: 5F 47 44 44 52 35 5F 38 47 42 5C 63 6F 6E 66 69  _GDDR5_8GB\confi 
0224h: 67 2E 68 00 00 00 24 00 01 01 41 54 4F 4D 00 00  g.h...$...ATOM.. 
0234h: 97 03 CC 01 75 02 20 01 BC 03 00 00 00 00 6B 10  —.Ì.u. .¼.....k. 
0244h: 00 00 50 02 BC 51 62 52 A1 00 00 00 50 43 49 52  ..P.¼QbR¡...PCIR 
0254h: 02 10 DF 67 00 00 18 00 00 00 80 03 80 00 32 0F  ..ßg......€.€.2. 
0264h: 00 80 00 00 41 4D 44 20 41 54 4F 4D 42 49 4F 53  .€..AMD ATOMBIOS 

Vega Bios from iMac 18,3 firmware.

Share this post


Link to post
Share on other sites

BSD Panic. I cant even boot. Restored macOS from real mac. Tried via createmedia. Same result, everytime.

 

T8ROrRv.jpg

Same here... seems to be AppleACPIPlatform (try booting with keepsyms=1). I've already tried different DSDT edits/etc but nothing has worked so far.

Share this post


Link to post
Share on other sites

I'm booting to installer then stuck at Loading disks in disk utility or if I press install macOS and click on continue nothing happens only deactivate the button.

Share this post


Link to post
Share on other sites

Im working everyday on Sierra so there is patched bios in GPU. I will check with 290X (no moded rom) later 

 

thanks man, i just want to know if there is still need of an helper card or iGPU for Polaris, i really hope not :D

Share this post


Link to post
Share on other sites
00F4h: 31 31 33 2D 44 30 30 30 31 41 30 2E 30 30 39 00  113-D0001A0.009. 
0104h: 45 4C 4C 45 53 4D 45 52 45 00 50 43 49 5F 45 58  ELLESMERE.PCI_EX 
0114h: 50 52 45 53 53 00 47 44 44 52 35 00 0D 0A 45 4C  PRESS.GDDR5...EL 
0124h: 4C 45 53 4D 45 52 45 20 58 54 20 41 30 20 47 44  LESMERE XT A0 GD 
0134h: 44 52 35 20 32 35 36 4D 78 33 32 20 38 47 42 20  DR5 256Mx32 8GB  
0144h: 33 30 30 65 2F 31 37 35 30 6D 20 20 20 20 20 20  300e/1750m       
0154h: 20 20 20 20 20 20 20 20 20 20 20 20 20 20 20 20                   
0164h: 20 20 20 20 20 20 20 20 20 20 0D 0A 00 0D 0A 20            .....  
0174h: 0D 0A 00 28 43 29 20 31 39 38 38 2D 32 30 31 30  ...(C) 1988-2010 
0184h: 2C 20 41 64 76 61 6E 63 65 64 20 4D 69 63 72 6F  , Advanced Micro 
0194h: 20 44 65 76 69 63 65 73 2C 20 49 6E 63 2E 00 41   Devices, Inc..A 
01A4h: 54 4F 4D 42 49 4F 53 42 4B 2D 41 4D 44 20 56 45  TOMBIOSBK-AMD VE 
01B4h: 52 30 31 35 2E 30 35 30 2E 30 30 30 2E 30 30 30  R015.050.000.000 
01C4h: 2E 30 30 30 30 30 30 00 44 30 30 30 31 41 30 2E  .000000.D0001A0. 
01D4h: 30 30 39 20 00 31 32 36 35 31 39 32 20 00 33 34  009 .1265192 .34 
01E4h: 34 39 34 37 20 20 00 20 20 20 20 20 20 20 20 00  4947  .        . 
01F4h: 46 41 4C 43 4F 4E 5F 45 4C 4C 45 53 4D 45 52 45  FALCON_ELLESMERE 
0204h: 4D 5F 58 54 41 5F 50 4F 52 54 41 47 45 5F 41 30  M_XTA_PORTAGE_A0 
0214h: 5F 47 44 44 52 35 5F 38 47 42 5C 63 6F 6E 66 69  _GDDR5_8GB\confi 
0224h: 67 2E 68 00 00 00 24 00 01 01 41 54 4F 4D 00 00  g.h...$...ATOM.. 
0234h: 97 03 CC 01 75 02 20 01 BC 03 00 00 00 00 6B 10  —.Ì.u. .¼.....k. 
0244h: 00 00 50 02 BC 51 62 52 A1 00 00 00 50 43 49 52  ..P.¼QbR¡...PCIR 
0254h: 02 10 DF 67 00 00 18 00 00 00 80 03 80 00 32 0F  ..ßg......€.€.2. 
0264h: 00 80 00 00 41 4D 44 20 41 54 4F 4D 42 49 4F 53  .€..AMD ATOMBIOS 

Vega Bios from iMac 18,3 firmware.

 

 

That's Ellesmere... aka  POLARIS  (RX580) 

Share this post


Link to post
Share on other sites

Hi Mattew82

which clover kernel patch are you using in your config.plist?

could you share your 10.13 Efi?

Thank you

http://www.insanelymac.com/forum/topic/324194-pre-release-macos-high-sierra/?p=2435885

 

 

 

What about black screen on boot is still persist?

 

 

 

Is present. You have to boot with patched gpu bios

Share this post


Link to post
Share on other sites

please confirm
shasum /Applications/Install*OS*.app/Contents/SharedSupport/InstallESD.dmg

dc9e81f0ba874b23ed62a084ac63702bedebc8cd

Share this post


Link to post
Share on other sites

please confirm

shasum /Applications/Install*OS*.app/Contents/SharedSupport/InstallESD.dmg

dc9e81f0ba874b23ed62a084ac63702bedebc8cd

kvMp7BH.png

Share this post


Link to post
Share on other sites

please confirm

shasum /Applications/Install*OS*.app/Contents/SharedSupport/InstallESD.dmg

dc9e81f0ba874b23ed62a084ac63702bedebc8cd

shasum /Applications/Install*OS*.app/Contents/SharedSupport/InstallESD.dmg
dc9e81f0ba874b23ed62a084ac63702bedebc8cd  /Applications/Install macOS 10.13 Beta.app/Contents/SharedSupport/InstallESD.dmg

Share this post


Link to post
Share on other sites

please confirm

shasum /Applications/Install*OS*.app/Contents/SharedSupport/InstallESD.dmg

dc9e81f0ba874b23ed62a084ac63702bedebc8cd

Mac-Pro-Mateusz:~ mateuszjachym$ shasum /Applications/Install*OS*.app/Contents/SharedSupport/InstallESD.dmg
dc9e81f0ba874b23ed62a084ac63702bedebc8cd  /Applications/Install macOS 10.13 Beta.app/Contents/SharedSupport/InstallESD.dmg

Share this post


Link to post
Share on other sites

please confirm

shasum /Applications/Install*OS*.app/Contents/SharedSupport/InstallESD.dmg

dc9e81f0ba874b23ed62a084ac63702bedebc8cd

Optiplex-van-Rico:~ rico$ shasum /Applications/Install*OS*.app/Contents/SharedSupport/InstallESD.dmg
47504144b692798f4713873c5383d8e6755e97f1  /Applications/Install macOS 10.13 Beta.app/Contents/SharedSupport/InstallESD.dmg
I feel special now

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By chris1111
      Here my theme of OC 

      How to create are own Theme with Icnspack-Builder
       

       
       
      You can also have the themes on ➤ Github
       
      You can also have the themes on ➤ HTML Page
       
    • By MaLd0n
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
        1 -Create a USB bootable
       
      Create your usb installer, use this tool and download Catalina or Big Sur from Apple servers
       
      Catalina
      installScript_allfullapp.zip
       
      Big Sur
      installScript_1016fullapp.zip
       
      Credits: crazybirdy
       
      Copy Catalina / Big Sur installer to Applications folder, open terminal and run
       
      Catalina
       
       
      Big Sur
       
       
      If you want check one step by step, check here
       
      -Opencore Vanilla Tutorial
      https://tinyurl.com/ycvcnp8h
       
      2- EFI folder USB installation
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/yxsw7d3t
       
      3- EFI folder SSD
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD 
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD
      https://tinyurl.com/yxsw7d3t
       
      4- Start Fine Tune
       
      Run this app and post full dump here for full ACPI solution
       
      RunMe.app
      https://tinyurl.com/y9562hz7
       
       
      If you like a SSDT way, here we go
      SSDT-OLARILA.aml.zip
       
      5- USB Solution
       
      Use these kexts, enable XHCI port limit patch
       
      USB INTEL SERIE 400.zip
       
      and follow this tutorial for remap USB ports
       
       
      --DSDT PATCHES--
       
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -HDMI / HDAU  
      --SCREENSHOTS--































      -If you want to buy me a beer - Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By chetan100
      Hi 
      I need the Catalina mbr patcher. If anyone can reupload it for me I would be grateful!
    • By gekko.be
      I have an old Hackintosh that I have brought back to life. An ASUS P5KPLAM-SE mobo, Intel Core 2 Quad, with a Sapphire HD 5670 1GB graphics card. It used to work just fine on High Sierra 10.13.3 (I think it was .3) However I only used the DVI port. Updated to 10.13.6 and with AMD kexts rollback to the previous versions I got everything o wrk just fine: boot, HDMI video, HDMI audio etc etc. The only problem I face is that my USB keyboard and mouse freeze/hang seemingly very random... I can not seem to get it right. Unplugging and replugging the USB device makes it work again, sometimes for a few seconds sometimes for an hour ... No idea what's wrong... Have tried tons of options in clover, USBInjectall.kext with port limit patch, whatever I could find... Would there be anyone out there who would have an idea of what could be the problem?
    • By macinsane
      *This guide is deprecated and will not be maintained anymore*

      Update: Now running Mojave! Thanks to mojave2core! Yeah   Still using C2D in 2019!
      Inserted a nice and cheap GT710 that is not relying on nVidias Webdrivers and runs OOB under Mojave.
       
      Nice, seeing High Sierra running on this old but capable system! It rocks with a new ASUS GT1030
       
      Config:
      Gigabyte EP43-DS3L
      Core2Quad Q9300
      6 GB DDR2 RAM
      Asus GT1030 2GB
      Sandisk SSD 128GB
      TP-Link AC1200 Wifi USB
      Inateck KT4006 USB 3.0 PCIe (No boot)
       
      SMBIOS: iMac14,1
      Clover: 4297  4360
       
      A good deal of DSDT editing was necessary to get this machine to boot High Sierra but finally it works flawlessly, even sleep and wake!
      You NEED to have the DSDT put in place for installation because otherwise macOS doesn't recognize the SATA ports.
      There are a few important BIOS settings: SATA hast to be set to AHCI and "native" and HPET has to be run "64-bit", I'd recommend to disable IDE and the serial and parallel port.
      For the GT1030 nVidia Webdrivers are needed, have to boot with nv_disable=1 until you have them installed.
      You have to install Clover in legacy mode because this old fella does not support UEFI.
       
      Only downside: The so often recommended Inateck USB-card isn't recognized by BIOS, so you cannot boot from it. It works perfectly within macOS though, have the ac-Wifi connected to it.
      config.plist.zip
      DSDT.aml.zip
×