Jump to content
fantomas

[pre-release] macOS High Sierra

3,845 posts in this topic

Recommended Posts

Hi LuCyr04. I still needed to change 4 kexts for the Sierra to achieve graphics acceleration. I'm having the same Sierra result in OpenGL Extensions Viewer, which sounds good to me. I think total support in HS will not have without an auxiliary graphics card, so we'll have to make this little kexts exchange, but it has not affected the performance at all, and that's very good.

What kexts you install from sierra? The names...

 

Sent from my HTC One M9 using Tapatalk

Share this post


Link to post
Share on other sites
Advertisement

I use to change this:

<key>Mac-F60DEB81FF30ACF6</key>

<string>none</string>
 
config1>none
from time ago it works for me
with other methods I have problem (maybe I am not able to use it in right way!
 
 

Share this post


Link to post
Share on other sites

 

I use to change this:

<key>Mac-F60DEB81FF30ACF6</key>

<string>none</string>
 
config1>none
from time ago it works for me
with other methods I have problem (maybe I am not able to use it in right way!

 

Yes, the patch I mentioned above just does this, but in a different way. Have a try. :)

Share this post


Link to post
Share on other sites

Hey bro, how can you install nvidia web for GT710? Does it work smoothly?

 

I didn't install the web drivers, the card works OOB for me. However, the overall system is really slow and when using Safari the system gets unusable. This improved a little in DP2, but it still isn't smooth.

I suspect that the graphics card is the culprit here

Share this post


Link to post
Share on other sites

The first time I tried it gave me Beta 1 attachicon.gifScreen Shot 2017-06-22 at 2.07.57 pm.pngbut now its Beta 2 I think.attachicon.gifScreen Shot 2017-06-22 at 2.08.22 pm.png

You need remove of you Hack all Beta 1 Installer and download Beta 2 Installer

Share this post


Link to post
Share on other sites

You need remove of you Hack all Beta 1 Installer and download Beta 2 Installer

Do you have a link for the new beta 2. macOSSierraDeveloperBetaAccessUtility doesn't work anymore.

Share this post


Link to post
Share on other sites

Do you have a link for the new beta 2. macOSSierraDeveloperBetaAccessUtility doesn't work anymore.

Its a same pkg remove al installer even in trash and other ssd

Share this post


Link to post
Share on other sites

Its a same pkg remove al installer even in trash and other ssd

 

Thanks ;)

 

I was using another PC without any installer and the macOSSierraDeveloperBetaAccessUtility wasn't working so I used the direct link and now it's downloading.

 

This the link that @Kynyo posted here: macappstores://itunes.apple.com/app/id1209167288

 

But the package is only 14.5 MB?!?!?

I downloaded it twice and it's only 14.5 MB!!!!

Share this post


Link to post
Share on other sites

macOS High Sierra Beta 2 success on my Haswell Lappy.

attachicon.gifScreen Shot 2017-06-22 at 3.35.56 pm.png

Still same issue of battery status but it's a beta.

 

EDIT: On the plus side i can now boot my my laptop with HDMI connected and it doesn't reboot halfway through booting. With HDMI audio.

Hi SavageAUS, 

 

Could you please send me the EFI folder for High Sierra Beta,

 

I can't install 10.13

 

Thank you.

Share this post


Link to post
Share on other sites

Hi SavageAUS,

 

Could you please send me the EFI folder for High Sierra Beta,

 

I can't install 10.13

 

Thank you.

I'm using my phone so can't see signatures, what are your system specs?

 

Sent from my SM-G930F using Tapatalk

I did, and I don't have any adblockers.

I had similar issue. I had to delete / rename beta 1 to download beta 2 as its naming it the exact same for beta 1 and 2.

macOSSierraDeveloperBetaAccessUtility does work still as that's how I got beta 2.

If your getting an incomplete download check network settings / reboot modem / router.

 

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

I'm using my phone so can't see signatures, what are your system specs?

 

Sent from my SM-G930F using Tapatalk

I had similar issue. I had to delete / rename beta 1 to download beta 2 as its naming it the exact same for beta 1 and 2.

macOSSierraDeveloperBetaAccessUtility does work still as that's how I got beta 2.

If your getting an incomplete download check network settings / reboot modem / router.

 

Sent from my SM-G930F using Tapatalk

I have no other copy of macOS High Sierra on my computer. But I will try to download it later. Thanks for the tip.

Share this post


Link to post
Share on other sites

What kexts you install from sierra? The names...

 

Sent from my HTC One M9 using Tapatalk

AMDRadeonX3000.kext, AMDRadeonX3000GLDriver.bundle, IOAccelerator2D.plugin, IOAcceleratorFamily2.kext.

Share this post


Link to post
Share on other sites

AMDRadeonX3000.kext, AMDRadeonX3000GLDriver.bundle, IOAccelerator2D.plugin, IOAcceleratorFamily2.kext.

And you get the card fully working without iGPU?

 

Sent from my HTC One M9 using Tapatalk

Share this post


Link to post
Share on other sites

And you get the card fully working without iGPU?

 

Sent from my HTC One M9 using Tapatalk

I still needed to change 4 kexts for the Sierra to achieve graphics acceleration. I'm having the same Sierra result in OpenGL Extensions Viewer, which sounds good to me. I think total support in HS will not have without an auxiliary graphics card, so we'll have to make this little kexts exchange, but it has not affected the performance at all, and that's very good.

Share this post


Link to post
Share on other sites

I still needed to change 4 kexts for the Sierra to achieve graphics acceleration. I'm having the same Sierra result in OpenGL Extensions Viewer, which sounds good to me. I think total support in HS will not have without an auxiliary graphics card, so we'll have to make this little kexts exchange, but it has not affected the performance at all, and that's very good.

So it's usable, you tried YouTube videos?

 

Sent from my HTC One M9 using Tapatalk

Share this post


Link to post
Share on other sites

All works flawlessly. Try it.

I need to repair my Sierra now, tried to partition SSD and broke all... Will try today anyway.

 

Sent from my HTC One M9 using Tapatalk

Share this post


Link to post
Share on other sites

Anyway, what's puzzling me is that in the compatibility list I saw out there, iMac 2009 appears on, and they had no auxiliary video card ... I've been looking at the plist of the X3000 and I've seen that it looks like it has odd errors or changes and the torque is less than 10.12.5 . Would they release this beta with this so spoiled kext ????

 

Edit: Unless the Core2Duo used in this iMac 10.1 is considered an aid because it has the ability, even if very old, to generate video. And since Core2Quad does not have it, we can not have native support and we always need to use these Sierra kexts. I think that maybe that's why this iMac is on the compatibility list.

 

Edit2: Another thing I noticed: i'm not sure how graphics injection works, but since the Sierra i could no longer patch on the fly through Clover and when i put the framebuffer Baboon or Eulemur for my video card, which always worked previously, stays with screen Black (monitors turn off). I tried several things, but i did not want to have to modify the kext manually, so i did not have to do this at all update. Now i was thinking, if the bootloader is who tells the system what framebuffer to use, it will be that in the bootloader, the address of the framebuffer informed is outdated, thus causing a deviation of the AMD5000Controller.kext to a wrong address, making it impossible to be completed The patch?

Share this post


Link to post
Share on other sites
Hello to everyone.

 

I have had difficulty installing the update according to the normal procedure.

I solved this: After downloading the upgrade, I started in the previous High Sierra, opened the update folder, made it accessible, and then I started my install.app from inside the system.

So a new installation started that has recovered all the previous one.

I apologize for my google-english. Hope it is understandable.

Share this post


Link to post
Share on other sites

Anyway, what's puzzling me is that in the compatibility list I saw out there, iMac 2009 appears on, and they had no auxiliary video card ... I've been looking at the plist of the X3000 and I've seen that it looks like it has odd errors or changes and the torque is less than 10.12.5 . Would they release this beta with this so spoiled kext ????

 

Edit: Unless the Core2Duo used in this iMac 10.1 is considered an aid because it has the ability, even if very old, to generate video. And since Core2Quad does not have it, we can not have native support and we always need to use these Sierra kexts. I think that maybe that's why this iMac is on the compatibility list.

 

Edit2: Another thing I noticed: i'm not sure how graphics injection works, but since the Sierra i could no longer patch on the fly through Clover and when i put the framebuffer Baboon or Eulemur for my video card, which always worked previously, stays with screen Black (monitors turn off). I tried several things, but i did not want to have to modify the kext manually, so i did not have to do this at all update. Now i was thinking, if the bootloader is who tells the system what framebuffer to use, it will be that in the bootloader, the address of the framebuffer informed is outdated, thus causing a deviation of the AMD5000Controller.kext to a wrong address, making it impossible to be completed The patch?

Man, changed the kexts you said and still can't boot without -x, can you upload your kexts because I'm on 10.12.6 beta 4 and I think that's the problem.

 

Sent from my HTC One M9 using Tapatalk

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By End3rPower50
      Hi, i want install MacOS catalina in my laptop.
      i created a USB bootable with Catalina and Clover but it crashed at startup.
      Thanks in advance. 
       
      P.S I upload my EFI’s folder and crash screenshot
       
      Sorry for my bad english.
       
      This is my laptop: 
      CPU: intel i7 6500U 
      Graphics: Intel HD Graphics 520
      Ethernet: Realtek FE Family 
      Wireless: Dell 1820A (BCM94350ZAE)
      USB 3.0
       

      EFI.zip
    • By anokic
      I have been using clover to install and configuration my Hackintosh High Sierra 10.13.6. It's been a struggle and a pain. Can't restart/shutdown/wake from sleep. Random freezes. When freeze happens mouse works but in loading state. UI and open apps freeze not the mouse. I can make the apps smaller and move them.

      I haven't used any DSDT nor SSDT. Tried 5 or 6 of them from others but sometimes i end up not booting. Could someone explain me do i even need them and why? Do i need DSDT or SSDT or both?

      I'm going to try to install everything OpenCore. The first thing is i can't use a method that needs an internet while installing MacOS cause my ethernet/internet only works when i install MacOS. So i can't use the images i need full installation. Okay i have the full installation for 10.13.6. I need to use a version 10.13.4-6 versions cause application Sketch needs the newer one High Sierra 10.13.4++ version.

      Can you tell me? Can i use same kexts from Clover on OpenCore? Secondly how can i install full USB MacOS installer? (High Sierra 10.13.6 version i have is 7gb i think thats it)
      Is there a version of AMDHigh Sierra version made from the community for 10.13.4++ version?
      If i use the normal 10.13.6 High Sierra should i use this AMD 10.13.6 Kernel when i have installed the MacOS or some other kernel that's better for my system? https://github.com/Shaneee/AMD-High-Sierra-XNU/releases
      Whats the best version of High Sierra to use for Ryzen and Nvidia system?

      Will it be better to use OpenCore?

      Specs:
      Mortar Max B450M
      Ryzen 2600x
      Nvidia GTX 1060
      16gb DDR4 2400mhz
    • By midi-sama
      After a long time of cooking this computer up with a lot of stuff, I'm finally releasing my guide for this P50 with OpenCore.
       
      Lenovo ThinkPad P50 macOS Install with OpenCore
       
      This thread may be used for questions/corrections/additions. Good Luck.
    • By Rohan20
      Opencore is running really really slow on Catalina 10.15.4. So It was running perfectly before I put the ssdt-pnlf for enabling Brightness control. it is running really slow and I verified my config with the sanity checker and its all correct. can someone please help. I am attaching my oc folder.

       
      https://www.dropbox.com/s/drkek0eaz19ina5/OC.zip?dl=0
       
    • By RyzenDude
      Hi everyone,
      Today I finished my High Sierra install with OpenCore. I got everything up and running but I can't seem te get rid of this text on te boot screen while booting up. Does anyone have a solution to this?
      Thanks in advance!
      Hardware:
      CPU: Ryzen 5 1600
      GPU: GTX 980
      RAM: 16 GB DDR4 2666 MHz
      Motherboard: ASUS EX-A320M-GAMING
      Audio Codec: AppleALC
      Ethernet Card: Realtek RTL8111
      Bootloader: OpenCore 0.5.5

×