Jump to content
fantomas

[pre-release] macOS High Sierra

3,845 posts in this topic

Recommended Posts

Advertisement

 

I was able to boot to the installer using CloverX64-High.efi and apfs.efi in the Clover64UEFI folder.  I had to boot with cpus=1 because the LAPIC patch did not work.  Kext injection did work and I was able to use RehabMan's voodoops2.kext and acpibattery.kext.  I don't think I had bluetooth or wifi.  I couldn't tell.  Either way, I hit a stumbling block and can't seem to get past it.  Anyone else run into this?

 

attachicon.gifIMG_3270.JPG

 

Got the same error with Enoch 2883 (-v -f) and MBR installing method, patched kernel as attached.

kernel_10.13.db1.17A264c.HP_lapic_native_XCPM.zip

Share this post


Link to post
Share on other sites

Some private stuff from latest apple firmware. Also APFS Jump Start driver

https://yadi.sk/d/_JdX6vPU3GeESy

UPD:

Updated APFS Jump Start driver

 

guid: CFFB32F4-C2A8-48BB-A0EB-6C3CCA3FE847

APFS.efi from /usr/standalone isn't designed to run manually, cause dat stuff runs via mechanism inside apple frmw or boot.efi

APFS.ffs.zip

Share this post


Link to post
Share on other sites

Second try  :P

 

 

img_1020.jpg

 

I format in Mac OS Extend Journalise  this is  Good?

 

Because APFS is available in Disk Utility  :yes:

 

 

same thing Error OSInstall.mpkg  :cry:

How did you get that far in the first place? I'm still stuck at kextd stall AppleACPICPU

 

Edit: I am able to enter the installer now, but "an error occurred while verifying firmware"

Share this post


Link to post
Share on other sites

If we're not using APFS I'm assuming it should be enough to fake the firmware features string Clover announces to make the installer think that the firmware supports APFS. Just a case of finding out what the correct value is.

You're absolutely right, but it won't solve OSInstall.mpkg error

PS: You can set FirmwareFeatures to ff ff ff ff bits, then validation will passed

Share this post


Link to post
Share on other sites

OSInstall.mpkg error is related to the bootable media which macOS is loaded from.

 

I just created a bootable USB using disk utility and then copied the "Package" folder manually and I got the same error on my MacBook Air, then I used createinstallmedia and it just booted to the installer with no error.

 

here is the terminal command I used to create the High Sierra bootable USB disk:

 

For the first developers preview:

sudo /Applications/Install\ macOS\ 10.13\ Beta.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ macOS\ 10.13\ Beta.app —nointeraction

and

 

for the public beta

sudo /Applications/Install\ macOS\ High\ Sierra\ Beta.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ macOS\ High\ Sierra\ Beta.app —nointeraction

Share this post


Link to post
Share on other sites

Setting FirmwareFeatures to 0xFFFFFFFF didn't pass validation here. I still got the unable to verify firmware error at second stage install. The log shows a different value for "ROM Features returned" but still follows that up with "ROM does not support APFS".

 

I've also replaced the apfs.efi in EFI with the JumpStart one extracted from the MBP91 firmware. Thanks for the GUID, I wasn't able to find the right module last night by searching the firmware in UEFITool.

 

Update: Setting FirmwareFeatures doesn't change the FirmwareFeaturesMask value. Maybe that's the problem. I tried setting it in nvram but Clover replaces it with its default value on reboot.

Share this post


Link to post
Share on other sites

I've installed macOS High Sierra too. Have the same problem with OSInstall.mpkg appears to be missing. Just restore image from real mac. 

Image was taken before user creation by @m-dudarev from applelife.ru [Link Removed]

Clover by @denskop Clover_r4079_High_Sierra.zip This version don't work on 10.12... Start it from USB drive.  

Intel HD 530 have the same problem as in 10.12.5. But Lilu.kext + IntelGraphicsFixup.kext deals with this :thumbsup_anim:

Used boot arguments for Lilu an Plugins 

-lilubeta -igfxbeta -alcbeta

Graphics is working. So smoooooth with metal2 :P

post-1069282-0-99965000-1496748207_thumb.png

Audio is working. ALC887 with AppleALC, HDMI - native with ig-platform-id 0x193b0000

post-1069282-0-40207100-1496748228_thumb.png

Don't work hardware acceleration on HD 530 with Shiki.kext and -shikigva bootarg. Problem is Shiki hangs entire system when open QuickTime or iTunes. Need further research. 

post-1069282-0-70091800-1496748273_thumb.png

Edited by Allan
Link removed - Remember of our forum rules

Share this post


Link to post
Share on other sites

So far, all those who posted screenshots of running 10.13 Hackintosh installations used a cloned image off a real Mac. That's of little use to most of us, except to state that it runs on PC platforms. But thanks Vanroiy2012 for stating this most important "detail"...  ;)

Share this post


Link to post
Share on other sites

How did you get that far in the first place? I'm still stuck at kextd stall AppleACPICPU

 

Edit: I am able to enter the installer now, but "an error occurred while verifying firmware"

What error ? same as mine ?

here the file I used with my error OSInstall.mpkg

CLOVERX64 from Applelife.ru 

Sierra 10.13.zip

Share this post


Link to post
Share on other sites

What error ? same as mine ?

here the file I used with my error OSInstall.mpkg

CLOVERX64 from Applelife.ru 

Thanks, but I figured it out already. I'm stuck at the OSInstall.mpkg error too. I'm making a manual USB install now. .Let's see how that will go. 

I guess it's because the Packages folder is in InstallESD.dmg, while the installer looks for it in BaseSystem.dmg. 

Share this post


Link to post
Share on other sites

What error ? same as mine ?

here the file I used with my error OSInstall.mpkg

CLOVERX64 from Applelife.ru 

Hi Chris1111,

 

Did you get passed kexts stall[0] error?

Share this post


Link to post
Share on other sites

Just for the temporary solution, you can patch OSInstaller to bypass firmware update and check's, but I'm not sure about this

JE - > JMP here

attachicon.gifСнимок экрана 2017-06-06 в 17.52.06.png

 

Nice try, but still error as same as OSInstall.mpkg.

Jun  6 20:53:31 localhost opendirectoryd[183]: opendirectoryd (build 465.000) launched - installer mode
Jun  6 20:53:36 localhost powerd[170]: powerd process is started
Jun  6 20:53:44 localhost Unknown[534]: kern.boottime: { sec = 1496782400, usec = 0 } Tue Jun  6 20:53:20 2017
Jun  6 20:54:13 iMac Installer Progress[177]: IASGetCurrentInstallPhaseList: Unable to get phases
Jun  6 20:54:13 iMac Installer Progress[177]: IASGetCurrentInstallPhase: Unable to get the current phase name
Jun  6 20:54:13 iMac Installer Progress[177]: Progress App loading...
Jun  6 20:54:13 iMac Installer Progress[177]: Progress App is running with no progress set.
Jun  6 20:54:13 iMac Installer Progress[177]: Progress App running...
Jun  6 20:54:15 iMac Unknown[571]: Launching the Language Chooser for an OS Install
Jun  6 20:54:15 iMac launchprogresswindow[569]: ISAP: show progress UI called.
Jun  6 20:54:15 iMac Installer Progress[177]: IASGetCurrentInstallPhase: Current phase name is: Boot 1
Jun  6 20:54:15 iMac Installer Progress[177]: Showing Progress UI
Jun  6 20:54:16 iMac Installer Progress[177]: IOProgressColorTheme is set to 0
Jun  6 20:54:34 iMac Installer Progress[177]: Shield windows created.
Jun  6 20:54:34 iMac Installer Progress[177]: Shield windows ordered front.
Jun  6 20:54:36 iMac Language Chooser[572]: Using progress phase: Language Chooser
Jun  6 20:54:36 iMac Unknown[573]: Setting boot completed.
Jun  6 20:55:06 iMac Language Chooser[572]: LCA+BT2: failed to get BT host controller after 30 seconds
Jun  6 20:55:06 iMac Language Chooser[572]: LCA+BT2: BT host controller appeared after 30 seconds
Jun  6 20:55:06 iMac Language Chooser[572]: AppleSecureBootFailureReason: 0x00, StartupManagerFailureReason: 0x00
Jun  6 20:55:06 iMac Language Chooser[572]: AppleSecureBootFailureReason: 0x00, StartupManagerFailureReason: 0x00
Jun  6 20:55:06 iMac Language Chooser[572]: Could not read prev-lang:kbd to set keyboard.
Jun  6 20:55:36 iMac Language Chooser[572]: ISAP: hide progress UI called.
Jun  6 20:55:36 iMac Installer Progress[177]: Hiding Progress UI
Jun  6 20:55:36 iMac Installer Progress[177]: End progress UI called...
Jun  6 20:55:36 iMac Language Chooser[572]: LCA+BT2: failed to get BT host controller after 30 seconds
Jun  6 20:55:36 iMac Language Chooser[572]: LCA+BT2: BT host controller appeared after 30 seconds
Jun  6 20:55:38 iMac powerd[170]: Assertion Created. Type:UserIsActive Name:'com.apple.iohideventsystem.queue.tickle.4294968395.17' Id:0x900008002 Process:hidd [System: DeclUser kDisp]
Jun  6 20:55:38 iMac Language Chooser[572]: LCA+BT2: failed to get BT host controller after 30 seconds
Jun  6 20:55:38 iMac Language Chooser[572]: LCA+BT2: BT host controller appeared after 30 seconds
Jun  6 20:55:38 iMac Language Chooser[572]: AppleSecureBootFailureReason: 0x00, StartupManagerFailureReason: 0x00
Jun  6 20:55:38 iMac Language Chooser[572]: No primary language hint found
Jun  6 20:55:42 iMac Language Chooser[572]: AppleSecureBootFailureReason: 0x00, StartupManagerFailureReason: 0x00
Jun  6 20:55:42 iMac Language Chooser[572]: Launching the Installer using language code "en"
Jun  6 20:55:43 iMac Unknown[573]: objc[583]: Class OSIDebuggerTool is implemented in both /System/Library/PrivateFrameworks/OSInstaller.framework/Versions/A/OSInstaller (0x10d9c32f0) and /System/Installation/CDIS/macOS Installer.app/Contents/MacOS/macOS Installer (0x10d8ef638). One of the two will be used. Which one is undefined.
Jun  6 20:55:44 iMac storagekitd[584]: Starting SKDaemon...
Jun  6 20:55:44 iMac storagekitd[584]: Client entitled for destructive operations
Jun  6 20:55:44 iMac storagekitd[584]: Adding client connection <NSXPCConnection: 0x7faafec02580> connection from pid 583
Jun  6 20:55:47 iMac OSInstaller[583]: No mutable product specified in NVRAM.
Jun  6 20:55:49 iMac OSInstaller[583]: Connected to daemon. Language set to: English
Jun  6 20:55:49 iMac OSInstaller[583]: Connected to daemon. Language set to: English
Jun  6 20:55:49 iMac OSInstaller[583]: We are not image source booted attempting more robust automation fallback.
Jun  6 20:55:49 iMac Unknown[573]: 2017-06-06 20:55:49.218 macOS Installer[583:3881] Connected to daemon. Language set to: English
Jun  6 20:55:49 iMac Unknown[573]: 2017-06-06 20:55:49.219 macOS Installer[583:3881] Connected to daemon. Language set to: English
Jun  6 20:55:49 iMac OSInstaller[583]: No mutable product specified on boot disk.
Jun  6 20:55:49 iMac OSInstaller[583]: Hardware: iMac13,1 @ 2.99 GHz (x 2), 6144 MB RAM
Jun  6 20:55:49 iMac OSInstaller[583]: Running OS Build: Mac OS X 10.13 (17A264c)
Jun  6 20:55:49 iMac OSInstaller[583]: Env: DYLD_NO_FIX_PREBINDING=1
Jun  6 20:55:49 iMac OSInstaller[583]: Env: PATH=/usr/bin:/bin:/usr/sbin:/sbin
Jun  6 20:55:49 iMac OSInstaller[583]: Env: PWD=/
Jun  6 20:55:49 iMac OSInstaller[583]: Env: XPC_FLAGS=0x0
Jun  6 20:55:49 iMac OSInstaller[583]: Env: XPC_SERVICE_NAME=0
Jun  6 20:55:49 iMac OSInstaller[583]: Env: SHLVL=1
Jun  6 20:55:49 iMac OSInstaller[583]: Env: __OSINSTALL_ENVIRONMENT=1
Jun  6 20:55:49 iMac OSInstaller[583]: Env: CI_DEFAULT_OPENCL_USAGE=0
Jun  6 20:55:49 iMac OSInstaller[583]: Env: OS_INSTALL=1
Jun  6 20:55:49 iMac OSInstaller[583]: Env: _=/System/Library/CoreServices/Language Chooser.app/Contents/MacOS/Language Chooser
Jun  6 20:55:49 iMac OSInstaller[583]: Will not update firmware because we can't find the mutable product ((null))
Jun  6 20:55:49 iMac OSInstaller[583]: Creating connection
Jun  6 20:55:49 iMac OSInstaller[583]: Connection = 0x7ffda75ed720, callers = (
	    "<IASUPCaller: 0x7ffda75d59b0>"
	)
Jun  6 20:55:49 iMac OSInstaller[583]: Registering the connection
Jun  6 20:55:49 iMac OSInstaller[583]: client 0x7ffda75eaca0: phaseName = OS Installer 2
Jun  6 20:55:49 iMac OSInstaller[583]: Mutable product: Looking for automation file at (null)
Jun  6 20:55:49 iMac OSInstaller[583]: No file at (null)
Jun  6 20:55:49 iMac OSInstaller[583]: Install Config: Looking for automation file at (null)
Jun  6 20:55:49 iMac OSInstaller[583]: No file at /System/Installation/Packages/Extras/minstallconfig.xml
Jun  6 20:55:49 iMac OSInstaller[583]: Looking for automation file at (null)
Jun  6 20:55:49 iMac OSInstaller[583]: Install will not be automated.
Jun  6 20:55:49 iMac OSInstaller[583]: Install will not be automated, automation is required to proceed.
Jun  6 20:55:49 iMac OSInstaller[583]: Failed to open installer document
Jun  6 20:55:49 iMac OSInstaller[583]: Connection = 0x7ffda75ed720, callers = (
	    "<IASUPCaller: 0x7ffda75d59b0>",
	    "<IASUPCaller: 0x7ffda74de400>"
	)
Jun  6 20:55:49 iMac OSInstaller[583]: Registering the connection
Jun  6 20:55:49 iMac OSInstaller[583]: client 0x7ffda74e4100: phaseName = OS Installer
Jun  6 20:55:49 iMac OSInstaller[583]: client 0x7ffda74e4100: phaseName = "OS Installer"
Jun  6 20:55:49 iMac OSInstaller[583]: ISAP: hide progress UI called.
Jun  6 20:55:49 iMac OSInstaller[583]: Failed to get UUID for system rebless.
Jun  6 20:55:49 iMac OSInstaller[583]: calling progress app remoteObjectProxy
Jun  6 20:55:49 iMac OSInstaller[583]: Connection = 0x7ffda75ed720, callers = (
	    "<IASUPCaller: 0x7ffda75d59b0>",
	    "<IASUPCaller: 0x7ffda74de400>",
	    "<IASUPCaller: 0x7ffda75e0bb0>"
	)
Jun  6 20:55:49 iMac OSInstaller[583]: version = 2
Jun  6 20:55:49 iMac OSInstaller[583]: isModernOS = 1
Jun  6 20:55:49 iMac OSInstaller[583]: Connection = 0x7ffda75ed720, callers = (
	    "<IASUPCaller: 0x7ffda75d59b0>",
	    "<IASUPCaller: 0x7ffda74de400>",
	    "<IASUPCaller: 0x7ffda75e0bb0>",
	    "<IASUPCaller: 0x7ffda75de1c0>"
	)
Jun  6 20:55:49 iMac OSInstaller[583]: Registering the connection
Jun  6 20:55:49 iMac OSInstaller[583]: client 0x7ffda75bc880: phaseName = OS Installer
Jun  6 20:55:49 iMac OSInstaller[583]: client 0x7ffda75bc880: phaseName = "OS Installer"
Jun  6 20:55:49 iMac OSInstaller[583]: ISAP: hide progress UI called.
Jun  6 20:55:49 iMac OSInstaller[583]: client 0x7ffda75bc880: phaseName = OS Installer
Jun  6 20:55:49 iMac OSInstaller[583]: Releasing Connection
Jun  6 20:55:50 iMac OSInstaller[583]: client 0x7ffda75eaca0: phaseName = OS Installer 2
Jun  6 20:55:50 iMac OSInstaller[583]: Releasing Connection
Jun  6 20:55:50 iMac Language Chooser[572]: AppleSecureBootFailureReason: 0x00, StartupManagerFailureReason: 0x00
Jun  6 20:55:50 iMac Language Chooser[572]: Not hiding Language Chooser in window counter
Jun  6 20:56:18 iMac Unknown[573]: Keyboard Layouts: duplicate keyboard layout identifier -14934.
Jun  6 20:56:18 iMac Unknown[573]: Keyboard Layouts: keyboard layout identifier -14934 has been replaced with -28673.
Jun  6 20:56:23 iMac Unknown[573]: 2017-06-06 20:56:23.013 macOS Installer[583:3878] NSColorList could not parse color list file /System/Library/Colors/System.clr
Jun  6 20:56:23 iMac Unknown[573]: 2017-06-06 20:56:23.093 macOS Installer[583:3878] NSSoftLinking - The Quartz framework's library couldn't be loaded from /System/Library/Frameworks/Quartz.framework/Versions/A/Quartz.
Jun  6 20:56:23 iMac Unknown[573]: Got xpc error message: Connection invalid
Jun  6 20:56:27 iMac Unknown[573]: 2017-06-06 20:56 macOS Installer[583] (FSEvents.framework) FSEventStreamStart: ERROR: FSEvents_connect() => Unknown service name (1102)
Jun  6 20:56:33 iMac OSInstaller[583]: Folder Manager is being asked to create a folder (down) while running as uid 0
Jun  6 20:56:33 iMac OSInstaller[583]: Folder Manager is being asked to create a folder (down) while running as uid 0
Jun  6 20:56:33 iMac Unknown[573]: 2017-06-06 20:56:33.729 macOS Installer[583:3878] NSSoftLinking - The Quartz framework's library couldn't be loaded from /System/Library/Frameworks/Quartz.framework/Versions/A/Quartz.
Jun  6 20:56:33 iMac Unknown[573]: 2017-06-06 20:56 macOS Installer[583] (FSEvents.framework) FSEventStreamStart: ERROR: FSEvents_connect() => Unknown service name (1102)
Jun  6 20:56:49 iMac OSInstaller[583]: There are still active callers
Jun  6 20:56:50 iMac OSInstaller[583]: There are still active callers

Share this post


Link to post
Share on other sites

Create Install Media

Clover 4079 UEFI or ESP 

 

I'm using the same version and I created the bootable installer with createinstallmedia method as well, but I'm still stuck at kexts stall[0], (240): 'AppleACPICPU' error

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By NikTheNoob
      Hi,
       
      I'm rather new to Hackintosh and trying my first build with OpenCore on AMD, but I run into issues causing OpenCore to crash before even loading the macOS installer. As I'm not sure which one is causing the crash, I'm trying to resolve all of them and one of the error messages has to do with WhateverGreen, which I was able to see in this slow-mo loading video. Basically I'm getting an error that I'm running an unsupported processor, even though I think I was following this guide by the step.
      What could be causing this and what do I need to do to resolve it?
       
      CPU: AMD Ryzen 2700X
      MB: Gigabyte Aorus X470 Ultra Gaming
      Memory: 4x8 GB HyperX Predator, 3000 MHz Cl15
      Storage: Samsung Evo 970 Nvme 512 GB, Crucial MX500 500GB SATA
      GPU: MSI Radeon RX580 GamingX 8GB
    • By MaLd0n
      --Donations via PayPal--
      https://tinyurl.com/r2bvzm7
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      Just paste EFI folder inside EFI partition
      https://www.olarila.com/files/Clover.Folder/Lenovo IdeaPad S145.zip
      Notebooks with ELAN trackpad use it with my folder above
      IdeaPad S145 ELAN.zip
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Cannon Point-LP Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
    • By fantomas
      macOS Catalina 10.15.4 beta (19E224g)
    • By MaLd0n
      ---TUTORIAL---
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Original Post--
      https://www.olarila.com/topic/6531-olarila-hackbeast-z390-designare-thunderbolt-full-dsdt-patches-clover-opencore/
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://www.olarila.com/topic/6364-mojave-catalina-on-mobos-series-100200300-with-opencore-bootloader/
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By NoEnd
      Hi team,
       
      I'm looking for the best route to achieve this upgrade, so I have been stuck with HS since Nvidia drivers stopped being supported on newer MacOS releases. Now I'm having an AMD 5700 xt on the way and want to plan the upgrade properly. I have added some information below and questions that might help with your recommendation.
       
      Current GPU 1080 ti with Nvidia webdrivers installed. So should I uninstall the webdriver before adding the new GPU? Clover is being used and EFI attached. Any kext must be removed? or parameters adjusted MacOS HS 10.13.6, should I upgrade before using the new GPU? CPU: 9900K Motherboard:ROG MAXIMUS XI HERO (WI-FI) Dual Monitors I have a Time machine backup, Do you recommend a fresh install? and If I did, will I be able to restore my data/apps as-is?  
      Please let yourself free to explore further aspects to considers.
      EFI-20200204.zip
×