Jump to content
fantomas

[pre-release] macOS High Sierra

3,845 posts in this topic

Recommended Posts

 

For WiFi all i use is FakeID

<string>0x43a014E4</string>
And this patch
 
<key>Comment</key>
<string>AirPortBrcm4360 - fcvo, 10.12.x (credit the-darkvoid)</string>
<key>Find</key>
<data>gflSqgAAdSk=</data>
<key>Name</key>
<string>AirPortBrcm4360</string>
<key>Replace</key>
<data>gflSqgAAZpA=</data>
</dict>
</plist>

 

this works for me only if I use the pcie kernel panic patches by neodarkman, other wise its a kennel panic.

Do you have those or  simply this patch fixes it for you?

 

I can deal with manually ticking a box for a DP1. Everything else on my laptop is working even my wifi without any new patches, just need to change the country code. IntelGraphicsFixUp fixed the "stretched" apple logo on bootup. Trackpad works, touchpad, brightness and volume keys.

how does your trackpad work ,any fixes?

Share this post


Link to post
Share on other sites
Advertisement

Hello,

 

About USB max limit port patch, use this one instead under 10.13: (Target kext: AppleUSBXHCIPCI)

83 7D 84 10 -> 83 7D 84 xx

Note: xx means your new max limit port, which is typically 0x16 for 9-series and 0x1B for 100-series.

Hi PMHeart,

 

I can confirm that the patch works on 100 series, but it only works with the installed version of macOS Sierra. The patch won't work on my bootable USB 3.0 flash drive.

macOS High Sierra installer only loads from USB 2.0 ports.

 

Thanks :)

Share this post


Link to post
Share on other sites

this works for me only if I use the pcie kernel panic patches by neodarkman, other wise its a kennel panic.

Do you have those or simply this patch fixes it for you?

 

 

how does your trackpad work ,any fixes?

I have no other patches and no kernel panics.

I didn't need to do anything for my trackpad and it works great. I'm using appleps2smarttouchpad I think it's called.

 

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

Is there any hope for Sky Lake laptops? Not a single method works for me. Previously I got a kernel panic (similar to this one), but with Clover 8084, it results in instant reboot.

I have installed IntelGraphicsFixup, IntelGraphicsDVMTFixup, Lilu, FakePCIID, FakePCIID_Intel_HD_Graphics, FakeSMC and booted with -lilubeta -igfxbeta -igdvmtbeta, it didn't work.

(I will upload my Clover folder later, I'm currently on windows).

Share this post


Link to post
Share on other sites

It may be changed after an upgrade, just wait for DP2. ;)

Solved, thanks anyway.

Any idea when DP2 will be available?

Share this post


Link to post
Share on other sites

Is there any hope for Sky Lake laptops? Not a single method works for me. Previously I got a kernel panic (similar to this one), but with Clover 8084, it results in instant reboot.

I have installed IntelGraphicsFixup, IntelGraphicsDVMTFixup, Lilu, FakePCIID, FakePCIID_Intel_HD_Graphics, FakeSMC and booted with -lilubeta -igfxbeta -igdvmtbeta, it didn't work.

(I will upload my Clover folder later, I'm currently on windows).

Here's the Clover folder

Share this post


Link to post
Share on other sites

Ok, I'm on Kaby Lake, Dell XPS 15  9560. I finally was able to boot into HS! Yay, My trackpad works, but I can not get my USB ports working. What can I do to get these ports working? I thought USBinjectall.kext would help, but nope.  My usb mouse doesn't detect, bluetooth isn't detected, etc --anything that runs through usb. This is a notebook so I expect this type of setback, but is there a kext or something that I can get to get this problem alleviated?

Share this post


Link to post
Share on other sites

Ok, I'm on Kaby Lake, Dell XPS 15 9560. I finally was able to boot into HS! Yay, My trackpad works, but I can not get my USB ports working. What can I do to get these ports working? I thought USBinjectall.kext would help, but nope. My usb mouse doesn't detect, bluetooth isn't detected, etc --anything that runs through usb. This is a notebook so I expect this type of setback, but is there a kext or something that I can get to get this problem alleviated?

I'm not sure if one exists for 10.13 yet but maybe try a port limit increase patch as well as USBInjectAll.

 

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

Is there any hope for Sky Lake laptops? Not a single method works for me. Previously I got a kernel panic (similar to this one), but with Clover 8084, it results in instant reboot.

I have installed IntelGraphicsFixup, IntelGraphicsDVMTFixup, Lilu, FakePCIID, FakePCIID_Intel_HD_Graphics, FakeSMC and booted with -lilubeta -igfxbeta -igdvmtbeta, it didn't work.

(I will upload my Clover folder later, I'm currently on windows).

Hello @Muntashir; how about this one? Here.

Share this post


Link to post
Share on other sites

Hi,

I've Skylake 6600K - HD530,

I used the new clover 4084 but it doesn't work with Sierra upgrade to High Sierra (not clean install).

Can someone upload his own clover which can update Sierra to High Sierra without problem (Skylake + HD 530)

This is my config.plist which works with Sierra without problem and igfx works with acceleration and without glitches.

The 4084 boots up to the middle of loading bar and it restarts.

config.plist1.zip

Share this post


Link to post
Share on other sites

Hi,

I've Skylake 6600K - HD530,

I used the new clover 4084 but it doesn't work with Sierra upgrade to High Sierra (not clean install).

Can someone upload his own clover which can update Sierra to High Sierra without problem (Skylake + HD 530)

This is my config.plist which works with Sierra without problem and igfx works with acceleration and without glitches.

The 4084 boots up to the middle of loading bar and it restarts.

try this one

https://www.dropbox.com/s/qyfwjrft7spxirl/GA-Z170X-Gaming%205%20High%20Sierra.zip?dl=0

 

Just beware that I wasn't able to get my HD 530 to work yet because I use 1070 and I have to remove it to see if I can get HD530 to work. I simply didn't want to go to the process.

You might need to add Inject Intel=True and put in the ig-platformid

Share this post


Link to post
Share on other sites

try this one

https://www.dropbox.com/s/qyfwjrft7spxirl/GA-Z170X-Gaming%205%20High%20Sierra.zip?dl=0

 

Just beware that I wasn't able to get my HD 530 to work yet because I use 1070 and I have to remove it to see if I can get HD530 to work. I simply didn't want to go to the process.

You might need to add Inject Intel=True and put in the ig-platformid

Thank you so much buddy, but I got this error "gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0" and it immediately restarts.

I took a shot and upload it.

post-1665664-0-00261000-1497186415_thumb.jpg

Share this post


Link to post
Share on other sites

do you have lilu.kext, IntelGraphicsFixup.kext?

 

if not add them to /EFI/Clover/kexts/Other and add the following boot flags to your config.plist under boot section:

 

-lilubeta, -igfxbeta, -alcbeta,

 

-alcbeta is for sound, if you need it just in case ;)

AppleALC-Lilu-IntelGraphicsFixup.zip

Share this post


Link to post
Share on other sites

do you have lilu.kext, IntelGraphicsFixup.kext?

 

if not add them to /EFI/Clover/kexts/Other and add the following boot flags to your config.plist under boot section:

 

-lilubeta, -igfxbeta, -alcbeta,

 

-alcbeta is for sound, if you need it just in case ;)

Thank you, but it doesn't change.

Share this post


Link to post
Share on other sites

Well to be honest I didn't have any luck booting into macOS High Sierra by using IGFX yet. I got the same errors so I assumed they might be because of my 1070 GPU.

 

What is your mobo?

Share this post


Link to post
Share on other sites

Well to be honest I didn't have any luck booting into macOS High Sierra by using IGFX yet. I got the same errors so I assumed they might be because of my 1070 GPU.

 

What is your mobo?

I tested with both igfx and dedicated graphics (gt210).

on both it doesn't work.

my mobo is Gigabyte z170-D3H

Share this post


Link to post
Share on other sites

Well to be honest I didn't have any luck booting into macOS High Sierra by using IGFX yet. I got the same errors so I assumed they might be because of my 1070 GPU.

 

What is your mobo?

 

My IGFX HD530 works like a charm in 10.13 with Lilu + IntelGraphicsFixup. 

Share this post


Link to post
Share on other sites

My IGFX HD530 works like a charm in 10.13 with Lilu + IntelGraphicsFixup. 

Would u mind sharing your clover folder ?

Thank you :)

Share this post


Link to post
Share on other sites

My IGFX HD530 works like a charm in 10.13 with Lilu + IntelGraphicsFixup. 

I still get the black screen, and it's driving me nuts :D:rofl:

I even tried the latest versions of the IntelGraphicsFixup.kext you posted earlier today.

 

Do you have a discreet GPU? or just the IGFX?

@Mork vom Ork gave me some great instructions but I didn't have the time to test them yet. He suggested:

 

"This is what i have done to make it work, as it is now doing:

 

• Removed all cards from internal, like RX480, Gigabyte ThunderboltCard and my TV-Card (which i use under WIN10). Installed a completely fresh ASUS BIOS to the board, restarted machine and set BIOS to all their desired values. iGPU as primary, CSM enabled etc.

 

• Removed "DSDT.aml" and ALL not neccesary *.aml files  from EFI/CLOVER/ACPI/patched folder. Set "Inject INTEL = true" in my CLOVER config.plist under "Graphics"

 

• booted with this so prepaired macOS10.13 installstick and installed fresh system.

 

• botted from the fresh installed High Sierra SSD and moved EFI folder from Stick to the High Sierra SSD. so stick no longer needed to boot CLOVER. Btw: CLOVER is latest rev.4084

 

• installed RX480 into slot1 and rebooted. WORX. Installed Gigabyte Alpine Ridge Thunderbolt3 card, rebooted, WORX, too.

 

This did it for me. No patch needed to make iGPU and RX480 to work as expected now. Hope, this helps. Try out step-by-step and take your time. Don't hesitate.

Regards... Mork vom Ork"

Share this post


Link to post
Share on other sites

try this one

https://www.dropbox.com/s/qyfwjrft7spxirl/GA-Z170X-Gaming%205%20High%20Sierra.zip?dl=0

 

Just beware that I wasn't able to get my HD 530 to work yet because I use 1070 and I have to remove it to see if I can get HD530 to work. I simply didn't want to go to the process.

You might need to add Inject Intel=True and put in the ig-platformid

No, your clover I mean which u gave me. (there's nothing in ACPI folder)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
      -Donations with PicPay 
      @danielnmaldonado
      -Donation with Mercado Livre 
      https://tinyurl.com/y9evkj5u
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -Tutorial
      https://tinyurl.com/re2c9sz
       
      -Post Installation
      Paste EFI folder into EFI Partition in your SSD, reboot and extract one full dump with this app and post here!
      https://tinyurl.com/ybwr9kq3
      RunMe.app
      https://tinyurl.com/y9562hz7
       
      --DSDT PATCHES--
       
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--
       









































       
       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, headkaze, onemanosx, erroruser, Jenny David, Sampath007, Facebook Hackintosh community, Facebook Olarila community, SchmockLord, daliansky and many, many, many others!
       
      We're all here to have fun and learn from each other!
    • By fantomas
      macOS Catalina 10.15.6 beta (19G36e)
    • By mavifree
      Sir 
       
      I am new in Hackintosh and i try to make my hp laptop a hackintosh but am not able to boot in Installation menu i don't know why please help as am new in hackintosh world so i really need your help if some can. I really be very thankful to you. Please Help me.
       
      installation stuck at (Please go to https://panic.apple.com to report this panic)
       
      MY Laptop Specs :
       
      --------------------------------------------------------------------
      Laptop : HP cs2082tx
      Mobo : HP84C1
      Southbridge : Coffee Lake-U/Y PCH
      CPU : Intel Core i5 8265U @ 1.60GHz Kaby Lake- U/Y
      Ram : 8 Gb
      HDD : 256GB SSD & 1TB HDD
      Graphics : Intel UHD Graphic 620 with nvidia MX250
      ----------------------------------------------------------------------
       
      And here is the screenshot attachment and my EFI folder:
       


      Clover.rar
    • By y010204025
      Perhaps it was the first NEC (Lenovo) Lavie Z HZ550 to install hackintosh. I hope more people who like Lavie Z series can experience Hackintosh at HZ550. She is really great.
       
      I found HZ550 & HZ750 on the Chinese website, which is amazing. It weighs only 790g, 13.3 inches, and the standard 2k screen, which is too attractive to me. I am a Hackintosh enthusiast. I think HZ550 or HZ750 with MacOS is the best Unfortunately, the Lavie Z series is not listed in China, only exists in the Japanese and American markets, and in the Japanese market is the NEC brand, while the American market uses the Lenovo logo.
       
      Fortunately, I got an HZ550 from Taobao. Yes, not HZ750. In comparison, HZ750 has more touch screens and 360 ° flip. These are hard to attract me. More importantly, HZ750 is about 200g heavier than HZ550 That's why I chose HZ550. Well, because he is only 2,000 RMB.
       
      The specific introduction can refer to NEC Japan official website:http://nec-lavie.jp/products/hz13b/
       
      The HZ550 hardware list I obtained:
                                    
                       -/+:.          ningnan@ningnandeMacBook-Air
                      :++++.          OS: 64bit Mac OS X 10.15.5 19F96
                     /+++/.           Kernel: x86_64 Darwin 19.5.0
             .:-::- .+/:-``.::-       Uptime: 19m
          .:/++++++/::::/++++++/:`    Packages: 1
        .:///////////////////////:`   Shell: zsh 5.7.1
        ////////////////////////`     Resolution: 3840x2160
       -+++++++++++++++++++++++`      DE: Aqua
       /++++++++++++++++++++++/       WM: Quartz Compositor
       /sssssssssssssssssssssss.      WM Theme: Blue (Dark)
       :ssssssssssssssssssssssss-     Disk: 11G / 108G (12%)
        osssssssssssssssssssssssso/`  CPU: Intel Core i7-5500U @ 2.40GHz
        `syyyyyyyyyyyyyyyyyyyyyyyy+`  GPU: Intel Iris Graphics 6100
         `ossssssssssssssssssssss/    RAM: 4376MiB / 8192MiB
           :ooooooooooooooooooo+.    
            `:+oo+/:-..-:/+o+/-     
       
       
      Advantages: small size, light weight, 2K screen, 8G memory, 512g SSD, keyboard feels good, and wireless network card can be replaced, which is unimaginable in today's thin and light books.
      Disadvantages: The sound is small, almost the same as the mosquitoes.
       
      Ok, bragging is over!
      In order to use the wireless network, I changed the wireless network card from inter 7265 to BCM94352ZAE. Some people called it DW1560. It is uncomfortable that in China, this card and his elder brother DW1830 were hyped to a high price of 480RMB. of. Fortunately, I bought it early, and this card is also very stable under win10, and there is no high delay and outage. The hard disk should be PM951 of Samsung, not PM981, which is lucky.   Before installing Hackintosh: You need to prepare a 16G U disk, SanDisk is not a rough choice for making MacOS installation disk, I used the latest MacOS Catalina 10.15.5, got config.plist from Rehabman, and put together an EFI, the latest version of clover and kext drivers. Thanks to Rehabman and the developers of the Black Apple community. I do n’t like that OC team very much.
      Make an installation disk: If you have a computer running MacOS, you can use the command line to make it, if you do n’t have a computer running MacOS, you can try VMware, I know that the insanelymac forum allows discussion, or use ether to write the image to U disk, use the EFI I provided to boot into the installation process.   BIOS setting: Press F12 at boot to enter the BIOS settings, Tab switches to "Security-Secure boot", set to "DISable", this is what we need, and switch to "Boot -Boot devices", set the U disk as the first boot item You can directly enter the clover guide interface, please follow it for google it.
      It is worth noting that the remaining space of your EFI partition needs to be greater than 200M, otherwise, the disk format will be wrong. In addition, the format partition format is APFS, do not choose to encrypt, your data is not valuable, at least you must have this awareness of Hackintosh, the file safe is also the same, do not enable, do not use to find your mac, otherwise, change the machine, OK .   Fortunately, no additional ssdt patch is required. All the patch functions are implemented through clover. The flat Apple is turned on. This is to solve the problem of the flower screen. You can find a solution yourself.
      Experience your black apple, this will bring a better experience than MacBook Pro. EFI_HZ550.zip
×