Jump to content
fantomas

[pre-release] macOS High Sierra

3,845 posts in this topic

Recommended Posts

Hi, I don't know whether this is somewhat off-topic, if so, feel free to contact me and delete the post.

 

As for XCPM for unsupported CPUs patches of 10.13, please try this one:

 

1) Patch for _cpuid_set_info:

The disassembled code looks like this: (From DP1)

ffffff80003a1326	8a 05 21 5d 75 00 	movb	0x755d21(%rip), %al
ffffff80003a132c	04 72 	addb	$0x72, %al
ffffff80003a132e	3c d0 	cmpb	$-0x30, %al
ffffff80003a1330	77 50 	ja	0xffffff80003a1382

Alright, so that add is what we want to patch, and it's only needed for Broadwell-E CPUs, the patch will be:

72 3c d0 77 50 0f b6 c0
to
6a 3c d0 77 50 0f b6 c0

2) Patch for _xcpm_bootstrap:

The disassembled code looks like this:

ffffff80003d08c3	89 d8 	movl	%ebx, %eax
ffffff80003d08c5	04 c4 	addb	$-0x3c, %al
ffffff80003d08c7	3c 22 	cmpb	$0x22, %al
ffffff80003d08c9	77 22 	ja	0xffffff80003d08ed

And the patch will be:

89 d8 04 c4 3c 22 77 22
to
89 d8 04 xx 3c 22 77 22

Note: The xx is your exact platform CPUID, for example, the default one is 0x3C and I want it to be Ivy Bridge which is 0x3A, and the desired patch is:

89 d8 04 c4 3c 22 77 22
to
89 d8 04 c6 3c 22 77 22

3) Instant reboot fix

Look at these ones:

ffffff80003d107e	48 8d 3d 9b e1 65 00 	leaq	_xcpm_pkg_scope_msrs(%rip), %rdi
ffffff80003d1085	be 07 00 00 00 	movl	$0x7, %esi
ffffff80003d108a	31 d2 	xorl	%edx, %edx
ffffff80003d108c	e8 8f fc ff ff 	callq	0xffffff80003d0d20
ffffff80003d1091	83 fb 00 	cmpl	$0x0, %ebx
ffffff80003d1094	74 05 	je	0xffffff80003d109b
ffffff80003d1096	45 20 e5 	andb	%r12b, %r13b
ffffff80003d1099	74 13 	je	0xffffff80003d10ae
ffffff80003d109b	48 8d 3d ce e2 65 00 	leaq	_xcpm_core_scope_msrs(%rip), %rdi
ffffff80003d10a2	be 03 00 00 00 	movl	$0x3, %esi
ffffff80003d10a7	31 d2 	xorl	%edx, %edx
ffffff80003d10a9	e8 72 fc ff ff 	callq	0xffffff80003d0d20
ffffff80003d10ae	48 8d 3d 4b e3 65 00 	leaq	_xcpm_SMT_scope_msrs(%rip), %rdi
ffffff80003d10b5	be 0b 00 00 00 	movl	$0xb, %esi
ffffff80003d10ba	31 d2 	xorl	%edx, %edx
ffffff80003d10bc	e8 5f fc ff ff 	callq	0xffffff80003d0d20

Alright, so the patches will be:

# _xcpm_SMT_scope_msrs
be 0b 00 00 00 5d e9 08 00 00 00 -> be 0b 00 00 00 5d c3 90 90 90 90
and
be 0b 00 00 00 31 d2 e8 5f fc ff ff -> be 0b 00 00 00 31 d2 90 90 90 90 90

# _xcpm_core_scope_msrs
be 03 00 00 00 31 d2 e8 72 fc ff ff -> be 03 00 00 00 31 d2 90 90 90 90 90

# _xcpm_pkg_scope_msrs
be 07 00 00 00 31 d2 e8 8f fc ff ff -> be 07 00 00 00 31 d2 90 90 90 90 90

And if you want to disable the calls/jumps entirely, you should ret this offset:

ffffff80003d0d20	55 	pushq	%rbp  // Change this '55' to 'c3'

The patch is:

BE 0B 00 00 00 5D E9 08 00 00 00 0F 1F 84 00 00 00 00 00 55 48 89 E5 41 57 -> BE 0B 00 00 00 5D E9 08 00 00 00 0F 1F 84 00 00 00 00 00 C3 48 89 E5 41 57

4) Performance fix

89 D8 C1 E0 08 48 63 D0 -> B8 00 FF 00 00 48 63 D0 

5) AVX stuffs (Only for Pentium and Celeron users)

B9 A0 01 00 00 0F 32 -> B9 A0 01 00 00 31 C0 

All credits go to Pike R. Alpha, okrasit, vit9696 and other generous guys.

 

EDIT @ 25/07/17: Removed redundant bytes for 10.13 DP4 compatibility

EDIT @ 17/07/17: Added more patches and credit information

EDIT @ 22/06/17: Removed redundant bytes for 10.13 DP2 compatibility

Edited by PMheart

Share this post


Link to post
Share on other sites
Advertisement

Preparing the flash drive to install the beta with PMheart's precompiled clover boot files, wish that the igpu wont cause any hassle.

 

XrkzBFo.png

Share this post


Link to post
Share on other sites

PMheart's kext injection fix doesn't appear to be working with the installer usb here.

 

Actually it's not working for any version. You'll need to roll back to boot into your existing system.

Share this post


Link to post
Share on other sites

I am interested in the versions for the GPU Kexts. I am wondering if they are getting ready to do entirely new branches for High Sierra considering how dependent the windowserver will be on Metal. I don't think Metal could be considered robust under existing 10.12 kexts. Metal 2 makes me nervous, even with all of the announcements about middleware support, with how bad the current Metal situation is.

 

APFS will be interesting, about time they got off of HFS+. Though the 64-bits full file system talk was hilarious. Just remembering back to the talk way back about ZFS support (a 128-bit fs) and how they dropped that when they realized it would require engineering.

 

Update:

Since I am not going to risk my main hack with the first DP release I decided to take a look at VR support. Not sure if I am hitting an issue with the Nvidia WebDrivers or a USB device limit, but SteamVR won't initialise the display on my MTC Vive using the current Steam VR Beta. It still just views it as a single display that only outputs to the right eye. Oh well.

Share this post


Link to post
Share on other sites

PMheart's kext injection fix doesn't appear to be working with the installer usb here.

 

Actually it's not working for any version. You'll need to roll back to boot into your existing system.

 

So what exactly seems to be the problem?  Clover kext injection not working?  Need to add APFS.efi to Clover drivers64?  You make it sound like it is not yet possible to install High Sierra.  Was that your intention?

Share this post


Link to post
Share on other sites

I copied afps.efi to Clover.

 

I booted the install in verbose mode and saw errors related to some of my kexts (error allocating or something like that) and it never made it to the installer page. Looks like failure to inject the kexts.

Share this post


Link to post
Share on other sites

I copied afps.efi to Clover.

 

I booted the install in verbose mode and saw errors related to some of my kexts (error allocating or something like that) and it never made it to the installer page. Looks like failure to inject the kexts.

 

Which folder in Clover did you put apfs.efi?  Any luck putting your Clover kexts in your USB drive's S/L/E? (BTW, I'm trying to learn from you while my laptop backup slowly makes progress.  I don't want to try this without a very current backup.)

Share this post


Link to post
Share on other sites

I put it into drivers64uefi. It loads at startup and prints output over the screen when enumerating drives in the Clover menu so I know it's working. I don't put anything into /S/L/E these days. I can just wait until kexts are injecting properly from EFI.

 

Just wanted to report that it didn't work and that I also couldn't get back into Sierra until I rolled back the Clover files.

Share this post


Link to post
Share on other sites

guys, i'm lost. any help, pls? 

 

what i did:

 

> 10.12.3 fresh install

> post-install, ok, with latest clover

> enrolled the device and downloaded the 10.13 developer preview dmg from appstore

> rebooted and selected the installer on the clover's gui

> it stays on the apple loading screen for something like 10 minutes and then white screen with no mouse arrow or circle.

 

tried nv_disable=1 GraphicsEnabler=0, maxmem=4096, nothing works

tried again in verbose mode and the last thing shown before white screen was something like "kextd stall AppleCPUID"...

 

i know i'm probably doing something really wrong, haha, i'm sorry for that, but i'm very new to this.

 

thanks in advance

 

i5 4690 | Gigabyte H97M-3DH | GTX 760 2GB |

Share this post


Link to post
Share on other sites

guys, i'm lost. any help, pls? 

 

what i did:

 

> 10.12.3 fresh install

> post-install, ok, with latest clover

> enrolled the device and downloaded the 10.13 developer preview dmg from appstore

> rebooted and selected the installer on the clover's gui

> it stays on the apple loading screen for something like 10 minutes and then white screen with no mouse arrow or circle.

 

tried nv_disable=1 GraphicsEnabler=0, maxmem=4096, nothing works

tried again in verbose mode and the last thing shown before white screen was something like "kextd stall AppleCPUID"...

 

i know i'm probably doing something really wrong, haha, i'm sorry for that, but i'm very new to this.

 

thanks in advance

 

i5 4690 | Gigabyte H97M-3DH | GTX 760 2GB |

Same here

Share this post


Link to post
Share on other sites

I was able to boot to the installer using CloverX64-High.efi and apfs.efi in the Clover64UEFI folder.  I had to boot with cpus=1 because the LAPIC patch did not work.  Kext injection did work and I was able to use RehabMan's voodoops2.kext and acpibattery.kext.  I don't think I had bluetooth or wifi.  I couldn't tell.  Either way, I hit a stumbling block and can't seem to get past it.  Anyone else run into this?

 

post-270804-0-50384700-1496716301_thumb.jpg

 

Also, here's my installation log.  Maybe someone can identify the error and its cause.

Jun  6 02:32:14 localhost opendirectoryd[183]: opendirectoryd (build 465.000) launched - installer mode
Jun  6 02:32:15 localhost powerd[170]: powerd process is started
Jun  6 02:32:24 MacBook-Pro Unknown[537]: kern.boottime: { sec = 1496716324, usec = 0 } Tue Jun  6 02:32:04 2017
Jun  6 02:32:24 MacBook-Pro Unknown[549]: Launching the Language Chooser for an OS Install
Jun  6 02:32:25 MacBook-Pro launchprogresswindow[547]: ISAP: show progress UI called.
Jun  6 02:32:42 MacBook-Pro Installer Progress[177]: IASGetCurrentInstallPhaseList: Unable to get phases
Jun  6 02:32:42 MacBook-Pro Installer Progress[177]: IASGetCurrentInstallPhase: Unable to get the current phase name
Jun  6 02:32:42 MacBook-Pro Installer Progress[177]: IASGetCurrentInstallPhaseList: Unable to get phases
Jun  6 02:32:42 MacBook-Pro Installer Progress[177]: IASGetCurrentInstallPhase: Unable to get the current phase name
Jun  6 02:32:42 MacBook-Pro Installer Progress[177]: Progress App loading...
Jun  6 02:32:42 MacBook-Pro Installer Progress[177]: Progress App is running with no progress set.
Jun  6 02:32:42 MacBook-Pro Installer Progress[177]: Progress App running...
Jun  6 02:32:42 MacBook-Pro Installer Progress[177]: Showing Progress UI
Jun  6 02:32:42 MacBook-Pro Installer Progress[177]: IOProgressColorTheme is set to 1
Jun  6 02:32:55 MacBook-Pro Installer Progress[177]: Shield windows created.
Jun  6 02:32:55 MacBook-Pro Installer Progress[177]: Shield windows ordered front.
Jun  6 02:32:57 MacBook-Pro Language Chooser[550]: Using progress phase: Language Chooser
Jun  6 02:32:57 MacBook-Pro Unknown[551]: Setting boot completed.
Jun  6 02:32:57 MacBook-Pro Language Chooser[550]: AppleSecureBootFailureReason: 0x00, StartupManagerFailureReason: 0x00
Jun  6 02:32:57 MacBook-Pro Language Chooser[550]: AppleSecureBootFailureReason: 0x00, StartupManagerFailureReason: 0x00
Jun  6 02:32:57 MacBook-Pro Unknown[551]: Keyboard Layouts: duplicate keyboard layout identifier -14934.
Jun  6 02:32:57 MacBook-Pro Unknown[551]: Keyboard Layouts: keyboard layout identifier -14934 has been replaced with -28673.
Jun  6 02:32:57 MacBook-Pro Language Chooser[550]: Set keyboard to id: 0
Jun  6 02:32:57 MacBook-Pro Language Chooser[550]: Found primary language hint "en"
Jun  6 02:32:57 MacBook-Pro Language Chooser[550]: AppleSecureBootFailureReason: 0x00, StartupManagerFailureReason: 0x00
Jun  6 02:32:57 MacBook-Pro Language Chooser[550]: Launching the Installer using language code "en"
Jun  6 02:32:58 MacBook-Pro Unknown[551]: objc[569]: Class OSIDebuggerTool is implemented in both /System/Library/PrivateFrameworks/OSInstaller.framework/Versions/A/OSInstaller (0x1024d32f0) and /System/Installation/CDIS/macOS Installer.app/Contents/MacOS/macOS Installer (0x102404638). One of the two will be used. Which one is undefined.
Jun  6 02:32:59 MacBook-Pro Language Chooser[550]: AppleSecureBootFailureReason: 0x00, StartupManagerFailureReason: 0x00
Jun  6 02:32:59 MacBook-Pro Language Chooser[550]: Not hiding Language Chooser in window counter
Jun  6 02:32:59 MacBook-Pro storagekitd[570]: Starting SKDaemon...
Jun  6 02:32:59 MacBook-Pro storagekitd[570]: Client entitled for destructive operations
Jun  6 02:32:59 MacBook-Pro storagekitd[570]: Adding client connection <NSXPCConnection: 0x7fb52ac110d0> connection from pid 569
Jun  6 02:33:02 MacBook-Pro OSInstaller[569]: No mutable product specified in NVRAM.
Jun  6 02:33:02 MacBook-Pro Language Chooser[550]: ISAP: Done with phase "Language Chooser"
Jun  6 02:33:02 MacBook-Pro Installer Progress[177]: Ending progress UI via 100% progress.
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Connected to daemon. Language set to: English
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Connected to daemon. Language set to: English
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: We are not image source booted attempting more robust automation fallback.
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: No mutable product specified on boot disk.
Jun  6 02:33:03 MacBook-Pro Unknown[551]: 2017-06-06 02:33:03.684 macOS Installer[569:3985] Connected to daemon. Language set to: English
Jun  6 02:33:03 MacBook-Pro Unknown[551]: 2017-06-06 02:33:03.684 macOS Installer[569:3985] Connected to daemon. Language set to: English
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Hardware: MacBookPro9,2 @ 2.50 GHz, 16384 MB RAM
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Running OS Build: Mac OS X 10.13 (17A264c)
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Env: DYLD_NO_FIX_PREBINDING=1
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Env: PATH=/usr/bin:/bin:/usr/sbin:/sbin
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Env: PWD=/
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Env: XPC_FLAGS=0x0
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Env: XPC_SERVICE_NAME=0
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Env: SHLVL=1
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Env: __OSINSTALL_ENVIRONMENT=1
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Env: CI_DEFAULT_OPENCL_USAGE=0
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Env: OS_INSTALL=1
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Env: _=/System/Library/CoreServices/Language Chooser.app/Contents/MacOS/Language Chooser
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Will not update firmware because we can't find the mutable product ((null))
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Creating connection
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Connection = 0x7f86b2ab15d0, callers = (
	    "<IASUPCaller: 0x7f86b2ac4840>"
	)
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Registering the connection
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: client 0x7f86b2acd1a0: phaseName = OS Installer 2
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Low battery status changed: 0
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: client 0x7f86b2acd1a0: phaseName = "OS Installer 2"
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Mutable product: Looking for automation file at (null)
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: No file at (null)
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Install Config: Looking for automation file at (null)
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: No file at /System/Installation/Packages/Extras/minstallconfig.xml
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Looking for automation file at (null)
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Install will not be automated.
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Install will not be automated, automation is required to proceed.
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Failed to open installer document
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Connection = 0x7f86b2ab15d0, callers = (
	    "<IASUPCaller: 0x7f86b2ac4840>",
	    "<IASUPCaller: 0x7f86b2c31b80>"
	)
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Registering the connection
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: client 0x7f86b2accaa0: phaseName = OS Installer
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: client 0x7f86b2accaa0: phaseName = "OS Installer"
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: ISAP: hide progress UI called.
Jun  6 02:33:03 MacBook-Pro OSInstaller[569]: Failed to get UUID for system rebless.
Jun  6 02:33:03 MacBook-Pro Installer Progress[177]: Hiding Progress UI
Jun  6 02:33:03 MacBook-Pro Installer Progress[177]: End progress UI called...
Jun  6 02:33:04 MacBook-Pro OSInstaller[569]: calling progress app remoteObjectProxy
Jun  6 02:33:04 MacBook-Pro OSInstaller[569]: Connection = 0x7f86b2ab15d0, callers = (
	    "<IASUPCaller: 0x7f86b2ac4840>",
	    "<IASUPCaller: 0x7f86b2c31b80>",
	    "<IASUPCaller: 0x7f86b2ad0ac0>"
	)
Jun  6 02:33:04 MacBook-Pro OSInstaller[569]: version = 2
Jun  6 02:33:04 MacBook-Pro OSInstaller[569]: isModernOS = 1
Jun  6 02:33:04 MacBook-Pro OSInstaller[569]: Connection = 0x7f86b2ab15d0, callers = (
	    "<IASUPCaller: 0x7f86b2ac4840>",
	    "<IASUPCaller: 0x7f86b2c31b80>",
	    "<IASUPCaller: 0x7f86b2ad0ac0>",
	    "<IASUPCaller: 0x7f86b2ae00e0>"
	)
Jun  6 02:33:04 MacBook-Pro OSInstaller[569]: Registering the connection
Jun  6 02:33:04 MacBook-Pro OSInstaller[569]: client 0x7f86b2af4490: phaseName = OS Installer
Jun  6 02:33:04 MacBook-Pro OSInstaller[569]: client 0x7f86b2af4490: phaseName = "OS Installer"
Jun  6 02:33:04 MacBook-Pro OSInstaller[569]: ISAP: hide progress UI called.
Jun  6 02:33:04 MacBook-Pro OSInstaller[569]: client 0x7f86b2af4490: phaseName = OS Installer
Jun  6 02:33:04 MacBook-Pro OSInstaller[569]: Releasing Connection
Jun  6 02:33:04 MacBook-Pro OSInstaller[569]: client 0x7f86b2acd1a0: phaseName = OS Installer 2
Jun  6 02:33:04 MacBook-Pro OSInstaller[569]: Releasing Connection
Jun  6 02:34:04 MacBook-Pro OSInstaller[569]: There are still active callers
Jun  6 02:34:04 MacBook-Pro OSInstaller[569]: There are still active callers
Jun  6 02:34:13 MacBook-Pro powerd[170]: Assertion Created. Type:UserIsActive Name:'com.apple.iohideventsystem.queue.tickle.4294968556.17' Id:0x900008002 Process:hidd [System: DeclUser kDisp]
Jun  6 02:34:17 MacBook-Pro Unknown[551]: Keyboard Layouts: duplicate keyboard layout identifier -14934.
Jun  6 02:34:17 MacBook-Pro Unknown[551]: Keyboard Layouts: keyboard layout identifier -14934 has been replaced with -28673.
Jun  6 02:34:38 MacBook-Pro Unknown[551]: 2017-06-06 02:34:38.560 macOS Installer[569:3979] NSColorList could not parse color list file /System/Library/Colors/System.clr
Jun  6 02:34:38 MacBook-Pro Unknown[551]: 2017-06-06 02:34:38.622 macOS Installer[569:3979] NSSoftLinking - The Quartz framework's library couldn't be loaded from /System/Library/Frameworks/Quartz.framework/Versions/A/Quartz.
Jun  6 02:34:38 MacBook-Pro Unknown[551]: Got xpc error message: Connection invalid
Jun  6 02:36:07 MacBook-Pro Unknown[551]: 2017-06-06 02:36 macOS Installer[569] (FSEvents.framework) FSEventStreamStart: ERROR: FSEvents_connect() => Unknown service name (1102)
Jun  6 02:36:14 MacBook-Pro OSInstaller[569]: Folder Manager is being asked to create a folder (down) while running as uid 0
Jun  6 02:36:14 MacBook-Pro OSInstaller[569]: Folder Manager is being asked to create a folder (down) while running as uid 0
Jun  6 02:36:14 MacBook-Pro Unknown[551]: 2017-06-06 02:36:14.939 macOS Installer[569:3979] NSSoftLinking - The Quartz framework's library couldn't be loaded from /System/Library/Frameworks/Quartz.framework/Versions/A/Quartz.
Jun  6 02:36:15 MacBook-Pro Unknown[551]: 2017-06-06 02:36 macOS Installer[569] (FSEvents.framework) FSEventStreamStart: ERROR: FSEvents_connect() => Unknown service name (1102)
Jun  6 02:36:27 MacBook-Pro OSInstaller[569]: Folder Manager is being asked to create a folder (down) while running as uid 0
Jun  6 02:36:27 MacBook-Pro OSInstaller[569]: Folder Manager is being asked to create a folder (down) while running as uid 0
Jun  6 02:37:00 MacBook-Pro Language Chooser[550]: Child process exited 0
Jun  6 02:37:00 MacBook-Pro Unknown[581]: Launching the Installer Crash Log Viewer
Jun  6 02:37:00 MacBook-Pro storagekitd[570]: Removing client connection <SKDaemonConnection: 0x7fb52ac125a0>
Jun  6 02:37:00 MacBook-Pro storagekitd[570]: No more connections, storagekitd will exit...
Jun  6 02:37:01 MacBook-Pro Viewer[582]: Creating connection
Jun  6 02:37:01 MacBook-Pro Viewer[582]: Connection = 0x7fef40cccc60, callers = (
	    "<IASUPCaller: 0x7fef40ccd940>"
	)
Jun  6 02:37:01 MacBook-Pro Viewer[582]: Registering the connection
Jun  6 02:37:01 MacBook-Pro Viewer[582]: client 0x7fef40cb4560: phaseName = Installer Crash Catcher
Jun  6 02:37:01 MacBook-Pro Viewer[582]: client 0x7fef40cb4560: phaseName = "Installer Crash Catcher"
Jun  6 02:37:01 MacBook-Pro Viewer[582]: ISAP: hide progress UI called.
Jun  6 02:37:01 MacBook-Pro Viewer[582]: client 0x7fef40cb4560: phaseName = Installer Crash Catcher
Jun  6 02:37:01 MacBook-Pro Viewer[582]: Releasing Connection
Jun  6 02:37:15 MacBook-Pro powerd[170]: Assertion Released. Type:PreventUserIdleSystemSleep Name:'com.apple.diskmanagementd' Id:0x100008001 Process:diskmanagementd [System: DeclUser kDisp]
Jun  6 02:37:20 MacBook-Pro Viewer[582]: Folder Manager is being asked to create a folder (down) while running as uid 0
Jun  6 02:37:20 MacBook-Pro Viewer[582]: Folder Manager is being asked to create a folder (down) while running as uid 0
Jun  6 02:37:25 MacBook-Pro Viewer[582]: Folder Manager is being asked to create a folder (down) while running as uid 0
Jun  6 02:37:25 MacBook-Pro Viewer[582]: Folder Manager is being asked to create a folder (down) while running as uid 0

Share this post


Link to post
Share on other sites

Second try  :P

 

 

img_1020.jpg

 

I format in Mac OS Extend Journalise  this is  Good?

 

Because APFS is available in Disk Utility  :yes:

 

 

same thing Error OSInstall.mpkg  :cry:

Share this post


Link to post
Share on other sites

 

I was able to boot to the installer using CloverX64-High.efi and apfs.efi in the Clover64UEFI folder. 

where did you get CloverX64-High.efi?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By razor6986
      My hardware is as follows-
      Motherboard- MSI H310M PRO-VH
      Cpu- I5 9400F
      GPU- Zotac Nvidia GTX 1060 6GB mini
      I have uploaded a pic of the error which I am getting. Please Help.

    • By gengik84
      First beta... build 20A4299v 
       
      Useful information:
      macOSDeveloperBetaAccessUtility.dmg.zip
      OpenCore is now able to boot the installer and pre-existing installed macOS 11 Big Sur New!
    • By poisson-myfish
      So I have some less powerful hardware, that's why I'm installing High Sierra in 2020. Anyway, I'm trying to boot from the USB and I get the following errors:
      00:000 00:000 OCB: Missing DMG signature, aborting 00:585 00:585 OCB: LoadImage failed - Unsupported That's it. The logs begin and end there. The rest of the file is zeroes.
       
      Bootloader: OpenCore 0.5.9 Release
      Drivers:
      HfsPlus.efi
      OpenRuntime.efi
       
      Kexts:
      AppleALC.kext
      Lilu.kext
      RealtekRTL8111.kext
      SMCBatteryManager.kext
      SMCLightSensor.kext
      SMCProcessor.kext
      SMCSuperIO.kext
      VirtualSMC.kext
      WhateverGreen.kext
       
      ACPI:
      SSDT-EC.aml
      SSDT-HPET.aml
      SSDT-PLUG.aml
      Note: I used SSDTTime to make the DSDT dumps for this exact computer
       
      Hardware:
      Intel Core i3 (Haswell)
      An Intel VGA-Compatible Haswell iGPU
      An nVidia Geforce 920m GPU (part of the reason for installing High Sierra)
      USB: Intel 8 Series USB xHCI HC
      SATA: Intel 8 series SATA Controller
       
      If you need more details, here's my laptop https://www.asus.com/Laptops/X540LJ/ . I have the 512GB version with 4GB of RAM
       
      I found a lot of forum posts about people having the same error, except nothing solved mine. Also, I haven't found anything online about the error with the Missing DMG Signature.
       
      EDIT: If anybody needs my config.plist, feel free to ask for it and I'll happily post it
    • By PropoFlexWX4
      After hearing that OpenCore is so much better than Clover, and that it will probably be able to boot Big Sur before Clover does, I decided to take the jump.
       
      Running Catalina 10.15.5 18F101 with OC 0.5.9.
       
      So far I like the result. The OS feels faster, boots faster.
      And absolutely everything works (sleep, network, etc...)
       
      So, that's it? Is there anything else I have to do?
×