Jump to content
fantomas1

[pre-release] macOS High Sierra

3,845 posts in this topic

Recommended Posts

not work

attachicon.gif1.png

 

Oops. MFG? So you are using that com.apple.driver.AirPort.BrcmNIC-MFG? Alright, the patch above is for com.apple.driver.AirPort.BrcmNIC

 

Try this for MFG driver (Oops but the value is the same)

00000000001608cb	41 83 fc ff 	cmpl	$-0x1, %r12d
00000000001608cf	74 35 	je	0x160906
00000000001608d1	48 8d 55 d0 	leaq	-0x30(%rbp), %rdx

Share this post


Link to post
Share on other sites
Advertisement

I finally made it. Thanks to Chris1111 etc.

Here's what i did.

I upgraded my existing Sierra 10.12.6 to clover 4082.

Make a new 10.13 folder inside kext folder on my Sierra Clover.

Copied all kext on 10.12 to 10.13 and Other folders.

Copied apfs.efi to driversx64

Upgrade High Sierra app to Install SSD. Takes less than one minute to reboot.

Boot again to my sierra clover and select my Install ssd. It continue istallation showing 18 minutes to complete.

Reboot again and proceeded second stage to desktop.

Everything work except sound ALC887.

Install clover 4082 and add -lilubeta and -alcbeta to boot arguments to enable sound.

Restart and everthing OK.

High Sierra is perfect for H97M-E Asus Mobo.

 USB installer is not needed.35167994866_d90b5fd6a0_b.jpg

Share this post


Link to post
Share on other sites

Hi Sherlocks. Did you know something about AMD legacy support? I have HS installed, but no GPU acceleration. Thanks.

Share this post


Link to post
Share on other sites

 

Oops. MFG? So you are using that com.apple.driver.AirPort.BrcmNIC-MFG? Alright, the patch above is for com.apple.driver.AirPort.BrcmNIC

 

Try this for MFG driver (Oops but the value is the same)

00000000001608cb	41 83 fc ff 	cmpl	$-0x1, %r12d
00000000001608cf	74 35 	je	0x160906
00000000001608d1	48 8d 55 d0 	leaq	-0x30(%rbp), %rdx

yes

 

same. it's working now. remains board-id patch.

 

BT4LE-Handoff-Hotspot patch is same before. but not working Handoff(no) Hotspot(no)

Share this post


Link to post
Share on other sites

yes

 

same. it's working now. remains board-id patch.

For now, you can use this: (Not working, removed)

The patch is the same. But I don't suggest this way, I think a symbol patch (e.g. Lilu) may help us more.

Edited by PMheart

Share this post


Link to post
Share on other sites

For now, you can use this:

Kext: AirPortBrcmNIC || AirPortBrcmNIC-MFG
# whitelist patch

Find: 55 48 89 e5 41 57 41 56 53 48 81 ec 88 00 00 00 49 89 f6
Repl: 48 31 c0 48 ff c0 5d c3 53 48 81 ec 88 00 00 00 49 89 f6

The patch is the same. But I don't suggest this way, I think a symbol patch (e.g. Lilu) may help us more.

 

force reboot now, can't boot macos

Hi Sherlocks. Did you know something about AMD legacy support? I have HS installed, but no GPU acceleration. Thanks.

 

i dont know. i dont have amd gpu.

Share this post


Link to post
Share on other sites

idk, anyway patch is wrong now. i can't get boot

This is related to that patch I posted some minutes ago? (whitelist)

not working, PMHeart

Have you already added

-lilubeta -igfxbeta

to your boot-args if you are trying 10.13?

Share this post


Link to post
Share on other sites

This is related to that patch I posted some minutes ago? (whitelist)

 

Have you already added

-lilubeta -igfxbeta
to your boot-args if you are trying 10.13?
Whitelist patch-> force reboot now

 

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

Whitelist patch-> force reboot now

 

나의 LG-F800S 의 Tapatalk에서 보냄

Weird. I just let

__ZN19AirPort_BrcmNIC_MFG12checkBoardIdEPKc

always return true. I have no idea now. Sorry...

Share this post


Link to post
Share on other sites

Weird. I just let

__ZN19AirPort_BrcmNIC_MFG12checkBoardIdEPKc
always return true. I have no idea now. Sorry...
Whitelist patch is relate hotspot n handoff enable?

 

I dont use both.

 

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

Whitelist patch is relate hotspot n handoff enable?

 

I dont use both.

 

나의 LG-F800S 의 Tapatalk에서 보냄

Handoff can be also related to BT if I remember correctly? As for whitelist, nope, it's just for Wi-Fi.

Share this post


Link to post
Share on other sites

Hello,

 

GT640 was not working like many of us.

 

I've been able to make it works, just by removing injection in my DSDT.  :)

No clover injection.

 

Not working DSDT.

Store (Package (0x0A)
                                    {
                                        "@2,AAPL,boot-display", 
                                        Buffer (Zero) {}, 
                                        "@2,connector-type", 
                                        Buffer (0x04)
                                        {
                                             0x00, 0x08, 0x00, 0x00                         
                                        }, 
 
                                        "hda-gfx", 
                                        Buffer (0x0A)
                                        {
                                            "onboard-1"
                                        }, 
 
                                        "subsystem-id", 
                                        Buffer (0x04)
                                        {
                                             0x10, 0x00, 0x00, 0x00                         
                                        }, 
 
                                        "subsystem-vendor-id", 
                                        Buffer (0x04)
                                        {
                                             0x6B, 0x10, 0x00, 0x00                         
                                        }
                                    }, Local0)
 

Working DSDT, no HDMI, original driver, full acceleration

                                Store (Package (0x06)
                                    {
 
                                        "hda-gfx", 
                                        Buffer (0x0A)
                                        {
                                            "onboard-1"
                                        }, 
 
                                        "subsystem-id", 
                                        Buffer (0x04)
                                        {
                                             0x10, 0x00, 0x00, 0x00                         
                                        }, 
 
                                        "subsystem-vendor-id", 
                                        Buffer (0x04)
                                        {
                                             0x6B, 0x10, 0x00, 0x00                         
                                        }
                                    }, Local0)

Share this post


Link to post
Share on other sites

 

like this?

 

<dict>
<key>Comment</key>
<string>Remove USB limit MacOS</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>g32EEA==</data>
<key>MatchOS</key>
<string>10.13.x</string>
<key>Name</key>
<string>AppleUSBXHCIPCI</string>
<key>Replace</key>
<data>g32EFg==</data>
</dict>

 

Anyone can confirm this please

Share this post


Link to post
Share on other sites

 

like this?

 

<dict>
<key>Comment</key>
<string>Remove USB limit MacOS</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>g32EEA==</data>
<key>MatchOS</key>
<string>10.13.x</string>
<key>Name</key>
<string>AppleUSBXHCIPCI</string>
<key>Replace</key>
<data>g32EFg==</data>
</dict>

 

Yes, sorry for the late reply!

Anyone can confirm this please

Well, you can try it yourself, I made this patch with a friend of mine, he/she has confirmed it worked.

Share this post


Link to post
Share on other sites

Yes, sorry for the late reply!

Well, you can try it yourself, I made this patch with a friend of mine, he/she has confirmed it worked.

great! 

Yes, sorry for the late reply!

Well, you can try it yourself, I made this patch with a friend of mine, he/she has confirmed it worked.

this usb3.0 patch can be used on 100-series motherborad?

Share this post


Link to post
Share on other sites

 

Hello,

 

GT640 was not working like many of us.

 

I've been able to make it works, just by removing injection in my DSDT.  :)

No clover injection.

 

Not working DSDT.

Store (Package (0x0A)
                                    {
                                        "@2,AAPL,boot-display", 
                                        Buffer (Zero) {}, 
                                        "@2,connector-type", 
                                        Buffer (0x04)
                                        {
                                             0x00, 0x08, 0x00, 0x00                         
                                        }, 
 
                                        "hda-gfx", 
                                        Buffer (0x0A)
                                        {
                                            "onboard-1"
                                        }, 
 
                                        "subsystem-id", 
                                        Buffer (0x04)
                                        {
                                             0x10, 0x00, 0x00, 0x00                         
                                        }, 
 
                                        "subsystem-vendor-id", 
                                        Buffer (0x04)
                                        {
                                             0x6B, 0x10, 0x00, 0x00                         
                                        }
                                    }, Local0)
 

Working DSDT, no HDMI, original driver, full acceleration

                                Store (Package (0x0A)
                                    {
 
                                        "hda-gfx", 
                                        Buffer (0x0A)
                                        {
                                            "onboard-1"
                                        }, 
 
                                        "subsystem-id", 
                                        Buffer (0x04)
                                        {
                                             0x10, 0x00, 0x00, 0x00                         
                                        }, 
 
                                        "subsystem-vendor-id", 
                                        Buffer (0x04)
                                        {
                                             0x6B, 0x10, 0x00, 0x00                         
                                        }
                                    }, Local0)

 

I had similar patches and tried to remove some/all of them

even tried to boot without modified dsdt/ssdt

also tried without renaming GFX0->IGPU and PEGP->GFX0

same results.   :(

Share this post


Link to post
Share on other sites

Link to Sierra HD.dmg already installed? I accidentally deleted and it's only way to install because my video card it's not working.

 

Sent from my HTC One M9 using Tapatalk

Share this post


Link to post
Share on other sites

I'm using APFS drivers to start high sierra but it's slow and also the recovery is missing from clover options

In verbose mode, it slow when those line goes:

 

post-1767774-0-36732200-1497092132_thumb.png

Share this post


Link to post
Share on other sites

Hello,

 

can someone Post me Links to all Files that are needed for installation?

What are your hardware specs?

 

Installing macOS on a hackintosh is not that simple. You need to give us more details about your hardware.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      Making a High Sierra USB Installer Entirely From Scratch in Windows
      This is a proof of concept tutorial, to show it's possible to create a vanilla High Sierra installer, entirely from scratch, in Windows (even without App Store downloaded "Install macOS High Sierra.app" from a real Mac ).  @PikeRAlpha's link to Apple's Software Catalog provides us with all the URLs necessary to download the needed files directly from Apple instead of some dubious source from the internet...
       

      Pre-Requisites
      8GB or larger USB drive Boot Disk Utility v2.1.2017rev021b from @CVAD TransMac (free 15 day trial) Paragon Hard Disk Manager Free Download Installer Files Directly from Apple
      1)  Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist (Hint - search page for "InstallESD" to find its URL and others nearby)

      to a folder named "SharedSupport" on your Windows NTFS drive.  A browser download manager (eg Chrono for Chrome, dTA for FireFox) is handy since InstallESD is >4GB ---> allows you to pause/resume interrupted download...

      2)  Rename InstallESDDmg.pkg to InstallESD.dmg
      3)  Edit InstallInfo.plist with WordPad/text editor to remove the chunklistURL and chunklistid keys for InstallESD, and renaming it from InstallESDDmg.pkg to InstallESD.dmg (example of edited file attached to this post)...
      Note:  You can verify the SHA1 checksum of your InstallESD.dmg and BaseSystem.dmg with the correct ones at this website.
      Boot Disk Utility to format the Installer USB and Restore OS X Base System HFS partition
      1.  Format USB with BDU & latest Clover ---> creates boot files in CLOVER partition + second FAT partition
      2.  Extract 4.hfs from \SharedSupport\BaseSystem.dmg with BDU --> save to it's local folder
      3.  Restore 4.hfs to USB second partition with BDU --->  2nd partition becomes bootable "OS X Base System"
      Paragon Hard Disk Manager to extend HFS Partition to its Full Extent
      Open Paragon Partition Manager Free and resize the second partition of the USB drive to the full size allowed.  Don't forget to apply the changes at the end...
      Transmac to Copy "SharedSupport" folder to OS X Base System
      1.  Open the TransMac program and navigate to the HFS+ Volume/Install macOS High Sierra.app/Contents folder.  Right click anywhere in the empty space on the RHS pane and select "Copy Here"...
      2.  In the next stage, select the "SharedSupport" folder we created above as the "Files and Folders to be copied to the Mac Volume"...
       
      Clover Settings
      Clover configuration is required now.  The default config.plist (in the Clover FAT32 partition of the USB) maybe sufficient to boot your machine if you’re lucky.  If not, the hackintosh-vanilla-desktop-guide has some good explanations on the various settings available and also offers sample configuration files based on CPU type.  Also, look at the Clover Wiki, Clover Instructions and Clover Configuration Thread for pointers and edit /EFI/Clover/config.plist accordingly with Wordpad or Notepad.
      The location of the important configuration files for Clover are summarized below
      config.plist--->EFI/CLOVER folder DSDT.aml with or without SSDT.aml--->EFI/CLOVER/ACPI/patched (don't need one if your DSDT is auto patched by Clover in config.plist) Kexts eg FakeSMC, NullCPUPowerManagement --->EFI/CLOVER/kexts/<osx version> or /Other. NB BootDiskUtility by default already has FakeSMC.kext installed here.  You may need to add VoodooPS2Controller for your laptop keyboard/trackpad to work. If UEFI booting, you will most likely need one of the OsxAptioFixDrv-64 drivers copied from /EFI/CLOVER/drivers-off/drivers64UEFI to /EFI/CLOVER/drivers64UEFI. If you want to use the installer to run High Sierra in Windows on VMware, you can follow my guide to set up the Virtual Machine and replace Clover's default config with EFI_Clover for VMware (which is compatible to run in VMware).  In the screenshots below, I have attached the USB Installer (in this case PhysicalDrive7) to my macOS Virtual Machine.  Reboot the system to the USB installer to install High Sierra ...
      What happens if we don't have access to TransMac or Paragon Hard Disk Manager?
      Not a problem, as long as we get "OS X Base System" bootable, we can launch terminal from the Utilities Menu to copy the SharedSupport folder over to the Installer app.  In essence, we will build the full installer app = 5GB+ on the target HD eg "Macintosh HD", by copying both the "small" installer app = 15MB (on "OS X Base System") and the SharedSupport folder from the NTFS volume (mounted in this example on /Volumes/DATA)...
      -bash-3.2# cd / -bash-3.2# cp -R Install\ macOS\ High\ Sierra.app /Volumes/Macintosh\ HD/ -bash-3.2# cp -R /Volumes/DATA/SharedSupport /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app/Contents/  
      ...then start installation with the startosinstall utility...
      -bash-3.2# /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app/Contents/Resources/startosinstall --volume /Volumes/Macintosh\ HD --converttoapfs NO --applicationpath /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app  
      The above steps can be automated with the attached "startosinstall.command" script, which will assemble "Install macOS High Sierra.app" on "Macintosh HD" and launch the startosinstall utility targeting the "Macintosh HD" volume.  Copy/download to "Macintosh HD", then run in terminal (after attaching DATA USB with /Shared Support folder)...
      cd "/Volumes/Macintosh HD" chmod +x startosinstall.command ./startosinstall.command Updated Download Links for macOS Mojave 10.14.5_18F132
      Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist  
      Note: In Mojave, Apple has removed the --converttoapfs NO and --applicationpath arguments from the startosinstall utility....
       
      eg to use startosinstall for the above section "What happens if we don't have access to TransMac or Paragon Hard Disk Manager?", the syntax is now
      -bash-3.2# /Volumes/Macintosh\ HD/Install\ macOS\ Mojave.app/Contents/Resources/startosinstall --volume /Volumes/Macintosh\ HD  
      This basically means that for Mojave, the default installation will always convert the target volume to the apfs file system.
       
       
      startosinstall.command.zip
      InstallInfo.plist_edited_10.13.6.zip
      InstallInfo.plist_edited_10.14.5.zip
       
       
    • By Pentothal.Z
      Hello all,
      I have a working hackintosh....ok.....but it takes a lot to boot and according to the boot.log there are a few problems.
      One of them is a black screen that stays on for a long time.
      I would like to ask anyone in this community some help to fine tune my machine.
      Boot.log and config.plist attached


      Any help would be appreciated.
      bootlog.txt
      config.plist
    • By eliot6001
      I don't know whether my LAN device will work on MAC and Which version of mac but i still want to run MAC on my PC, Also i checked my CPU-GPU and it turned out that i can Run MAX High sierra but i realized that some people have trouble with Sound and Internet connection so Here's the NAME of my LAN device:
       
      PCI\VEN_10EC&DEV_8136&SUBSYS_012310EC&REV_05\4&45F2A70&0&00E1 as (LAN DEVICE took the name from device manager in  windows). 
      also from compatibleIds i got this:
      PCI\VEN_10EC&DEV_8136&REV_05
       
      Is it Supported on any version of macOS ?
    • By Aldaro
      I have been running macOS Mojave on my system for 3 months and everything was working pretty well.  After taking an update for clover, my entire system got wrecked, and I cannot even boot to an installation environment anymore (which I really need to do since I am starting back at square one).  I still have the old EFI folder backed up, but I know it'll only be a matter of time before Apple introduces an update that requires me to update Clover in order to work correctly.  I have tried all the available memory fixes, but none of them seem to work.  I was previously using the original osxaptiofix; so, I gave v2, and v3 a try, but to no success.  I read somewhere on the main discussion board for clover that AptioMemoryFix was no longer going to be supported and I therefor decided to skip over it (not to mention it isn't even available in newer clover installation packages).
       
      System specs:
      Motherboard: GIGABYTE Z390 M GAMING
      CPU Intel core i5 9600k @ stock 3.7GHz
      RAM 32GB DDR4 2667MHz
      GPU AMD Radeon RX 580 with 8GB of GDDR5
      SSD Intel 660p 512GB NVME
      NIC: Intel i210 10/100/1000 as it is natively supported in macOS
       
      I have been using the iMac 19,1 SMBIOs as I built this machine to match it as close as humanly possible.  As for my UEFI settings, I did the usual:
      Disabled Windows specific features and secure boot
      Enabled XHCI hand off
      Enabled Above 4G decoding
      Disabled onboard NIC since it is made irrelevant by my intel i210
       
      --INJECT KEXTS--
      FakeSMC
      Lilu
      WhateverGreen
      AppleALC
      USBInjectAll -- WITH PATCHED SSDT in /EFI/CLOVER/ACPI/patched
      Below are images of the errors I am receiving when trying to boot the macOS Mojave installer.
       
      with original osxaptiomemoryfix

       
      osxaptiofixv2

       
      osxaptiofixv3

       
      Anyway, if somebody can help me figure out what's going on, that'd be greatly appreciated.  My ultimate goal is to get an install with minimal clover patches as to be better prepared when the winds of change from Apple come roaring.
       
      p.s: I have also attached a copy of my EFI folder
       
       
      EFI.zip
    • By fusion71au
      Clover r4989 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4989 for VMware.zip". Mount Clover-v2.4k-4989-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
×