Jump to content
fantomas1

[pre-release] macOS High Sierra

3,845 posts in this topic

Recommended Posts

Advertisement

What is your ffm ff?

FirmwareFeature: 0xE907F537
FirmwareFeatureMask : 0xFFFFFFFF
PlatformFeature: 0xFFFF

FYI, I'm using MBP10,1 SMBios, Clover Legacy w.o rc.script.

 

Plz note, that Datas above are from Clover r4170 (with ROM Release Date: 08/08/2017) << Post-Install from macHDD.

On Pre-install via USB with createinstallmedia >>

Using Clover r4167 with 07/27/2017 (provided by CC v4.47.1) I have no "OSInstall.mpkg error.", but on 2nd stage I got these awesome error message:

"macOS could not be installed on your computer:

An error occurred while verifying firmware"."

 

And then I repeat the process after manually updating r4169 with 08/08/2017 on SMBios, unfortunately "OSInstall.mpkg error" was back again.

So, my complete setup has done using partition to partition install method. Thanks.

i am confused that why nvidia quadro 1000m has no QE/CI on high sierra. i test hs pb1.

So am I, if I have such graphics though.. I still can't get a clear answer about ur question. As we've known since last year Ap*ple && nVd*ia have "break up" and yeah,

I don't wanna speculate too much.. simply ask them. Sorry.. my GF119 is also not so good since Sierra  :) and I got it.

post-826765-0-85268700-1502810397_thumb.jpg

Share this post


Link to post
Share on other sites
FirmwareFeature: 0xE907F537
FirmwareFeatureMask : 0xFFFFFFFF
PlatformFeature: 0xFFFF

FYI, I'm using MBP10,1 SMBios, Clover Legacy w.o rc.script.

 

Plz note, that Datas above are from Clover r4170 (with ROM Release Date: 08/08/2017) << Post-Install from macHDD.

On Pre-install via USB with createinstallmedia >>

Using Clover r4167 with 07/27/2017 (provided by CC v4.47.1) I have no "OSInstall.mpkg error.", but on 2nd stage I got these awesome error message:

"macOS could not be installed on your computer:

An error occurred while verifying firmware"."

 

And then I repeat the process after manually updating r4169 with 08/08/2017 on SMBios, unfortunately "OSInstall.mpkg error" was back again.

So, my complete setup has done using partition to partition install method. Thanks.

So am I, if I have such graphics though.. I still can't get a clear answer about ur question. As we've known since last year Ap*ple && nVd*ia have "break up" and yeah,

I don't wanna speculate too much.. simply ask them. Sorry.. my GF119 is also not so good since Sierra  :) and I got it.

 

 

on 4169, already has latest biosversion 08/08/2017. no need to manually add until release dp7. clover choice latest biosversion between clover data and users smbios data.
ofc user add biosversion, but already same values in clover data.
i think sandy and ivy smbios or other smbios dont need exact ffm ff values.
 
EDIT1.
i do not understand.
fresh install
- nop?
upgrade install
- problem?

Share this post


Link to post
Share on other sites

EDIT1.

i do not understand.
fresh install
- nop?
upgrade install
- problem?

Oops, sorry forgot to mention: I did clean install DP6 with run "OSInstall.mpkg" from a working 10.11.6 and selected an empty HFS+ as 10.13 target partition.

But, I may try again with USB Installer method tomorrow and let see if "An error occurred while verifying firmware" message is still there  :rolleyes: Thanks again.

Share this post


Link to post
Share on other sites

Oops, sorry forgot to mention: I did clean install DP6 with run "OSInstall.mpkg" from a working 10.11.6 and selected an empty HFS+ as 10.13 target partition.

But, I may try again with USB Installer method tomorrow and let see if "An error occurred while verifying firmware" message is still there :rolleyes: Thanks again.

After sucess install, upload full log.

 

Now. Im gathering info for resolve issue.

Thanks in advance.

 

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

@Badruzeus Where did you find the OSInstall.mpkg? (where does App Store save it after update download is complete?)

 

EDIT: Actually meant macOSUPd10.13.pkg (not OSInstall.mpkg) and it gets saved to /Library/Updates. If this update fails again, will try running it from other partition lol

 

post-838036-0-75214900-1502824971_thumb.png

 

EDIT: After downloading the update again in App Store, the update process worked normally. Must have been that the prior update files were corrupt or something like that

Share this post


Link to post
Share on other sites

@Badruzeus Where did you find the OSInstall.mpkg? (where does App Store save it after update download is complete?)

/"Install macOS High Sierra Beta.app"/Contents/SharedSupport/InstallESD.dmg/Packages/OSInstall.mpkg

(But sorry, I don't recommend this if USB Install method with createinstallmedia just works).

Share this post


Link to post
Share on other sites

/"Install macOS High Sierra Beta.app"/Contents/SharedSupport/InstallESD.dmg/Packages/OSInstall.mpkg

(But sorry, I don't recommend this if USB Install method with createinstallmedia just works).

 

Well, I have old High Sierra Beta.app.. How do I force update the app? Should I delete it and download again? I'm gonna try the Appstore update again, but I doubt it will work. Tried everything, latest clover, changed SMBIOS values (FF, FFM, Bios version && Bios Date), even used configs from this thread.. nothing works, always stuck at the OSInstall.mpkg error..

 

 

Also, yeah. If I already download the app, it doesn't make much sense to not create the installer.

Share this post


Link to post
Share on other sites

Well, I have old High Sierra Beta.app.. How do I force update the app? Should I delete it and download again? I'm gonna try the Appstore update again, but I doubt it will work. Tried everything, latest clover, changed SMBIOS value, even used configs from this thread.. nothing works, always stuck at the OSInstall.mpkg error..

I think it depends on ur mach specs (where's ur clear signature?). The update mechanism may varies and also the results, and since it's still on Beta stage; Apple may change a lots on each seed. For my mach however it sometimes gotta succeeded with just an update via AppStore, but another time it failed so I did clean install.

For "OSInstall.mpkg" error was an issue since 10.13 DP1 but you may try using Clover w/o rc.script, or w/o Emuvariable (UEFI). Good luck.  :)

Share this post


Link to post
Share on other sites

For "OSInstall.mpkg" error was an issue since 10.13 DP1 but you may try using Clover w/o rc.script, or w/o Emuvariable (UEFI). Good luck.  :)

 

First time I run into it. Was on developer update channel for HS and every update worked so far. Yesterday clean install with last weeks HS Beta.app (beta channel), thinking I would be able to update via the App Store easily.. boy was I wrong.. 

Share this post


Link to post
Share on other sites

Sherlocks, can you help me with my GTX 750 Ti? Since DP4 I can't get my video card to work properly: with web drivers, clover inject Nvidia and fake id, I get video on just one monitor (I have 3), without fake id I get black screen (no signal). In Sierra 10.12.6 all works fine, 3 monitors, HDMI sound, etc.

Share this post


Link to post
Share on other sites

as you can see in this post there are new Bios Versions and Bios Release dates.

for example if you use the iMac15,1 SMBIOS the new BIOS version is: IM151.88Z.0211.B00.1708080656 with the new BIOS Release Date: 08/08/2017

 

You need to add the FirmwareFeaturesMask=0xff1fff3f and FirmwareFeatures=0xf80fe137

Seems like you interchanged FF and FFM

Share this post


Link to post
Share on other sites

Anybody with this problem? Can anybody help me please?

 

"Sherlocks, can you help me with my GTX 750 Ti? Since DP4 I can't get my video card to work properly: with web drivers, clover inject Nvidia and fake id, I get video on just one monitor (I have 3), without fake id I get black screen (no signal). In Sierra 10.12.6 all works fine, 3 monitors, HDMI sound, etc."

Share this post


Link to post
Share on other sites

I always clean install with MBR patch for db1~db6, all work fine without firmware error cause of it been removed. :P

 

post-846696-0-39333900-1502872786_thumb.jpg

 

For those with firmware errors during installation, I can confirm that @crazybirdy's modified BaseSystem Installer method works well for upgrading or clean installing High Sierra DB6 on my legacy BIOS desktop (GA-P55a-UD3/Intel i5-750/ATI HD5770).

  • Clover legacy r4173, latest DB6 apfs.efi in /EFI/CLOVER/drivers64
  • SMBIOS iMac11,3, no FF/FFM/PF or Board-ID/BIOS ver/date set in config.plist
  • Deleted all NVRAM.plist files from all EFI partitions (including on the USB Installer), ran sudo NVRAM -c in terminal before upgrade
  • Created USB installer using @crazybirdy's modified "Base System Restore Method" and patched OSInstaller
  • Ran "Install macOS High Sierra Beta.app" targetting my HiSierra partition ---> automatically creates /HiSierra/macOS\ Install\ Data folder
  • At the first restart, booted to my "Disk1mbrInstaller" USB
  • At second restart, booted into fully updated HiSierra DB6_17A344B

post-846696-0-20987300-1502864810_thumb.png
post-846696-0-07640000-1502864843_thumb.png
post-846696-0-78429800-1502864871_thumb.jpg
post-846696-0-07776000-1502845350_thumb.png

 
Notes
  • An advantage of this method is that you can change kexts in the installer's /S/L/E eg you can replace AppleAHCIPort.kext v329 with v328, to fix "Still Waiting for Root Device Error" on systems with ICH10
  • Directly booting to /HiSierra/macOS Install Data at first restart (instead of Disk1mbrInstaller) ---> firmware error preventing further installation
  • On my newer UEFI system with functioning hardware NVRAM (NUC6i5SYH/Intel i5-6260U/Iris Graphics 540), I updated DB5 to DB6 normally through App Store upgrade without incident (SMBIOS iMac17,1, Clover r4167, no FF/FFM/PF set in config.plist)

apfs_DB6.efi.zip

AppleAHCIPort_v328.kext.zip

Clover_v2.4k_r4173.zip

Clover r4173 bootlog.txt.zip

Share this post


Link to post
Share on other sites

After sucess install, upload full log.

 

Now. Im gathering info for resolve issue.

Thanks in advance.

Perfecto..!!! :thumbsup_anim: Succeeded with 2nd time "Clean Install" using USB Installer Method.

 

My configs are:

1. macOS 10.13 High Sierra (17A344b) downloaded from AppStore.

2. Create USB Installer with createinstallmedia (Boot Buddy.app here's just another GUI version)

3. Using Clover v2.4k r4173 Legacy on USB's ESP w/o rc.script for succeeded install purpose only

4. My SMBios Datas: 

 

Product Name: MacBookPro10,1
Board ID: Mac-C3EC7CD22292981F

(for Datas below are autogenerated by Clover)

ROM Version: MBP101.88Z.00F2.B00.1708080809
ROM Release Date: 08/08/2017
FirmwareFeature: 0xE00DE137
FirmwareFeatureMask : 0xFF1FFF3F
PlatformFeature: 0xFFFF 

 

 

 

>> DONE..!!! Thanks @Sherlocks, @PMheart, @Slice, @ErmaC, @Apianti, @syscl etc. for great support.

 

#EDIT: as @fusion71 has said, I also removed any nvram.plist found from all bootable macOS Volumes just b4 install proccess.

#EDIT2: on my EFI/CLOVER/kexts/10.13 I only use @rehabman's FakeSMC v6.25-333 and @EmlyDinesh's ApplePS2SmartTouchpad v4.7 Beta 5 (ELAN_101).

post-826765-0-69978100-1502845101_thumb.jpg

install-A43SJ-17A344b.log.zip

preboot.log.zip

Share this post


Link to post
Share on other sites

Clover r4173 Works with startosinstall or MACOSInstaller Updated  to r4173  :)

 

smbios macBookPro 10

macBookPro 11.4

iMac 13

Not need

FirmwareFeature

FirmwareFeatureMask
PlatformFeature

B) 

Confirming here first pics MacBook Pro 11.4

Second Pics iMac 13.1

post-951341-0-47591100-1502847812_thumb.jpg

post-951341-0-29985400-1502852410_thumb.jpg

Share this post


Link to post
Share on other sites

Clover r4173 Works with startosinstall or MACOSInstaller Updated  to r4173  :)

 

smbios macBookPro 10

iMac 13

Not need

FirmwareFeature

FirmwareFeatureMask

PlatformFeature

B) 

Confirming here 

biosversion should be updated lately

Share this post


Link to post
Share on other sites

Perfecto..!!! :thumbsup_anim: Succeeded with 2nd time "Clean Install" using USB Installer Method.

 

My configs are:

1. macOS 10.13 High Sierra (17A344b) downloaded from AppStore.

2. Create USB Installer with createinstallmedia (Boot Buddy.app here's just another GUI version)

3. Using Clover v2.4k r4173 Legacy on USB's ESP w/o rc.script for succeeded install purpose only

4. My SMBios Datas:

 

Product Name: MacBookPro10,1Board ID: Mac-C3EC7CD22292981F(for Datas below are autogenerated by Clover)ROM Version: MBP101.88Z.00F2.B00.1708080809ROM Release Date: 08/08/2017FirmwareFeature: 0xE00DE137FirmwareFeatureMask : 0xFF1FFF3FPlatformFeature: 0xFFFF

 

 

>> DONE..!!! Thanks @Sherlocks, @PMheart, @Slice, @ErmaC, @Apianti, @syscl etc. for great support.

 

#EDIT: as @fusion71 has said, I also removed any nvram.plist found from all bootable macOS Volumes just b4 install proccess.

#EDIT2: on my EFI/CLOVER/kexts/10.13 I only use @rehabman's FakeSMC v6.25-333 and @EmlyDinesh's ApplePS2SmartTouchpad v4.7 Beta 5 (ELAN_101).

Great! Thanks for clean report.

Enjoy

 

나의 LG-F800S 의 Tapatalk에서 보냄

yes.right...should change in smbios?

No need. Clover detect latest bios version between your config and clover smbios data. I already implement this function on latest clover r4173.

 

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

Sherlocks, can you help me with my GTX 750 Ti? Since DP4 I can't get my video card to work properly: with web drivers, clover inject Nvidia and fake id, I get video on just one monitor (I have 3), without fake id I get black screen (no signal). In Sierra 10.12.6 all works fine, 3 monitors, HDMI sound, etc.

Share this post


Link to post
Share on other sites

Great! Thanks for clean report.

Enjoy

 

나의 LG-F800S 의 Tapatalk에서 보냄

No need. Clover detect latest bios version between your config and clover smbios data. I already implement this function on latest clover r4173.

 

나의 LG-F800S 의 Tapatalk에서 보냄

good function!   :thumbsup_anim:  :thumbsup_anim:  :thumbsup_anim: 

Share this post


Link to post
Share on other sites

Sherlocks, can you help me with my GTX 750 Ti? Since DP4 I can't get my video card to work properly: with web drivers, clover inject Nvidia and fake id, I get video on just one monitor (I have 3), without fake id I get black screen (no signal). In Sierra 10.12.6 all works fine, 3 monitors, HDMI sound, etc.

I think web driver issue or something. Still DP. Need to consider HS release and web driver official version in future.

 

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fantomas1
      This update:
      • Makes downloaded issues available in the My Magazines section of Apple News+, both online and offline
      • Adds all publications in Apple News+, including newspapers, to the catalog at the top of the News+ feed
      • Adds the ability to clear downloaded magazine issues in Apple News+ by selecting History > Clear > Clear All
      • Addresses an issue which prevents creation of a new Boot Camp partition on iMac and Mac mini with Fusion Drive
      • Resolves an issue that may cause a hang during a restart
      • Resolves a graphics issue that may occur when waking from sleep
      • Fixes an issue that may cause fullscreen video to appear black on Mac mini
      • Improves file sharing reliability over SMB
       
      macOS Mojave 10.14.6 (18G84)
       
      Update
      Combo

      View full article
    • By fantomas1
      This update:
      • Makes downloaded issues available in the My Magazines section of Apple News+, both online and offline
      • Adds all publications in Apple News+, including newspapers, to the catalog at the top of the News+ feed
      • Adds the ability to clear downloaded magazine issues in Apple News+ by selecting History > Clear > Clear All
      • Addresses an issue which prevents creation of a new Boot Camp partition on iMac and Mac mini with Fusion Drive
      • Resolves an issue that may cause a hang during a restart
      • Resolves a graphics issue that may occur when waking from sleep
      • Fixes an issue that may cause fullscreen video to appear black on Mac mini
      • Improves file sharing reliability over SMB
       
      macOS Mojave 10.14.6 (18G84)
       
      Update
      Combo
    • By fantomas1
      macOS Mojave 10.14.6 (18G84)
       
      Update
      Combo
    • By fusion71au
      Making a High Sierra USB Installer Entirely From Scratch in Windows
      This is a proof of concept tutorial, to show it's possible to create a vanilla High Sierra installer, entirely from scratch, in Windows (even without App Store downloaded "Install macOS High Sierra.app" from a real Mac ).  @PikeRAlpha's link to Apple's Software Catalog provides us with all the URLs necessary to download the needed files directly from Apple instead of some dubious source from the internet...
       

      Pre-Requisites
      8GB or larger USB drive Boot Disk Utility v2.1.2017rev021b from @CVAD TransMac (free 15 day trial) Paragon Hard Disk Manager Free Download Installer Files Directly from Apple
      1)  Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist (Hint - search page for "InstallESD" to find its URL and others nearby)

      to a folder named "SharedSupport" on your Windows NTFS drive.  A browser download manager (eg Chrono for Chrome, dTA for FireFox) is handy since InstallESD is >4GB ---> allows you to pause/resume interrupted download...

      2)  Rename InstallESDDmg.pkg to InstallESD.dmg
      3)  Edit InstallInfo.plist with WordPad/text editor to remove the chunklistURL and chunklistid keys for InstallESD, and renaming it from InstallESDDmg.pkg to InstallESD.dmg (example of edited file attached to this post)...
      Note:  You can verify the SHA1 checksum of your InstallESD.dmg and BaseSystem.dmg with the correct ones at this website.
      Boot Disk Utility to format the Installer USB and Restore OS X Base System HFS partition
      1.  Format USB with BDU & latest Clover ---> creates boot files in CLOVER partition + second FAT partition
      2.  Extract 4.hfs from \SharedSupport\BaseSystem.dmg with BDU --> save to it's local folder
      3.  Restore 4.hfs to USB second partition with BDU --->  2nd partition becomes bootable "OS X Base System"
      Paragon Hard Disk Manager to extend HFS Partition to its Full Extent
      Open Paragon Partition Manager Free and resize the second partition of the USB drive to the full size allowed.  Don't forget to apply the changes at the end...
      Transmac to Copy "SharedSupport" folder to OS X Base System
      1.  Open the TransMac program and navigate to the HFS+ Volume/Install macOS High Sierra.app/Contents folder.  Right click anywhere in the empty space on the RHS pane and select "Copy Here"...
      2.  In the next stage, select the "SharedSupport" folder we created above as the "Files and Folders to be copied to the Mac Volume"...
       
      Clover Settings
      Clover configuration is required now.  The default config.plist (in the Clover FAT32 partition of the USB) maybe sufficient to boot your machine if you’re lucky.  If not, the hackintosh-vanilla-desktop-guide has some good explanations on the various settings available and also offers sample configuration files based on CPU type.  Also, look at the Clover Wiki, Clover Instructions and Clover Configuration Thread for pointers and edit /EFI/Clover/config.plist accordingly with Wordpad or Notepad.
      The location of the important configuration files for Clover are summarized below
      config.plist--->EFI/CLOVER folder DSDT.aml with or without SSDT.aml--->EFI/CLOVER/ACPI/patched (don't need one if your DSDT is auto patched by Clover in config.plist) Kexts eg FakeSMC, NullCPUPowerManagement --->EFI/CLOVER/kexts/<osx version> or /Other. NB BootDiskUtility by default already has FakeSMC.kext installed here.  You may need to add VoodooPS2Controller for your laptop keyboard/trackpad to work. If UEFI booting, you will most likely need one of the OsxAptioFixDrv-64 drivers copied from /EFI/CLOVER/drivers-off/drivers64UEFI to /EFI/CLOVER/drivers64UEFI. If you want to use the installer to run High Sierra in Windows on VMware, you can follow my guide to set up the Virtual Machine and replace Clover's default config with EFI_Clover for VMware (which is compatible to run in VMware).  In the screenshots below, I have attached the USB Installer (in this case PhysicalDrive7) to my macOS Virtual Machine.  Reboot the system to the USB installer to install High Sierra ...
      What happens if we don't have access to TransMac or Paragon Hard Disk Manager?
      Not a problem, as long as we get "OS X Base System" bootable, we can launch terminal from the Utilities Menu to copy the SharedSupport folder over to the Installer app.  In essence, we will build the full installer app = 5GB+ on the target HD eg "Macintosh HD", by copying both the "small" installer app = 15MB (on "OS X Base System") and the SharedSupport folder from the NTFS volume (mounted in this example on /Volumes/DATA)...
      -bash-3.2# cd / -bash-3.2# cp -R Install\ macOS\ High\ Sierra.app /Volumes/Macintosh\ HD/ -bash-3.2# cp -R /Volumes/DATA/SharedSupport /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app/Contents/  
      ...then start installation with the startosinstall utility...
      -bash-3.2# /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app/Contents/Resources/startosinstall --volume /Volumes/Macintosh\ HD --converttoapfs NO --applicationpath /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app  
      The above steps can be automated with the attached "startosinstall.command" script, which will assemble "Install macOS High Sierra.app" on "Macintosh HD" and launch the startosinstall utility targeting the "Macintosh HD" volume.  Copy/download to "Macintosh HD", then run in terminal (after attaching DATA USB with /Shared Support folder)...
      cd "/Volumes/Macintosh HD" chmod +x startosinstall.command ./startosinstall.command Updated Download Links for macOS Mojave 10.14.5_18F132
      Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist  
      Note: In Mojave, Apple has removed the --converttoapfs NO and --applicationpath arguments from the startosinstall utility....
       
      eg to use startosinstall for the above section "What happens if we don't have access to TransMac or Paragon Hard Disk Manager?", the syntax is now
      -bash-3.2# /Volumes/Macintosh\ HD/Install\ macOS\ Mojave.app/Contents/Resources/startosinstall --volume /Volumes/Macintosh\ HD  
      This basically means that for Mojave, the default installation will always convert the target volume to the apfs file system.
       
       
      startosinstall.command.zip
      InstallInfo.plist_edited_10.13.6.zip
      InstallInfo.plist_edited_10.14.5.zip
       
       
    • By Pentothal.Z
      Hello all,
      I have a working hackintosh....ok.....but it takes a lot to boot and according to the boot.log there are a few problems.
      One of them is a black screen that stays on for a long time.
      I would like to ask anyone in this community some help to fine tune my machine.
      Boot.log and config.plist attached


      Any help would be appreciated.
      bootlog.txt
      config.plist
×