Jump to content
fantomas

[pre-release] macOS High Sierra

3,845 posts in this topic

Recommended Posts

Question:

 

My External NVMe patch does suddenly not work anymore with 10.13 DP5.

 

Name: IONVMeFamily Find: 4885c074 07808b20 Replace: 4885c066 90808b20

 

Can somebody give me a working one please?

 

Cheers,

 

KGP

Hi, the patch changed... Try this one under dp5:

 

48 85 c0 74 07 -> ​48 85 c0 66 90

Share this post


Link to post
Share on other sites
Advertisement

I got it going on SIerra and High Sierra - i9 7900x, as have a few others now. I'll start a thread and post pics of my clover, efi and kexts.

It was way easier than X99 :)

Which kernel to patch entries did you use under 10.12?

Share this post


Link to post
Share on other sites

Compared to the first beta, it seems DB5 working much better with APFS on old spinning HDDs .  Successful clean install here on my GA-P55aUD3 desktop (5 series MB with legacy BIOS/i5-750/ATI HD5770) with 7200rpm HDD.  

 

USB installer made with "createinstallmedia method", Clover r4128 and latest apfs.efi in /EFI/CLOVER/drivers64...

 

post-846696-0-52669500-1502233682_thumb.png

 

 

 

Core.pkg method isn't working anymore in DB5, any other method to install on ICH10? I need to replace AppleAHCIPort.kext to boot.

 

As a work around, you can install DB5 on an external USB hard disk, replace AppleAHCIPort.kext v329 in /S/L/E with v328 (don't forget to repair permissions and rebuild kernel cache), then clone the working system back to your internal SATA hard disk eg with Carbon Copy Cloner or Disk Utility.

 

PS Just tried a Core install of DB5 (from my Yosemite volume to a newly formatted HFS+ partition named macOS) and it still works....

 

 

post-846696-0-25121200-1502247032_thumb.png

post-846696-0-13695800-1502247051_thumb.png

 

 

Post-Installation Terminal Commands (I had AppleAHCIPort.kext v328 and Developer SeedEnrollment.plist in my ~/Downloads folder)

sudo cp /Volumes/macOS/usr/standalone/i386/boot.efi /Volumes/macOS/System/Library/CoreServices
sudo mv /Volumes/macOS/System/Library/Extensions/AppleAHCIPort.kext /Volumes/macOS/System/Library/Extensions/AppleAHCIPort.329
sudo cp -R ~/Downloads/AppleAHCIPort.kext /Volumes/macOS/System/Library/Extensions
sudo touch /Volumes/macOS/System/Library/Extensions  && sudo kextcache -u /Volumes/macOS
cp ~/Downloads/SeedEnrollment.plist /Volumes/macOS/Users/Shared/.SeedEnrollment.plist

AppleAHCIPort_v328.kext.zip

apfs.efi.zip

SeedEnrollment.plist.zip

Share this post


Link to post
Share on other sites

Compared to the first beta, it seems DB5 working much better with APFS on old spinning HDDs .  Successful clean install here on my legacy GA-P55aUD3 desktop with 7200rpm HDD....  

 

 

 

 

Any of the other SATA ports on ICH10 recognised?  Try connecting the hard disk to another SATA port and see if it shows up in disk utility when you boot from the USB installer?  

 

As a work around, you can install DB5 on an external USB hard disk, replace AppleAHCIPort.kext v329 in /S/L/E with v328 (don't forget to repair permissions and rebuild kernel cache), then clone the working system back to your internal SATA hard disk eg with Carbon Copy Cloner or Disk Utility.

Which SATA chipset do you use? I may have better workaround then...

Share this post


Link to post
Share on other sites

@cyberdevs ,high sierra 13 can be installed on ssd with apfs?

i have installed it to my Intel 600p series SSD 256gb. Since day one...when it was possible APSF.efi Thanks for that!

When it wworks nice!

post-2200747-0-17884400-1502234609_thumb.png

post-2200747-0-12439100-1502234642_thumb.png

Share this post


Link to post
Share on other sites

Successful clean install here on my GA-P55aUD3 desktop (5 series chipset, legacy BIOS) with 7200rpm HDD.

 

What Graphics Card are you using for High Sierra with your 5-series motherboard?

 

I have a P55A-UD4P but am stuck on El Capitan as I am using a 9800GT and have been unable to upgrade to Sierra (and soon High Sierra)

Share this post


Link to post
Share on other sites

Glad to know that I'm not alone who gotta trackpad (minor) issue on 10.13 DP5.. #NoWorry << 10.11.x Trackpad.pref works though  :P

^ both using @rehabman VoodooPS2 v1.8.27 or @EmlyDinesh ApplePS2Tp v4.7 Beta 5 (ELAN_101).

And I think it' s not a good idea to push the devs with Beta System (for TP fix)... so, it' s just a report.

 

SzkvUvp.jpg

 

#ADD: Another issue even on some Real MBPs with Beta 5: Beta 5 fails on MacBook Pro

Share this post


Link to post
Share on other sites

Which SATA chipset do you use? I may have better workaround then...

I have P43 ICH10

Strange thing that on my laptop with ICH9M is working...

 

Sent from my HTC One M9 using Tapatalk

Share this post


Link to post
Share on other sites

As a work around, you can install DB5 on an external USB hard disk, replace AppleAHCIPort.kext v329 in /S/L/E with v328 (don't forget to repair permissions and rebuild kernel cache), then clone the working system back to your internal SATA hard disk eg with Carbon Copy Cloner or Disk Utility.

 

What issue did you get on why you need to revert v329 to v328?

Share this post


Link to post
Share on other sites

I got it going on SIerra and High Sierra - i9 7900x, as have a few others now. I'll start a thread and post pics of my clover, efi and kexts.

It was way easier than X99 :)

Oh, that's wonderful :)

Does it have a native support? or you need to use fakeCPUID?

Share this post


Link to post
Share on other sites

What issue did you get on why you need to revert v329 to v328?

Stuck at waiting for root device.

 

Sent from my HTC One M9 using Tapatalk

Share this post


Link to post
Share on other sites

I got it going on SIerra and High Sierra - i9 7900x, as have a few others now. I'll start a thread and post pics of my clover, efi and kexts.

It was way easier than X99 :)

 

Can you provide a link to your new thread please?

Share this post


Link to post
Share on other sites

Hi, the patch changed... Try this one under dp5:

 

48 85 c0 74 07 -> ​48 85 c0 66 90

 

Does not work with the EVO 960 either.... Any other values?

Share this post


Link to post
Share on other sites

Glad to know that I'm not alone who gotta trackpad (minor) issue on 10.13 DP5.. #NoWorry << 10.11.x Trackpad.pref works though  :P

^ both using @rehabman VoodooPS2 v1.8.27 or @EmlyDinesh ApplePS2Tp v4.7 Beta 5 (ELAN_101).

And I think it' s not a good idea to push the devs with Beta System (for TP fix)... so, it' s just a report.

 

SzkvUvp.jpg

 

#ADD: Another issue even on some Real MBPs with Beta 5: Beta 5 fails on MacBook Pro

As RehabMan said, "I'm in no hurry (it comes with age)".

It seems 10.13.pb4 has just been released along with new Command Line Tools beta for Xcode 9. According to the previous releases, this should have the same build number as dp5.

Share this post


Link to post
Share on other sites

Here you go :thumbsup_anim:

Seems the same as mine... Enlarged the bytes, try it:

 

48 85 C0 74 07 80 8B -> 48 85 C0 90 90 80 8B

I have P43 ICH10

Strange thing that on my laptop with ICH9M is working...

 

Sent from my HTC One M9 using Tapatalk

Is your P43 ICH10 chipset ID 0x3a228086 ?

Share this post


Link to post
Share on other sites

Oh, that's wonderful :)

Does it have a native support? or you need to use fakeCPUID?

 

Native support on High Sierra.

Also my patches and kexts are a fraction of what they used to be on the X99.

Add to that my oob Vega and I'm looking around for an old Mac Pro case to put it in! haha

Share this post


Link to post
Share on other sites

Native support on High Sierra.

Also my patches and kexts are a fraction of what they used to be on the X99.

Add to that my oob Vega and I'm looking around for an old Mac Pro case to put it in! haha

Thanks for the update! I didn't know that it has native support in High Sierra :)

 

X299 should look gorgeous in a MacPro Case ;) I'm looking forward to see your build once it's completed! 

Share this post


Link to post
Share on other sites

Seems the same as mine... Enlarged the bytes, try it:

 

48 85 C0 74 07 80 8B -> 48 85 C0 90 90 80 8B

 

Is your P43 ICH10 chipset ID 0x3a228086 ?

Yes

 

Sent from my HTC One M9 using Tapatalk

Share this post


Link to post
Share on other sites

Yes

 

Sent from my HTC One M9 using Tapatalk

This is a simple trick which originally by @RehabMan for his HackrFamily, I'm not sure whether this will work as well, but anyway I think it's worth trying.

 

Firstly set FakeID for SATA in config.plist to 0xabcd8086. It looks like this:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>Devices</key>
	<dict>
		<key>FakeID</key>
		<dict>
			<key>SATA</key>
			<string>0xabcd8086</string>
		</dict>
	</dict>
</dict>
</plist>

And then put this dummy kext into Clover/kexts/Other or 10.13 folder. Delete the patched one from /S/L/E (Restore to vanilla one, in case you don't have it, will post the original one below)

 

Dummy kext: (not working, removed)

 

 

Original v329 kext from DP5:

orig_AppleAHCIPort_v329.kext.zip

 

Please test, if you can normally boot then, thanks.

Share this post


Link to post
Share on other sites

Seems the same as mine... Enlarged the bytes, try it:

 

48 85 C0 74 07 80 8B -> 48 85 C0 90 90 80 8B

Is your P43 ICH10 chipset ID 0x3a228086 ?

 

Nope, does not work either....

 

I am doing o.k. when using it as a KextToPatch entry, right?

 

Name*: IONVMeFamily     Find*[HEX]: 4885c074 07808b    Replace*[HEX]: 4885c090 90808b  Comment: External NVMe Icon Patch   MatchOS: 10.13.x

 

old entry below worked including DP4:

 

Name*: IONVMeFamily     Find*[HEX]: 4885c074 07808b20    Replace*[HEX]: 4885c066 90808b20  Comment: External NVMe Icon Patch   MatchOS: 10.13.x

Share this post


Link to post
Share on other sites

Native support on High Sierra.

Also my patches and kexts are a fraction of what they used to be on the X99.

Add to that my oob Vega and I'm looking around for an old Mac Pro case to put it in! haha

So should I edit my previous post about SkyLake X not having the native support in Sierra? or my assumption is correct?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By poisson-myfish
      So I have some less powerful hardware, that's why I'm installing High Sierra in 2020. Anyway, I'm trying to boot from the USB and I get the following errors:
      00:000 00:000 OCB: Missing DMG signature, aborting 00:585 00:585 OCB: LoadImage failed - Unsupported That's it. The logs begin and end there. The rest of the file is zeroes.
       
      Bootloader: OpenCore 0.5.9 Release
      Drivers:
      HfsPlus.efi
      OpenRuntime.efi
       
      Kexts:
      AppleALC.kext
      Lilu.kext
      RealtekRTL8111.kext
      SMCBatteryManager.kext
      SMCLightSensor.kext
      SMCProcessor.kext
      SMCSuperIO.kext
      VirtualSMC.kext
      WhateverGreen.kext
       
      ACPI:
      SSDT-EC.aml
      SSDT-HPET.aml
      SSDT-PLUG.aml
      Note: I used SSDTTime to make the DSDT dumps for this exact computer
       
      Hardware:
      Intel Core i3 (Haswell)
      An Intel VGA-Compatible Haswell iGPU
      An nVidia Geforce 920m GPU (part of the reason for installing High Sierra)
      USB: Intel 8 Series USB xHCI HC
      SATA: Intel 8 series SATA Controller
       
      If you need more details, here's my laptop https://www.asus.com/Laptops/X540LJ/ . I have the 512GB version with 4GB of RAM
       
      I found a lot of forum posts about people having the same error, except nothing solved mine. Also, I haven't found anything online about the error with the Missing DMG Signature.
       
      EDIT: If anybody needs my config.plist, feel free to ask for it and I'll happily post it
    • By PropoFlexWX4
      After hearing that OpenCore is so much better than Clover, and that it will probably be able to boot Big Sur before Clover does, I decided to take the jump.
       
      Running Catalina 10.15.5 18F101 with OC 0.5.9.
       
      So far I like the result. The OS feels faster, boots faster.
      And absolutely everything works (sleep, network, etc...)
       
      So, that's it? Is there anything else I have to do?
    • By fantomas
      macOS Big Sur beta (20A4299v)
    • By gengik84
      First beta is coming... and as always...
       

       
       
      Useful information:
      macOSDeveloperBetaAccessUtility.dmg.zip
×