Jump to content
Cyberdevs

[Guide] Install macOS Sierra 10.12.5 on GA-Z170X-Gaming 5

519 posts in this topic

Recommended Posts

So, for a couple of days i have this issuue now with the App Store. I can't download updates. It says my device or computer could not be verified. My PW is working. Anybody know what the problem is?

Bildschirmfoto 2018-05-01 um 09.18.22.jpg

Share this post


Link to post
Share on other sites
Advertisement

I figured it out myself: Deleting Library > Preferences > SystemConfiguration > Networkinterefaces.plist and rebooting resolved the issue. 

Share this post


Link to post
Share on other sites

In step 2, it says

" You can easily replace the whole “Clover” folder inside the “EFI” folder on the EFI partition of your bootable disk (hard disk drive or USB flash drive) with the folder included with this guide"

 

Where is the folder that's supposed to be included?

Share this post


Link to post
Share on other sites
6 hours ago, cyclepathology said:

In step 2, it says

" You can easily replace the whole “Clover” folder inside the “EFI” folder on the EFI partition of your bootable disk (hard disk drive or USB flash drive) with the folder included with this guide"

 

Where is the folder that's supposed to be included?

On the bottom of the first post there are several attachments and first two links are the ones that you are looking for.

Share this post


Link to post
Share on other sites
9 minutes ago, Cyberdevs said:

On the bottom of the first post there are several attachments and first two links are the ones that you are looking for. 

The bottom of the first post looks like this:

image.thumb.png.7908d34360211ec5803a8524863bec88.png

 

and those first two links are not the clover folder.

Share this post


Link to post
Share on other sites

The links which start with GA-Z170X-Gaming 5 are the ones that the guide is referring to, these links include the EFI folder that I was referring to.

GA-Z170X-Gaming 5 Release 01 DSDT and SSDT nVidia Version.zip

GA-Z170X-Gaming 5 Release 01 DSDT and SSDT IntelHD 530 Version.zip

Share this post


Link to post
Share on other sites

Just a quick note: most of these kexts in this zip are outdated and might only work with the initial release of Sierra (10.12.0). Especially NvidiaGraphicsFixup.kext does no longer work from 10.12.5(?) on forward for Nvidia Cards. It since then has been replaced by shiki.kext. You need that if you use an Nvidia Card otherwise you get no picture.

 

If all kets work as supposed depends on what Build of Sierra is actually provided in the App Store download. If it's the latest build (10.12.6), you need to use updated versions of Lilu and Shiki at least to make it work. I might be wrong but that has been my experience so far.

Share this post


Link to post
Share on other sites
1 hour ago, 5T33Z0 said:

Just a quick note: most of these kexts in this zip are outdated and might only work with the initial release of Sierra (10.12.0). Especially NvidiaGraphicsFixup.kext does no longer work from 10.12.5(?) on forward for Nvidia Cards. It since then has been replaced by shiki.kext. You need that if you use an Nvidia Card otherwise you get no picture.

 

If all kets work as supposed depends on what Build of Sierra is actually provided in the App Store download. If it's the latest build (10.12.6), you need to use updated versions of Lilu and Shiki at least to make it work. I might be wrong but that has been my experience so far.

Thanks for you note. Actually I was thinking the same thing about updating the EFI folders for macOS Sierra and High Sierra bu since the upload function is broken in the web site I might need to use a third party site to upload the files to untill the site is fixed.

I’ll keep you all posted.

 

Cheers  

Share this post


Link to post
Share on other sites

Here is the latest files for macOS Sierra and High Sierra

Please let me know if you have any problem with these folders.

 

GA-Z170X-Gaming 5 DSDT and SSDT for AMD - Clover r4459

GA-Z170X-Gaming 5 DSDT and SSDT for nVidia - Clover r4459

GA-Z170X-Gaming 5 DSDT and SSDT for IntelHD 530 - Clover r4459

 

 

Edited by Cyberdevs

Share this post


Link to post
Share on other sites
9 hours ago, cyclepathology said:

and those first two links are not the clover folder.

What do you mean they are not the Clover folder?

Share this post


Link to post
Share on other sites
4 hours ago, Cyberdevs said:

Here is the latest files for macOS Sierra and High Sierra

Please let me know if you have any problem with these folders.

 

GA-Z170X-Gaming 5 DSDT and SSDT for AMD - Clover r4459

GA-Z170X-Gaming 5 DSDT and SSDT for nVidia - Clover r4459

GA-Z170X-Gaming 5 DSDT and SSDT for IntelHD 530 - Clover r4559

 

 

 

If using the new APFS file system users will also need the correct file for that. Currently that file  appears to need updating with point releases but does anyone know if the newer ones are backward compatible?

Share this post


Link to post
Share on other sites
28 minutes ago, f00b4r said:

 

If using the new APFS file system users will also need the correct file for that. Currently that file  appears to need updating with point releases but does anyone know if the newer ones are backward compatible?

As far as I know the APFS files are backward compatible and they will get improved with each release. Since it isn't included in the official clover installers because they are part of the macOS updates or the full installers it's better to update it in the EFI folder with each major update.

I didn't include the APFS.efi in the EFI folders because of the copyright reasons, so if anyone needs to use it it's better to extract it from the macOS installer itself.

Edited by Cyberdevs

Share this post


Link to post
Share on other sites

@SavageAUS

Hey buddy I decided to continue our conversation here.

 

The old DSDT for Sierra has several ACPI errors on boot in macOS High Sierra so I decided to go DSDT free. Everything has been working OK os so far with the exception of my boot time on the NVME drive. On SSD it loads way faster and I guess the reason might be that the NVME has Trim support enable by default and I think you're right we need to ask @MaLd0n to doo his magic on a new DSDT for the latest BIOS update and new settings.

 

I made some changes in my rig which won't matter that much because the only major change is that I just added a NVME drive for booting to macOS and I changed the case for better cooling and add some extra fans.

I switched to AMD RX580 and all the headaches from the nVidia web drivers and lags (which I know is resolved now) are gone.

Share this post


Link to post
Share on other sites
[mention=1083558]SavageAUS[/mention]

Hey buddy I decided to continue our conversation here.

 

The old DSDT for Sierra has several ACPI errors on boot in macOS High Sierra so I decided to go DSDT free. Everything has been working OK os so far with the exception of my boot time on the NVME drive. On SSD it loads way faster and I guess the reason might be that the NVME has Trim support enable by default and I think you're right we need to ask [mention=557433]MaLd0n[/mention] to doo his magic on a new DSDT for the latest BIOS update and new settings.

 

I made some changes in my rig which won't matter that much because the only major change is that I just added a NVME drive for booting to macOS and I changed the case for better cooling and add some extra fans.

I switched to AMD RX580 and all the headaches from the nVidia web drivers and lags (which I know is resolved now) are gone.

I'm on bios F22f as that's the latest as of now. I've been hoping and waiting for a new bios but I guess (as long as [mention=1376005]MaLdOn[/mention] can work his magic) we can use F22f as the base for the next DSDT for the gaming 5. Just waiting for input from MaLdOn.

 

Sent from my SM-G930F using Tapatalk

 

 

 

Share this post


Link to post
Share on other sites

Yeah I'm use the same BIOS version.

But I think there should be another BIOS release soon to address the new Spectre/Meltdown bugs 

Share this post


Link to post
Share on other sites

Isn't that what F22f did? With the update to cpu microcode?

F22c was also Update Intel ME for security vulnerabilities

Edited by SavageAUS

Share this post


Link to post
Share on other sites
2 hours ago, Cyberdevs said:

@SavageAUS

Hey buddy I decided to continue our conversation here.

 

The old DSDT for Sierra has several ACPI errors on boot in macOS High Sierra so I decided to go DSDT free. Everything has been working OK os so far with the exception of my boot time on the NVME drive. On SSD it loads way faster and I guess the reason might be that the NVME has Trim support enable by default and I think you're right we need to ask @MaLd0n to doo his magic on a new DSDT for the latest BIOS update and new settings.

 

I made some changes in my rig which won't matter that much because the only major change is that I just added a NVME drive for booting to macOS and I changed the case for better cooling and add some extra fans.

I switched to AMD RX580 and all the headaches from the nVidia web drivers and lags (which I know is resolved now) are gone.

Hey

send me files

run app

RunMe.app

have some news xD

Share this post


Link to post
Share on other sites
17 minutes ago, SavageAUS said:

See previous post.

update bios to last version and extract untouched tables, i'll patch last version

Share this post


Link to post
Share on other sites
1 hour ago, MaLd0n said:

Hey

send me files

run app

RunMe.app

have some news xD

Here is my folder. I'm on the latest BIOS F22f.

https://www.dropbox.com/s/cyzet79h2rp634c/Send me Cyberdevs-iMac.zip?dl=0

 

Thanks a lot for you time and Magic Touch Bro :)

Edited by Cyberdevs

Share this post


Link to post
Share on other sites
28 minutes ago, Cyberdevs said:

Here is my folder. I'm on the latest BIOS F22f and here is my folder,

https://www.dropbox.com/s/cyzet79h2rp634c/Send me Cyberdevs-iMac.zip?dl=0

 

Thanks a lot for you time and Magic Touch Bro :)

check if work

CLOVER.zip

need a serials

replace full clover folder, reboot and send me new SEND_ME , i need check if error in log is gone, have some about usb

Nvidia or AMD, i put two injectors

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By tluck
      Lenovo T460 macOS with Clover Guide
      Latest Release on GitHub (February 2020) Updated to Clover r5104 Updated Lilu based kexts - Lilu, ALC, WEG Updated acidanthera VoodooPS2 kext v2.1.1 the older 1.9 to the Misc Folder as an option.
        Various Tweaks over Last months The zip file is a complete Clover ESP (/EFI) bundle and kext pack for the Lenovo T460. The current file bundle is tested on Sierra. 
      Note: I never got the GFX fully working on El Capitan. 
      Full Clover file set - config.plist etc. Includes all custom kexts Includes custom DSDT/SSDT scripts and patches Utility scripts The zip bundles are posted to GitHub: https://github.com/tluck/Lenovo-T460-Clover/releases
      Caveat: The T460 systems used here was configured with: i5-6300U, Intel HD Graphics 520, 1920x1080 touch screen. If you have a different system model, then extract the ACPI files and use the included scripts to create a set of files consistent with your system type and BIOS version. See below for details.
      Credits: RehabMan, Shmilee, vusun123, TimeWalker, Mieze from which, much of their work and help is/was was used to get the T460 to this point.
      Devices and aspects working:
      Ethernet -  Intel I219LM is enabled via IntelMausiEthernext.kext WiFi/BT - substitute the Intel WiFi/BT with a compatible Broadcom or Atheros chip Audio - ALC293 codec implemented via AppleALC.kext (the old AppleHDA_ALC293 and CodecCommander kexts are not needed) PS2 - ClickPad + TrackPoint + all 3 buttons - using a modified VoodooPS2Controller to support new layouts - and added some custom Fn key maps based on 440/450 dsdt USB - implemented via custom SSDT + USBInjectAll kext. All USB3/USB2 ports are intel-based and work -  3 external USB and internal Camera, BT, etc  Sleep/Wake - the sleepwatcher package and custom sleep/wake scripts are used to help with sleep/wake for BT and PS2 devices. Note: have not tried to implement the SD card reader - no driver found.
      ACPI Files
      New Installation - Steps and Details
      Part 1 - OS Installation
      Part 2- Post OS Installation and Setup
      Notes on Custom Kexts
       
    • By gengstapo
      @Hervé
       
      Im having similar issue with my HS setup, dell latitute 3480, i5-7200U
      Once the hdmi plugged in, the laptop display went blank, only could see the external tv
      But, when i put my laptop to sleep & wake up again, both screen got display (hdmi still connected)
      Even the hdmi could be plugged off & in (after sleep), the laptop display is fine
       
      What could be the culprit?
      Dell’s MacBook Pro IORegistry.zip
      config.plist.zip
    • By TomZanna
      Hi, I'm trying to install Mac Os Catalina on a HP 550-132NL.
      The system has:
      i7-6700
      RAM 12 GB
      GT 730
      LAN Realtek RTL8161
      ALC3863
       
      It passes the verbose phase but after the Apple logo goes away, it gets stuck on a grey screen and I can only move the pointer.
      Can I try to boot with the iGPU?
       
      origin.zip
      CLOVER_dGPU_USB_3.zip
    • By kushwavez
      A really good motherboard with macOS compatible bult-in Wifi & Bluetooth

      ASUS Z170-Deluxe (with Wifi)
      BIOS: v3801
      CPU: i7-6700K 4.0 to 4.2 GHz (w/o OC)
      RAM: 1x 16 GB Corsair DDR4 2400 MHz
      GPU: Intel HD 530 (Headless) & ASUS Radeon RX 5700 OC 8 GB
      Audio: ALC 1150
      Ethernet: I219V2, I211-AT
      WiFi & Bluetooth: Broadcom BCM94360HMB Half-Mini-PCI-E
      More Specs: https://www.asus.com/Motherboards/Z170-DELUXE/specifications/
       
      Catalina 10.15.3 - Windows 10
      What is working:
      BCM94360HMB Wifi and Bluetooth AirDrop, Handoff, FaceTime, Messages, App Store, iCloud, etc. Intel HD 530 (QE/CI tested, but now I'm using it in headless) Sleep RX 5700 (QE/CI with 2 1080p monitors connected) Sound USB Ports Two Ethernet ports macOS with a light OC (4.12 GHz - 4.5 Ghz, XMP, ASUS optimal) No problem so far ASUS HyperKit with a KINGSTON NVMe SSD - 250 GB  
      What is not working:
      -  
       
      Not tested:
      VideoProc says that Hardware Decoding\Encoding is fully supported and enabled on both HD 530 and RX 5700 but I didn't test it Thunderbolt (no equipment)  
      Issues:
      None  
      BIOS Settings:
      Boot\CSM (Compatibility Support Module): Launch CSM: Disabled Boot\Secure Boot: OS type: Other OS Secure Boot State: Disabled Advanced\System agent (sa) Configuration: VT-d: Enabled Graphics Configuration: Primary Display: Auto iGPU Multi-monitor: Enabled RC6(Render Standby): Enabled DVMT Pre-Allocated: 128M Advanced\PCH Storage Configuration: SATA Mode Selection: AHCI HyperKit: Enable (if you have NVMe SSD with ASUS HyperKit) Advanced\CPU Configuration: Intel Virtualization Technology: Enabled CPU- Power Management Control: Intel SpeedStep: Enabled CPU- C-States: Enabled Intel SpeedShift: Enabled  
      Getting ready for installation:
      Download the bootpack (Clover v5098): Click here -> ASUS-Z170_catalina.zip  
      Installation:
      Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager) Copy my Clover folder to the USB's EFI folder Boot with the Installer USB If you have any problem (kp or freeze) boot with config_debug.plist to see what causes the issue  
      Post Installation:
      Download Clover Configurator and generate a new Serial Number for yourself  
      Some pictures:
       

       




       
       
       
      Catalina & Windows 10 Dual-Boot (clean install, on one drive):
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac)
       Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart
      Boot into your Win installer, Format the partition you created for Win, install. 
      Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type: 
      bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi  
      You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)  
      Mounting EFI from Windows:
      Open cmd in administrator mode and type: mountvol b: /s (This will mount your EFI) Open Total Commander or Explorer++ in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI)  
      Notes:
       
      2020.02.11: Updated to 10.15.3 -> No problem when/after installing
      2020.01.19: Added ASUS HyperKit NVMe SSD to the "What is working" list
      2020.01.12: Tested system with OC, added more informations to BIOS settings
      2020.01.11: Added SmallTreeIntel82576.kext for 2nd Ethernet, Tested Ethernet ports
      2020.01.11: First upload
       
    • By Andres ZeroCross
      First i will give you information about my specification
       
      Processor : Intel Core i7 6700
      Motherboard : Gigabyte GA-Z170-HD3
      RAM : Team DDR4 8GB (2X4GB) 2133Mhz - up to 3000Mhz at XMP Profile
      Graphics Card : Palit Jetstream GTX960 4GB DDR5
      SSD and HDD : Fujitsu F200 for System + 500GB Seagate connect with add on PCI-e to Sata 3 Asmedia ASM1062 Chipset
      Other harddrive : 1 Natno SSD, 2x 2TB Seagate, 2x 500GB Seagate connect with internal SATA Controller Interface
      Wifi Card : TP-Link TL-WDN4800
      Monitor : 2x Asus VN248H (HDMI and Display Port with Converter)
      I need 2 new hardware to support this
      a. PCIe to Sata with 2 Ports Sata (because i use 2 important storage)
      b. PCI to USB 2.0 with NEC Chipset (i Plug USB Keyboard, Mouse and USB Installer here)
       
      My steps :
      1. Make USB installer El Capitan 10.11 Public Release with CreateinstallMedia method
      2. Install Clover Rev 3280 into it
      3. Basic configuration for BIOS (Disable serial port at IO section in bios, Boot with UEFI Mode,  Primary Graphics set to PCI-E, Sata Controller = AHCI, CSM Support = Disable, OS Mode = Windows 8/10 WHQL)
      4. My Masic Configuration for Config.plist (open with Clover Configurator Version 4.24)
          ACPI = tick FixHpet, AddDTGP, FixHDA, New Way, Delete Unused, AddHDMI, Drop OEM_DSM of HDA and SATA.
          Bootflag = nv_disable=1 -v dart=0
          Devices = USB Inject, Add Clock ID, Fix OwnerShip, Audio Layout = 2, Reset HDA
          Graphics = There is no change here
          Kernel and Kext Patches = FakeCPUIID 0x00306F2 and tick KernelHasswellE (Please anybody,, i dont want use this. Latest El Capitan 10.11.1 Beta is supported native to this processor right. Help me with kernel so i don't need to use fakeCpuIID again) I I use Clover R3292 and i don't need to use FakeCPUID again,, just tick Kernel Haswell-E and it will boot. So you need to use Clover R3292 and later
          Rt Variables = BooterConfig 0x28 and CsrActiveConfig 0x067
          SMBios = First i use SMBios MacPro 6.1 but later i just need to use iMac17,1 because My System build is identical with iMac17,1 hardware (SkyLake System)
          System Parameters = Inject Kexts Detect and Tick Inject System ID
      5. Boot from Your USB Installer and do everything like normal until you get into desktop
      6. Install Kext Utility,  
      7. Copy "AppleGraphicsControl.kext" from "System/Library/Extensions" to Desktop and then edit info.plist at "AppleGraphicsControl.kext/Contents/Plugins/AppleGraphicsDevicePolicy.kext/Contents/info.plist" and look at OKitPersonalities->AppleGraphicsDevicePolicy->ConfigMap and change "Mac-F60DEB81FF30ACF6 - Config1" to "Mac-F60DEB81FF30ACF6 - None". Reinstall this kext with Kext Utility.
       
      Note : the reason you need to "Config1" of "Mac-F60DEB81FF30ACF6" because it's BOARD-ID for MacPro6,1. so if you use SMBios of iMac17,1 then Check your Board-Id (you can use Clover Configurator and open your config.plist and see your Board-id at SMBios Section) and change "Config2/Config1" to "none". Now i use "Mac-DB15BD556843C820" as my Board-ID because i use iMac17,1 SMBios  so i need to change ConfigMap that related to it 
       
      8. Install Nvidia Web Driver version 346.03.02f02, and restart.
      9. Change bootflag "nv_disable=1" to "nvda_drv=1"
      10. After you get into desktop, get Latest Beta Build 10.11.1 Seed. You need to change seed catalog update first (google it).
      11. Do update to 10.11.1 Build 15B38b and restart
      12. Boot again with bootflag "nv_disable=1", and copy "NVDAStartupWeb.kext" from "System/Library/Extensions" to desktop. And open info.plist at "NVDAStartupWeb.kext/Contents/Info.plist". Look at "IOKitPersonalities->NVDAStartup" and change "NVDARequiredOS - 15A284" to "NVDARequiredOS - 15B". Save,, and reinstall this kext with Kext Utility
      13. IMPORTANT, if you use SMBIOS MacPro 6.1 or iMac 15.1 and some type (I forgot) then do "7Th Step" above again.
      14. Restart and reuse "nvda_drv=1"
      15. Now you have El Capitan 10.11.1 at your SKYLAKE Computer
       
      Problem
      1. Internal Sata is still not function, it show "Intel 10 Series Chipset" but "unknown" for Harddrive Solved by Mod Bios to disable IOAPIC 24-119 Entries or Patch Apple APIC
      2. USB 3.0 is not function too, but it shot at USB System Report Solved by Mod Bios to disable IOAPIC 24-119 Entries or Patch Apple APIC
      3. When you open Browser Applications, Movies or Something like that then it will freeze for 10 seconds. I check console and i found "NVDA(Graphics): Channel exception! Exception type = 0x8 DMA Engine Error (FIFO Error 8)" Solved by Mod Bios to disable IOAPIC 24-119 Entries or Patch Apple APIC
      4. Address of Sound HDEF is different with my DSDT. Normally it should be "0x001B0000" but at my board's DSDT is "0x001F0003". So ScriptCommand of Toleda for ALC is not work anymore, we need to change that script command from HDEF-B to HDEF-F (just look at the script)
      5. We need to change Device HDAS to HDEF at address "0x00fF0003", but something weird after 5times my system freeze and i look at Audio System Report it suddenly show all of AUDIO Interface , before not. Solved by Mod Bios to disable IOAPIC 24-119 Entries or Patch Apple APIC
      6. I look at my Graphics/Displays Sytem report and at PCIe Lane Width, it show "x4" or "x8". Damn,, it should be "x16". It will random change after freeze from "x4" or "x8" My bad, i just need to plug out and plug in again. Just assembly case
       
       
       
      Maybe Rehabman, Slice and Pike R. Alpha want to help me
       
      Well,,
      i attach my file (Darwin Dumper File) <<<<< Before Patched, and
      i attach my DSDT + SSDT + Config.plist <<<<< After Patched and working well
       
       
       
      Before Patch
       
      Before Mod Bios / Patch 1
       
       
       
      Before Mod Bios / Patch 2
       
       
      Before Mod Bios / Patch 3

       
      Before Mod Bios / Patch 4
       
      =================================================================================================
      AFTER PATCH
       
      After Mod Bios / Patch 1
       
       
       
      After Mod Bios / Patch 2
       
       
       
       
      After Mod Bios / Patch 3
       
       
       
      After Mod Bios / Patch 4
       
       
      After Mod Bios / Patch 5
       
       
      After Mod Bios / Patch 6
       
       
      After Mod Bios / Patch 7
       
       
       
×