Jump to content
InsanelyMac Forum
  1. Cyberdevs


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By tluck
      Lenovo T460 macOS with Clover Guide
      Release v2018.05.17 on GitHub Updated to Clover r4458 Updated Lilu.kext - supports both Sierra and High Sierra Updated AppleALC.kext - supports both Sierra and High Sierra + added back DVMT patch for 10.13.2+ Updated VoodooPS2Controller.kext (RehabMan version) + SSDT updates for T460 Added Frank's T470p DSDT files
        Various Tweaks over Last months The zip file is a complete Clover ESP (/EFI) bundle and kext pack for the Lenovo T460. The current file bundle is tested on Sierra. 
      Note: I never got the GFX fully working on El Capitan. 
      Full Clover file set - config.plist etc. Includes all custom kexts Includes custom DSDT/SSDT scripts and patches Utility scripts The zip bundles are posted to GitHub: https://github.com/tluck/Lenovo-T460-Clover/releases
      Caveat: The T460 systems used here was configured with: i5-6300U, Intel HD Graphics 520, 1920x1080 touch screen. If you have a different system model, then extract the ACPI files and use the included scripts to create a set of files consistent with your system type and BIOS version. See below for details.
      Credits: RehabMan, Shmilee, vusun123, TimeWalker, Mieze from which, much of their work and help is/was was used to get the T460 to this point.
      Devices and aspects working:
      Ethernet -  Intel I219LM is enabled via IntelMausiEthernext.kext WiFi/BT - substitute the Intel WiFi/BT with a compatible Broadcom or Atheros chip Audio - ALC293 codec implemented via AppleALC.kext (old AppleHDA_ALC293 and CodecCommander kexts are not needed) PS2 - ClickPad + TrackPoint + all 3 buttons - using a modified VoodooPS2Controller to support new layouts - and added some custom Fn key maps based on 440/450 dsdt USB - implemented via custom SSDT + USBInjectAll kext. All USB3/USB2 ports are intel-based and work -  3 external USB and internal Camera, BT, etc  Sleep/Wake - the sleepwatcher package and custom sleep/wake scripts are used to help with sleep/wake for BT and PS2 devices. Note: have not tried to implement the SD card reader - no driver found.
      ACPI Files
      New Installation - Steps and Details
      Part 1 - OS Installation
      Part 2- Post OS Installation and Setup
      Notes on Custom Kexts
    • By zeg66
      Trying to install Mavericks on an Asus H170M-E D3 motherboard, Skylake I3-6100 cpu, Intel 530 graphics.
      Last message I see is "root device uud is" and a series of "+++" but then it just stops.
      Have prepared usb with createinstallmedia, added Clover 4413 and changed a few settings with Configurator.
      Any help is welcome.
    • By Cyberdevs
      First of all I want to thank all the people in advance who helped make this happen all the credit goes to them, I just gathered what I’ve learned from them.
      Pike R Alpha, RehabMan, Majonéz, Yassinex, Toledo, Todeleda, TheRacerMaster, OiCKilL, Andres ZeroCross, bomerr and many other great minds who helped me out. If any name/s is/are left out please let me know so I put it/them right here.
      These are my specs:
      Gigabyte Z170X-Gaming 5
      Intel Skylake 6700K @ 4.0 GHz up to 4.2 GHz
      4x8 GB 2666 DDR4 GSKILL RIPJAWS Memory Modules
      Kingston HyperX Savage 240 GB 6Gbps SSD
      AMD Radeon HD7790 1 GB GDDR5
      TP-Link WDN-4800
      CoolerMaster Nepton 120XL Cooling Unit
      CoolerMaster V750-Gold Power Supply Unit
      CoolderMaster Silencio 452 MidTower Case
      BIOS Settings:
      In BIOS from M.I.T. choose Advanced Memory Settings
           I. From Extreme Memory Profile(X.M.P.) I Choose [Profile1] it's crucial to choose this option if you want your memory modules work with their full frequency.
           II. Enter the correct System Memory Multiplier which in my case based on my 2666MHz DDR4 it must be 26.6.
           III. Select [Enhanced Performance] from Memory Enhancement Settings. You can choose any of the options I chose Enhanced Performance.
           IV. From BIOS Features Fast Boot is disabled, Windows 8/10 Features is set to Windows 8/10 WHQL, LAN PXE Boot Option is disabled, CMS Support is Enabled, Storage Boot Option Control is UEFI Only, Other PCI Device RPM Priority is UEFI Only and Network Stack is Disabled and Secure Boot State is Disabled.
           V. From Peripherals: VT-d is disabled, Internal Graphics is set to Auto, Audio Controller is Enabled, Audio DSP is Disabled, PCH LAN Controller,SATA Configuration is set to AHCI, Wake on LAN and High Precision Timer are Enabled. I didn’t patch my BIOS because of a great job that Pike R Alpha did with a kext based patch for Skylake processors and to patch the AppleACPI.kext.
      Under Super IO Configuration Serial Port must be disabled as well.
      UPDATE: I recently updated my BIOS to f5h and IOAPCIEntries 24-119 Entries is there so if you are using that version of the BIOS or anything prior to original f4 you don't need to use the ACPI patch.
           VI. Save your new settings and reboot.
      Here is a copy of my EFI folder which works great with this configurations, Just remember I didn’t inject any Graphic Adapters so you have to configure it with yourself based on the graphic adapter you are using.
      Activating Audio:
      Download and install VoodooHDA 2.8.8.V3
      Use clover configurator to edit your config.plist
      ACPI: "Add the following DSDT Patch"
      Comment: Rename HDAS to HDEF
      Find* [HEX] :48444153
      Replace [HEX] :48444546
      Set the following flags under Boot section:
      kext-dev-mode=1 and rootless=0
      The audio won't work by default, you need to install Toledo's audio driver or install VoodooHDA.
      Toledo's commands are available at: https://github.com/t...audio_CloverALC
      VoodooHDA is available at: http://sourceforge.n...ects/voodoohda/
      I personally use VoodooHDA instead of Toledo's script because for some unknown reason with Toledo's audio kexts and script while I was playing musics after a few minutes I could hear a noise which was getting worse so I tried VoodooHDA and now it work perfectly fine.
      My audio layout is set to 1.
      FYI: If you are going to use VoodooHDA just remember after you installed the VoodooHDA there will be a file in your application folder called "VoodooHdaSettingsLoader" which you need to place it in your login items in system preferences under "Users and groups" ---> "login Items" and adjust the "input Gain" under "VoodooHDA" in system preferences to avoid the hissing sound every time the OS starts. and if you don't every time you restart the system you'll need to adjust your audio settings. By loading this application OS will remember you settings and load them.
      USB 3.0
      Under ACPI add this DSDT Patch:
      Comment: change _OSI to XOSI
      Find* [HEX] : 5F4F5349
      Replace [HEX] : 584F5349
      Comment: Change EHC1 to EH01
      Find* [HEX] : 45484331
      Replace [HEX] : 45483031
      Comment: Change EHC2 to EH02
      Find* [HEX] : 45484332
      Replace [HEX] : 45483032
      Under Kernel and Kext Patches add the following to “KextsToPatch”:
      Name*: AppleUSBXHCIPCI
      Find* [HEX] : 83BD8CFEFFFF10
      Replace [HEX] : 83BD8CFEFFFF15
      Comment: Raise USB Port Limit
      You also need to add RehabMan’s “USBInjectAll.kext” to the following path under EFI\Clover\kexts\10.11\
      which is available for download at RehabMan’s site.
      I Use an AMD RadeonHD 7790 Graphic Adapter with these settings:
      Under Graphics:
      Dual Link is set to 1, FB Name is set to Baladi, VRAM is set to 1024, Video Ports is se to 4, Load VBIOS is checked and finally Inject ATI is checked too.
      Under Kernel and Kext Patches:
      ATI Connectors Data is set to:
      ATI Connectors Patch is set to:
      and finally Ati Connectors Controller is set to 8000