Jump to content
MaLd0n

[Guide] Sierra / High Sierra on GA H97M-DS3P / DSDT

9 posts in this topic

Recommended Posts

Now have a Olarila app, just download app and clover folder for your Chipset!
 
mobo.png
 
First...
If you need DSDT edits...
-Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen)
-Run it, post files generated in your desktop
gathering.gif
Installation
 
--Create a bootable copy of macOS Sierra
Check out the link
 
--Create a bootable copy of macOS HighSierra
Check out the link
 
--Install Clover in USB stick
 
--Replace with my Clover folder 
 
--Install Sierra/High Sierra and boot into system!
 
Post Installation
 
--Install Clover in HDD/SSD and replace with my folder
 
--Reboot and activate video!
 
-Nvidia WebDriver Sierra
-Nvidia WebDriver High Sierra
-Cuda
 
-DSDT
My DSDT
 
-Patches
-FIX ERRORS AND WARNINGS
-HPET
-SATA
-DMAC
-SLPB
-DARWIN
-LPC
-XHCI
-HDEF
-RTC
-IRQs
-SBUS
-MIKEY
-BUS1
-MCHC
-ALS0
-SHUTDOWN
-LAN
-EC
-PNLF
-HDMI

01.png

02.png

03.png

04.png

05.png

06.png

-FakeSMC

-Audio
-LAN
 
-Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
 
Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!
 
We're all here to have fun and learn from each other!
 
ENJOY!

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By BrianWong11031
      Hi,
      Please help me to enable and use hd 3000 with Mojave.
      I know that I can install some .bundle or .kext files to make it can be enable.
      But it always show an err msg up. "IOConsoleUsers gIOScreenLockState 3 ......"
      I have tried to reinstall the refi drivers and kexts.
      but still not solved this issue.
      I will upload my EFI partition as a zip file below (Google Drive, Because It's bigger than 10 mb).
      Thanks for helping.
      For the details about my hardwares, please see my "About Me" page->Brian's Budget Hackintosh.
      https://drive.google.com/file/d/1E2aFpweYwKzcJj98zRroWSwFLVf5gz62/view?usp=sharing
      Cheers,
      Brian
    • By rdall96
      Hello everyone!
       
      I am fairly new to the world of Hackintosh. I recently moved my previous build into a smaller form factor. However, I am running into a series of problems with the USB ports on the new case and the new motherboard.
       
      Part List:
      - i7-7700k
      - Gigabyte Z270N Gaming 5
      - 16GB Trident Z RGB 3200 MHz
      - Sapphire RX 470
      - NZXT Kraken x62
      - NZXT H200 for the case
       
      Everything in the Hackintosh works just like it did before, nothing changed in the hardware department other than the motherboard (previously a gigabyte Z20X Ultra) and the case.
      This motherboard does not have any USB 2.0 ports in the back, there is only one header on the board, currently taken by the Kraken x62. The rest of the ports are all either USB 3.1 Gen1 or USB 3.1 Gen2, and the front of the case has 3.1 Gen1 ports as well.
       
      This is my current problem:
      When I plug something into either the type A or type C Gen2 ports, it works fine as a normal USB 3.x device with normal speeds, but when I plug something into any other USB port, it only works at lower 2.0 speeds. This is a big problem for me, since I have a few external devices that need the 3.0+ speeds and I don't know what to do.
      I tried to follow many different guides on how to patch USB ports, remove the limits, etc... But nothing seems to work.
       
      Please someone help me!
    • By BrianWong11031
      Hi, my hackintosh won't sleep!
      It often sleeps for 3-5 seconds and auto wakes up.
      sometimes it can't enter the sleep mode even you click the sleep button.
      I have uploaded my DSDT file.
      but I don't know how to patch DSDT.
      If you know how to solve this issue, please help me!
       
      Cheers,
      Brian
      DSDT.aml
    • By angelo_ios
      EDIT: MacOS Mojave 10.14 ONLY I didn’t test 10.14.1! The EFI folder is compatible with High Sierra.
       
      Guide to installing 10.14 Mojave on a ASUS X555L
       
      What Works:
      -WiFi
      -Sound
      -Graphics (Intel)
       
      What doesn't Work:
      -Bluetooth
      -NVidia Web Drivers
      -Battery Indicator
       
      Used Kexts:
      Picture
       
      Clover setup:
      Clover plist is downloadable in this topic.
       
      Let's start
       
      Step one:
      First get a USB with 8+ GB of storage and a MacOS Mojave 10.14 installer from the AppStore.
       
      Partition the USB in a GUID style and 2 partitions, one partition HFS+ and one partition FAT32.
       
      In the FAT32 partition put the EFI Folder there.
       
      On the HFS+ partition get the MacOS Mojave .app using this command:
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USBNAME --applicationpath /Applications/Install\ macOS\ Mojave.app --nointeraction Lets install!
       
      Put the USB in a 3.0 port on the LEFT side of the Notebook.
       
      In the BIOS follow the default Hackintosh settings, do NOT forget to put Memory allocation to 64MB (Otherwise you won't boot)
       
      Boot into the Installer and install MacOS Mojave.
       
      Boot into MacOS. Now your Graphics are working but your WiFi and Sound are not! for the WiFi follow this video:
      https://www.youtube.com/watch?v=OxFsjhc-AuM Once rebooted WiFi is working! 
       
      For sound get the VooDooHDA.kext and place it into /Library/Extensions
       
      Reboot once again and your sound is now working flawlessly!
       
      My EFI Folder is downloadable

      config.plist
      EFI.zip
    • By fusion71au
      Clover r4747 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4747 for VMware.zip". Mount Clover-v2.4k-4747-X64 by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
×