Jump to content
FMAranda

Vaio Fit 15E - No screen backlight after wake

6 posts in this topic

Recommended Posts

Hi everyone!

 

I have a Sony Vaio Fit15E running macOS 10.12.5 with almost everything working. The only problem is that, when it wakes up from sleep (hibernatemode 3), the screen's backlight doesn't light up. In order to make it work, I have to close and open the lid one more time. After that, the backlight lights up just fine.

 

The backlight worked fine until Yosemite, if i recall. I've tried a zillion methods, including some old GMA950 topics about that issue and also messed with all those darkwake options.

 

I've attached my DSDT. It has the following patches: GFX0 -> IGPU, HDA Layout ID 3, Remapping Q8E and Q8F keys (for brightness keys) and Sony Vaio SVE Battery Patch.

 

For brightness, I'm using the new method with separate SSDT_PNLF.aml. Brightness slider works fine.

 

Also, I have the follwing kexts at Clover's other kext folder: ACPIBatteryManager.kext, CodecCommander.kext (HDA sound after sleep), FakePCIID_XHCIMux.kext, FakePCIID.kext, USBInjectAll.kext (without these three, I can't get my built-in webcam and RT2870 usb wifi to work), FakeSMC.kext, RealtekRTL8111.kext and VoodooPS2Controller.kext.

 

On System/Library/Extensions, I have: AppleHDA.kext (patched with HDA-Patcher) and RT2870USBWirelessDriver.kext.

 

As boot flags, I have: npci=0x2000, dart=0 and slide=100 (with this flag, hibernatemode 25 'full hibernate' works).

 

I'm really creating this topic because I don't know what else I can do. I have years of hackintosh (since Tiger, not on this same hardware, lol), but I can't find a solution for this particular issue.

 

Thanks you all.

DSDT.aml.zip

Share this post


Link to post
Share on other sites
Advertisement

Check

DSDT.aml.zip

U can delete FakePCIID_XHCIMux.kext and FakePCIID.kext, use USBInjectAll.kext and rename USB devices


if u have a problem, just press O key in Clover boot screen, go to Acpi Patching, DSDT NAME and change to DSDT.02.aml

Share this post


Link to post
Share on other sites

Check

attachicon.gifDSDT.aml.zip

U can delete FakePCIID_XHCIMux.kext and FakePCIID.kext, use USBInjectAll.kext and rename USB devices

if u have a problem, just press O key in Clover boot screen, go to Acpi Patching, DSDT NAME and change to DSDT.02.aml

 

Thanks for the help!

 

I've tried the DSDT modified by you, but the problem persists. Can you share with me what did you do with the DSDT?

Share this post


Link to post
Share on other sites

My  AMD Radeon HD 7650M is not working in 10.12.5(clover 4077), it was previously working gr8 in 10.11.6(clover 3974)

how can i get it work again ! :( 

Share this post


Link to post
Share on other sites

I had a similar problem with SVF15A, what I did to solve it was (paste from another thread):

 

Actually it may be a native DSDT problem: I instrumented DSDT to debug with your ACPIDebug.kext... So I was able to see when I put to sleep via menu, LID return value was 1 for open and 0 for close, but when I put to sleep closing LID, the return value was always 0. So I decided to try re-run the routine to check lid, before returning the value to WAK
Original:
Device (LID0)
{
Name (_HID, EisaId ("PNP0C0D")) // _HID: Hardware ID
Name (LDRT, Zero)
Method (_LID, 0, NotSerialized) // _LID: Lid Status
{
If (ECOK)
{
UPDL ()
Store (Zero, LDRT)
}

Return (LIDS)
}
}
Change I did:

Device (LID0)
{
Name (_HID, EisaId ("PNP0C0D")) // _HID: Hardware ID
Name (LDRT, Zero)
Method (_LID, 0, NotSerialized) // _LID: Lid Status
{
If (ECOK)
{
UPDL ()
Store (Zero, LDRT)
}

UPDL ()
Return (LIDS)
}
}

Using the second "UPDL ()" solved completely the problem.

Share this post


Link to post
Share on other sites

I had a similar problem with SVF15A, what I did to solve it was (paste from another thread):

 

Actually it may be a native DSDT problem: I instrumented DSDT to debug with your ACPIDebug.kext... So I was able to see when I put to sleep via menu, LID return value was 1 for open and 0 for close, but when I put to sleep closing LID, the return value was always 0. So I decided to try re-run the routine to check lid, before returning the value to WAK

Original:

Device (LID0)

{

Name (_HID, EisaId ("PNP0C0D")) // _HID: Hardware ID

Name (LDRT, Zero)

Method (_LID, 0, NotSerialized) // _LID: Lid Status

{

If (ECOK)

{

UPDL ()

Store (Zero, LDRT)

}

 

Return (LIDS)

}

}

Change I did:

 

Device (LID0)

{

Name (_HID, EisaId ("PNP0C0D")) // _HID: Hardware ID

Name (LDRT, Zero)

Method (_LID, 0, NotSerialized) // _LID: Lid Status

{

If (ECOK)

{

UPDL ()

Store (Zero, LDRT)

}

 

UPDL ()

Return (LIDS)

}

}

 

Using the second "UPDL ()" solved completely the problem.

 

Thank you so much! I wasn't using my laptop for a while, but, today I decided to update it to High Sierra (which was a success) and then, tried your method. "UPDL ()" got it working!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      Clover r4542 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 14 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4542 for VMware.zip". Mount Clover-v2.4k-4542-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By ITzTravelInTime
      Hi guys, this thread is to show you a new and open source app, created by me, that I called TINU:
       
      The name means: TINU Is Not #####, the U refers to a popular software that is used to create Mac OS hackintosh installers (that for good reasons is banned on this forum), but the aim of the name is to explain that this app is a totally different thing from that software and works in a totally different way.
       
      This app basically is a graphical interface for the createinstallmedia executable that is inside the Mac OS installer apps, it is capable to create a Mac OS installer on a drive completely vanilla like what you do using the command line method, and also this method is recommended by apple itself. In addition to this, this app provvides also to you some customization features and a better management of the hall macOS isntall media creation process
       
      Allows you to create easily a macOS install media without messing around with command line stuff and without using disk utility, all you need to do is use the app and then install clover on the usb drive once TINU has finished or leave it as is you want to use it on a Mac.
       
      Features:
        - Simple to use UI that allows you to easily start the macOS install media creation process
        - It can work with every Mac OS installer app that has the createinstallmedia executable inside of it's resources folder (including also beta and newly released installers)
        - You can use any drive or partition you want that can be erased and is at least 7 GB of size
        - Works on Mac OS recovery, so you can create a macOS install media from a bootable macOS installer or from the macOs recovery, and you can use TINU to install macOS too.
        - All vanilla, the macOS install medias created with this tool are 100% vanilla, just like you created them using the command line "createinstallmedia" method in the terminal, with also some extra optiona features
        - Open source, you will know what this program does on your computer and also you can create your own version by downloading and playing with the source code
        - Does not requires to do anything of special first, just open the program
        - No need to go in disk utility first, TINU can format your drive for you
        - Uses recent and more modern APIs and SDKs and Swift 3 language
        - Transparent graphics style available (use alt + s on the keyboard or View->Use transparent style)
        - Works using the latest versions of macOS and will also support newer Mac installers out of the box without needing for an update
        - Advanced section, to customize your macOS install media
        - Installer customization: Kernelcache/prelinkedknerel and boot files replacement (a feature that can be handy while dealing with old Macs or with beta installers when you need to mod or change the boot files some times)
        - Clover EFI folder installer
       
        Features that are planned for some future versions:
        - Integrated EFI partition mounter tool (TINU can already mount EFI partitions from version 2.0, but a dedicated section which allows to mount every EFI partition in the system will be added)
        - Install clover and configure clover
        - Install kexts inside the kexts folder of clover
        - Clover drivers customization
        - Use custom dsdt in clover
        - integrated pre-made clover config templates database from a remote and open repository
        - Support for other languages, at least Italian   Rquirements:  - A computer that runs Mac OS X Yosemite or a more recent version (Mac OS X El Capitan is required to use TINU in a macOS recovery or installer)  - A drive or a free partition of at least 7 GB that you want to turn into a macOS/Mac OS X installer  - A copy of a macOS/Mac OS X installer app (Maveriks or newer versions are supported) in the /Applications folder or in the root of any storage device in your machine (excepted the drive or volume you want to turn into your macOS install media)   Note that this app is under the GNU GPL v3 license so any reuse of the source code must follow the license's terms   Latest stable TINU release:   Download the app:                                https://github.com/ITzTravelInTime/TINU/releases   View the source code:                            https://github.com/ITzTravelInTime/TINU       Frequently asked questions about TINU:  https://github.com/ITzTravelInTime/TINU/wiki/FAQs     NOTE: if you have problems with your USB installer of 10.13.4 or newer version not being detected by clover you have to use the latest clover and if it still does not detectets your usb installer you have to remove the invivible file called .IAPhysicalMedia located into the root of the usb installer. This issue is caused by a changement in the apple's createinstallmedia, don't blame TINU for that, TINU does only uses the installer creation method from apple, which has been changed by appleitself, causing this problem for hackintosh users some times, this issue should be resolved in the latest versions of clover which will no longer require that you do changements to let your usb dive to be detected, a setting to do this fix automatically in tinu is also present TINU in the adavnced settings, starting from the version 2.0 of the app. I leave also some screenshots as well
       
       
       
       
       
       
       
       

    • By PingoLinkin
      Motherboard: ASUS / X99 Deluxe II
      Chipset: Intel® X99
      Processador: i7-6800 LGA2011 v3
      Memoria: HyperX - DDR4 24000MHz - 32GB(2x16gb)
      Rede: Intel® I218V, 1 x Gigabit LAN; Intel® I211-AT, 1 x Gigabit LAN LAN; Dual Gigabit LAN controllers- 802.3az Energy Efficient Ethernet (EEE) appliance
      Audio: Realtek® ALC1150 com 8 canais
      Video: Geforce GTX 750 Ti 2GB SC DDR5 128 bits PCI-E 3.0 (1x DVI, 1x DisplayPort, 1x HDMI)
      Keyboard: Apple Aluminium
      Mouse: Microsoft
      HD: SAMSUNG SSD 840 EVO 1TB
       
      ///////////////////////////////////////////
       

       
      1 - Preparando PENBOOT:
        1.1 - Baixe a imagem do Sierra e deixe na pasta "Applications";
        1.2 - Formate o PenDrive e altere o nome para: "MyVolume";
        1.3 - Abra o Terminal e digite a seguinte linha de código, dê enter e quando solicitado digite sua senha. Aguarde o término da instalação, geralmente demora em torno de 20min:
      sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume --applicationpath /Applications/Install\ macOS\ Sierra.app  
       
      1.4 - Baixe a última versão do Clover EFI bootloader: Download
        1.5 - Abra o Clover, na última etapa, clique em Customize, depois marque a opção "Install for UEFI booting only", como na imagem abaixo:

       
        1.6 - Provavelmente a partição "EFI" estará montada, abra a partição e substitua a pasta "CLOVER" por esta CLOVER Asus X99 Deluxe II - Sierra.zip.
       
      2 - Configurando BIOS
        2.1 - Atualize sua BIOS para a versão mais recente, a minha é: 1902
        2.2 - Reset as configurações de sua BIOS em: Exit/Load Optimized Defaults;
        2.3 - Vá para: Boot/CMS (Compatibility Support Module)/Launch CMS: ENABLED;
        2.4 - Vá para: Boot/Secure Boot/OS Type: Other OS;
       
      3 - Instalando OS
        3.1 - Ligue o computador com o Pendrive espetado, ele automaticamente irá iniciar o Clover, caso isso não aconteça, na tela inicial da ASUS, pressione F8 para escolher o pendrive como boot primário;
        3.2 - Em algum momento futuro, seu clover pode não arrancar corretamente, caso isso aconteça, na tela inicial do CLOVER pressione F11 para limpar o NVRAM, ele irá reiniciar a máquina automaticamente, em seguida voltará a arrancar normalmente;
       
      4 - PÓS-INSTALAÇÃO
        4.1 - Inicie seu MAC temporariamente pelo Pendrive como boot primário;
        4.2 - Instale o clover seguindo as etapas 1.4, 1.5 e 1.6 . Apenas não esqueça de alterar o destino para o HD Interno com a instalação do Sierra.
        4.3 - Feito isso, reinicie seu mac, agora sem o pendrive;
       
      5 - VÍDEO
        5.1 - Na pasta CLOVER que anexei acima, já possui as kexts NvidiaGraphicsFixup.kext e Lilu.kext ;
        5.2 - Baixe e instale o nVidia Web Driver(Download) de acordo com a versão do seu OS;
        5.3 - A minha versão, por exemplo, é: "macOS 10.12.6 (16G1408)";
        5.4 - Veja abaixo onde encontrar sua versão:

       
      Obs.: Existe um bug no vídeo, caso queira utilizar a entrada DVI, é preciso iniciar a máquina já com o cabo plugado, caso contrário ele deixará sua tela preta e não voltará mais ao normal até que reinicie a máquina.
       
        5.5 - INSTALANDO O CUDA:
           1 - A última versão não funcionou, então baixei a penúltima e funcionou perfeitamente. A versão instalada foi: CUDA 387.178 driver for MAC.

       
       
      6 - ÁUDIO
        6.1 - Baixe o Voodoo HDA 2.9.0 Clover (Download)
        6.2 - Siga as etapas das imagens que estão dentro do anexo;
       
       
      Não solucionado:
      Não consigo habilitar a placa ThunderboltEX 3;
       
       
      Valeu.
    • By moman2000
      Hi,
       
      I thought it would be nice that I would be the first here to give my experience with getting Mojave running and mostly working on my system.
       
      My specifications are as follows:
       
      iMac 14,2
       
      GIGABYTE GA-Z97X-UD5H / Intel Core i7-4770k @ 4.4GHz / 16GB Corsair Vengeance DDR3 @ 1600MHz
      MSI AMD Radeon HD 7870 2GB OC
      250GB SanDisk Ultra 3D NAND SSD / 120GB OCZ Agility 3 SSD
      1TB 5.4K HDD
       
      I used the config that @MaLd0n helped me with. Seriously, he is a legend. HERE is my Clover Config including everything I use for 10.13 High Sierra and 10.14 Mojave.
       
      Installation Procedure:
       
       
      Create bootable USB media with createinstallmedia - sudo /Applications/Install\ macOS\ 10.14\ Beta.app/Contents/Resources/createinstallmedia --volume /Volumes/"Insert Volume Name here"  ***** Remove quotation marks!!! 
       
      **"--Applicationpath" is now depreciated and should not be used when making a 10.14 Mojave USB. I do not know if this will change in upcoming releases.
       
      ** ConvertToAPFS is now depreciated and no longer works when installing 10.14 Mojave beta 1. Using the command "--converttoapfs NO" will not work if you use it with "createinstallmedia".
       
      Editing "minstallconfig.xml" within the "macOS Install Data" folder on the target partition chosen during installation to change "ConvertToAPFS" from "TRUE" to "FALSE" would also not disable APFS conversion.
       
      Installation ran through well, but it did restart just after installation began which seemed to have been caused by a crash, but it seemed like it was normal as this happened twice as I tried installing Mojave earlier and the same thing happened. Rebooting again into the installation on the target drive that was selected before described as "macOS Install"  and named "macOS 10.14" resumed installation.
       
      Everything from then on was easy and smooth. I set-up my iCloud and things as such and was brought to the desktop of macOS 10.14 Mojave!
       
       
      What does work:
       
      Graphics (Acceleration/Metal) // 4K video dropped 0 frames // Picture-in-Picture
      Mouse and Keyboard
      USB 3.0 -  Full 5 GBP/s - Only ports above HDMI Port and front I/O
      USB 3.0 under both Intel and Killer Ethernet ports function with USB 2.0 devices.
      Ethernet (only Intel NIC so far) Both NIC's work, Intel I217-V and Killer E2200
      iMessage
      Sleep and Wake
      Shutdown
      Restart
       
      Update #1:
       
      Temporary Fix: ***I have gotten audio to work after browsing Reddit, I stumbled across this post: https://www.reddit.com/r/hackintosh/comments/8orn7w/mojave_files_needed/e05kkj9/
       
      Update #2:
       
      I have just found a kext for the on-board Killer E2200 NIC after searching with device and vendor ID's on this forum.
      https://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/
       
      Update #3:
       
      Audio is now fully operational with new version 1.2.8 of AppleALC, from here: 
       
      What does NOT work:
       
      USB 3 under Intel I217-V NIC and Killer E2200 NIC Ethernet Ports // Only function with USB 2.0 devices.
      Audio Temporary fix in Update #1 above   Fixed in Update #3
      Killer E2200 NIC Fixed in Update #2 above
       
       
       
      This is the information I have been able to gather thus far whilst using Mojave.
       
      I hope this helps someone in getting Mojave running on their system.
       
      Regards,
      Mohamed
       
       
      CLOVER_moman2000 No SN.zip







×