Jump to content

10.4.8 Apple.Airport2.kext link/load error


5 posts in this topic

Recommended Posts

I've tried to get my Broadcom 4320 based pci card working. I'v tried most of the fixes in the forums here. None seem to work.


When booting with -v I see that a "link load error occured System/Library/Extensions/AppleAirport2.kext "


This is with a fresh install of the new 10.4.8. No changes. (though this has been a problem with earlier versions)


Any ideas ?

Link to comment
Share on other sites

Need to add the device id to the kext.


In Terminal, edit the kext:

cd /System/Library/Extensions
sudo nano IO80211Family.kext/Contents/PlugIns/AppleAirPortBrcm4311.kext/Contents/Info.plist

Add the following string: "<string>pci14e4,4320</string>"


Clean up:


sudo chown -R root:wheel AppleAirport2.kext
sudo chmod -R 755 AppleAirport2.kext
cd /System/Library
sudo rm -rf Extensions.mkext Extensions.kextcache
sudo diskutil repairPermissions /

Link to comment
Share on other sites

I'm a little confused.....


I modify the IO80211Family.kext (where you said) and chown & chmod the AppleAirport2.kext ??

Modifying the IO80211Family.kext using "sudo" shouldn't affect its permissions. Plus, later on, you do a general permission repair for good measure.


But you were having a link/load problem with the AppleAirport2.kext, so fixing its specific permissions is an attempt to fix that.

Link to comment
Share on other sites


  • Create New...