Jump to content
MaLd0n

[Guide] Sierra / High Sierra on GA Z170M-D3H / DSDT

74 posts in this topic

Recommended Posts

Advertisement

Just realized that with or without your dsdt nothing changes , I can only boot with deselecting use Nvidia drivers from clover and of course without graphics drivers. If I boot without touching anything it tries to boot than give me a fast disconnection to the monitor (like no source available ) and then a black screen. Here's the files you asked me. Thanks in advance

https://www.dropbox.com/s/8kzpccchdhg8umh/Send%20me%20iMac-di-Niccolo.station.zip?dl=0

Share this post


Link to post
Share on other sites

Just realized that with or without your dsdt nothing changes , I can only boot with deselecting use Nvidia drivers from clover and of course without graphics drivers. If I boot without touching anything it tries to boot than give me a fast disconnection to the monitor (like no source available ) and then a black screen. Here's the files you asked me. Thanks in advance

https://www.dropbox.com/s/8kzpccchdhg8umh/Send%20me%20iMac-di-Niccolo.station.zip?dl=0

u use 4k monitor? 

CLOVER.zip

Share this post


Link to post
Share on other sites

I'm using an ultrawide 21:9 monitor, but not 4k.

with your new folder first reboot works well (also nvidia graphics) then all the other times I boot it shows  kextd stall 'NVDAgl', 'IOResources' and bootloops

 

 

Edited by parodiniccolo9999

Share this post


Link to post
Share on other sites

Hello Look at my DSDT how to fix the warnings? Sorry for errors, use Google translator.
Gigabyte GA-Z170-D3H bios F22f
Intel Core i5-7500
Intel HD 630
Wi-Fi adapter TP-LINK TL-WN881ND
8GB DDR4-2400 samsung
SSD OCZ 60GB

DSDT.aml

Edited by vik-vo

Share this post


Link to post
Share on other sites
5 hours ago, vik-vo said:

Hello Look at my DSDT how to fix the warnings? Sorry for errors, use Google translator.
Gigabyte GA-Z170-D3H bios F22f
Intel Core i5-7500
Intel HD 630
Wi-Fi adapter TP-LINK TL-WN881ND
8GB DDR4-2400 samsung
SSD OCZ 60GB

DSDT.aml

DSDT.aml.zip

Share this post


Link to post
Share on other sites

Tell me how to start the PCI Wi-Fi adapter TP-LINK TL-WN881ND?

how to make it work and what is needed for this?

 

1811343479_2018-08-2514_13_22.thumb.png.f16984dfb02767c78a004d1503e06b08.pngimageproxy.php?img=&key=c17464ef1b1b51c7

Screen Shot 2018-08-25 at 15.30.35.png

Screen Shot 2018-08-25 at 15.31.03.png

Edited by vik-vo

Share this post


Link to post
Share on other sites
6 hours ago, vik-vo said:

Tell me how to start the PCI Wi-Fi adapter TP-LINK TL-WN881ND?

how to make it work and what is needed for this?

 

1811343479_2018-08-2514_13_22.thumb.png.f16984dfb02767c78a004d1503e06b08.pngimageproxy.php?img=&key=c17464ef1b1b51c7

Screen Shot 2018-08-25 at 15.30.35.png

Screen Shot 2018-08-25 at 15.31.03.png

if don't work native, u need check if have a thirty party driver

Share this post


Link to post
Share on other sites

Hi, just before to start please excuse me for my english ! I'm french ^^

I would like to wake up this post... I'm on the same MB GA Z170M D3H.

 

I would like to know if the file for patch are working for Mojave too ?

I have issues to activate usb 3 since I update to Mojave and find this post.

 

I'm a noob and it's not very easy to create DSDT ! 

 

Thank's for help :)

Share this post


Link to post
Share on other sites
On 12/7/2018 at 11:18 PM, adamrose1309 said:

Hi, just before to start please excuse me for my english ! I'm french ^^

I would like to wake up this post... I'm on the same MB GA Z170M D3H.

 

I would like to know if the file for patch are working for Mojave too ?

I have issues to activate usb 3 since I update to Mojave and find this post.

 

I'm a noob and it's not very easy to create DSDT ! 

 

Thank's for help :)

check here

https://olarila.com/forum/viewtopic.php?p=65287#p65287

Share this post


Link to post
Share on other sites
17 hours ago, myedit001 said:

GA Z170MD3H(bios f22f with CPU microcode update)

6700K

 

Initial_History: 2years back i installed 10.11.6 on my system (i didnt remember bios) , 15 days ago my my system get into issue as its hangs at boot, so i tried to install 10.11.6 again, but successfully installed but only problem is i can boot only with cpus=1 ,  so i searched few forums and i tried solutions like CPU microcode update, voodooTSCsync with IOCPUNumber 7 but no luck, tried everything still no success, 
today i tried olaria image 10.13.6 High sierra , facing same issues not booting without cpus=1 
attaching ioreg and efi/clover  , i m heavy fcpx user , its very imp to get system started , plz help 

 

Send me ak-pcs-iMac .zip

DSDT.aml.zip

Share this post


Link to post
Share on other sites

Hello MaLd0n, can I use your patches for my i5 6600 (same motherboard) ?

 

Right now, I cant access olarila, so maybe I will use your patches. Thanks

Share this post


Link to post
Share on other sites
On 1/26/2020 at 12:39 PM, MaLd0n said:

--Run_Me
RunMe.app

 

I cant run runme properly, because ioreg always not responding and make "Retrying Increased delay x2 for IOREG dump" (I already try permission, ioreg v3, iojones and reinstall HS twice with olarila installer). One time, runme produce ioreg but in 50 mb size.

 

Problem: Sleep not working properly, after sleep mode it cant wake up again (pc running but screen blank with restart)

 

If i use your dsdt, when sleep, the screen will turning off & logout but the pc still running (fan keep spinning and light still on).

Im not using egpu, only igpu intel 530

 

this is my dsdt DSDT.aml 

CLOVER.zip

Thanks

Edited by redvamik

Share this post


Link to post
Share on other sites
8 hours ago, redvamik said:

nope, its not working, same problem, the screen cant wake up.

 

Finally i can make ioreg file after waiting 30 minute.

Thanks

 

Send me Vamik-iMac.zip

man, intelhd 530 desktop, wake don't work, forget it

Share this post


Link to post
Share on other sites
9 hours ago, MaLd0n said:

man, intelhd 530 desktop, wake don't work, forget it

How about using eGPU 1050ti ? thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By sierra2600
      The laptop in question: Acer TravelMate 8472 TM8472 (Model: ZQ3) (refer to the "Spoiler" at the end if you want the machine specs)
       
      "So what are you bugging us for?" Good question, because I am usually an introvert and usually just keep looking for answers but I could not find some. Jumping to it...
      What does not work and I would like thoughts on:
      Bluetooth does not register, used to on previous installs (sorry, I did not pay attention to see if this was caused by me updating to 10.8.5 but that was necessary for the below functions) (It does not work in Debian either - Ignore) LAN and WLAN  - I have found Kexts (somewhere, I think I just lost them... dang it...) for the WLAN but I have yet to try them, nothing for the LAN I know this is cheating but I read that The NDISulator for FreeBSD (HINT HINT) is a port of NDISwrapper for Linux that runs Windows XP network drivers in Linux or BSD Brightness controls work from the middle down on the "Sun" brightness overlay, I got this far from following this: https://www.insanelymac.com/forum/topic/287133-guide-backlight-brightness-for-intel-80860046-1st-gen-hd-gma-5700mhd/ but I am kind of thinking of trying: https://www.insanelymac.com/forum/topic/287133-guide-backlight-brightness-for-intel-80860046-1st-gen-hd-gma-5700mhd/?do=findComment&comment=2214344 . My "magic number" is: 0xF        I used DSDTEditor in Windows, since I figured all the drivers are loaded, to extract the DSDT and compile something that somewhat works... Wake from sleep issue - I tried the above guide for that but I get a no backlit display and I can see that the cursor in the password field is not flashing when I use an external light source, but it will reboot when I press Ctrl + Alt + Power "button" (it is actually a slider) and then also clear my freaking CMOS right down to the clock... yeah I have the ACPI fix implmented and it usually works... DVD Player.app reports that no viable video device was found (personally I don't care about the DVD Player.app problem, just wanted to put that out there for the heck of it) The microphone port always sounds like it is going through a [dirty] guitar effects petal no matter what sliders are adjusted  
      Likely causes of:
      Bluetooth (BCM92046), WIFI (BCM943225HM) - So, I USED TO be able to turn on the WIFI from within Windows then reboot into Mac OS and have it work but I noticed recently that the indicator light for them turns off BEFORE it reboots now. When Windows or Android load, it lights up- "No... really, captain obvious?!"... anyways... working "No really Sherlock!" so OBVIOUSLY, the OS has to activate them... and preferably ignore the wireless switching button For the WIFI module, if you omit the 9 and HM in a search, results appear! Brightness - Will get reset to full "Bright light! Bright light!" when a "Load System Defaults" is applied from within the BIOS settings but like the WIFI and Bluetooth the OS will forcefully take control of it Microphone In sounding dirty - me being lazy with the audio drivers LAN (BCM57760) - I dunno...  when I search it, nothing comes up...  
      "How did you get this far?"
      Update the BIOS, this is oh so very important (refer to the battery section of the "Spoiler" for the reson) PLEASE BACKUP YOUR BIOS FIRST! PLUG THE MACHINE INTO THE AC ADAPTER/CHARGER! DO NOT FORCE THE COMPUTER TO SHUTDOWN NOR REMOVE THE BATTERY NOR UNPLUG IT FROM THE AC ADAPTER/CHARGER WHILE IT IS UPDATING! I WILL NOT BE HELD LIABLE FOR BRICKED MACHINES! So it will boot off of the (Niresh) Mac OS X 10.8 with no changes to anything "Awesome" but you may still need at least a USB mouse "Aww" If you have the option to remove the display drivers/kexts otherwise it will not to boot or not display If you forgot this, breathe "You think that's air your breathing?"... anyways... during the bootloader, go into single user mode [ -s ] and follow the on screen instructions to allow for modifying the files. You will want to PREFERABLY create a folder where Mac OS cannot read them and move the IntelHDGraphics Kexts into it You are likely going to need an external USB keyboard as well now that it is installed Now install the described Kexts in the "Spoiler" associated with the hardware to get more functionality and loose the USB HICs  
      Any help pertaining to the Bluetooth, WIFI, LAN, bizarre brightness and wake after sleep backlit display issue would be wonderful... Thank you for your time and I hope that I helped anyone else out with some of their own issues pertaining to the Acer TravelMate 8472 TM8472 ZQ3 no nVidia with i5 laptop...
      (Attached are non-modified extracted DSDT DSL and AML files "with errors according to DSDTEditor" for reference of the machine with a Phoenix BIOS version of 1.28 (07/20/2011))
      dsdt.aml
      dsdt.dsl
       
       
    • By DoZe
      Hi :0)
       
      Hope As usual a perfect matching DSDT for this good Laptop.
       
      Regards, Ray
       
       
      SendMeStudiMac.zip
    • By tluck
      Lenovo T460 macOS with Clover Guide
      Latest Release on GitHub (February 2020) Updated to Clover r5104 Updated Lilu based kexts - Lilu, ALC, WEG Updated acidanthera VoodooPS2 kext v2.1.1 the older 1.9 to the Misc Folder as an option.
        Various Tweaks over Last months The zip file is a complete Clover ESP (/EFI) bundle and kext pack for the Lenovo T460. The current file bundle is tested on Sierra. 
      Note: I never got the GFX fully working on El Capitan. 
      Full Clover file set - config.plist etc. Includes all custom kexts Includes custom DSDT/SSDT scripts and patches Utility scripts The zip bundles are posted to GitHub: https://github.com/tluck/Lenovo-T460-Clover/releases
      Caveat: The T460 systems used here was configured with: i5-6300U, Intel HD Graphics 520, 1920x1080 touch screen. If you have a different system model, then extract the ACPI files and use the included scripts to create a set of files consistent with your system type and BIOS version. See below for details.
      Credits: RehabMan, Shmilee, vusun123, TimeWalker, Mieze from which, much of their work and help is/was was used to get the T460 to this point.
      Devices and aspects working:
      Ethernet -  Intel I219LM is enabled via IntelMausiEthernext.kext WiFi/BT - substitute the Intel WiFi/BT with a compatible Broadcom or Atheros chip Audio - ALC293 codec implemented via AppleALC.kext (the old AppleHDA_ALC293 and CodecCommander kexts are not needed) PS2 - ClickPad + TrackPoint + all 3 buttons - using a modified VoodooPS2Controller to support new layouts - and added some custom Fn key maps based on 440/450 dsdt USB - implemented via custom SSDT + USBInjectAll kext. All USB3/USB2 ports are intel-based and work -  3 external USB and internal Camera, BT, etc  Sleep/Wake - the sleepwatcher package and custom sleep/wake scripts are used to help with sleep/wake for BT and PS2 devices. Note: have not tried to implement the SD card reader - no driver found.
      ACPI Files
      New Installation - Steps and Details
      Part 1 - OS Installation
      Part 2- Post OS Installation and Setup
      Notes on Custom Kexts
       
    • By gengstapo
      @Hervé
       
      Im having similar issue with my HS setup, dell latitute 3480, i5-7200U
      Once the hdmi plugged in, the laptop display went blank, only could see the external tv
      But, when i put my laptop to sleep & wake up again, both screen got display (hdmi still connected)
      Even the hdmi could be plugged off & in (after sleep), the laptop display is fine
       
      What could be the culprit?
      Dell’s MacBook Pro IORegistry.zip
      config.plist.zip
×