Jump to content
lilins

Issue with Realtek ALC 892 intel 100 chipset zotac magnus en1060

57 posts in this topic

Recommended Posts

Advertisement

post-2058756-0-42208800-1494787872_thumb.jpg

 

post-2058756-0-85354300-1494787912_thumb.jpg

 

Finally found the issue.

 

Here are all the kext i need.

 

But to activate bluetooth i need fakepciid.kext to be activated one boot then removed. If i let it wifi wont work.

 

Have you already seen such "cold start" kext thingie?

 

All kexts in clover foler now.

Share this post


Link to post
Share on other sites

Dell dw1560 is:

 

Dell Wireless 1560 - Broadcom BCM4352 (2T2R abgn/ac)

PCI ID: 14e4:43b1, SS: 1028:0019, USB BT: 0a5c:216f

PCI\VEN_14E4&DEV_43B1&SUBSYS_00191028

[0a5c:216f] BCM20702A1 combo (DW1560 Bluetooth 4.0 LE)

Bluetooth USB ID:

[0a5c:216f] BCM4352 + BCM20702A1

Share this post


Link to post
Share on other sites

i think u need this patch

<dict>
    <key>Comment</key>
    <string>AirPortBrcm4360 - fcvo</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>gflSqgAAdSk=</data>
    <key>Name</key>
    <string>AirPortBrcm4360</string>
    <key>Replace</key>
    <data>gflSqgAAZpA=</data>
</dict>

Share this post


Link to post
Share on other sites

use DSDT patch for activate wifi

 

remove kexts about wifi and apply patch in correct device, check in ur ioreg

Use MacIasl

 

 

into device label PXSX parent_label RP19 insert

begin
Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method\n
                    {\n
                        If (LEqual (Arg2, Zero))\n
                        {\n
                            Return (Buffer ()\n
                            {\n
                                 0x03    \n                                       
                            })\n
                        }\n
                        Return (Package ()\n
                        {\n
                            "compatible", \n
                            "pci14e4,43a0"\n
                        })\n
                    }\n
end

Share this post


Link to post
Share on other sites

Hi @MaLd0n , i was pretty busy recently, i need to focus on work a more few days but then i'll come back and check the thing with the DSDT and missing Input output lines for audio. really thanks for your help and i may ask you a little more again soon :)

Share this post


Link to post
Share on other sites

OK, so now i'm back @MaLd0n

 

first let's do the wifi/bt thing. so i need to use the DSDT patch you sent me. if i remember correctly, i have first to extract my DSDT with MaciASL. then i create the patch. i put it in CLOVER/ACPI/PATCHED

 

 

Do i need to give it a special name?

 

then i remove all WIFI related extentions.

 

am i right?

Share this post


Link to post
Share on other sites

if u have a compatible wifi, in many cases, just a simple patch solve, others need a several mods and others work real oob

Share this post


Link to post
Share on other sites

post-2058756-0-55245800-1498414415_thumb.png

 

When i try to apply patch you gave me to existing custom DSDT (i forgot i already had one for audio) i get a compile error

Share this post


Link to post
Share on other sites

attachicon.gifCapture d’écran 2017-06-25 à 20.24.11.png

 

When i try to apply patch you gave me to existing custom DSDT (i forgot i already had one for audio) i get a compile error

ur DSDT have _DSM into RP19/PXSX, just rename to ZDSM ;)

post DSDT here, i don't remember what patches we apply in months ago ;)

Share this post


Link to post
Share on other sites

yes. sorry, no problem, here it is:

 

it was the DSDT for AUDIO, without it i can't have DisplayPort sound


so i tried with ZDML, i can save DSDT, if i remove wifi ext and reboot, i don't have wifi anymore

 

here are systemprofile and DPCI pics

 

 

post-2058756-0-18914500-1498455241_thumb.png

 

post-2058756-0-86146900-1498455246_thumb.png

DSDT.aml.zip

Share this post


Link to post
Share on other sites

i think ur card work with it

https://bitbucket.org/RehabMan/os-x-fake-pci-id/downloads/RehabMan-FakePCIID-2017-0527.zip

use FakePCIID.kext + FakePCIID_Broadcom_WiFi.kext in LIbrary/Extensions

 

put kexts there and run KextUtility

 

Share this post


Link to post
Share on other sites

should i remove any other kext except replacing the to i had with the two you posted?

 

post-2058756-0-87899100-1498482775_thumb.png

Share this post


Link to post
Share on other sites

oh, yes i did this, but i wanted to know if i had to remove any other. but i found, it works now. there was a kext that was supposed to be necessary for this BT card to work - but wasn't

 

post-2058756-0-64999400-1498483948_thumb.png

 

Now WIFI and BT working great. thanks a lot.

 

there is now issue of jack line out and mic line it on unit. i am first going to test again, maybe the removed kext was messing with that too.

 

I tell you after :)


YES YES YES!!!!!

 

so, here i have sound:

 

the good line in is in fact:

post-2058756-0-12715000-1498485145_thumb.png

 

the internal mic:

post-2058756-0-53005000-1498485233_thumb.png

 

the good line out is in fact:

post-2058756-0-50308300-1498485262_thumb.png

 

the internal speaker:

post-2058756-0-45939300-1498485282_thumb.png

 

So now, have a question: is there a way to avoid system showing me the useless line in, line out and digital out?

 

post-2058756-0-12249400-1498485352_thumb.png

 

thanks :)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×