Jump to content

Issue with Realtek ALC 892 intel 100 chipset zotac magnus en1060


57 posts in this topic

Recommended Posts



I'm very new to the hackintosh scene and not much used to lots of things here. I tried my best to make my hackintosh work but i have one last problem i can't figure on my own.


My setup is a Barebone pc zotac magnus en1060. Checking on windows and on zotac site. It is based on intel 100 serie chipset and has realtek alc 892 audio (at least that's what the windows driver tell me)


I don't know a thing in sound card and system, i'm totally lost, i tried asking on other forums, but instead of being guided on right path so i can test some things i'm somehow sent on a "you're the hero" novel where forums and subforum follows, without end.


I will post you here later the details of my setup (config files, etc... ) but at least for now, what i now is:


Under os x i have no output line for sound so only airplay available.


Sound works on airplay, on bluetooth speakers, headphones, and on usb speakers.


Whatever i tried up to now:

I can't have any line in/out listed in sound

I can't play audio through display port to my monitor.


I'm eager to give you all the information you need to help me, so please, help!

  • Like 1
Link to comment
Share on other sites

here are the official specs


Computing System 

  • Processor 
    Intel Core i5-6400T (quad-core, 2.2 GHz, up to 2.8 GHz)
  • Chipset 
    Intel 100 Series, NVIDIA
  • System Memory 
    2 x DDR4-1866/2133 SODIMM Slots (up to 32GB)


  • Graphics Engine 
    GeForce® GTX 1060 6GB GDDR5 192-bit
  • Video Output 
    2 x HDMI 2.0 
    2 x DisplayPort 1.3 


  • Hard Drive 
    1 x 2.5-inch SATA 6.0 Gbps HDD/SSD bay
  • Mass Storage 
  • Optical Drive 
  • mSATA 
  • M.2 
    1 x M.2 PCIEx4 / SATA SSD slot (22/42,22/60,22/80)
  • Card Reader 
    3-in-1 (SD/SDHC/SDXC)

I/O Ports 

  • Audio 
    Microphone, Headphone
  • USB Port 
    2 x USB 3.0 
    1 x USB 3.1 Type-C 
    1 x USB 3.1 
    2x USB 2.0
  • LAN 
    Dual Gigabit LAN
  • Antenna 
    1 x WiFI SMA connetor
  • Wifi 
  • Bluetooth 
    Bluetooth 4.0
  • Legacy I/O 
  • CIR Infrared Port 
  • Thunderbolt 
  • USB 
  • IDE 
  • VGA 


  • Kensington Lock 
  • LED Indicators 
    Power, HDD, WiFi
  • Power Supply 
    AC Adapter 
    O/P: DC 19.5V/180W
  • Cooling system 
    Fan + Heatsink
  • ZBOX Dimensions 
    210mm x 203mm x 62.2mm
  • Case Mounting 

Here is my progress:

What works:

Boot ok

Clover decently configured with OSS theme

Mac OS booting

GTX1060 recognized

Imessage running, icloud and stores login ok

4k 60hz ok, HiDPI ok

Usb and chipset seems ok. 

Serial system and mlb setup ok 


Bought dell 1560 wifi/bt card wor osx recognize wifi/bt.


Wifi Working

Bluetooth working - says handoff but only have partial working handoff/continuity



What is half working:

Sound - no hdmi or dp sound, no jack sound. Only Airplay BT or USB sound

What is not working:

Sd card reader

What is planned:

Trying to fix hdmi audio (i need help as none of the guide i followed seemed to get me some improvment!)

It seems sd card reader on intel 100 series chipset is a no go, i can leave with that!


this week end i'm gonna try to remove everything i've tried up until now for sound, both kexts, or in config, and post here the information of "clean" audio setup. i don't need a solution but i need guidance of wich direction to look.


  • Like 1
Link to comment
Share on other sites

-Post ur full Clover folder with original tables, press F4 in Clover Boot Screen, files generate in Clover/Acpi/origin

-Post Ioreg, extract with Ioreg Explorer

-Run it, post files generate in ur desktop

  • Like 1
Link to comment
Share on other sites

Dell Dw1560, i'm fighting with it, i don't understand why it's not recognized, all the kexts are here and config file is ok

here is the second ioreg

  • Like 1
Link to comment
Share on other sites

with dsdt id 5 i still have dp audio, internal speaker (but none on my unit) a numerical output (but i don't have, only 1 jack line in and 1 jack line out ports on the unit)


here is new ioreg

use it


and reboot


u use my full clover folder, i see u dont use fakesmc in my folder ;)


i'll try this.


strange because i remember i needed fakesmc and i have it also in /Library/Extentions

same issue. here


  • Like 1
Link to comment
Share on other sites

strange, hdef is full load

MaLd0n 2017-05-13 às 14.47.11.png


check, i removed _DSM into HDEF, just test ids, inject in config.plist, devices tab


Inject 1

MaLd0n 2017-05-13 às 14.50.08.png


ids for test ALC892, inject, save, reboot, test

MaLd0n 2017-05-13 às 14.52.21.png


Check ur folder L/E and S/L/E, use all kexts in Clover/kexts/other


if u can, run KextUtility for full rebuild

Kext Utility.app.zip

Link to comment
Share on other sites

so, layout 4 is the only one wich detect headphones (but still no audio out) other lines are useless


here is ioreg with that

But honestly, having DP audio out thanks to you i could live with that. Now i need to fix my wifi :)


  • Like 1
Link to comment
Share on other sites

It was harder than that but i now have thanks to you a working customized clover folder for my build! If i have the will later i'll check about that jack in/out thing and may ask some more help. but for now i'm good :)


thanks a lot @MaLd0n ! truly.

  • Like 1
Link to comment
Share on other sites

just for information, my wifi/bt worked only when some kexts where in /S/L/E i'll have to check how to bypass that to have all in CLOVER/kext/others :)

  • Like 1
Link to comment
Share on other sites

First i had all in clover kext folder, and i could make either wifi either bt work separately. I think kext inject was on yes.

I'm gonna check this today

  • Like 1
Link to comment
Share on other sites


  • Create New...