Jump to content
InsanelyMac Forum
MaLd0n

[GUIDE] EL Capitan / Sierra / High Sierra on Intel LGA 775 motherboards / DSDT

Recommended Posts

Advertisement

Hello Mald0n:
I also have an old notebook, the hase A550-I7, a Chinese brand notebook.
Cpu:i7 Q720
Motherboard: PM55
Memory: DDR3 1600 4G *2
Graphics Card: NV GT205M

This notebook does not support UEFI boot, I used clover to simulate UEFI boot GPT hard drive.
This is the first time I have installed Hackintosh with NV cards. I don't know how to drive NV cards.

I just successfully entered macOS and run Runme.app

https://drive.google.com/open?id=14NHBrdv0lnedDqrOWj23tc8TWC5WCG0g

Share this post


Link to post
Share on other sites
1 hour ago, visin said:

Hello Mald0n:
I also have an old notebook, the hase A550-I7, a Chinese brand notebook.
Cpu:i7 Q720
Motherboard: PM55
Memory: DDR3 1600 4G *2
Graphics Card: NV GT205M

This notebook does not support UEFI boot, I used clover to simulate UEFI boot GPT hard drive.
This is the first time I have installed Hackintosh with NV cards. I don't know how to drive NV cards.

I just successfully entered macOS and run Runme.app

https://drive.google.com/open?id=14NHBrdv0lnedDqrOWj23tc8TWC5WCG0g

https://www10.zippyshare.com/v/yNddStOM/file.html
 

Share this post


Link to post
Share on other sites

Hello! @MaLd0n, Thanks so much for compiling the DSDT last time!So far it is working good on my 10.12.6 and 10.13.4.By the way,Could u pls help me inject the built-in Mic ?I hv generated the send_me file based on the App u offered!Really appreciate your help.

My EFI:https://drive.google.com/open?id=1lqzF5QUD8E_Csr5qp8sdeSVp6UZGDjoU

5acd6cdc5ac6f_ScreenShot2018-04-06at2_18_39AM.thumb.jpg.dd2c0dda9f59daefb8ce6bf481f483c5.jpg

Archive.zip

Share this post


Link to post
Share on other sites
51 minutes ago, HurricaneX said:

Hello! @MaLd0n, Thanks so much for compiling the DSDT last time!So far it is working good on my 10.12.6 and 10.13.4.By the way,Could u pls help me inject the built-in Mic ?I hv generated the send_me file based on the App u offered!Really appreciate your help.

My EFI:https://drive.google.com/open?id=1lqzF5QUD8E_Csr5qp8sdeSVp6UZGDjoU

5acd6cdc5ac6f_ScreenShot2018-04-06at2_18_39AM.thumb.jpg.dd2c0dda9f59daefb8ce6bf481f483c5.jpg

Archive.zip

DSDT.aml.zip

what audio codec?

send me new files with new app, i update some things

RunMe.app.zip

up in zippyshare

https://www.zippyshare.com/

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, MaLd0n said:

Thanks MaLd0n.
I changed the SMBIOS to MacBook Pro 6,2, I don't know if it's the right model
I used your clover and found several problems:
1, there is no battery information, the top bar does not show battery information
2, Mic no signal input, the speaker is normal. There are only built-in speakers and built-in Mic in the sound setup options.

How to solve these problems?

Edited by visin

Share this post


Link to post
Share on other sites
10 minutes ago, visin said:

Thanks MaLd0n.
I changed the SMBIOS to MacBook Pro 6,2, I don't know if it's the right model
I used your clover and found several problems:
1, there is no battery information, the top bar does not show battery information
2, Mic no signal input, the speaker is normal. There are only built-in speakers and built-in Mic in the sound setup options.

How to solve these problems?

i dont apply battery patch, just check rehabman repo for it

audio/mic, is just a layout-id, check ur audio codec and change

Share this post


Link to post
Share on other sites
Posted (edited)
On 2018/4/11 at 10:58 AM, MaLd0n said:

DSDT.aml.zip

what audio codec?

send me new files with new app, i update some things

RunMe.app.zip

up in zippyshare

https://www.zippyshare.com/

@MaLd0n

Audio Codec:https://www118.zippyshare.com/v/8vCNKUqW/file.html

EFI:https://www118.zippyshare.com/v/johy7a78/file.html

Send me Clarences-iMac:https://www118.zippyshare.com/v/TxPQHp7Z/file.html

3465.jpg.d587218095018f0eaef19497e2314dbb.jpg

Could u pls help me inject the built-in Mic for my 10.12.6 and 10.13.4?Thanks so much in advance!

Edited by HurricaneX

Share this post


Link to post
Share on other sites

So I formatted the new SSD to GPT and the USB finally booted to clover. Now another problem, at clover menu i added -v -s -x nv_disable=1 npci=0x2000 PCIRootUID=1 and it booted to a complete black screen. I tried booting with just -v nv_disable=1, same thing. I used clover configurator and changed SMIOS to iMac 10,1 system definition. 

Share this post


Link to post
Share on other sites
Posted (edited)

Hello Mald0n:

Nice to meet you, I have created a post about my problem on High Sierra before and I was redirected to this guide by Allan.

As mentioned in the post, I was not able to get pass the login screen at initial boot and the system could not shutdown occasionally.

However I solve the high temperature problem when I replace the clover folder you provide on first post, currently the cpu temperature is around 5x-6x'c after 10 mins up time.

Attached is the clover folder, ioreg as well as the send me app, thanks for your help!

p.s. I notice that your clover boot efi is a old traditional grey apple boot logo, Is there a version of modern dark and white logo one that I could replace with? Thank you!


https://www.insanelymac.com/forum/topic/333867-cant-get-pass-2nd-stage-boot-logo-on-initial-boot-and-high-temperature/

 

My system:
Gigabyte GA-X48-DQ6
Core 2 Extreme QX9650 C0
4 x Kingston DDR2 800ghz Ram
Galaxy GTX460 1GB
120GB SSD Leven JS500120C, high Sierra installed
250GB seagate ST3250310AS
250GB WDC WD2500JS-08NCB1


File:

https://drive.google.com/file/d/1_k3_jxvzGaLfDzin0zSAUT5ml16Hq15c/view?usp=sharing

 

 

 

Edited by winipcfg

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/25/2017 at 12:53 PM, MaLd0n said:

--AUDIO

 

Device HDEF + AppleAlc + Lilu

 

Hi Maldon, great guide! I got my old Dell 780 (LGA775) running High Sierra 10.13.4 nicely, thank you!

 

I have no audio and I see where you mention "Device HDEF + AppleALC + Lilu". I have AppleALC + Lilu in my KEXT folder but not sure what "Device HDEF" is. 


Also when it goes to sleep it takes like 2 minutes to wake. I have a Q9400 quad core + Nvidia Quadro FX580 but don't have a DSDT for it. Can you help me with a DSDT?

 

Here are my RunMe Results

https://drive.google.com/file/d/1Duv3XYyW4UhziDVVWdquwxYcGQ-D5tvm/view?usp=sharing

 

SPECS: Dell 780 MT, Q9400 2.66GHz Core2Quad Core, Nvidia Quadro FX580 

Edited by bocajoe

Share this post


Link to post
Share on other sites
9 hours ago, winipcfg said:

Hello Mald0n:

Nice to meet you, I have created a post about my problem on High Sierra before and I was redirected to this guide by Allan.

As mentioned in the post, I was not able to get pass the login screen at initial boot and the system could not shutdown occasionally.

However I solve the high temperature problem when I replace the clover folder you provide on first post, currently the cpu temperature is around 5x-6x'c after 10 mins up time.

Attached is the clover folder, ioreg as well as the send me app, thanks for your help!

p.s. I notice that your clover boot efi is a old traditional grey apple boot logo, Is there a version of modern dark and white logo one that I could replace with? Thank you!


https://www.insanelymac.com/forum/topic/333867-cant-get-pass-2nd-stage-boot-logo-on-initial-boot-and-high-temperature/

 

My system:
Gigabyte GA-X48-DQ6
Core 2 Extreme QX9650 C0
4 x Kingston DDR2 800ghz Ram
Galaxy GTX460 1GB
120GB SSD Leven JS500120C, high Sierra installed
250GB seagate ST3250310AS
250GB WDC WD2500JS-08NCB1


File:

https://drive.google.com/file/d/1_k3_jxvzGaLfDzin0zSAUT5ml16Hq15c/view?usp=sharing

 

 

 

DSDT.aml.zip

Share this post


Link to post
Share on other sites
3 hours ago, bocajoe said:

 

Hi Maldon, great guide! I got my old Dell 780 (LGA775) running High Sierra 10.13.4 nicely, thank you!

 

I have no audio and I see where you mention "Device HDEF + AppleALC + Lilu". I have AppleALC + Lilu in my KEXT folder but not sure what "Device HDEF" is. 


Also when it goes to sleep it takes like 2 minutes to wake. I have a Q9400 quad core + Nvidia Quadro FX580 but don't have a DSDT for it. Can you help me with a DSDT?

 

Here are my RunMe Results

https://drive.google.com/file/d/1Duv3XYyW4UhziDVVWdquwxYcGQ-D5tvm/view?usp=sharing

 

SPECS: Dell 780 MT, Q9400 2.66GHz Core2Quad Core, Nvidia Quadro FX580 

CLOVER.zip

Share this post


Link to post
Share on other sites
31 minutes ago, MaLd0n said:

 

Thanks for the Clover Maldon. Sleep still not working... display goes to sleep but computer doesn't go to sleep... power button is solid and the fans are still on.

Share this post


Link to post
Share on other sites
8 minutes ago, bocajoe said:

 

Thanks for the Clover Maldon. Sleep still not working... display goes to sleep but computer doesn't go to sleep... power button is solid and the fans are still on.

run app again, send me new files

RunMe.app.zip

Share this post


Link to post
Share on other sites
13 minutes ago, bocajoe said:

the command return?

log show --style syslog | fgrep "Wake reason"

what audio codec?

back old intel Lan kext

Share this post


Link to post
Share on other sites
1 minute ago, MaLd0n said:

the command return?


log show --style syslog | fgrep "Wake reason"

what audio codec?

back old intel Lan kext

ADI 1984A High Definition Audio Codec on my Dell 780.

OK I will put back old lan kext

Share this post


Link to post
Share on other sites
11 minutes ago, bocajoe said:

Oh Sorry. Here is the wake reason:

Macs-iMac:~ mac$ log show --style syslog | fgrep "Wake reason"

2018-04-17 15:09:34.369357-0400  localhost kernel[0]: (AppleACPIPlatform) Wake reason: USB0

2018-04-17 15:09:34.369358-0400  localhost kernel[0]: (AppleACPIPlatform) Wake reason: USB0

2018-04-17 15:11:29.506753-0400  localhost kernel[0]: (AppleACPIPlatform) Wake reason: USB0

2018-04-17 15:11:29.506755-0400  localhost kernel[0]: (AppleACPIPlatform) Wake reason: USB0

2018-04-17 16:10:00.311659-0400  localhost kernel[0]: (AppleACPIPlatform) Wake reason: USB0

2018-04-17 16:10:00.311674-0400  localhost kernel[0]: (AppleACPIPlatform) Wake reason: USB0

2018-04-19 11:23:32.028355-0400  localhost kernel[0]: (AppleACPIPlatform) Wake reason: USB0

2018-04-19 11:23:32.028356-0400  localhost kernel[0]: (AppleACPIPlatform) Wake reason: USB0

2018-04-19 14:58:57.360846-0400  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: USB0

2018-04-19 14:58:57.360847-0400  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: USB0

2018-04-19 16:12:18.472864-0400  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: USB0

2018-04-19 16:12:18.472865-0400  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: USB0

2018-04-19 18:00:53.210702-0400  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: USB0

2018-04-19 18:00:53.210703-0400  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: USB0

2018-04-19 19:20:50.096705-0400  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: USB0

2018-04-19 19:20:50.096706-0400  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: USB0

2018-04-19 20:21:37.992600-0400  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: USB0

2018-04-19 20:21:37.992602-0400  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: USB0

2018-04-19 23:49:46.175981-0400  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: USB0

2018-04-19 23:49:46.175983-0400  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: USB0

2018-04-23 19:30:03.322370-0400  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: USB0

2018-04-23 19:30:03.322371-0400  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: USB0

2018-04-23 19:50:04.167217-0400  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: USB0

2018-04-23 19:50:04.167218-0400  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: USB0

Macs-iMac:~ mac$

Share this post


Link to post
Share on other sites
15 minutes ago, bocajoe said:

ADI 1984A High Definition Audio Codec on my Dell 780.

OK I will put back old lan kext

DSDT.aml.zip

check if audio work

ur codec work with 11 or 13 only

Share this post


Link to post
Share on other sites
10 minutes ago, MaLd0n said:

DSDT.aml.zip

check if audio work

ur codec work with 11 or 13 only

 

I tired the new DSDT and 11 & 13 in clover configurator and still no audio.

Testing sleep now.

Share this post


Link to post
Share on other sites
Posted (edited)

Unfortunately it still doesn't sleep. Monitor does but not computer

Edited by bocajoe

Share this post


Link to post
Share on other sites
14 hours ago, MaLd0n said:

 

Thanks MaLd0n, but is the file put at the path /EFI/Clover/ACPI/patched ?

I have put the aml in the above path but can't solve the boot problem.

Share this post


Link to post
Share on other sites
11 hours ago, bocajoe said:

Unfortunately it still doesn't sleep. Monitor does but not computer

i'll check it, back to home in a few hours

9 minutes ago, winipcfg said:

 

Thanks MaLd0n, but is the file put at the path /EFI/Clover/ACPI/patched ?

I have put the aml in the above path but can't solve the boot problem.

what boot problem u have?

Share this post


Link to post
Share on other sites
1 hour ago, MaLd0n said:

what boot problem u have?

 

The problem I got is the system will stuck between the 2nd stage boot logo and login screen on first boot,
I need to soft restart the PC in order to get pass the stuck,  whatever at clover or at bios.
The system also can't shutdown occasionally if it's been on for a while. I believe they are the same problem.

p.s. 'cpus=1 boot flag can solve it, but as you know the performance will be slow as hell. 

screen.jpg.1c39b8a2f81c5a5425296d5cf844a852.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By Jiji The Fox
      Hey, long time no post!
       
      Apologies if this has been answered, every time I search I get a timeout on the site and I can't seem to get the search to work
       
      I've been sitting pretty with Yosemite for a while , but a recent hardware upgrade (Audio interface) means I can jump from Yosemite. 

      I've successfully upgraded Clover, then the OS and for the most of it, it seems great. Everything works but the Graphics Driver (NVidia GeForce GTX670.)
       
      I can only boot into Mac if disable the NVIDIA drivers with the boot flag nv_disable=1  however that's not great I end up with one monitor working at 1024 x 768.
       
       
      I've updated the NVIDIA web drivers to the latest my build of sierra can take. 
      I have the boot flag for web driver to be enabled (can't remember off the top of my head.. I'm on the work pc, soon to be home)
       
      Any ideas would be grateful, I spent much of last night and morning on this.

      Many Thanks
       
       
    • By zebity
      Hi Hypervisors,
       
      I have been working to move my Late 2009 Xserve MacOS Server onto Ubuntu 18.04 LTS QEMU/KVM based virtual machine using OVMF and Clover.
       
      After much effort and testing based on the following information from: Kraxel's, Kholia, Gordon Turner and Clover site:
      https://www.kraxel.org/blog/2017/09/running-macos-as-guest-in-kvm/
      https://github.com/kholia/OSX-KVM
      https://gist.github.com/gordonturner/2a2e5ecde5e7860b52e2
      https://clover-wiki.zetam.org/Home
       
      I have now managed to get OVMF/Clover boot and install of MacOS Sierra.
       
      I started with Ubuntu 16.04 initially but this required download and compile of QEMU to get update of machines to: pc-q35-2.9 or better, so I moved to Ubuntu 18.04, which has pc-q35.2.11 available as standard.
       
      So I am now working with standard Ubuntu 18.04 LTS based systems with following packages: kvm/qemu/libvirt/bridge-utils/ovmf/virt-manager
       
      As I want to use PCIe Passthrough for a number of PCIe card currently installed in the server (SmallTree 10GbE & Areca ARC-1883 SAS RAID) I set up my machine with linux kernel boot configuration (/etc/default/grub) of: 
      GRUB_CMDLINE_LINUX_DEFAULT="iommu=1 intel_iommu=on" (as my machine is intel VT-d based HW virtualisation)
       
      This resulted in creation of a number of iommu groups (see /sys/kernel/iommu_group directory for this and this posting for information: https://forum.level1techs.com/t/ubuntu-17-04-vfio-pcie-passthrough-kernel-update-4-14-rc1/119639 , noting that Ubuntu 18.04 LTS has kernel version: 4.15.0-22-generic so there is no need to do kernel update for iommu to work).
       
      Using bare minimal Clover config.plist:
       
       
      And following Clover UEFI drivers:
       
      I can boot MacOS, but it is very very slow... it sits on the apple boot logo for over a minutes before finally moving onto the progress bar.
      The other problem I have is that no PCI or Network devices appear in the "About This Mac" System Information Report and I cannot get any network connectivity from bridged E1000 network device.
       
      Here is my virtlib.xml dump for the virtual machine:
       

      Can any one advise of whether I need to update the CLOVER config.plist to add extra items in to allow network and PCI Passthrough to work.
       
      Thank you.
       
      Regards,
       
      Zebity
       
    • By Gymnae
      Introduction
      The H370 chipset powers 8th generation Intel Core-i CPUs. Even though the name H370 rings comparable to Z370, the H370 is based on newer silicon. This it also requires some new approaches compared to the Z370. An example would be on-die USB 3.1 and WiFi support.
       
      Since this guide is not a "hold-your-hand-every-step" guide, I assume you know:
      Clover installation and configuration How to create an install medium for MacOS Access and configure the BIOS Have heard of ACPI patching (I'm a newb at this myself)  
      What works
      Sleep (via DSDT edits and emulated NVRAM) On-board Audio (via CloverALC script) Native power management (without any kext or patch) All USB ports (and only those present are active) iGPU for both acceleration and display dGPU (I'm running an Nvidia GTX 1080)  
      Untested
      NIC --> I'm using WiFi only  
      What doesn't work
      Native NVRAM via AptioMemoryFix.efi DMVT Pre-alloc higher than 64MB (but not necessary)  
      Changes to the guide:
      22.5.18: Added SSDT hot-patching to enable sleep, replacing DSDT static patching as an alternative.
      23.5.18: Add iMac18,1 as alternative SMBIOS config for those relying on the iGPU for output
       
      1. Installation
      This guide heavy inspired by the work of /u/corpnewt of /r/hackintosh and his (sorta) Vanilla guide
       
      1.1 Create the install media for MacOS
      Follow this, if you are using a Mac to start off with. If you are totally new to MacOS, then please check the basic guide Creation of an installer media in windows or linux
       
      1.2 Install Clover on the install media
      Using the Clover installer, ensure you are installing to the USB medium you are using for the installer.
      Chose the following options:
      AptioMemoryFix UEFI booting only Install to ESP You have to get your hands on an apfs.efi. A google search can help, or extracting it from the Installer package. Make sure you procure a version matching the MacOS version you are about to install. Place the apfs.efi in drivers64UEFI.
       
      1.2 Adjust the config.plist for the installer
      You can use the config.plist attached as a guideline, but take a look at it before and at least adjust the SMBIOS - otherwise it won't boot.
      Attention: The attached plist contains audio patches introduced by a post-install step. If you run into problems, you might remove those. It also contains a manual slide value, which should normally not be needed, but works fine for me. It is also tuned for usage with an Nvidia Pascal dGPU as main GPU.
       
      The config you create now should serve you nicely for install and running the system.
       
      Take care of adding the following basics:
      SMBIOS: iMac18,3 - You can generate a serial number via Clover Configurator. The creation of a proper SMBIOS is covered in many guides to good extend Note: If you aim at using the iGPU for output, a user reported that iMac18,1 works better - since iMac18,3 produces sever flicker. Look at the graphics section and adjust the injection for Intel to your situation  
      Fixes

      Patches

      Devices

      Graphics

      Kernel and Kext patches
       
      1.3 kexts and friends
      Add the supplied SSDT-UAIC.aml to "patched" - it limits the injected USB Ports to the actual number and ports valid for this board.
       
      Required kexts on "Other":
      FakeSMC.kext IntelGraphicsFixup.kext Lilu.kext When having an Nvidia card: NvidiaGraphicsFixup.kext IntelMausiEthernet.kext in case you're running Ethernet USBInjectAll.kext with the HCI-300-series-injector.kext --> These two should be installed to /L/E after install  
      We are leaving sound out at the moment, this is something for post-install. Please note the absence of Shiki, I don't find it necessary. Video material I tried made use of the iGPU without shiki.
       
      1.4 Check BIOS and install
      You should be ready for install. But before you reboot, please take a look at your BIOS and set it up accordingly (copied from the aforementioned guide and adapted):
      Load Optimized Defaults Disable VT-d setting If your system has Secure Boot Mode, disable it Set OS Type to Windows 8/10 or OtherOS - I have not seen a difference Turn off internal Serial and Parallel port Turn off Network stack for boot Turn off wake-on-lan (for now) Set XHCI Handoff to Enabled Don't enable decode over 4G Depending on your GPU, set priority for boot Set internal GPU to enable Set DMVT pre-alloc to 64MB Set USB legacy to enabled Activate XMP profile 1 f your Ram has it (mine doesn't and I added the timings manually) Set ERP to enable, disable platform power management (I need to do more research if this could be enabled)  
      I've attached my current BIOS config "hack2". You can place that on a fat32 drive (the EFI partition of your install USB drive might be an idea) and see if it loads. It's made for and with the F2 BIOS.
       
      The install itself should be like other MacOS Hackintosh installs with it several reboots and ensuring to select the correct boot device in Clover.
       
      2. Post-install
       
      2.1 Install clover on target
      This is a no-brainer, but install a fresh copy of Clover on your target medium.
       
      During install select again AptioMemoryFix but also additionally
      EmuVariableUefi-64.efi Install RC scripts on target volume because otherwise NVRAM doesn't seem to work
       
      After the install, copy
      config.plist contents of "Other" content of "patched" apfs.efi from drivers64UEFI to your new clover install.
       
      2.1 Edit ACPI for slumber
      Choose one option, not both. The hot-patch is experimental, but for the moment it is stable.
       
      2.1.1 Edit DSDT
      This is necessary only once on initial install and every time, you edit or upgrade the BIOS. The DSDT.aml attached to this post might work for your system or give you a file to compare to. Don't expect it to work for you, though.
      I won't go into the details of DSDT extraction and patching. There are better guides (the linked guide is a rip-off of rehabman's guide from a different forum). Please follow such a guide to extract your ACPI data.
       
      Locate and disassemble the DSDT with the newest iasl binary you can put your hands on, then open it with MacIASL in its newest version you can find (Hint: Here is a good source) You can check if the version is new enough if MacIASL doesn't throw error upon compiling a freshly extracted DSDT.aml or DSDT.dst
       
      Add rehabmans repo (as per linked guide) and apply the following patches:
      Rename _DSM to _XDSM Fix _WAK Arg0 v2 USB3 _PRW 0x6D Skylake (instant wake) Find the CNVW device and remove the _PWR function there.
       
      Compile the DSDT and place it in "patched".
       
      2.1.2 Use SSDT hot-patching
      Instead of having to re-extract and re-patch the DSDT on every BIOS change or update, Hardware change one can also use ACPI hot-patching.
      It's a combination of config.plist patches and an SSDT, which is hot-patched into the ACPI (if I understand the process correctly)
       
      You need to add this SSDT-GPRW.aml to your Clover folder in the designated position at Clover/ACPI/patched You need to add this patch to your config.plist. It goes into the DSDT patch section  
      Note: This works for me, but the patch removes the _PRW method from all devices in the DSDT. This could have side-effects. So far, I have seen none. At the moment I'm also not applying any other patch, compared with the additional edits I made to the DSDT method before.
       
      2.2 Install kexts to system
      As mentioned in the install section, it's better to follow rehabman's instruction and install USBinjectAll.kext to /L/E:
      sudo cp -R Release/USBInjectAll.kext /Library/Extensions sudo touch /System/Library/Extensions && sudo kextcache -u / 2.3 Enable onboard Audio
      This is where I'm not so happy currently, I'd like it to work without altering AppleHDA. But currently I find no other way.
       
      2.3.1 Install FakePCIID & FakePCIID_Intel_HDMI_Audio
      Rehabman tells us to use a kext installer to install it to /S/L/E. Chose the RELEASE folder
       
      2.3.2 Run CloverALC command
      Ensure your EFI partition is mounted before running this command
      Get the newest version of CloverALC command (audio_cloverALC-xxx.sh) and run it. Our Audio codec is RTL887 and I'm running with layout ID 1
       
      2.4 Optional steps
      If you have a dGPU, now it's the time to install its drivers and adjust the config.plist for it.
      This is out of scope of this guide. Yet, my supplied config.plist is ready to be used with Nvidia Pascal cards and using the Nvidia web driver.
       
      3. ToDo
      Move away from static DSDT patching to SSDT hotpatching --> requires my work Native NVRAM --> requires developer work Audio without AppleHDA patching --> requires developer work  
      4. Thanks to
      @MaLd0nfor helping finding the right way with the DSDT
      @RehabMan, for being a legend and helping me out patching
      @toleda, for audio patches for the 300 series
      /u/corpnewt, for his superb vanilla guide
      @wmchris for his super XPS 9550 guide and introducing me to hot-patching
      all the developers of clover and it's awesomeness
       
      SSDT-UIAC.aml
      config.plist
      DSDT.aml
      hack2
    • By MaLd0n
      Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell     Skylake, Kabylake and Coffeelake is here http://www.insanelymac.com/forum/topic/321872-guide-sierra-on-gigabyte-mobos-serie-200-kabylake-dsdt/   First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder CLOVER Install.zip   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder CLOVER Post Install.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
×